Jump to content

[Résolu] upgrade à la version 0.9 difficile...


Recommended Posts

J'ai effectué la mise à jour depuis la version .8.5.1 à la 0.9 et voici les deux erreur SQL annoncées:

 

 

 

INSERT INTO `ps_shopconfiguration` (`name`, `value`, `date_add`, `date_upd`) VALUES ('PS_TAX_OUT', '0', NOW(), NOW())

 

INSERT INTO `ps_shopconfiguration` (`name`, `value`, `date_add`, `date_upd`) VALUES ('PS_DISPLAY_QTIES', '1', NOW(), NOW())

 

ALTER TABLE `ps_shopcurrency` ADD `iso_code` VARCHAR( 3 ) NOT NULL DEFAULT '0' AFTER `name`

 

ALTER TABLE `ps_shopproduct_attribute` ADD `default_on` TINYINT( 1 ) UNSIGNED NOT NULL DEFAULT '0' AFTER `weight`

 

ALTER TABLE `ps_shopcarrier` ADD `tax` INT( 10 ) UNSIGNED NOT NULL DEFAULT '0' AFTER `deleted`

 

ALTER TABLE `ps_shoporder_detail` ADD `download_hash` VARCHAR(255) default NULL AFTER `tax_rate`, ADD `download_nb` INT(10) unsigned default 0 AFTER `tax_rate`, ADD `download_deadline` DATETIME DEFAULT NULL AFTER `tax_rate`

 

CREATE TABLE `ps_shopproduct_download` ( `id_product_download` INT(10) unsigned NOT NULL auto_increment, `id_product` INT(10) unsigned NOT NULL, `display_filename` VARCHAR(255) default NULL, `physically_filename` VARCHAR(255) default NULL, `date_deposit` DATETIME NOT NULL, `date_expiration` DATETIME default NULL, `nb_days_accessible` int(10) unsigned default NULL, `nb_downloadable` int(10) unsigned default 1, PRIMARY KEY (`id_product_download`) ) DEFAULT CHARSET=utf8

 

INSERT INTO `ps_shopcarrier` (`name`, `url`, `active`, `deleted`) VALUES ('My download manager', NULL, 1, 0)

 

INSERT INTO `ps_shopcarrier_lang` (`id_carrier`, `id_lang`, `delay`) VALUES (LAST_INSERT_ID(), 1, 'Direct download!'), (LAST_INSERT_ID(), 2, 'Téléchargement électronique'), (LAST_INSERT_ID(), 3, 'Direct download!')

 

INSERT INTO `ps_shopmodule` (`id_module`, `name`, `active`) VALUES (14, 'editorial', 1)

 

(1062) Duplicate entry '14' for key 1

INSERT INTO `ps_shophook_module` (`id_module`, `id_hook`, `position`) VALUES (14, 8, 1)

 

INSERT INTO `ps_shopaccess` (`id_access`, `id_profile`, `id_tab`, `view`, `add`, `edit`, `delete`) VALUES (38, 1, 38, 1, 1, 1, 1)

 

(1062) Duplicate entry '38' for key 1

/* Make clean in tabs */ TRUNCATE TABLE `ps_shoptab`

 

INSERT INTO `ps_shoptab` (`id_tab`, `id_parent`, `class_name`, `position`) VALUES (1, 0, 'AdminCatalog', 1), (2, 0, 'AdminCustomers', 2), (3, 0, 'AdminOrders', 3), (4, 0, 'AdminPayment', 4), (5, 0, 'AdminShipping', 5), (6, 0, 'AdminStats', 6), (7, 0, 'AdminModules', 7), (8, 0, 'AdminPreferences', 8), (9, 0, 'AdminTools', 9), (10, 1, 'AdminManufacturers', 1), (11, 1, 'AdminAttributesGroups', 3), (12, 2, 'AdminAddresses', 1), (13, 3, 'AdminOrdersStates', 1), (14, 4, 'AdminDiscounts', 3), (15, 4, 'AdminCurrencies', 1), (16, 4, 'AdminTaxes', 2), (17, 5, 'AdminCarriers', 1), (18, 5, 'AdminCountries', 2), (19, 5, 'AdminZones', 3), (20, 5, 'AdminRangePrice', 4), (21, 5, 'AdminRangeWeight', 5), (22, 7, 'AdminModulesPositions', 1), (23, 8, 'AdminDb', 6), (24, 8, 'AdminEmails', 4), (26, 8, 'AdminImages', 5), (27, 8, 'AdminPPreferences', 3), (28, 9, 'AdminContacts', 4), (29, 9, 'AdminEmployees', 1), (30, 9, 'AdminProfiles', 2), (31, 9, 'AdminAccess', 3), (32, 9, 'AdminLanguages', 5), (33, 9, 'AdminTranslations', 6), (34, 1, 'AdminSuppliers', 2), (35, 9, 'AdminTabs', 7), (36, 1, 'AdminFeatures', 4), (37, 9, 'AdminQuickAccesses', 8), (38, 8, 'AdminAppearance', 2)

 

INSERT INTO `ps_shoptab_lang` (`id_lang`, `id_tab`, `name`) VALUES (1, 38, 'Appareance'), (2, 38, 'Apparence')

 

DELETE FROM `ps_shoplang` WHERE `id_lang` = 3

 

/* Clean currency table */ TRUNCATE TABLE `ps_shopcurrency`

 

INSERT INTO `ps_shopcurrency` (`id_currency`, `name`, `iso_code`, `sign`, `format`, `conversion_rate`, `deleted`) VALUES (1, 'Euro', 'EUR', '€', 2, 1.00, 0), (2, 'Dollar', 'USD', '$', 1, 1.38, 0)

 

J'avoue être largué. J'ai suivu la procédure de mise à jour indiquée. Est ce récupérable ou faut retourner en 0.8.5?!

 

De plus tous les prix de mes articles affiché sur la partie client sont à 0.-

Dans les détails d'articles, pas de problème il sont correctement affiché.

 

Salutations et merci de votre aide.

Share this post


Link to post
Share on other sites

Bonsoir,

 

Je vous conseille d'attendre la v0.9.1 qui sera disponible ce lundi ou mardi au plus tard.

Par ailleurs, si vous êtes pressés vous pouvez lire les autres messages du forum qui devraient vous aiguiller sur la bonne piste.

 

Bien cordialement,

Bruno Lévêque

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More