Jump to content
zouline

[RESOLU] Help, installation prestashop et base de données sur perso OVH

Recommended Posts

Bonsoir à tous,

Voici mon problème avec l'installation de prestashop 1.4.9, alors voilà, j'ai placé tous les dossiers prestashop sur mon serveur mutualisé perso ovh, mais l'installation a bugué au niveau de l'installation de la base de données (connexion ok à la base de données), message suivant : "Une base de données PrestaShop existe déjà avec ce préfixe, vous devez la supprimer manuellement ou changer son préfixe." J'avais déjà tout désinstallé et réinstallé sur le serveur une première fois car j'avais déjà eu ce problème avant.

J'ai relancé, juste pour voir, une nouvelle fenêtre avec le nom de domaine, le site fonctionne mais impossible d'accéder à l'admin alors que j'ai bien renommé ce dossier et supprimé le dossier install sur le serveur. On me demande un login et mot de passe pour me connecter à l'admin mais comme je n'ai pas pu aller au bout de l'installation je n'ai pas ces informations, comment faire?

merci pour votre aide.

céline

Edited by zouline (see edit history)

Share this post


Link to post
Share on other sites

Bonjour

 

Si je comprends bien vous avez installer une version 1.4.9 sur une version existante.

 

Les fichiers et dossiers sont une chose , la base de donnée c'est autre chose.

 

Ce qui veut dire que le fait de suppirmer tous les fichies et dossiers Ne supprime Pas la base de donnée.

 

Pour supprimer une base de donnée il faut via phpmyadmin supprimer l'ancienne base.

Si vous la supprimer pas que vous faites une Installation il faudrat modifier le préfixe ps_ en ps_2

Je déconseille de mettre différentes base de donnée dans une seule.

 

Si l'installation n'est pas aller jusqu'au bout, il faut tout d'abord vérifier le nombre de table via phpmyadmin, mais je me pose une question vu que vous êtes chez ovh et que certaine base de donnée on n'a pas accès,

 

Si on peut accéder la table ps_employee là vous avez le login et le mot de passe, pour le modifier il faut prendre la ligne dans le fichier /config/setting.inc.php

define('_COOKIE_KEY_', 'hdXAKTUkwCQaBaYgPtSwwrEptmiUqiGgPgk9ENLK6xALfJkukxHIhmF5');

 

Là vous copiez : hdXAKTUkwCQaBaYgPtSwwrEptmiUqiGgPgk9ENLK6xALfJkukxHIhmF5 et sur le site http://www.md5.fr vous le coller dans le cadre et ajouter à la suite le mot de passe

 

Exemple : hdXAKTUkwCQaBaYgPtSwwrEptmiUqiGgPgk9ENLK6xALfJkukxHIhmF5MonMotDePasse

 

 

Pour info ne jamais mettre cette ligne sur un forum, là c'est un exemple d'une installation en local non accessible de l'extérieur. Et ne pas utiliser ce que je viens de mettre pour votre site.

Share this post


Link to post
Share on other sites

bonjour,

j'avais simplement enlevé le dossier d'installation du serveur (puis remis) et également supprimé avec phpmyadmin toutes les tables de ma base de données qui était donc vide la 2ème fois que j'ai refait l'installation. J'ai laissé les champs tels quels lors de l'installation ps_ et type de base de donnée InnoDB et juste indiqué le mot de passe et nom de la base de données à laquelle on pouvait se connecter sans problème depuis l'installation mais à chaque fois même message lorsque je clique sur installation complète avec 100 modules gratuits : "Une base de données PrestaShop existe déjà avec ce préfixe, vous devez la supprimer manuellement ou changer son préfixe."

Dans la documentation de prestashop il est indiqué qu'il faut créer une base de données, ce que j'ai fait avant l'installation, alors je ne comprends pas trop pourquoi ce message apparaît, on dirait qu'on ne doit pas créer préalablement une base de données puisque ce message apparaît.

Edited by zouline (see edit history)

Share this post


Link to post
Share on other sites

Bonjour

 

C'eest un cas récurrent chez ovh, est-ce que via votre manager avez vous supprimer la base de donnée puis recréer ?

 

A moins que ce soit votre navigateur qui garde cette page dans le cache, videz le cache les fichier temporaires les cookies.

Share this post


Link to post
Share on other sites

Bonjour,

Ok merci! tout fonctionne à présent que j'ai désinstallé et réinstallé la base de données et coché le type base de données Myisam.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More