Jump to content
thwasser

Mise à jour auto 1.5.0.17 -> 1.5.1 erreur Javascript

Recommended Posts

Juste au tout début de la maj avec 1-clic, une fenêtre m'indique ceci:

 

Javascript error (parseJSON) detected for action "upgradeNow".Début de la restauration ...

 

Il ne se passe plus rien....

 

Que dois-je faire ?

Share this post


Link to post
Share on other sites

Bonjour,

Idem exactement même erreur pour moi sur une fresh install en test

MAJ de 1.5.0.17 vers 1.5.1 avec 1clickupgrade bug

Share this post


Link to post
Share on other sites

Bonjour,

 

J'avais pour ma part essayé avec la version 0.8.8 je viens de faire la MAJ vers la 0.8.9 et je n'ai plus le problème.

 

Merci

Share this post


Link to post
Share on other sites

dans la section des modules, à côté du module concerné, il y a un bouton mettre à jour au sessus du bouton désinstaller quand une mise à jour est disponible.

Share this post


Link to post
Share on other sites

Ok j'ai vérifié c'est bien la 0.8.9

 

Par contre quand je parcours le forum au sujet des mises à jour, ça fait froid dans le dos, j'ai pas trop envie de tester seul en manuel :(

Share this post


Link to post
Share on other sites

Bonjour,

j'ai essayé de faire les mises à jour avec les modules V0.7.2, V0.8.1, V.0.8.6, V.0.9.0 et la V.0.9.1 (sur prestashop addon) qui une fois installé s'appelle V.0.9.3, et j'ai toujours l'erreur : "erreur javascript (parseJson) détectée pour l'action "upgradenow"...

 

Par ailleurs le module me propose la Dernière version sur le canal officiel de mise à jour minor 1.4.9.0 final (1.4.9.0)

 

le mode expert propose la même version 1.4.9.0, je parle donc même pas de la 1.5.1 stable.

A cette vitesse là...

Share this post


Link to post
Share on other sites

module mis à jour mais même problème: "Erreur Javascript (parseJSON) détectée pour l'action"upgradeDb"...

 

Une solution à ce problème ?

 

Arrivera t-on un jour à faire une mise à jour sans problème ??

 

Parce que sortir une mise à jour toutes les semaines pour finalement galérer des jours et des jours pour installer cette mise à jour, ça commence qu'en même à être un peu problématique....

Edited by balaizeben2 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai voulu tenté MAJ 1.4.7 vers 1.5.2

Avec au vue des nombreuses MAJ qui sont apparament GALERE j'ai installé le module 1-Click Upragde - AutoUpgrade v 0.9.3

J'ai tout installé à propre en vidant mon cache, compil, cache navigateur etc ..

 

Au moment de la MAJ, déjà ca veut faire MAJ vers 1.4.7 à 1.4.9

( Je me dis pourquoi pas histoire peut etre que cela soit pas trop brutal ) :)

 

Mais à peine j'appuis sur le bouton Mettre à jour PrestaShop Maintenant ! Hop !! magie magie :ph34r:

"Erreur Javascript (parseJSON) détéctée pour l'action "upgradeNow".Début de la restauration"

 

Donc je cherche une vraie solution car Prestashop nous annonce tout beau sur le coté : avec le module de mise à jour en un clic, mettre à jour votre boutique vers la dernière version de Prestashop disponible n'a jamais été aussi facile !

 

Alors je voudrais dire que pour moi ca se transforme du coup en : mise à jour en un clic et seulement en un clic car STOP tu iras pas plus loin :lol: ...

 

Je suis preneur de vraie solution et encore plus de bonne réaction de la Team de Prestashop car je pense vraiment que se pencher de plus près sur une MAJ justement en un clic et sans probleme apportera bien plus de notoriété à Prestashop...

 

Je redonne cette exemple qui peu ne pas plaire mais quand je fais des mises à jours de nouvelle version sur mes WORPRESS avec des tonnes de modules différents d'installés et de modifisé je n'ai jamais mais alors jamais eu un problème pour les MAJ ....

 

 

Merci de votre soutien

Lokiiy

Edited by lokiiy (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

 

De mon côté, j'avais la même erreur. En cherchant un peu, j'ai noté une erreur dans les logs disant que le répertoire /config/xml/ n'avait pas les droits en écriture. J'ai donc mis les droits en écriture sur ce répertoire en récursif et la mise à jour est passée.

 

En espérant que ça vous aidera.

Share this post


Link to post
Share on other sites

Bonjour,

 

De mon côté, j'avais la même erreur. En cherchant un peu, j'ai noté une erreur dans les logs disant que le répertoire /config/xml/ n'avait pas les droits en écriture. J'ai donc mis les droits en écriture sur ce répertoire en récursif et la mise à jour est passée.

 

En espérant que ça vous aidera.

 

Super !!! J'ai fais le test et cela fonctionne presque parfaitement bien lol

 

Je suis bien en 1.4.9 cependant ma MAJ a fait une erreur que je comprend pas

 

[ERROR] SQL 1.4.9.0 1146 in ALTER TABLE `ps_order_tax` ADD `id_order_tax` INT UNSIGNED NOT NULL AUTO_INCREMENT PRIMARY KEY FIRST: Table 'teramerboutik.

ps_order_tax' doesn't exist

 

 

ps_order_tax

 

Je n'ai pas de table ps_order_tax dans ma BDD

Et en regardant dans la sauvegarde de ma BDD avant la MAJ je n'ai pas non plus de ps_order_tax

 

Que faut t'il que je fasse d'après vous ?

Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

Quelqu'un a t'il trouvé une solution à ce problème ?

Je lance l'update de 1.4.8.2 vers 1.4.9 (idem vers 1.5.3.1) et j'ai ce message d'erreur lors de l'étape de mise à jour de la base de données.

 

Erreur Javascript (parseJSON) détectée pour l'action"upgradeDb". Début de la restauration ...

 

:(

Share this post


Link to post
Share on other sites

J'a récemment utilisé la méthode du post #14 qui a marché pour moi en version 1.4.7 vers 1.4.9

Share this post


Link to post
Share on other sites

J'ai bien essayé aussi.

Mais ça n'a pas changé grand chose.

Je viens de retenter en chmod récursif 777 sur le répertoire config directement, mais rien. :(

 

je pense que je vais aller me pendre. :ph34r:

Share this post


Link to post
Share on other sites

Je viens de retenter en chmod récursif 777 sur le répertoire config directement, mais rien. :(

 

Attention de ne pas laisser tes dossiers/fichiers en chmod 777...

- chmod 755 sur les dossiers

- chmod 644 sur les fichiers

 

Pour la mise à jour, je n'ai pas eu d'autres alternatives que de tout faire en localhost sous xampp (osx)

 

Quel est ton hébergeur ?

- Sur un serveur dédié 1&1 j'ai le même problème.

- Sur un mutualisé 1&1 je n'ai pas d'erreur

 

... je pense donc que c'est un double problème :

- Prestashop capricieux et pas stable en 1.5.x

- Configuration du serveur mais ???

 

Mes autres "CMS" Joomla, Wordpress et Dolibarr se mettent à jour sans aucun problème sur le dédié.

Share this post


Link to post
Share on other sites

mutualisé premium chez PHPNET

si c'est pas stable, je vais attendre pour faire ma mise à jour.

 

Mais même en upgradant vers du 1.4.9 j'ai le même problème.

Share this post


Link to post
Share on other sites

si c'est pas stable, je vais attendre pour faire ma mise à jour.

 

J'avais fais quelques tests en local sur la 1.5 de prestashop et j'ai attendu la 1.5.2 pour me lancer sur la màj...

Erreur !

 

L'interface est sympa, les nouvelles options sont bien pensées mais le code n'est pas encore stable malheureusement :

- erreur paiement paypal (corrigé sur 1.4.9 et erreur sur 1.5 ???)

- erreur payment B2B systempay (corrigé sur 1.4.9 et erreur sur 1.5 ???)

- erreur import produits (prod en 1.5.3.1 et fichier import en 1.5.2 pour avoir un semblant d'import)

- erreur 500 sur certains .php du site (chmod Ok, template origine... incompréhensible)

- erreur override (upload complet d'un dossier override neuf et encore quelques erreurs...)

- lenteur du site si modules stats activés (google analytics presque obligatoire)

- ...

 

Bref, perte de production et baisse des ventes sur le début janvier :/

 

Honnêtement, je pense sérieusement qu'il faut attendre pour passer en 1.5.x

Edited by Weetabix40 (see edit history)

Share this post


Link to post
Share on other sites

j'ai trouvé une solution en désinstallant et réinstallant le module de mise à jour.

 

j'aurais bien voulu comprendre pourquoi, l’essentiel est que cela marche.

Share this post


Link to post
Share on other sites

Bonjour,

 

je deterre un peu ce sujet car je ne trouve pas de solution a mon probleme.

 

Je n'arrive pas a mettre les droits en ecriture (777) sur mon dossier et sous dossier autoupgrade qui ce trouve dans /web/admin/autoupgrade car apparement car j'ai la case proprietaire/groupe qui a un N° different des autres donc il ne me change pas les droits grrr

 

Quelqu'un autrai la solution?

 

Cyril.

Share this post


Link to post
Share on other sites

Evidement ce message date de plusieurs mois, mais une solution se trouve bêtement dans le guide de mise à jour automatique ( http://doc.prestashop.com/pages/viewpage.action?pageId=11272345 )

je cite :

"Sur certaines configurations serveur, un message d'erreur peut apparaître, disant "Erreur Javascript (parseJSON) détectée pour l'action "upgradeNow". Début de la restauration ..."

Pour résoudre ce problème, suivez ces étapes :

  • Ouvrez votre fichier php.ini et activez (décommentez) les extensions MySQLi et MySQL PDO. Si vous n'avez pas accès au fichier php.ini, contactez votre hébergeur à ce propos.
  • Ouvrez le fichier /modules/autoupgrade/db/Db.php et trouvez ces lignes (autour de la ligne 210) :

    public static function getClass()
    {
        $class = 'MySQL';
        /*if (PHP_VERSION_ID >= 50200 && extension_loaded('pdo_mysql'))
            $class = 'DbPDO';
        else if (extension_loaded('mysqli'))
            $class = 'DbMySQLi';*/
        return $class;
    }

    Décommentez simplement ces lignes (retirez /* et */). Elles devraient ressembler à cela :

    public static function getClass()
    {
        $class = 'MySQL';
        if (PHP_VERSION_ID >= 50200 && extension_loaded('pdo_mysql'))
            $class = 'DbPDO';
        else if (extension_loaded('mysqli'))
            $class = 'DbMySQLi';
        return $class;
    }

Ceci fait, relancer le processus de mise à jour automatique."

 

perso j'ai pas testé car à force de désinstaller/réinstaller le module ça a finit par passer... ça servira peut être à d'autres

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More