Jump to content

Please help me "max_input_vars" problem!


Recommended Posts

Hi everyone, I have a problem with my Xampserver configuration.

I am developing a site with Prestashop, when I go to the translation page I receive this warning:

"Warning, your PHP configuration limits the maximum number of fields to post in a form: 1000 for max_input_vars.

Please ask your hosting provider to increase the this limit to 4501 at least or edit the translation file manually."

How can I solve above the problem?

Thank you very much!

Share this post


Link to post
Share on other sites

Thanks! I'm using localhost on Windows Vista 64. I'm not a technician IT, so don know how to configuration. Please tell me how to do? Thanks again!

 

ok, so you must:

 

1) go to directory where you installed xampp

2) open php directory

3) find php.ini file and open it

4) now you must edit line:

 

max_input_vars = 1000

 

 

set higher value of this variable.

 

5) save php.ini file

6) restart your xampp server

 

 

if it helps, add to the title of topic [sOLVED] :)

Edited by vekia (see edit history)
  • Like 3

Share this post


Link to post
Share on other sites

You've removed semicolon? YOu've got there ;max_input_vars or only max_input_vars?

it's important to remove semicolon. If semicolon exists there, variable is set to default, which mean 1000

 

solution:

Search for 'max_input_vars', uncomment it (remove the semicolon), and set it to 3000('max_input_vars = 3000').

  • Like 1

Share this post


Link to post
Share on other sites

my solution writed above works with PHP in version 5.3.9+

 

if it doesn't work for you you can add in prestashop backoffice (tools->generators / htaccess file generation) this line:

 

php_value max_input_vars 6000

  • Like 2

Share this post


Link to post
Share on other sites

I tried 2 method: max_input_vars and ;max_input_vars. but It is not ok!

 

I'm using PrestaShop V1.5.1.0, I can't find Menu Tools > Generators htacess file. Please tell me how to find Generators htacess file in prestashop backoffice?

 

My Infor:

Server information

 

Server information: Windows NT build 6001 (Windows Vista Home Premium Edition Service Pack 1) i586

Server software version: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7

PHP version: 5.4.7

Memory limit: 128M

Max execution time: 30

Database information

 

MySQL version: 5.5.27

MySQL engine: InnoDB

Tables prefix: ps_

Store information

 

Prestashop version: 1.5.1.0

Shop URL: http://localhost/prestashop/

Current theme in use: default

Share this post


Link to post
Share on other sites

Hello, nguyen, you can force the generation of a new htaccess file from your 1.5.1 backoffice by simply turning off and on your Friendly URL option. It is a good idea to clear the cookies and cache when you do this.

Excuseme! I'm not IT technician, so I don't know how to do as you talk! Please tell me more! Thank so much!

Share this post


Link to post
Share on other sites

Hello ngueyen,

 

First, you should create and confirm a working back up of your store.

 

In PrestaShop 1.5.1 in your Back Office, please navigate to Preferences/ SEO and URL scroll down until you see a Friendly URL option and toggle that function to force a regeneration of the htaccess code.

 

To Clear the smarty cache - go to cache/smarty and delete files in both folders (do not delete index.php)

 

To learn about how to clear the cookies from different browsers, you can read this link

Share this post


Link to post
Share on other sites

Hello ngueyen, First, you should create and confirm a working back up of your store. In PrestaShop 1.5.1 in your Back Office, please navigate to Preferences/ SEO and URL scroll down until you see a Friendly URL option and toggle that function to force a regeneration of the htaccess code. To Clear the smarty cache - go to cache/smarty and delete files in both folders (do not delete index.php) To learn about how to clear the cookies from different browsers, you can read this link

 

Thank you! My problem is solved!

Share this post


Link to post
Share on other sites

In local, there are no problems as i can change the max_input_vars by myself. But online, the server i use doesn't allow the change of this value. The unique solution is to change in local mode the files then to send them online.

Share this post


Link to post
Share on other sites

In local, there are no problems as i can change the max_input_vars by myself. But online, the server i use doesn't allow the change of this value. The unique solution is to change in local mode the files then to send them online.

 

You can always ask your provider if he could change the value of this parameter

Share this post


Link to post
Share on other sites

Hello hobbes, that is very strange that they would say this to you. PresatShop doesnot take enough space or memory for you to require a VPS, I suggest you take a look at www.bluehost.com/prestashop . You will not need a vps and overall BlueHost has great configuration and compatibility/speed with PrestaShop

 

my clients have used the services of OVH, but gave up a long time ago, mainly due to poor support. Some of them just moved to Bluehost and I must admit that it is much better!

Share this post


Link to post
Share on other sites

Hi, can anyone help me! i have the same problem...

 

i use prestashop 1.5.2 & MAMP

 

i cannot change it.... already done like Benjamin Utterback says but i cannot do this step :

 

"To Clear the smarty cache - go to cache/smarty and delete files in both folders (do not delete index.php)"

 

Or

 

If you know how to change the .htaccess great ....

 

Or

 

Where i can change the php.ini on MAMP

 

 

Many Thanks..

Share this post


Link to post
Share on other sites

Well, i'm on a mutualized plan and the config is the same for everybody.

 

For the Bluehost, i don't know them but it seems their servers are only in US. I prefer a provider located in France for better comfort and speed.

Share this post


Link to post
Share on other sites

This is what i did and answer (my provider is OVH) was "not possible on this plan. You need a VPS server".

My provider is maybe the worst in Italy and they don't allow any edit to php.ini for the shared hosts, but when I asked them to modify JUST that string, they did it with no problem. Try to ask them again very gently and just for max_imput_vars

Share this post


Link to post
Share on other sites

Hello all, it is certainly strange that OVH is suggesting a VPS, it could be a low level VPS, that seems like an extreme case. Hobbes, I will ask my team for a recommended Hosting Provider that will work for you. You can also use Mura82's suggestion to simply ask again, maybe another representative will help you.

Share this post


Link to post
Share on other sites

Hello all, it is certainly strange that OVH is suggesting a VPS, it could be a low level VPS, that seems like an extreme case. Hobbes, I will ask my team for a recommended Hosting Provider that will work for you. You can also use Mura82's suggestion to simply ask again, maybe another representative will help you.

 

Hi benjamin :)

 

Maybe good thing is also to update prestashop source. I mean that issue with "max_input_vars" occur only in translation feature. It's because when we want to translate ONE module, we go to the translation page where other module is loaded too. Maybe good thing is a feature, where we can translate only ONE module, not all. simple solution, and make the whole process will be faster :)

  • Like 1

Share this post


Link to post
Share on other sites

my solution writed above works with PHP in version 5.3.9+

 

if it doesn't work for you you can add in prestashop backoffice (tools->generators / htaccess file generation) this line:

 

php_value max_input_vars 6000

 

for me this works :) thank you

Share this post


Link to post
Share on other sites

  • 10 months later...

Sometimes php.ini won't allow to edit by your hosting provider and .htaccess won't work, i've used .user.ini, it helped me to solve this max_input_vars problem, just created in directory where is prestashop installed file named .user.ini and put there code max_input_vars = xxxx (where xxxx your desired number of lines how much you needed 1000, 2000, 3000 etc.).

  • Like 1

Share this post


Link to post
Share on other sites

  • 7 months later...

Sometimes php.ini won't allow to edit by your hosting provider and .htaccess won't work, i've used .user.ini, it helped me to solve this max_input_vars problem, just created in directory where is prestashop installed file named .user.ini and put there code max_input_vars = xxxx (where xxxx your desired number of lines how much you needed 1000, 2000, 3000 etc.).

 

Perfect this worked for me too! Thx

  • Like 1

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 5 months later...

Hi

I've this error message:

 

Attenzione! La tua configurazione PHP limita il numero di campi dei post nel form 1000 per max_input_vars.
Per favore chiedi al tuo provider di aumentare questo limite ad 1404 almeno, o si dovranno modificare i file di traduzione.

 

I use xampp for MAC

 

Can you help me?
Thanks
Alessandro

Share this post


Link to post
Share on other sites

Hi

I've this error message:

 

Attenzione! La tua configurazione PHP limita il numero di campi dei post nel form 1000 per max_input_vars.

Per favore chiedi al tuo provider di aumentare questo limite ad 1404 almeno, o si dovranno modificare i file di traduzione.

 

I use xampp for MAC

 

Can you help me?

Thanks

Alessandro

 

 

you have to increase max input vars param of php settings:

have you tried solutions mentioned before ? (first page of this thread)

Share this post


Link to post
Share on other sites

  • 10 months later...
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More