Jump to content
Sign in to follow this  
Česká Faktura

Návod na upgrade Prestashop 1.5.0.17 na 1.5.1.0

Recommended Posts

Upgrade Prestashopu 1.5.0.17 na 1.5.1.0 pomoci modulu 1 click upgrade vyzaduje urcitou pripravu predtim nez upgrade spustime. Pokusim se popsat jak vse udelat tak, aby upgrade probehl spravne.

 

Predtim nez zacnete cokoliv delat provedte zalohu vsech souboru na serveru plus zalohu databaze v phpmyadmin !!!

 

nespolehejte na rollback v modulu

 

1) musite bezpodminecne prejit na novy file system pro obrazky jelikoz 1.5.1.0 automaticky pouziva novy a take pridava priponu _default za jmeno sablony obrazku.

 

!!!!* Pokud mate vic nez 200 polozek v eshopu budete muset vse udelat na localhostu jinak se vam prevod nepovede a system obrazku si pravdepodobne rozhodite(samozrejme zalezi na hostingu pokud mate VPS tak by nemel byt problem)

 

a) v nastaveni->obrazky prejmenujeme sablony obrazku pridanim _default za jmeno sablony

 

takto by to melo vypadat:

1 small_default

2 medium_default

3 large_default

4 thickbox_default

5 category_default

6 home_default

7 scene_default

8 m_scene_default

 

b ) presunte obrazky pomoci nastroje v nastaveni->obrazky

 

c) nastaveni->obrazky - Použít starý souborový systém pro obrázky - NE a Ulozit

 

d) nastaveni->obrazky - Regenerovat miniatury pro všechny obrázky (obrazky mame zalohovane takze muzeme nechat smazat stare)

 

Obrazky jsou pripraveny zkontrolujte zda se zobrazuji vsechny obrazky ve vasem eshopu pokud ano vse probehlo spravne a muzeme se vrhnout na upgrade.

 

2) Provedeme upgrade pomoci modulu autopgrade (1-click Upgrade) Verze :0.8.6 (pokud ho nemate je dole v priloze)

 

a) vypneme eshop nastaveni->udrzba> povolit eshop NE

 

b ) doporucene nastaveni : Backup my files and database NO (zalohu jiz mame)

Back up my images NO (zalohu jiz mame)

Deactivate custom modules Yes

Ostatni nechame tak jak je nastaveno

 

vsechny body Checks jsou zelene spustime upgrade

 

Muze se objevit chybova hlaska ze modul autoupgrade se nepovedlo aktualizovat coz nevadi pokud se objevi jina hlaska ctete co je spatne a pripadne cely proces opakujte.

 

 

 

* pokud vam po upgradu bude eshop hlasit pri objednavce ze objednane zbozi neni jiz k dispozici nahradete soubor classes/cart.php stejnym soubor z verze 1.5.0.17 to problem odstrani.

 

Tento postup jsem pouzil u eshopu s 5320 polozkami a vse fungovalo a eshop bezproblemu bezi na nove verzi.

 

navod jsem delal z hlavy tak snad je vsechno spravne kazdopadne za nic nerucim :)

 

Preju hodne stesti!

autoupgrade.zip

Edited by Ventos312 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More