Jump to content
mic84

Passage 1.5.017 à 1.5.1 probleme Panier

Recommended Posts

bonjour,

 

en 1.5.0.17 le panier fonctionne normalement

 

passage en 1.5.1.0 l'article se met dans le panier puis en cliquant sur commande on arrive sur le résumé de la commande et j'ai un message erreur en rose

------------------------------

 

" Il y a 1 erreur

  1. Un élément de votre panier n'est plus disponible pour cette quantité, vous ne pouvez pas continuer votre commande.

« Retour "

---------------------------------

et dessous il est affiché le produit avec tous les éléments

 

si je fais suivant il reste sur la même page

 

--------------

entre les deux versions je n'ai pas fais de manip sinon la régénération des images produits

 

 

cordialement

 

Michel

Share this post


Link to post
Share on other sites

Bonjour, le probleme pourrait bien venir d'une mauvaise écriture des tables lors de la mise a jour : regarde les photos de la table ps_stock_available de la version 1.5.0.17 et de la version 1.5.1

post-35477-0-47679600-1349517248_thumb.jpg

post-35477-0-72053200-1349517257_thumb.jpg

Edited by le grenier (see edit history)

Share this post


Link to post
Share on other sites

bonjour, merci pour votre aide,

 

effectivement la table ps_stock_available a des noms d'index modifiés .les 2 encadrés en rouge sur votre photo.

 

j'ai renommé les deux index comme en 1.5.0.17 fallait t'il les modifer?

 

j'ai essayé en faisant un import de la table 1.5.017 sur 1.5.1.0.

 

doit on executer une reindexation suite au changement, je ne sais pas comment proceder?

 

je n'ai pas solutionné pour l'instant.

 

Cordialement

 

Michel

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai le même problème avec la 1.5.1.0, en allant voir la BDD, j'ai la table de gauche, et non celle de droite (en référence au image du post juste au dessus)

 

En revanche je n'ai pas utilisé le module de mise à jours, j'ai fait la mise à jours manuellement.

Share this post


Link to post
Share on other sites

bonsoir a vous je n'ai pas résolu le probleme non plus, je ne sais pas comment il faut faire, mais il y a de fortes chances que le probleme viennent de la.

 

La 1ere photo est ma version 1.5.0.17, et celle de droite ce que l'on devrait avoir après une mise a jour (mais bien sur qu'on a pas !!!)

 

y a t il un moyen de corriger la base, car cela implique certainement d'autres tables ....

Share this post


Link to post
Share on other sites

bon j'ai trouvé le soucis, dans le fichier

 

classes/Cart.php à ligne 446, remplacer

 

 $sql->innerJoin('product_shop', 'product_shop', 'product_shop.id_shop='.$id_shop);

 

par

 

 $sql->innerJoin('product_shop', 'product_shop', 'product_shop.id_product = p.id_product AND product_shop.id_shop = '.$id_shop );

 

pour ceux qui le désire, je joins le fichiers corrigé

 

Cart.php

Share this post


Link to post
Share on other sites

bonjour,

 

merci pour vos réponse,

 

personnellement j'ai essayé de mieux réussir mon importation de produit et de catégorie.

 

après plusieurs tentatives j'ai réussi finalement à ne plus voir apparaitre ce problème au niveau du panier et j’espère ne plus le rencontrer.

 

il est difficile d’être certain d’où cela provient.

pour ma part j'avais des sous-catégories avec même nom "c'est interdit totalement"

d'autre part j'ai mis ignoré au champ date d'ajout produit et une seule catégorie par produit.

 

depuis hier mon site en développement fonctionne.

 

mais beaucoup de question reste.

 

Cordialement

 

Michel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More