Jump to content
jcmht

Module "sendadevis" - fourni en Décembre 2010 [gratuit]

Recommended Posts

Bonjour, j'avais fourni gratuitement en 2010 ce module, sur des anciens post, l'archive parrait corrompue, je me permet donc de le soummettre ici à nouveau.

 

Quelques explications :

 

j'avais developpé vite fait ce module pour mon activité ; Je l'ai mis sur le forum Gratuitement afin d' en faire profiter (je ne suis pas développeur - donc pas de support ...)

 

je l'ai testé sur la 1.5 et il fonctionne aussi

 

je répète ici les mofifs à faire :

 

1 - Dans sendadevis.TPL : Remplacer ligne 138 : value="votre@email.com" par : value="votreadresse@email.com"

 

2 - Dans sendadevis.PHP : Remplacer à la ligne 73 et 74 : ..... votre@email.com par votre adresse email comme à l'étape 1

 

Voilà, je l'ai fais moi même avec une adresse perso un peu longue sur hotmail.fr, et aucun soucis

d'autre boutiques que j'ai trouvé par hasard sur le web l'utilisent aussi.

 

je joint ici le module - il n'y a que ça à faire, donc si vous le faites bien, ça marche ! pas d'autre support, car je n'ai malheureusement pas le temps, et je pense qu'il n'y en a pas besoin ... je ne suis pas developpeur, alors si j'y suis arrivé, je pense que vous le pouvez aussi ;-)

 

P.S.: Si un dev, passe par là, je souhaiterais ajouter juste un morceau de code pour quand on clique sur le bouton dans la page produit, que les déclinaisons soient prises en compte....

j'ai pas réussi.... si qq peu m'aider, je mettrai lemodule à jour dans le forum ;-)

sendadevis.zip

  • Like 3

Share this post


Link to post
Share on other sites

Merci pour ce module très utile, par contre quand on est sur la demande de devis, les liens via les cms comme livraison ... ne fonctionnent plus, car redirigé vers : site/modules/sendadevis/cms.php?id_cms=1.

Est-ce qu'il y a une solution pour rediriger vers :site/cms.php?id_cms=1.

 

Merci d'avance

Share this post


Link to post
Share on other sites

Ce module marche en local? Je l'installe et dès lors qu'il est installé toutes mes fiches produits sont blanches je ne peut plus voire la page en question. Une idée?

 

En tout cas très bonne idée de module :)

Edited by apcojt (see edit history)

Share this post


Link to post
Share on other sites

Pour moi ce module marche très bien en local, à part si on veut revenir en direct sans passer par le bouton retour sur le site. Il se plaçait en pleine page sur mon site, j'ai donc rajouté une div dans le tpl pour que mes catégories et panier ne soit pas en dessous. Peut-être ton problème vient d'un placement qui ne se fait pas bien. essaie sur le thème prestashop de base pour voir.

Personne n'a d'idée pour ma question précédente.

Share this post


Link to post
Share on other sites

Je suis actuellement sur le thème par défaut, faut il faire quelque chose d'autre de particulier lors de l'installation? (Autre que changer les mail)

Share this post


Link to post
Share on other sites

Personnellement, je n'ai rien fait d'autre et il marche parfaitement, essaie de le réinstaller. Tu es bien passé par installation de module ?

Share this post


Link to post
Share on other sites

Oui Oui je ne comprend pas, j'ai même installé une nouvelle boutique pour vérifier et le même problème écran totalement blanc dès que l'on clic sur un produit....

Share this post


Link to post
Share on other sites

Bizarre tu as bien téléchargé le dernier sendadevis mis en ligne, tu es sur quelle version de prestashop ? je suis restée sur la 1.4.7.3. Si tu le désactives tu as à nouveau tes produits ?

Share this post


Link to post
Share on other sites

Oui lorsque je le réactive je retrouve ma page produit :s et j'ai bien la dernière version...

Je suis sur la dernière version 1.5.2

Share this post


Link to post
Share on other sites

Justement, il ne fonctionne peut-être pas bien avec la dernière version de Prestashop. J'ai lu qu'il y avait pas mal de soucis pour l'instant

Share this post


Link to post
Share on other sites

Désolée, je ne vois pas, est-ce que vous avez bien vidé le cache ? Moi il fonctionne bien. Je ne vois pas ce qui peut clocher

Share this post


Link to post
Share on other sites

Oui même en vidant le cache toujours ce problème. J'essaye dans peu de jour de l'installer en ligne avec une version plus ancienne je vous redirez quoi. Par ailleurs existe il un module de demande de devis autre?

 

Cordialement,

Share this post


Link to post
Share on other sites

meme probleme que apcot dès que je clique sur un produit ça me donne une fenêtre blanche, personne n'a trouvé une solution pour ce probleme ?

 

//Edit.

 

je debute avec prestashop aujourd'hui et j'ai passer quelques heures a faire des recherche sur ce probleme pour l'instant j'ai pu enlever la page blanche mais d'autre erreur ce presente.

pour debuter:

 

Ouvrez le le fichier Config.inc.php dans le dossier config et editez le,

Modifiez la valeur de "display_errors" en le passant a 'on';

 

Déjà là on peut voir les erreurs qu'on a au lieu de la page blanche, apres d'apres l'erreur qui s'affiche il faudra supprimez les {/if} dans les fichier "product_page.tpl" et "block_add_to_cart.tpl"

 

votre produit s'affiche maintenant mais d'autre erreurs sont present quand on appuis sur "Demander un devis". et c'est là ou je bloque donc si quelqu'un peut continuer a dechiffrer les erreurs et/ou les regler ce serait d'une grande aide.

Edited by keitaro49 (see edit history)

Share this post


Link to post
Share on other sites

Bonsoir,

Fonctionne sur PS 1.5.3 !

J'avais le même problème de page blanche suite à l'installation du module, voici ce que j'ai fais pour arriver à le faire fonctionner :

- Configuration de l'adresse mail dans les 2 fichiers, comme indiqué par jcmht (que je remercie au passage pour ce module !)

- Activation du mode debug :

Modification de la ligne 28 du define.inc.php : define('_PS_MODE_DEV_', true);

Ceci m'a permit de voir les erreurs successives, si vous appliquez ma solution, vous n'êtes pas obligé d'activer le debug, mais ça peut aider à comprendre ;)

- supression du {/if} et de toutes les lignes vides dans le fichier sendadevis/product_page.tpl

- supression du {/if} et de toutes les lignes vides dans le fichier sendadevis/block_add_to_cart.tpl

- Modification du fichier sendadevis/send-devis.tpl :

remplacer {include file=$tpl_dir./breadcrumb.tpl}

par {include file="$tpl_dir./breadcrumb.tpl"}

et

{include file=$tpl_dir./errors.tpl}

par {include file="$tpl_dir./errors.tpl"}

Il manquait les doubles cotes !

 

Ensuite, on peut avoir besoin de modifier le formulaire de saisie, si j'ai vos encouragements, je pourrais donner des tuyaux là dessus :)

  • Like 2

Share this post


Link to post
Share on other sites

 

Ensuite, on peut avoir besoin de modifier le formulaire de saisie, si j'ai vos encouragements, je pourrais donner des tuyaux là dessus :)

 

Tu as mes encouragements virtuel a 200% B)

Merci déjà des info pour vraiment activer le module il est du coup fonctionnelle

 

Cependant j'aimerais utiliser le module sur ma boutique et plus spécialement sur 2 catégories de produits.

J'aimerais donc savoir si vous savez comment faire afin de spécifier que le module apparaisse juste dans les catégories voulu ...

 

Merci de votre soutien !!

Share this post


Link to post
Share on other sites

Bonjour

Tout d abord merci beaucoup à jcmht pour son module

Ensuite merci à Modock d'avoir régler le problème de la page blanche. Le module fonctionne correctement mais si je suis en mode debug je peux voir encore quelque erreur

 

Il y a lorsque je suis sur la page du formulaire de demande de devis ces erreurs au tout début

 

Warning: Function displayHeader() is deprecated in C:\wamp\www\header.php on line 39

in C:\wamp\www\classes\Tools.php on line 1777

 

Warning: Function addCSS() is deprecated in C:\wamp\www\modules\blockcms\blockcms.php on line 771

in C:\wamp\www\classes\Tools.php on line 1777

 

Et juste à la fin du formulaire avant mon footer j'ai cette erreur

 

Warning: Function displayFooter() is deprecated in C:\wamp\www\footer.php on line 39

in C:\wamp\www\classes\Tools.php on line 1777

 

Ce sont des Warning donc je sais que ce n'est pas vraiment urgent mais bon je préfère éliminer ce genre de choses. Mais voilà j'arrive pas vraiment à comprendre ce qui cloche visiblement dans devis-form.php

 

Edit : et pour changer les champs du formulaire tu as tout mes encouragement !

Edited by Tatoo (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

vous serez il possible de poster le dossier avec les fichiers déjà modifiés ?

 

Merci a vous

Share this post


Link to post
Share on other sites

Pour obtenir le module ---> post numéro 1

Pour le faire marcher -----> faut siffler un coup :lol:

 

Oupss ben faut lire !!! Et ainsi tu en sauras plus !! B)

  • Like 1

Share this post


Link to post
Share on other sites

réponse pas très intelligente

cela ne m'aide pas du tout

si j’étaie administrateur je t'aurai déjà expulser de ce forum

Share this post


Link to post
Share on other sites

De l'expulsion !! Tiens un huissier de justice

Désolé si je t'ai vexé et si tu n'as pas d'humour !! :huh:

 

Cependant tu demandes :

 

Bonjour comment peut ton faire marcher ce module et comment l'avoir

 

Comment le faire marcher : installation classique d'un module et pour le coté technique lire le post entier !!

​Après si tu as des difficultés spécifique à toi aussi d’être plus clair dans ta demande !!

 

Comment l'avoir :

Pour obtenir le module ---> post numéro 1 ( jpeux pas être plus clair pour t'aider ) :blink:

  • Like 2

Share this post


Link to post
Share on other sites

Bonjour,

 

Le module fonctionne en 1.5.2, mais la photo du produit n'est pas affiché.

A la place de la photo du produit il y a une petite vignette avec une page brisé de 18*20, pourtant le lien ensuite en cliquant sur photo fonctionne.

 

Quelqu'un a t-il une idée ?

 

Cdt

Share this post


Link to post
Share on other sites

J'ai trouvé il faut modifier le fichier send-devis.tlp a la ligne 20 changer le titre de dimension de l'image par un titre qui existe dans votre configuration

Share this post


Link to post
Share on other sites

Bonjour et merci pour ce module qui va m'être bien utile.

 

Par contre j'ai un petit soucis qui est assez dérangeant à savoir que j'ai pas mal d'image qui ne s'affiche plus ou de JS qui ne fonctionne plus à cause de l'adresse de la page.

 

I à t'il un moyen de remédier à ce problème ?

Share this post


Link to post
Share on other sites

merci mais je comprend pas cela est pour régler le souci de fiches produits sont blanches

Bonjour,

Comme l'a justement indiqué Lokiiy, la solution a déjà été donnée dans ce topic. Un peu de lecture est la bienvenue...

 

En tout cas, je voulais surtout dire un énoooorme merci à Jcmht pour ce module, ainsi qu'à Modock pour avoir partagé sa solution ! Vous m'avez épargnée de longues heures de recherche et de code, alors merci beaucoup !

Par contre je n'utilise pas le thème par défaut : est-ce que quelqu'un saurait comment intégrer ce module à un autre thème que celui par défaut ? Car il fonctionne mais s'affiche de manière affreuse.

Edited by CamilleFr (see edit history)

Share this post


Link to post
Share on other sites

Bonjour

 

Le module fonctionne correctement si toutes les explications sont suivies correctement merci à vous.

 

Si vous le souhaitez je peux mettre a dispo mon fichier ZIP modifié avec les bonnes infos il vous restera juste a modifier votre adresse mail

 

merci @ vous

Share this post


Link to post
Share on other sites

Bonjour,

Je veux bien que vous partagiez votre fichier zip, merci beaucoup.

J'ai sans doute loupé une étape dans la modification des fichiers mais je ne sais pas laquelle.

Merci beaucoup.

Share this post


Link to post
Share on other sites

Bonjour,

 

voici le module modifié pour la version 1.5.2

 

il faut modifier renseignervotreemail@free.com a la ligne 138 du fichier send-devis.tpl par votre propre adresse mail et aussi sur les lignes 73 et 74 du fichier sendadevis.php

 

voila @++

sendadevis.zip

Share this post


Link to post
Share on other sites

Merci beaucoup ! Je vais tenter de le mettre en place, en espérant que ça fonctionne.

Share this post


Link to post
Share on other sites

Alors j'ai bien ré-installé le module ... mais j'ai toujours le même problème, le formulaire ne prend pas la bonne mise en page.

Pour info, j'utilise le thème Leo Shoes (comme base, je compte modifier le design par la suite).

Je m'arrache les cheveux avec ça depuis hier, donc si quelqu'un a une solution (je pense qu'il y a un bout de code à modifier) je suis preneuse. Et inversement, si jamais je trouve la solution je viendrais la partager ici.

Share this post


Link to post
Share on other sites

Pour info, j'ai tenté de remplacer le code du fichier send-devis.tpl du module par celui de mon fichier contact-form.tpl, et l'affichage est aussi mauvais. Alors que si je fais l'inverse, càd remplacer le code du fichier contact-form.tpl par celui de send-devis.tpl, tout s'affiche correctement.

Le soucis ne vient donc pas du fichier .tpl mais sans doute du fichier devis-form.php du module, non ?

 

J'ai donc en fichier devis-form.php le même que vous :

<?php
require(dirname(__FILE__).'/../../config/config.inc.php');
include(dirname(__FILE__).'/../../header.php');
include(dirname(__FILE__).'/sendadevis.php');
$SendADevis = new sendadevis();
echo $SendADevis->displayForm();
include(dirname(__FILE__).'/../../footer.php');

 

Et pour info, mon fichier contact-form.php est le suivant :

<?php
require(dirname(__FILE__).'/config/config.inc.php');
Tools::displayFileAsDeprecated();
Tools::redirect('index.php?controller=contact'.($_REQUEST ? '&'.http_build_query($_REQUEST, '', '&') : ''), __PS_BASE_URI__, null, 'HTTP/1.1 301 Moved Permanently');

 

La modification doit-être elle effectuée à ce niveau là ou je me plante totalement et le soucis vient d'un autre fichier ?

Edited by CamilleFr (see edit history)

Share this post


Link to post
Share on other sites

Salut Camille.

 

Juste une piste :

Tu utilises le thème Léo Shoes. Je crois que celui-ci a des problèmes de compatibilité avec le module de navigation à facette. Désactive ce module s'il est installé.

Edited by bigyom (see edit history)

Share this post


Link to post
Share on other sites

Salut, et merci pour ta réponse rapide. Malheureusement j'ai essayé en désactivant la navigation à facette (qui ne m'a d'ailleurs jamais posé problème avec le thème Leo), et rien ne change.

Quelle partie du code du module appelle le design du formulaire ? Quelque chose doit clocher par là, mais je ne sais pas vraiment où regarder ...

 

Je me permet de vous mettre les copies d'écrans de mon formulaire de contact et du formulaire de devis. Peut-être que ça sera plus parlant. En fait send a devis fonctionne, le seul soucis c'est qu'il s'affiche en "brut" sans prendre en compte le thème.

 

contactyf.jpg

 

devisr.jpg

Edited by CamilleFr (see edit history)

Share this post


Link to post
Share on other sites

J'ai enfin trouvé d'où vient le problème :

Etant donné que je ne trouvais pas de solution, j'ai tenté le tout pour le tout en changeant de thème. Et là c'est pareil, le formulaire s'affiche mal. Puisque j'utilise la version 1.5.4.0. de Prestashop j'ai retenté avec la version 1.5.3. et maintenant ça fonctionne.

Il y a donc une incompatibilité avec la version 1.5.4.0. Je n'ai pas encore trouvé quoi modifier donc je vais rester à la version 1.5.3. pour l'instant au lieu de m'arracher les cheveux avec ça. :)

Edited by CamilleFr (see edit history)

Share this post


Link to post
Share on other sites

Bonjour !!

 

Merci beaucoup jcmht pour ce module gratuit qui fonctionne super bien sur la version 1.5.3.

 

Je souhaite savoir comment faire pour changer l'emplacement du bouton "demande de devis" sur la page produit.

 

Merci beaucoup !

Share this post


Link to post
Share on other sites

bonjour merci vraiment pour ce module mais l image du produit ne s affiche pas dans la page du formulaire d envoi!!!solution???

Share this post


Link to post
Share on other sites

Bonjour à tous

 

Merci pour ce partage amicale , Bravo , excellent travail , j'ai vu sur le forum certains le vendent. ??

 

Amitiés

Edited by SMOK KYF (see edit history)

Share this post


Link to post
Share on other sites

j'utilise prestashop 1.5.4.1 et j ai tjs le message d erreur "An error occurred during the process" car la fonction ne passe pas.connaissez vous la solution svp???

Share this post


Link to post
Share on other sites

Bonjour à tous

 

 

@Amro j'ai la même version que toi chez moi ça fonctionne , je ne suis pas sur désactive le module facette j'ai vu ça sur le forum une personne avait le même problème que toi. Bon courage

 

Amitiés

Share this post


Link to post
Share on other sites

Bonjour Amro

 

Merci , C'était quoi , cela peut servir à nos amis (es) du forum !!

 

Amitiés

Edited by SMOK KYF (see edit history)

Share this post


Link to post
Share on other sites

franchement je me rappel pas tellement je travail sur le projet :( un grand cumul des données

mais dorénavant je mettrais les explications

Edited by amro (see edit history)

Share this post


Link to post
Share on other sites

Bonjour à tous

 

Alors que tout fonctionnait ?? Quand je clique sur devis le footer se retrouve en haut ?? Une fois le devis désactiver tout fonctionne correctement

 

Warning: File /var/www/vhosts/localhost/prestashop/header.php is deprecated

in /var/www/vhosts/localhost/prestashop/classes/Tools.php on line 1845

 

Warning: Function displayHeader() is deprecated in /var/www/vhosts/localhost/prestashop/header.php on line 40

in /var/www/vhosts/localhost/prestashop/classes/Tools.php on line 1845

 

Merci par avance

 

Amitiés

Edited by SMOK KYF (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Le code de ce module est très ancien et n'est pas adapté à Prestashop 1.5, d'où les messages d'erreurs que vous obtenez.

J'ai mis à disposition hier un module similaire sur le forum qui fonctionne de la même manière mais optimisé pour Prestashop 1.5.

 

(Lien de téléchargement supprimé)

 

Vous pouvez changer le texte dans les traductions du module une fois celui-ci installé, dans le BO -> Localisation -> Traductions

Dans Modifier les Traductions, dans la liste déroulante sélectionnez Traductions des modules installés puis cliqué sur le petit drapeau français. Normalement tout en bas de la page vous devrez voir le module productcontact et en modifier le texte des traductions.

 

Dans la configuration du module, vous pouvez saisir un texte qui s'affichera en haut du formulaire et paramétrer la taille des pièces jointes et des extensions autorisées.

 

Si vous souhaitez ajouter des champs supplémentaires, dites moi quels types de champs et si ils sont facultatifs ou obligatoires.

 

A+

Edited by Matt75 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour à tous

 

Merci beaucoup Matt75 pour votre intervention et le partage de ce module qui fonctionne très bien "félicitation".

 

S.V.P , Pouvez vous ajouter une option permettant de personnaliser le formulaire "Activer ou désactiver", Les champs marques d'une * doivent être obligatoirement remplis , Numéro Siret ?? J'aimerai ajouter un bouton juste en dessous (Ajouter au panier) , Comme sur le module ( sendadevis ) ??

 

Merci par avance. Bonne journée

 

Amitiés

Edited by SMOK KYF (see edit history)

Share this post


Link to post
Share on other sites

Salut,

 

J'ai ajouté un bouton juste en dessous du bouton Ajouter au panier, le texte de ce bouton est modifiable dans les traductions du module. (Sur la page de configuration du module, en bas dans Gérer ses traductions cliquez sur le drapeau Français)

 

Pour retirer le lien dans la colonne de gauche, dégréffé le module du hook "displayLeftColumnProduct" (Sur la page de configuration du module, en bas dans Gérer ses points d'accroche, cherchez displayLeftColumnProduct, cochez la case puis cliquez tout en bas sur Dégréffer la sélection)

 

Pour retirer le bouton dans la colonne de droite, même manipulation que précédemment mais avec le hook displayProductButtons.

 

J'ai ajouté un champs Siret au formulaire.

 

productcontact.zip

 

A+

  • Like 3

Share this post


Link to post
Share on other sites

Salut

 

Merci beaucoup Matt75. Bravo cela fait très plaisir pour la rapidité de votre intervention et les modifications apportées.

 

Bon week end

 

Amitiés

Edited by SMOK KYF (see edit history)

Share this post


Link to post
Share on other sites

J'ai trouvé il faut modifier le fichier send-devis.tlp a la ligne 20 changer le titre de dimension de l'image par un titre qui existe dans votre configuration

 

J'ai le même problème sur une version 1.5 mais je comprend pas ta solution ?

Qu'est ce que tu as fais pour que cela fonctionne ?

Share this post


Link to post
Share on other sites

Bonsoir,

 

Je viens de tester de mon côté je n'ai pas de problème.

Êtes vous sûr que votre boutique envoi bien les emails lors de l'inscription d'un client ou d'une commande ?

Si vous êtes en local, vous n'avez peut-être pas configuré la fonction mail dans php.ini

Si vous envoyer avec une pièce jointe elle est peut être trop grosse pour être envoyé par mail

 

La fonction Mail de Prestashop peut informer sur la raison de l'echec, il faut pour cela activer le _PS_MODE_DEV_ dans le fichier defines.inc.php dans le dossier config de Prestashop.

 

Cordialement

Share this post


Link to post
Share on other sites

Hello ! Juste une petite astuce pour éviter le duplicate content généré par ce module :

 

Dans le fichier devis-form.php rajouter après l'appel du fichier de config

 

$smarty->assign('nobots', 1);

 

Ce qui donne :

 

<?php

include(dirname(__FILE__).'/../../config/config.inc.php');
$smarty->assign('nobots', 1);
include(dirname(__FILE__).'/../../header.php');
include(dirname(__FILE__).'/sendadevis.php');

$SendADevis = new sendadevis();
echo $SendADevis->displayForm();

include(dirname(__FILE__).'/../../footer.php');

?>

 

Cela rajoute un "noindex" dans les méta du header.

 

Testé sous 1.4.x

 

 

@+

Share this post


Link to post
Share on other sites

Bonjour à tous

 

Je confirme que le module de Matt75 fonctionne très bien, Merci encore

 

Amitiés

Share this post


Link to post
Share on other sites

Bonjour,

 

Je cherche à ajouter une balise title à ce module.

 

J'ai essayé $smarty->assign('meta_title', 'mon titre');

 

Mais ne fonctionne pas.

 

Merci pour vos retours

Share this post


Link to post
Share on other sites

Bonjour,

 

Ce module "sendadevis" fonctionne bien sur ma version 1.4.4.1. Et je remercie le développeur. Cependant je n'arrive pas à obtenir l'image du produit. Il y a un point d'interrogation via Safari, et rien du tout avec firefox.

 

J'ai lu plus avant dans ce post : gillou75 :

- A la place de la photo du produit il y a une petite vignette avec une page brisé de 18*20, pourtant le lien ensuite en cliquant sur photo fonctionne.

- J'ai trouvé il faut modifier le fichier send-devis.tlp a la ligne 20 changer le titre de dimension de l'image par un titre qui existe dans votre configuration.

 

Je n'ai pas bien compris ce que signifie "le titre de dimensionde l'image", Est-ce : title="{$cover.legend}" ?? Qu'est-ce que je dois faire et où je dois substituer ??

 

 

Ligne 20 :

<a href="{$productLink}"><img src="{$link->getImageLink($product->link_rewrite, $cover.id_image, 'medium_default')}" alt="" title="{$cover.legend}" /></a><br/>

  <a href="{$productLink}">{$product->name}</a> 

 

Merci si vous pouvez m'aider.

 

Bonne journée

Share this post


Link to post
Share on other sites

Hello

 

Il s'agit des noms des différents formats d'images qui se trouvent dans le BO (Back Office) à Préférences > images.

Il y a à cet endroit plusieurs formats prédéfinis par prestashop et ton thème.

 

Si ton image n'apparait pas c'est que le format d'images 'medium_default' n'existe pas dans ton BO.

Il suffit de remplacer 'medium_default' par un autre nom de format qui se trouve dans les préférences et qui te correspond le mieux.

Tu peux même en créer d'autres !

Share this post


Link to post
Share on other sites

Bonjour,

 

Je suis toujours à la recherche d'une solution pour ajouté la balise <title> à ce module.

 

Merci à ceux qui pourrait m'aider.

Share this post


Link to post
Share on other sites

Bonjour,

J'ai essayé d'intégrer du css car le formulaire devis s'affiche en brut, quelqu'un a t'il des pistes ?

J'ai essayé de voir par rapport au mode d'emploi de création d'un module, mais ce module n'est pas conçu pareil mais fonctionnel.

Merci

Presta 1.5.3

Share this post


Link to post
Share on other sites

Bonjour j'ai installé se super module , mais j'ai cette erreur sur prestashop 1.5.6.1:

 

(!) Fatal error: Uncaught exception 'SmartyCompilerException' avec le message "Erreur de syntaxe dans le modèle" C: \ wamp \ www \ monsite \ modules \ sendadevis \ product_page.tpl "sur la ligne 5" {/ if} "balise de fermeture inattendue» dans C: \ wamp \ www \ monsite \ tools \ smarty \ sysplugins \ smarty_internal_templatecompilerbase.php en ligne 667

(!) SmartyCompilerException: erreur de syntaxe dans le modèle "C: \ wamp \ www \ monsite \ modules \ sendadevis \ product_page.tpl" sur la ligne 5 "{/ if}" balise de fermeture inattendue dans C: \ wamp \ www \ monsite \ tools \ smarty \ sysplugins \ smarty_internal_templatecompilerbase.php sur la ligne 667

Pile d'appels

# Temps Mémoire Fonction Emplacement

1 0,0011 382968 {Main} () .. \ Index.php : 0

2 0,2475 8652648 DispatcherCore-> dispatch () .. \ Index.php : 28

3 0,2637 9727824 ControllerCore-> run () .. \ Dispatcher.php : 348

4 0,5049 16338392 ProductController-> initContent () .. \ Controller.php : 167

5 0,5049 16338392 ProductControllerCore-> initContent () .. \ ProductController.php : 7

6 15,0352 41097432 HookCore de exec () .. \ ProductController.php : 259

7 15,7211 41636832 SendADevis-> hookExtraLeft () .. \ Hook.php : 475

8 15,7221 41660368 ModuleCore-> display () .. \ Sendadevis.php : 39

9 15,7245 41669416 Smarty_Internal_TemplateBase-> fetch () .. \ Module.php : 1690

10 15,7261 41697608 Smarty_Internal_Template-> compileTemplateSource () .. \ Smarty_internal_templatebase.php : 155

 

Quel<u'un peut il m'aider?

Merci pour votre réponse.

Share this post


Link to post
Share on other sites

Bonjour a tous

 

La version est t elle fonctionnelle  sur Pretashop 1.5.6   ?

 

Merci à tous de vos réponses.

Share this post


Link to post
Share on other sites

Merci de l'info DeyDDy

 

Je vais monter une boutique detest demain et vais tester ce module.

 

@ +

Share this post


Link to post
Share on other sites

Ben je n'ai pas trouver la version que DeyDDy propose ? du coup suis toujours à la recherche d'un module de devis.Dommage car c'est exactement ce que je cherchais...

 

Si je trouve quelque chose, j'en ferai part ici

Share this post


Link to post
Share on other sites

ok. Idem de mon coté... Pour l'instant je suis parti pour intégrer un script externe dans un bloc HTML si y'a pas mieux...

Share this post


Link to post
Share on other sites

Bonjour,

 

Ben je n'ai pas trouver la version que DeyDDy propose ? du coup suis toujours à la recherche d'un module de devis.Dommage car c'est exactement ce que je cherchais...

 

Si je trouve quelque chose, j'en ferai part ici

 

Tu n'as pas trouver?

 

Pourtant le zip est bien présent sur le post que je t'ai indiquer  :)

il s'agit du module sandadevis repris et adapté par Matt75 pour être fonctionnel sur 1.5 qui porte le nom de productcontact

 

mais ce n'est peut être pas le module que tu cherche?

 

@Bientôt

Edited by DeyDDy (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

 

Tu n'as pas trouver?

 

Pourtant le zip est bien présent sur le post que je t'ai indiquer  :)

il s'agit du module sandadevis repris et adapté par Matt75 pour être fonctionnel sur 1.5 qui porte le nom de productcontact

 

mais ce n'est peut être pas le module que tu cherche?

 

@Bientôt

 

Bonjour,

 

 

Tu n'as pas trouver?

 

Pourtant le zip est bien présent sur le post que je t'ai indiquer  :)

il s'agit du module sandadevis repris et adapté par Matt75 pour être fonctionnel sur 1.5 qui porte le nom de productcontact

 

mais ce n'est peut être pas le module que tu cherche?

 

@Bientôt

Oui ok bien trouver effectivement le module fonctionne.

 

Mais, ce n'est pas ce que je recherche.Je recherche un module ou à la fin de la commande un bouton devis remplace le bouton commander et la commande va vers le vendeur qui met un frais de port quelconque et la commande est renvoyée vers l'utilisateur qui valide la commande.

A ce jour, je n'ai pas trouvé ce type de module payant ou non ??

Share this post


Link to post
Share on other sites

Oui ok bien trouver effectivement le module fonctionne.

 

Mais, ce n'est pas ce que je recherche.Je recherche un module ou à la fin de la commande un bouton devis remplace le bouton commander et la commande va vers le vendeur qui met un frais de port quelconque et la commande est renvoyée vers l'utilisateur qui valide la commande.

A ce jour, je n'ai pas trouvé ce type de module payant ou non ??

 

Salut scea,

 

J'ai un module qui pourrait bien répondre a tes besoins 

 

fonctionnalité du module

Dans le procéssus de commande le module ajoute un bouton "envoyer le devis" au moment du choix du paiement 

même bouton que "paypal" ou "payer par chèque" 

 

Seulement voila,a la base il compatible avec PS1.4

 

je viens de faire un test sur 1.5,il fonctionne sauf au moment de validé la commande (page blanche)

mais il prend quand même en compte la commande que l'on retrouve dans le BO.

 

si tu es intéressé je le met à disposition

 

@Bientôt

quoteps1411Devis.zip

Share this post


Link to post
Share on other sites

Salut scea,

 

J'ai un module qui pourrait bien répondre a tes besoins 

 

fonctionnalité du module

Dans le procéssus de commande le module ajoute un bouton "envoyer le devis" au moment du choix du paiement 

même bouton que "paypal" ou "payer par chèque" 

 

Seulement voila,a la base il compatible avec PS1.4

 

je viens de faire un test sur 1.5,il fonctionne sauf au moment de validé la commande (page blanche)

mais il prend quand même en compte la commande que l'on retrouve dans le BO.

 

si tu es intéressé je le met à disposition

 

@Bientôt

Merci beaucoup Deyddy, malheureusement, je ne suis pas développeur.

C'est assez incroyable que personne n'ai fabriqué ce type de module car je pense que beaucoup personnes seraient intéressés.

 

Encore merci

@+

Share this post


Link to post
Share on other sites

Sinon en payant il y a ceux-là :

Prestashop Best Quote 40€

Module Ask for a Quote 70€

Module Devis Premium 1.5 150€

 

Je n'ai rien trouvé en gratuit, ni en overide...

Merci pour les liens mais aucuns d'eux n'a la fonction que je recherche à savoir :

 

Le client sélectionne les articles puis valide l'ensemble du caddy par un bouton devis, la commande part chez le vendeur, celui-ci inscrit les frais de port et la commande est renvoyée à l’utilisateur qui valide la commande.

 

Même payant c'est introuvable ..... Merci quand même.

Edited by scea (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

beau travail, mais j'aimerai ajouter à  productcontact.zip les informations liées aux champs de personnalisation texte et image.

Je n'arrive pas à trouver le code pour insérer les infos dans le formulaire de demande .

Quelqu'un a t il une idée?

FRAN9OIS

Share this post


Link to post
Share on other sites

Bonjour Frichard,

 

Les champs de personnalisation texte et image font partie du formulaire panier, il faut ajouter le produit au panier pour déclencher le stockage de ces informations dans la base de données et des images sur le serveur.

 

Ce module de devis est un formulaire distinct, donc si tu veux pouvoir récupérer les informations de ces champs, il faut les dupliquer dans ce formulaire... Le plus simple reste de demander au client de mettre ces images dans le champs fichier joint (dans un zip) et le reste des informations dans le champs message. Sinon on complique un peu trop le traitement en ajax du formulaire.

 

Cordialement,

Edited by Matt75 (see edit history)

Share this post


Link to post
Share on other sites