Jump to content
shagshag

Module "Nos partenaires"

Recommended Posts

Bonjour,

 

Voici un module qui permet d'afficher une page de partenaires.

Pour chacun d'entre eux on peut définir un nom, une adresse internet, une image et un texte de présentation. Ceux-ci sont modifiable depuis l'administration de la boutique.

 

L'adresse de la nouvelle page est /modules/partners, vous pouvez l'ajouter dans le bloc info ou liens par exemple. Le template de cette page a été testé avec l'apparence par défaut de la version 1 de prestashop. je ne sais pas ce que ça donne sur la 0.9.7.

 

Il y a un exemple d'utilisation sur Nature et Papiers.

 

Si ça peut en aider certain :)

 

-- Edit : j'ai corrigé le fichier de langue qui ne fonctionnait pas

764_R7JQkwukTT72uYLgQ7bq_t

766_qMqTAuRrYYAENudWqe1l_t

partners.zip

Share this post


Link to post
Share on other sites

Bonjour,

 

Comme d'habitude très jolie travail.  ;D

 

Mais la sur celui ci j'ai un petit problème car les écritures dans l'admins reste en anglais...

 

Il y a surement une manipulation à éfféctuer que j'ai surement oublier?  :D

 

Bien cordialement

 

Yoann.

Share this post


Link to post
Share on other sites

Bonjour et merci :)

 

Bin je ne sais pas pourquoi les textes restent en anglais :(

le fichier de traduction fr.php est bien dans le dossier du module ?

Sinon en passant par Outils->traduction->traduction des modules dans l'administration ça marche ?

 

Je remet le fichier de traduction en pièce jointe. Normalement il fonctionne c'est celui qui est sur Nature & Papiers

 

fr.php

Share this post


Link to post
Share on other sites

Bonjour Shagshag,

 

Voila je viens de mettre le fichier "fr.php" est maintenant c'est bien écrit en français.

 

Bonne continuation à vous.

 

Cordialement

 

Yoann.

Share this post


Link to post
Share on other sites

Ok j'ai corrigé le fichier zip à télécharger en mettant ce fichier de traduction.

 

Merci d'avoir signalé l'erreur.

 

Share this post


Link to post
Share on other sites

Salut shagshag, sympa et bien pratique ce petit module mais pour information il ne marche plus sur la RC3. Du moins dans le back office quand tu cliques sur configurer tu as une page blanche.

Share this post


Link to post
Share on other sites

pour info j'ai réussi à faire marcher ce module en modifiant les lignes 251 et 278

la fonction displayFlags ne marche plus pareil, elle est maintenant dans le modèle objet apparament

 

avant

 $this->_html .= displayFlags($languages, $defaultLanguage, $divLangName, 'cpara', true); 

 

après

$this->_html .= $this->displayFlags($languages, $defaultLanguage, $divLangName, 'cpara', true); 

 

par contre j'obtiens toujours une erreur 'Clef de sécurité incorrecte'' en essayant de supprimer un partenaire

Share this post


Link to post
Share on other sites

Tu as surement ce message d'erreur "Clef de sécurité incorrecte" ?

 

oui,que signifie ?

Share this post


Link to post
Share on other sites

Bonjour et merci d'avoir signalé l'erreur,

 

Il y a le même soucis dans le module blocklink :(, en pièces jointes les versions actualisées de ces deux modules.

 

C'était bien une histoire de tokens qui manquaient.

 

Pour info voici les corrections :

fichier /modules/partners/partners.php ligne 308

	 	global $currentIndex, $cookie;

devient

	 	global $currentIndex, $cookie, $adminObj;

 

ligne 315

				var links = new Array();';

devient

				var token=''.$adminObj->token.'';
			var links = new Array();';

 

fichier /modules/partners/blocklink.js ligne 23

 	document.location.replace(currentUrl+'&id='+linkId);

devient

 	document.location.replace(currentUrl+'&id='+linkId+'&token='+token);

 

blocklink.zip

partners.zip

Share this post


Link to post
Share on other sites

Je viens de mettre à jour mais j'ai toujours le message d'erreur "Clef de sécurité incorrecte" quand je veux supprimer une partenaire. Une idée ?

Share this post


Link to post
Share on other sites

Étrange, chez moi ça marche.

 

Le cache est vidé  (touche F5 sur la page de configuration du module) ?

 

Share this post


Link to post
Share on other sites

Je viens de faire un CTRL + F5 et la cela marche. Une question tu mets le dossier "partners" en CHMOD 777 ? Car en 775 j'ai un message d'erreur pour l'upload de l'image et il me semble pourtant qu'avant j'étais en 775.

Share this post


Link to post
Share on other sites

ça dépend de la configuration de ton serveur

 

chez moi, c'est en 777 car php n'est pas dans mon groupe d'utilisateur (donc il faut que les autres aient un droit d'accès) mais s'il est dans ton groupe 775 devrait suffire.

 

 

Share this post


Link to post
Share on other sites

En 775 cela ne marche pas alors je laisse 777 qui marche parfaitement :-) en tout cas un grand merci pour ton aide.

Share this post


Link to post
Share on other sites

une question : comment fait on pour positionner un module dans un template, exemple à un endroit fixé du header

 

je voudrais utiliser le module partners pour mettre une bannière modifiable à souhait

 

 

Share this post


Link to post
Share on other sites

I have a error follow this text :
Fatal error: Call to undefined function displayflags() in /home/oritech/public_html/Oritech/modules/partners/partners.php on line 251
Plz help me!!

Share this post


Link to post
Share on other sites

Bonjour

merci pour ce module, je voudrais ajouter des pages dans ce module, je m'explique.

je voudrais mettre sur la premiere page:

Boutique en ligne ------- club de sport ------- annuaire ---------

et quand on clic sur boutique en ligne on voit apparaitre mes partenaires dans cette categorie

faire comme un annuaire de referencement

merci de vos reponse
sinceres salutations

la boutique

Share this post


Link to post
Share on other sites

Bonjour,

quelqu'un a-t-il installé ce module dans la dernières version de Prestashop ?

Je n'arrive pas à résoudre le téléchargement d'image (chmod testé) et lorsque j'installe le module prestashop me donne une erreur comme quoi il n'es pas installé correctement.

Merci.

Share this post


Link to post
Share on other sites

testé sur PS 1.54 et erreur fatale dans partners/partners.php on line 251

Share this post


Link to post
Share on other sites

Bonjour,

Merci pour ce module que j'ai installé rapidement. J'ai paramétré mon premier lien vers le partenaire, mais impossible de l'afficher sur ma boutique.

Je suis en version 1.4.6.2

Quelqu'un a t'il réussi ?

Merci

Share this post


Link to post
Share on other sites

Je relance le Post, j'ai un problème pour la version de presta 1.5.6.1. Quand j'ajoute un lien il me fait une erreur comme quoi le lien n'a pas eu être ajouté, presta m'indique "mysql_insert_id() [function.mysql-insert-id]" alors je sais pas si c'est lié ?

 

Merci!

Edited by jeje34080 (see edit history)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More