Jump to content

Avis aux utilisateurs de Kwixo : tunnel de commande bloqué


Broceliande
 Share

Recommended Posts

Je vais essayer d'être le plus concis possible afin de ne pas m'attirer les foudres de fianet...

 

Les faits :

Kwixo subit ces derniers temps des problèmes avec la solution de paiement à crédit via leur interface.

D'après un technicien kwixo contacté ce matin par une de mes clientes le problème ne viendrait pas d'eux mais de sofinco.

 

Ceci étant dit, nous venons de constater que le module kwixo (nous utilisons la dernière version connue v4.4.14) est suceptible dans certains cas de planter purement et simplement la page de paiement a cause d'un appel distant qui échoue si j'en crois le message.

 

type Rapport d'exception

 

message

 

description Le serveur a rencontré une erreur interne () qui l'a empêché de satisfaire la requête.

 

exception

 

org.s in /home/www/xxxxxxxxx/www/modules/kwixo/fianetlib/kernel/XMLElement.class.php on line 44

 

Nous avons du désactiver le module pour que les clients puissent à nouveau commander sur le site via les autres modes de paiement.

 

En d'autres termes, si quelque chose foire dans le système de cette solution , alors le module plante votre page paiement et personne ne peut plus commander.

 

Je remonte l'info afin que les utilisateurs soient avertis et puissent agir si ils découvrent qu'étrangement plus de commandes n'arrivent dans leur back office.

 

Pour le coup dans le cas présent, le module semble attendre une réponse de tel ou tel serveur mais parait pas gèrer et intercepter les exceptions ou timeouts, ce qui plante prestashop tout court.

Share this post


Link to post
Share on other sites

En d'autres termes, si quelque chose foire dans le système de cette solution , alors le module plante votre page paiement et personne ne peut plus commander.

 

Personne ne peut plus commander, quelque soit le module de paiement ?

Share this post


Link to post
Share on other sites

Bonsoir,

 

Je confirme et je suis rassuré que nous ne sommes pas seuls à avoir ce problème. Nous avons plusieurs boutiques touchées.

Heureusement des clients nous ont contacté et nous avons desactivés de suite le module. Entre fianetfraud (certissim) qui rame tout le temps et fait ramer chaque ouverture de commande dans le back office et maintenant le module kwixo... c'est vraiment pénible. Les conséquences de tous ces aléas l'emportent sur les bénéfices de ces solutions pourtant interressantes. Dommage.

Edited by zi-dan (see edit history)

Share this post


Link to post
Share on other sites

Pour info une nouvelle version du module corrige le phénomène bloquant : en cas d'indisponibilité du serveur le module ne s'affichera tout simplement pas, et votre page de paiement sera convenablement chargée avec les modes de paiement restant.

 

Pour le coup je salue la réactivité des développeurs : la solution au problème d'hier était dans les bacs ce matin...

 

Pour mettre à jour votre module, suivez bien les instructions de maj , en gros :

- Ajoutez la nouvelle version depuis votre BO ou via ftp

- Désinstallez le module

- Réinstallez le

- Rendez vous dans la configuration , vous devriez y retrouver vos paramètres pré-entrés : ré-enregistrez les !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More