Jump to content

Backward compatibility


J. Danse
 Share

Recommended Posts

Bonjour,

 

Atention ! Ce module n´est pas un module magique ! Il ne fait pas le café non-plus, il permet seulement de faciliter le maintient de certains modules entre PS 1.4 et PS 1.5.

Il ne faut pas comprendre qu´en ajoutant ce module vos modules 1.5 fonctionneront en 1.4

 

Bon courage ;)

 

P.S: Effectivement, n´hésitez pas sur les remontés.

Share this post


Link to post
Share on other sites

Désolé c'était juste un petit troll.

 

Ce module n'est necessaire que pour certains modules et ne fonctionne que sur PrestaShop 1.4.

Pour être plus sérieux je pense que cette phrase signifie seulement qu'il fonctionnera uniquement avec les modules de la version 1.4 et supérieur, mais pas avec des modules pour la 1.3 par exemple.

 

Le module lui-même est bien compatible avec la 1.5 comme l'indique la ligne Compatibilité de la page, le logo "Compatible 1.5" et plus raisonnablement le code du module.

Share this post


Link to post
Share on other sites

euh... je n'ai toujours pas compris à quoi il sert ce module... on peut l'utiliser sur 1.4 et/ou 1.5 ??? par ce que :

Ce module n'est necessaire que pour certains modules et ne fonctionne que sur PrestaShop 1.4.

 

et pourtant il y a ce logo : compatible_1_5_icone.png et il y marqué : FDRw.jpeg

Share this post


Link to post
Share on other sites

Oui c'est ce que je signalais, la description du module est mal formulée. Le module est bien compatible avec la 1.4 et 1.5 mais ne permet que de faire fonctionner des modules de la 1.4, et pas les versions antérieures.

Share this post


Link to post
Share on other sites

Et, également, les tests sont souvent parlant, aussi... Sur une 1.4.9.0 toute neuve, le module Backward compatibility installé ainsi que le canvas de module (et donc, me semble-t-il, purement 1.5) ; ça ne fonctionne pas. ;)

 

Je pense, clairement, que la description est à revoir !

Share this post


Link to post
Share on other sites

Bonjour à tous !

Concernant la fiche addons nous sommes entrain de la modifier, le module n´a pas à être utilisé sur la 1.5.

Il apporte aux modules qui l´utilisent des outils qui ne sont présents nativement qu´en 1.5.

 

Le module n´est pas non-plus concu pour fonctionner en 1.3, les problèmes rencontrés sur cette version à cause de l´utilisation de ce module ne bénéficieront d´aucun support. Si il vous aide, tant mieux :)

 

de ce que j'ai compris il ne marche que sur la 1.4 pour faire fonctionner sur cette version des modules qui sont normalement pour la version 1.5. je trouve que le contraire aurait été plus logique mais bon

 

Effectivement, le contraire aurait été plus logique... Disons que cela permet aux développeur de développer leur modules à la manière 1.5 tout en apportant une rétro-compatibilité 1.4.

 

N´hésitez pas si vous avez des questions ou rencontrez des problèmes à l´utilisation de ce module (PS 1.4 biensûr !).

Merci ;)

Share this post


Link to post
Share on other sites

bonjour,

 

personnellement le module me fait buguer mon site =/ j'ai installer paypal 3.2 pour pouvoir installer le "thème mobile" et mon back office me dit que j'ai besoin de backwardcompatibility, je l'installe et PAF plus aucun module de s'affiche =/ est ce qe q''un a déjà eu ce problème ?

ça m'est arrivé sur la version 1.4.3.0 de Presta

Share this post


Link to post
Share on other sites

bonjour,

 

personnellement le module me fait buguer mon site =/ j'ai installer paypal 3.2 pour pouvoir installer le "thème mobile" et mon back office me dit que j'ai besoin de backwardcompatibility, je l'installe et PAF plus aucun module de s'affiche =/ est ce qe q''un a déjà eu ce problème ?

ça m'est arrivé sur la version 1.4.3.0 de Presta

 

Bj,

J'ai le même problème avec la 1.4.9 donc je suis revenu à Paypal 3.0.9

Module Paypal fait disparaitre la liste modules du BO

Edited by jog (see edit history)

Share this post


Link to post
Share on other sites

bonjour,

 

personnellement le module me fait buguer mon site =/ j'ai installer paypal 3.2 pour pouvoir installer le "thème mobile" et mon back office me dit que j'ai besoin de backwardcompatibility, je l'installe et PAF plus aucun module de s'affiche =/ est ce qe q''un a déjà eu ce problème ?

ça m'est arrivé sur la version 1.4.3.0 de Presta

 

Bonjour,

 

Pourriez-vous me fournir un acces à votre boutique (en PM) ? Je vais regarder ce qu´il en est.

P.S : Pensez à mettre votre module à jour, ne restez pas sur PayPal 3.0.9 !

Share this post


Link to post
Share on other sites

bonjour,

 

personnellement le module me fait buguer mon site =/ j'ai installer paypal 3.2 pour pouvoir installer le "thème mobile" et mon back office me dit que j'ai besoin de backwardcompatibility, je l'installe et PAF plus aucun module de s'affiche =/ est ce qe q''un a déjà eu ce problème ?

ça m'est arrivé sur la version 1.4.3.0 de Presta

 

Vérifie ta mémoire

Puis active le define('_PS_MODE_DEV_', true); dans config/defines.inc.php (heu non c'est la 1.5 ça désolé)

Active dans le config/config.inc.php:

@ini_set('display_errors', 'on');

define('_PS_DEBUG_SQL_', true);

 

Bien sur ramène tout à la nominale quand tu as trouvé la source du problème

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

@fGaillard: Le sujet de cette discussion ne serait-il pas plus approprié ailleurs que dans Prestashop 1.5 puisque par définition ça ne s'applique QUE pour des 1.4?

 

Effectivement, mais je n´ai pas les droits. J´envoi une demande ;)

Share this post


Link to post
Share on other sites

Bonjour,

 

Pourriez-vous me fournir un acces à votre boutique (en PM) ? Je vais regarder ce qu´il en est.

P.S : Pensez à mettre votre module à jour, ne restez pas sur PayPal 3.0.9 !

BJ,

Merci d'apporter votre solution sur ce post, moi aussi ça m'interresse <_< ! j'ai le même problème.

  • Like 1

Share this post


Link to post
Share on other sites

de ce que j'ai compris il ne marche que sur la 1.4 pour faire fonctionner sur cette version des modules qui sont normalement pour la version 1.5.

je trouve que le contraire aurait été plus logique mais bon

Nativement, la 1.5 sait faire tourner des modules développés pour 1.4 (au support près des nouvelles fonctions de la 1.5).

 

Je comprends que ce module de backward compatibility permet de faire tourner sur la 1.4 des modules développés "façon 1.5".

Share this post


Link to post
Share on other sites

et bien, j'avais pas vu vos reponses =/ on ne reçoit pas de notification ? bref, depuis j'ai formaté mon serveur et installer la version 1.4.8.2 de presta, avant d'en arrivé là j'avais aussi changer la version de paypal et ça fonctionné mieux. merci à vous tous !

Share this post


Link to post
Share on other sites

  • 3 months later...
  • 1 year later...

Bonjour,

 

Lorsque je désactive le module "paypal 3.8.1" j'ai le message d'erreur suivant:
Fatal error: Cannot redeclare class BackwardCompatibility in /homepages/1/d406254559/htdocs/prestashop_1.4.2.5/degustation-vin/modules/backwardcompatibility/backwardcompatibility.php on line 163

 

Et je n'ai plus accès aux modules!!! Je dois supprimer en ftp le module paypal pour y avoir de nouveau accés.

Comment ce fesse  :)?

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More