Jump to content
vekia

[module] HTML Box Pro - put the code anywhere you want - prestashop 1.7 / 1.6 / 1.5 / 1.4

Recommended Posts

Hello

 

How can add a custom HTML Box to pages like, contact, best-sales, new products and so on?

 

I understand that I could use the specific url function, but this doesn't allow me to chose more than 1! Please help me with that.

Share this post


Link to post
Share on other sites

Hello Vekia,

 

I used this code on "Header" predefined Hook

<div style="width: 30px; height: 100px; display: block; position: fixed; left: 0px; margin-left: 100px; top: 100px; background: none;"><img src="../img/cms/panel-prueba.png" width="261" height="882" div="" /></div>

In product page The image looks different than in Home, why?

post-752463-0-66118200-1423734773_thumb.png

post-752463-0-20957000-1423734799_thumb.png

Share this post


Link to post
Share on other sites

Hello Vekia

 

The more I use your module, the more problem I get. Could you please help.

 

I just wanted to add a block to a cms-category... Is this not possible? CMS-Page works well, but category not!?

 

Also is it not possible to use cms-page and url condition on the same block? I want for example show a block on cms pages 6, 28, 29 and on the url http://www.myurl.com/kontakt

Edited by wakabayashi (see edit history)

Share this post


Link to post
Share on other sites

Hello,

 

I think this is the product i have been looking for, but as yet i am unsure ?

 

I want to add HTML box to 2 places in my product page one under the gallary, another under short description.

 

So far i think this module is good for this ? however i want the HTML to be different for every product so example the HTML box will contain specific external links to the product user manual, this needs to be different on every product.

 

Will this module enable me to do this ? create 2 HTML boxes in the same position on every product page but then the conent be different on every product ? if so will the module also allow me to upload this data via a CSV file like the rest of my product information i have for the specific product ?

 

Many Thanks in advance for your support

Share this post


Link to post
Share on other sites

this module will meet your requirements

addon allows to display unlimited number of blocks on product page (and anywhere else)

  • Like 1

Share this post


Link to post
Share on other sites

Hello Vekia,

 

I bought your HTMLboxpro module yesterday, but got the following error (in debug mode) once i try to add a block anywhere (PS v1.6.0.9):

post-939155-0-42695700-1426668956_thumb.jpg

The HTMLbox worked out of the box, so i thought it would be the same for the pro version.

 

PS: I also send you a message through ur website's contact page

 

Share this post


Link to post
Share on other sites

Hello Vekia,

 

I bought your HTMLboxpro module yesterday, but got the following error (in debug mode) once i try to add a block anywhere (PS v1.6.0.9):

attachicon.giferror.jpg

The HTMLbox worked out of the box, so i thought it would be the same for the pro version.

 

PS: I also send you a message through ur website's contact page

 

 

hello

on module configuration page open "upgrade chceck" section

module will check your installation and if there will be some problems - module will fix then automatically

im convinced that it will help in your case

Share this post


Link to post
Share on other sites

Thanks alot Vekia, that fixed it.

Although i still ain't able to use the following javascript code:

<script id='webwinkelkeur_script_container'>(function () {
_webwinkelkeur_id = 3984;
_webwinkelkeur_theme = 'light';
_webwinkelkeur_color = '#ea0e8b';
_webwinkelkeur_show = 'yes';
_webwinkelkeur_view = 'slider';
_webwinkelkeur_amount = 6;
_webwinkelkeur_width = 'manual';
_webwinkelkeur_width_amount = '250px';
_webwinkelkeur_height = 0;
_webwinkelkeur_interval = 5000;
var js = document.createElement('script');
js.id = 'webwinkelkeur_script';
js.type = 'text/javascript';
js.async = true;
js.src = '//www.webwinkelkeur.nl/widget.js';
var s = document.getElementById('webwinkelkeur_script_container');
s.parentNode.insertBefore(js, s);
})();</script>

This is how it ouputs:

post-939155-0-93805200-1426677263_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks alot Vekia, that fixed it.

Although i still ain't able to use the following javascript code:

<script id='webwinkelkeur_script_container'>(function () {
_webwinkelkeur_id = 3984;
_webwinkelkeur_theme = 'light';
_webwinkelkeur_color = '#ea0e8b';
_webwinkelkeur_show = 'yes';
_webwinkelkeur_view = 'slider';
_webwinkelkeur_amount = 6;
_webwinkelkeur_width = 'manual';
_webwinkelkeur_width_amount = '250px';
_webwinkelkeur_height = 0;
_webwinkelkeur_interval = 5000;
var js = document.createElement('script');
js.id = 'webwinkelkeur_script';
js.type = 'text/javascript';
js.async = true;
js.src = '//www.webwinkelkeur.nl/widget.js';
var s = document.getElementById('webwinkelkeur_script_container');
s.parentNode.insertBefore(js, s);
})();</script>

This is how it ouputs:

attachicon.gifjs.jpg

 

where you inserted this code?

to </> source code tool or just directly to tinymce wysiwyg editor

if second - it's normal in that way. Tinymce treats this as text.

you have to turn on </> source code tool and paste it there.

Share this post


Link to post
Share on other sites

Ye, i tried both ways:

post-939155-0-43573200-1426763157_thumb.jpg

When i put the code directly in the editor it shows the plain text as intended, but when i put it in the source code it does not show anything.

I also tried it in the free HTMLbox module, but same output.

Edited by Yakje (see edit history)

Share this post


Link to post
Share on other sites

Hmm i noticed the javascript code i insert into htmlbox get's changed once saved.

It seems like TinyMCE automaticly adds:

// <![CDATA[ 

at the beginning, and

// ]]

 at the end, i think this is what corrupts the code. 

Share this post


Link to post
Share on other sites

your problem was related to fact that you used page cache and you saw raw code that you pasted to tinymce (probably)

another thing, if you will use "move js scripts to the end" option available in preferences > performance

script you have will not work, prestashop will remove "<script>" elemet and move script contents to the end.

 

it's necessary to alter code,

just create <div> element with the same id="" param as <script> have. everything will work then.

Share this post


Link to post
Share on other sites

Thanks Vekia, this did indeed solve the problem for me!

 

i also sent you email with this explanation

hope that you received it :-)

 

if you will need any kind of support just let me know at support [at] mypresta [dot] eu

i will respond quickly :-)

Share this post


Link to post
Share on other sites

Hello,

I'm using HTMLBox 1.5 with PS 1.6.0.14.  The module is set for Home and hooked to displayHome, but nothing is showing on the homepage.  Please advise :)

Share this post


Link to post
Share on other sites

Hi vekia,

 

I am trying to change the position of a block inside a hook relative to other block in that same hook, but it won't save that position.

 

I am using HTMLBoxPro v2.6.0.2 on Prestashop 1.6.0.14.

 

Please see picture for clarification.

 

post-406825-0-60715700-1429052408_thumb.png

 

Any ideas what is causing this?

 

Cheers

Dan

Share this post


Link to post
Share on other sites

Hello Vekia,

 

i have already bought html box pro version 2.6.0.2 to use in prestashop 1.5 , but when i used it on prestashop 1.6 the html block not showing, Are there any solution for that ?

Best regards

Edited by Ryowbw (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, j'ai la dernière version gratuite elle ne fonctionne pas sur ma version 1.0.6.14 Merci 

Amitiés

Share this post


Link to post
Share on other sites

Hi Vekia,

 

Having issues with HTML Box Pro is PS V1.6.0.14


EDIT: Figured it out. Not compatible with PHP 5.5

 

Reverted back to PHP 5.4 (all ok)

Edited by motion2082 (see edit history)

Share this post


Link to post
Share on other sites

After instalation preety url module (product, category without Id) this module doesn't work properly. You can't  use options like : Only on selected Category pages or product do display Hooks on selected pages.

I have instaled lates version Htm box pro. 2.6.2.

 

Any Idea??

Share this post


Link to post
Share on other sites

After instalation preety url module (product, category without Id) this module doesn't work properly. You can't  use options like : Only on selected Category pages or product do display Hooks on selected pages.

I have instaled lates version Htm box pro. 2.6.2.

 

Any Idea??

 

hello

what friendly urls module you use?

if from fme - there is a little bug (in fme) that removes $_GET param with for example id_product and other identificators like id_category, id_manufacturer etc.

Share this post


Link to post
Share on other sites

I have use fme module, I tested yours module but your module doesn't offer redaraction form old ulr to new. so problem is in fme module??

Share this post


Link to post
Share on other sites

Hello,

 

I have recently purchased htmlbox pro and I struggle to insert content on a selected CMS page (see attached screen shots).

It has already worked once but I have unfortunately deleted that hook. I have now created several hooks and even reinstalled the tool but nothing seems to work.

 

I am using Prestashop 1.6.0.14.

 

Thanks for your help,

Chris

 

 

 

post-1023658-0-42948000-1433139935_thumb.png

post-1023658-0-87645300-1433139937_thumb.png

Share this post


Link to post
Share on other sites

hello Nusserer

have you applied to hook execution function to your .tpl file

and after that, have you cleared cache to recompile theme with new code?

Share this post


Link to post
Share on other sites

hello Nusserer

have you applied to hook execution function to your .tpl file

and after that, have you cleared cache to recompile theme with new code?

 

I have executed my hooks in the cms.tpl and also for testing in index.tpl files and cleared smarty chache. The hooks didn't work in both files regardless if I choose a selected CMS page .

 

cms.tpl

<div class="rte{if $content_only} content_only{/if}">

        {$cms->content}

        {Hook::exec('aboutus')}

        {Hook::exec('reseller')}

    </div>

 

All standard hooks (i use footer and home) work perfectly well and i can create new ones and content without problem.

 

The only thing left I can think of is that I have used a Javascript before to create a contact form on a CMS page. The script had incidently replaced the "save block" button of the edit block with my "form send button". But I have deleted this hock and also the script. Afterwards, I have deleted and reinstalled the htmlbox pro module. But the module kept old the settings and hooks. Is there a way to completely reset the html box pro modul?

 

Thanks, Chris

Share this post


Link to post
Share on other sites

Hello i just purchased the pro version and i have an error 

 

In the "upgrade check" tab, i get a list of errors:

 

I try to refresh an uninstall and install, it is the same problem.

 

Thanks

 

 

bssl Database inconsistency, column does not exist ... ERROR!   shop Database inconsistency, column does not exist ... ERROR!   homeonly Database inconsistency, column does not exist ... ERROR!   productsonly Database inconsistency, column does not exist ... ERROR!   selectedproducts Database inconsistency, column does not exist ... ERROR!   cmsonly Database inconsistency, column does not exist ... ERROR!   selectedcms Database inconsistency, column does not exist ... ERROR!   productscat Database inconsistency, column does not exist ... ERROR!   selected_pcats Database inconsistency, column does not exist ... ERROR!   catsonly Database inconsistency, column does not exist ... ERROR!   selected_cats Database inconsistency, column does not exist ... ERROR!   manufsonly Database inconsistency, column does not exist ... ERROR!   selected_manufs Database inconsistency, column does not exist ... ERROR!   date Database inconsistency, column does not exist ... ERROR!   datefrom Database inconsistency, column does not exist ... ERROR!   dateto Database inconsistency, column does not exist ... ERROR!   urlonly Database inconsistency, column does not exist ... ERROR!   url Database inconsistency, column does not exist ... ERROR!   cgroup Database inconsistency, column does not exist ... ERROR!   hcgroup Database inconsistency, column does not exist ... ERROR!

Share this post


Link to post
Share on other sites

hello Laurent

after refresh "upgrade consistency" section

do you see "OK" instead of "column does not exist" then?

Share this post


Link to post
Share on other sites

I have executed my hooks in the cms.tpl and also for testing in index.tpl files and cleared smarty chache. The hooks didn't work in both files regardless if I choose a selected CMS page .

 

cms.tpl

<div class="rte{if $content_only} content_only{/if}">

        {$cms->content}

        {Hook::exec('aboutus')}

        {Hook::exec('reseller')}

    </div>

 

All standard hooks (i use footer and home) work perfectly well and i can create new ones and content without problem.

 

The only thing left I can think of is that I have used a Javascript before to create a contact form on a CMS page. The script had incidently replaced the "save block" button of the edit block with my "form send button". But I have deleted this hock and also the script. Afterwards, I have deleted and reinstalled the htmlbox pro module. But the module kept old the settings and hooks. Is there a way to completely reset the html box pro modul?

 

Thanks, Chris

i understand 

it's probably because of permissions to htmlboxpro.php file

this file must be writable

once you will add new hook - module creates new htmlboxpro.php file with new hooks support

please verify if file is writable, and if isn't - change permissions

then on module configuration page click on "regenerate hooks" button to regenerate code of new non-default hooks support

Share this post


Link to post
Share on other sites

hello Laurent

after refresh "upgrade consistency" section

do you see "OK" instead of "column does not exist" then?

I see Database inconsistency, column does not exist

Share this post


Link to post
Share on other sites

is there any chance to see your back office?

has your database user permissions to ALTER table command?

Share this post


Link to post
Share on other sites

 

i understand 

it's probably because of permissions to htmlboxpro.php file

this file must be writable

once you will add new hook - module creates new htmlboxpro.php file with new hooks support

please verify if file is writable, and if isn't - change permissions

then on module configuration page click on "regenerate hooks" button to regenerate code of new non-default hooks support

 

 

The permissions for htmlboxpro.php were correct and the file is writable. Also regenerating the hooks did not work.

So I have replaced all htmlbox pro files manually via FTP and deleted all previous non-default. It all new non-default hooks work now.

Must have been the js...

 

Thanks a lot for your help,

Chris

Share this post


Link to post
Share on other sites

The permissions for htmlboxpro.php were correct and the file is writable. Also regenerating the hooks did not work.

So I have replaced all htmlbox pro files manually via FTP and deleted all previous non-default. It all new non-default hooks work now.

Must have been the js...

 

Thanks a lot for your help,

Chris

 

great!

thank you for detailed explanation of the fix you applied

strange that it was a case of js scripts

anyway - it's great that it works now as you expected

if you will need some additional assistance just let me know

Share this post


Link to post
Share on other sites

Hi Vekia, I have HTML Box Pro v2.6.3 with Prestashop 1.6.1.0 and would like to add a facebook like button on my page.

 

I am trying to do what is on the facebook developper page

to create a like button but can't get it to work.

 

On the developper page, it say that I have to include the following JavaScript SDK on my page once, ideally right after the opening <body> tag.

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

Then place the following code for my plugin wherever I want the plugin to appear on your page.

<div class="fb-like" data-href="http://www.miraxsupplements.com" data-layout="button" data-action="like" data-show-faces="false" data-share="true"></div>

How do I incorporate this code to my HTML Box Pro to create a facebook like button?

 

or is there any other way to create a facebook like button with HTML Box Pro?

 

Cheers

Dan

Edited by papagino (see edit history)

Share this post


Link to post
Share on other sites

new version of the module is ready to download and use!

- added improvements related to custom hooks installation / deinstallation process. Now module checks if hook that we want to create and use already exists and depending on that addon will create entries in database or in module only. 

- improved tinyMCE editor

Share this post


Link to post
Share on other sites

Hi Vekia, I have HTML Box Pro v2.6.3 with Prestashop 1.6.1.0 and would like to add a facebook like button on my page.

 

I am trying to do what is on the facebook developper page

to create a like button but can't get it to work.

 

On the developper page, it say that I have to include the following JavaScript SDK on my page once, ideally right after the opening <body> tag.

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

Then place the following code for my plugin wherever I want the plugin to appear on your page.

<div class="fb-like" data-href="http://www.miraxsupplements.com" data-layout="button" data-action="like" data-show-faces="false" data-share="true"></div>

How do I incorporate this code to my HTML Box Pro to create a facebook like button?

 

or is there any other way to create a facebook like button with HTML Box Pro?

 

Cheers

Dan

 

js code that facebook suggested to use: add it to displayHeader hook (in html box pro section named "Header")

 

then., there where you want to display button use code:

 

<div class="fb-like" data-href="http://www.miraxsupplements.com" data-layout="button" data-action="like" data-show-faces="false" data-share="true"></div>

Share this post


Link to post
Share on other sites

 

js code that facebook suggested to use: add it to displayHeader hook (in html box pro section named "Header")

 

then., there where you want to display button use code:

 

<div class="fb-like" data-href="http://www.miraxsupplements.com" data-layout="button" data-action="like" data-show-faces="false" data-share="true"></div>

 

Thanks Vekia,

 

When I try to put the script code in the header and save it, the code is being changed from this:

 

<div id="fb-root"></div>

<script>(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));</script>

 

to this

 

<div id="fb-root"></div>

<script>// <![CDATA[

(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));

// ]]></script>

 

I think this has something to do with the "Move JavaScript to the end" option from the Performance menu in the Backoffice.

 

Is there a way to modify the code so the script element doesn't get modified?

 

Cheers

 

Dan

Share this post


Link to post
Share on other sites

new version is ready to download

- added fixes to notifications about "regenerate hooks" button

- added videotutorial related to module configuration

Share this post


Link to post
Share on other sites

Thanks Vekia,

 

When I try to put the script code in the header and save it, the code is being changed from this:

 

<div id="fb-root"></div>

<script>(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));</script>

 

to this

 

<div id="fb-root"></div>

<script>// <![CDATA[

(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));

// ]]></script>

 

I think this has something to do with the "Move JavaScript to the end" option from the Performance menu in the Backoffice.

 

Is there a way to modify the code so the script element doesn't get modified?

 

Cheers

 

Dan

 

 

this cdata shouldn't affect the script

js scripts works with this well

Share this post


Link to post
Share on other sites

new version of custom contents module is ready to download

- added installation fixes (prestashop cloud + self hosted solutions)

- tinyMCE rich text editor now supports <link> code to insert custom css files.

  • Like 1

Share this post


Link to post
Share on other sites

Hi vekia!

 

Would be grateful if you could add a line to translate this key! There is no row in the Back Office where I can translate this button. (Add hook) in to Swedish. Lägg till krok Module HTML box pro 2.6.6

 

 

 

 

Best regards

MacRoy

post-413956-0-07358600-1440591409_thumb.jpg

Share this post


Link to post
Share on other sites

Hello MacRoy

im checking it now! thats strange because i've got translation to polish and french there

 

im inspecting it

what is the version of the addon that you use?

Share this post


Link to post
Share on other sites

Hello MacRoy

im checking it now! thats strange because i've got translation to polish and french there

 

im inspecting it

what is the version of the addon that you use?

Hi vekia!

 

I agree with you, there is something very strange about that particular Swedish version of PrestaShop. There is almost not a single module that I have, but I've got this problem. In addition, there are a lot of problems inside the Back Office with translations as well. I've got to fix a lot of myself and I have had reported to PS about this too, but it happens like nothing. I do not know how serious the PrestaShop take this with reports that you submit. Or is it because you live in the wrong place Sweden?

 

 

Anyway, I would be grateful if you could look at this.

 

I use  HTML box pro version 2.6.6

 

Best regards

MacRoy

Share this post


Link to post
Share on other sites

one more question

what is exact version of your shop? 1.6.x.y ?

Share this post


Link to post
Share on other sites

one more question

what is exact version of your shop? 1.6.x.y ?

Prestashop 1.6.1.1

Share this post


Link to post
Share on other sites

Hi vekia!

 

I have been using HTMLBox Pro for a while now and it is a great module.

 

I would like to add a banner made with Shockwave Flash Object (SWF) to my page.

 

Is there a way to do this?

 

Thanks

Dan

Share this post


Link to post
Share on other sites

Hi vekia!

 

I have been using HTMLBox Pro for a while now and it is a great module.

 

I would like to add a banner made with Shockwave Flash Object (SWF) to my page.

 

Is there a way to do this?

 

Thanks

Dan

 

 

Ok, I realise I should probably not use flash but HTML5 instead... flash is not supported on smartphone etc...

I will recreate my banner using HTML5 instead and repost if I need further assistance...

 

Cheers

Dan

Edited by papagino (see edit history)

Share this post


Link to post
Share on other sites

I have just purchased this module ( i have had a couple from you already)

When the "Only on selected catagory pages" is set to yes and i enter the category number the it does not work on the frontend.

 

When it is set to "no" it becomes visible again.

 

Would it be that i have removed the number id from my url's ?

 

Thanks

Share this post


Link to post
Share on other sites

Hi there,

 

 

Seems I`ve problem with your module on my test site:

 

ORIGINAL LINK ON HOME PAGE TO IMAGE IS:

http://ideal-lux.sk/img/cms/platby/paypal_1.png

 

ORIGINAL LINK ON CATEGORY PAGE TO IMAGE IS:

http://ideal-lux.sk/img/cms/platby/paypal_1.png

 

ORIGINAL LINK ON SUBCATEGORY TO IMAGE IS:

http://ideal-lux.sk/led-ziarovky/img/cms/platby/paypal_1.png

 

Do u see where is problem?

Your module is adding extra /led-ziarovky/ to image url?

 

Any idea why?

I`m using version of PS161…

 

This problem is only on subcategory…

Share this post


Link to post
Share on other sites

Hi Vekia,

 

I requested a feature a while back and it was partially done on your side, but not very usefull.

 

Here it is, I have a shop that sell to different customer groups,  depending to what groups they belong, they will see contents and pricing that apply to them once logged in (regular online customer, retailers, distributors...)

 

Right now, on the HTML Box Pro module, it is only possible to either set "Visibility for" or "Hide for" for only one group from a drop down list.  It would be nice if you could set your module so the "Visibility for" and "Hide for" features could apply to many groups instead of just one group as it is now.

 

Please see the attached picture for clarification.

 

Cheers

Dan

 

 

post-406825-0-08837400-1442873736_thumb.png

 

Share this post


Link to post
Share on other sites

Hi!

 

New version released that solved the problem!

 

Thank you very much vekia!

 

Regards

 

MacRoy

Share this post


Link to post
Share on other sites

new version of custom html block module is ready

- added missed translation string (thanks Roy!)
- added improvements related to module installation process

  • Like 1

Share this post


Link to post
Share on other sites

Hello ,
I have problem.
When I put the text in place of enter the code here and I save changes , my new text is not registered.
What should I do?
Thank you in advance.

Share this post


Link to post
Share on other sites

new version is ready!

- added improvements related to custom hooks creation process, now module doesnt spawn "white" page


Hello ,
I have problem.
When I put the text in place of enter the code here and I save changes , my new text is not registered.
What should I do?
Thank you in advance.

 

hello

please follow documentation:
https://prestasupport.zendesk.com/hc/en-us/articles/202203981-I-can-t-save-new-block

Share this post


Link to post
Share on other sites
nouvelle version est prête!

- Correctifs liés à la mise à jour des boîtes ajoutée, désormais module sauvegarde contenu pour les nouvelles langues correctement

Share this post


Link to post
Share on other sites

new version of html box pro module ready to use!

- added fixes to appearance of boxes for selected groups of customers

  • Like 1

Share this post


Link to post
Share on other sites

new version of html box pro module ready to use!

- added fixes to appearance of boxes for selected groups of customers

 

 

Hi Vekia, is it me or I cannot find any differences from the previous version!

 

In my case, I have 6 different groups, but your module only has the option to have a box be hidden or be visible for one group only.

For example, if I want to show a particular box only for groups A, B and C, and be hidden for groups D, E and F, it is not possible to do it as of now...

 

You can easily fix this by having check boxes instead of a drop down list to select the groups to which the box is visible.

All checkboxes could be selected by default, and you would only uncheck the boxes for groups you want the box to be hidden.

 

You could remove the section "Hide for" (for group) as this would no longer be required

 

I have mentioned this recommendation about a year ago on this forum, but maybe it was not seen by you, so I am asking for it again.

 

I have recently paid for another year of updates hoping this feature would soon be available...

 

Anyway, keep up the good work and hopefully, you will notice this post and update your module again...

 

Cheers

 

Dan

Edited by papagino (see edit history)

Share this post


Link to post
Share on other sites

Hi

When i try to add new hook get the problem in the image, can you help me please?

 

Thank youry much

 

ps 1.6.1.2 upgraded from 1.5

htmlbox pro 2.7.0

post-441203-0-17871200-1448453139_thumb.png

Share this post


Link to post
Share on other sites

Hi

When i try to add new hook get the problem in the image, can you help me please?

 

Thank youry much

 

ps 1.6.1.2 upgraded from 1.5

htmlbox pro 2.7.0

 

hello

on module configuration page open "upgrade check" section

module will apply all necessary improvements and you will be able to create blocks then

Share this post


Link to post
Share on other sites

new version is ready!
- added feature to display blocks only when someone will search for selected terms (for exmaple customer search for product: blouse)

 

showcase:

Share this post


Link to post
Share on other sites

new version is ready to download

- added fixes related to recently released feature to display blocks on "search" pages

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

I am trying to put information with links in the footer section using this module.

 

The only issue i am having is trying to line it up corrtectly.

 

This is the link and as you can see it is slightly higher on the left hand side and this is causing me problems on mobile view etc.

 

www.slingsandstraps.co.uk

 

Any ideas on how i can solve this?

 

Thanks in advance

Share this post


Link to post
Share on other sites
check tutorial related to html box pro module, read how you can add google translate widget to your website to automatically translate the shop for all available in google translate languages!
 

Hi,

 

I am trying to put information with links in the footer section using this module.

 

The only issue i am having is trying to line it up corrtectly.

 

This is the link and as you can see it is slightly higher on the left hand side and this is causing me problems on mobile view etc.

 

www.slingsandstraps.co.uk

 

Any ideas on how i can solve this?

 

Thanks in advance

 

hello 

please send support request to support [at] mypresta [dot] eu

Share this post


Link to post
Share on other sites

new version of the module is ready to download

- added fixes related to <meta> tags in tinyMCE editor. now editor saves them properly

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

 

first - sorry for my english i am german.

i think about to buy the "html box pro" version. i already try the free version but in the freee version i cant use css?

i want to use full html css in this modul, did that work only in pro.. like body, css styhesheelt... in the trial i only can use html. example:

<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <title></title>
</head>

<body style="padding:0px; margin:0px; background-color:#fff;font-family:Arial, sans-serif">
<div style="margin: 0px; margin-top: -35px;">

    <!-- #region Slider Begin -->

so did i can make this in the proversion ?

Share this post


Link to post
Share on other sites

I have bought HTML Box Pro today but it will not show up after i have uploaded it to prestashop. I have a Swedish version of Prestashop and it is 1.6.1.3. When i upload the module to the program it says it's ok but i can't see it and i can't install it. 
Best Regards Lennart

Share this post


Link to post
Share on other sites

Hi Lelle66!

 

Have you uploaded it via FTP or via the Back Office?

 

Then go to the modules and display all models, and there you will find it.

 

Regards

MacRoy

 

Edited by MacRoy (see edit history)

Share this post


Link to post
Share on other sites

Dear Vekia,

 

HTML Boc Pro is an absolutely brilliant module- thank you. Just a quick query. I have put some html on my homepage and moved the HTML Box Pro module to the top. It works great but there is a duplicate of my code at the bottom of the page. Could you please let me know how to fix this. Here is the link: www.chelseafurnisher.co.uk

 

Thanks,

 

Alex

Share this post


Link to post
Share on other sites

When I try to paste script through the module like the one below, it automatically add <![CDATA[]]> around it. Is there's any tutorial or document that describes how to insert scripts to a specific page using the HTML Box pro module?

 

<script type="text/javascript">
 var product = {
 category : [ 'Women' ]
 };
</script>

Thanks in advance.

Share this post


Link to post
Share on other sites

html box pro module updated! added new feature that allows to use variables.

if you will use some variable in your contents, module will replace it with some value.

for example, you can use:

  1. {id_customer} - to display id of customer (if logged)
  2. {email_customer} - to display email of the customer (if logged)
  3. {id_category} - to display id of browsed category page
  4. ...
  5. ...
  6. more variables on module information website

these variables can be used to insert some tracking codes from external services - it's a huge improvement!

  • Like 2

Share this post


Link to post
Share on other sites

.. the description says that the free HTML box can be used with PS Cloud as well, but how can I import the downloaded files into PS? "Add new module" does not work as I am restricted to the modules from PS marketplace. Here I cannot find the free HTML box... any help?

Thanks,
Martin

Share this post


Link to post
Share on other sites

new version of html box pro module is ready!

- added new feature to display block on product pages only if viewed product is associated with selected manufacturers

- added better updates check system
- you can disable / enable autmatic updates

- you can check if new version is available manually (from module configuration page with one click on button)

  • Like 2

Share this post


Link to post
Share on other sites

Hi vekia!

 

Thanks for the update of you`re wonderful module! But i have a problem.

 

I have found a bug in the HTML Box Pro, which arises when I choose to activate the display on selected URL.

 

I will get the letter "a" in front of the text you can see it on the attached picture, that is marked with a red arrow. The most strange is that even if I delete the text and save, so do it not disappear "a". The only thing that works is that I have to remove the hook altogether. But now I try to create a new hook for the same purposes, but despite that pops this "a" again. This happens when I turn on the shoppingCartExtra, and select Only the selected URL.

 

 

Can you look at this?

 

I use version 2.7.9.1. and PS 1.6.1.5

 

Best regards

MacRoy

post-413956-0-44774200-1461267547_thumb.jpg

Edited by MacRoy (see edit history)

Share this post


Link to post
Share on other sites

Hi vekia!

 

I have downloaded you`re latest version and removed the earlier version, but i have still problems.

 

Your recent version v2.7.9.2 does not work either. It show now instead duplication of information, but "a" is gone!

 

Please take a look at it.

 

Best regards

MacRoy

Share this post


Link to post
Share on other sites

For me work perfect. I think if you give 777 permisions to folder of the module  your problems have solution

Share this post


Link to post
Share on other sites