Jump to content
Sign in to follow this  
paryski2

Categories multiples en import

Recommended Posts

Bonjour,
lors de l'import de produits, je souhaiterais que certains produits figurent dans plusieurs catégories et sous-catégories en même temps (home, category et subcategory).
mais en séparant les numéros des différentes catégories dans le CSV par des virgules (comme semble l'indiquer le nom du champ : categories (x,y,z)) ça foire bien...
Quelle est la bonne facon d'indiquer plusieurs catégories dans le csv ?
Merci d'avance

Share this post


Link to post
Share on other sites

ça fonctionne chez moi, tu as quelle version ?

Share this post


Link to post
Share on other sites

il "foire" comment ? message d'erreur ? le produit est-il créé ?
sinon c'est bien ça pour le format, l'erreur vient peut être d'une autre colonne.

Share this post


Link to post
Share on other sites

L'erreur affichée est : Warning: preg_match() expects parameter 2 to be string, array given in serveur/.../.../html/classes/Validate.php on line 569

au lieu de mettre le produit dans les catégories 1 et 82, il crée la catégorie "1,82" et met le produit dedans

Share this post


Link to post
Share on other sites

tu as bien laissé "," pour le param "Séparateur de champs" ?

Share this post


Link to post
Share on other sites

oui, j'ai essayé "," ";" ça ne change rien...
Ce que je vais faire c'est indiquer une seule catégorie et cocher à la main sur chaque fiche-produit celles que je veux rajouter...
Le chipot a ses limites...

Share this post


Link to post
Share on other sites

Bonjour

Oui effectivement c'est mieux quand on mets le séparateur de champs à virgule (sinon ça me crée des catégories avec comme nom les identifiants séparés par une virgule alors qu'avec la virgule comme séparateur de champs je n'ai pas ces catégories "bidon" mais pas non plsu mais articles importés dedans).

Avec le bon séparateur de champs il me rentre bien dans category_product les bon id mais par contre je vois la colonne position de la table à 0
alors que pour les autres j'ai 1 normal ? ça vient peut-être de là ?

Share this post


Link to post
Share on other sites

Bonsoir
As-tu créé tes catégories avant ?
Chez moi ca fonctionne aussi

Share this post


Link to post
Share on other sites

Bonsoir

Merci d'avoir répondu. Enfait je continue sur ma lancée les catégories ça a l'air de passer, les soucis que j'ai pu avoir ensuite, ce sont des problème de manip'

Oui en fait apparemment ça venait plus de mes TPL qui n'affichait pas bien les catégories.
en fait je trouve que l'import est assez bien fait mais par contre c'est pas toujours très clair (les caracteristiques par exemple: Id ou libellé )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More