Jump to content

Recommended Posts

HI,

I have problems with an image which I added using this module. In front is ok ( using path /img/cms/....), but on other pages the path for image is /en/img/cms/.... or other language code.

 

How to fix it?

Thanks in advance.

Share this post


Link to post
Share on other sites
  • Replies 591
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Prestashop HTML Box module --- for free --- works with: 1.2.x + 1.3.x. + 1.4.x + 1.5.x + 1.6.x + 1.7.x   This module is great tool for adding to your shop widgets created by other

yes you can, today I will write tutorial how to add a free image slider with this module

module has been improved to version 1.2   This update improved the interpretation of the characters you have used in your code, such as the ENTER (newline) were changed <br/> marker which caus

Posted Images

If i put image slider in home position I can place theme configurator to right. When I place html box in home, theme configurator drops to next line. How can i change html box size to allow theme configurator to right?

Share this post


Link to post
Share on other sites

Hi,

I am using presta 1.4.1 installed new version of htmlbox free, but can't get it to save changes. I get only default "enter code here" text. editor on/off button isn't working too, sometimes after "save changes" field to type code in is not visible (just editor buttons). Help please

Share this post


Link to post
Share on other sites
  • 1 month later...

Hi

 

I've tried to insert Java script into HTML box with no success.

 

Here is code:

 

<script type="text/javascript">

 var cnt_id = "cf9d5db5-18710";
 </script>
 <script type="text/javascript" src="https://www.viralsweep.com/external/widget.js"></script>
 
After inserting I've got such code:    
 
<script>// <![CDATA[
        var cnt_id = "cf9d5db5-18710";
// ]]></script>
 
So script isn't working, I've tried to disable editor, but it activates automatically after inserting script. 
 
HOW TO GET RID of CDATA? 
 
I've tried tutorial to extend tinymce, disable HTML purifier. Maybe somebody have ideas how to get rid of this? Or how can I wipe out TinyMCE editor completely from this plugin?
Edited by ZubastiK (see edit history)

Share this post


Link to post
Share on other sites
  • 4 weeks later...

What about such code?

 

it will work!

but please note that if you want to place it in some column - you have to disable feature (adv. parameters > performance) to move all js scripts to the end of page!

Share this post


Link to post
Share on other sites

download link to the module is available on first page of this thread

there you can find link to associated file (htmlbox.zip) with this topic

Share this post


Link to post
Share on other sites

Well, I checked out new version of the module and still it isn't working for me :(

 

 

<script type="text/javascript">

        var cnt_id = "cf9d5db5-18710";
        </script>
        <script type="text/javascript" src="https://www.viralsweep.com/external/widget.js"></script>
      

This code was converted in:

 

<script>// <![CDATA[

 var cnt_id = "cf9d5db5-18710"; 
// ]]></script>

 

vekia, can you help? how to insert this code right? I tried to turn off the editor, also tried to insert in source code.

Share this post


Link to post
Share on other sites

Well, I checked out new version of the module and still it isn't working for me :(

 

This code was converted in:

 

vekia, can you help? how to insert this code right? I tried to turn off the editor, also tried to insert in source code.

and what is wrong with this code?

// <![CDATA[ isn't bad code, script should work even with this CDATA

 

what problem you've got?

Share this post


Link to post
Share on other sites

and what is wrong with this code?

// <![CDATA[ isn't bad code, script should work even with this CDATA

 

what problem you've got?

 

 

Script simply doesn't work and page is empty. You posted screenshot with this script working, how you've got it working?

Share this post


Link to post
Share on other sites

Script simply doesn't work and page is empty. You posted screenshot with this script working, how you've got it working?

 

if you use option to move js scripts to the end, take a look at the bottom part of your page

script should be executed there. This is how this widget works - it adds contents there  where script is execuded.

with option to move scripts to the end - script will be executed at the end of the shop.

Share this post


Link to post
Share on other sites

it is a paypal banner scirpt

 

see below

 

<script type="text/javascript" data-pp-pubid="xxxxxxxxxxx" data-pp-placementtype="728x90"> (function (d, t) {
"use strict";
var s = d.getElementsByTagName(t)[0], n = d.createElement(t);
n.src = "//paypal.adtag.where.com/merchant.js";
s.parentNode.insertBefore(n, s);
}(document, "script"));
</script>
Edited by jewelcam (see edit history)

Share this post


Link to post
Share on other sites

 

it is a paypal banner scirpt

 

see below

 

<script type="text/javascript" data-pp-pubid="xxxxxxxxxxx" data-pp-placementtype="728x90"> (function (d, t) {
"use strict";
var s = d.getElementsByTagName(t)[0], n = d.createElement(t);
n.src = "//paypal.adtag.where.com/merchant.js";
s.parentNode.insertBefore(n, s);
}(document, "script"));
</script>

 

 

to what hook you added it?

Share this post


Link to post
Share on other sites

okay

thank you for clarification

one additional thing: is there a chance to see your website ? 

i want to inspect code to see if this code appears in your page source code

Share this post


Link to post
Share on other sites

+ one additional question:

if you save this code in module, after save code looks the same as before save?

Correct looks the same after save.

 

i can send complete code with my id to a private message or email if you like

Share this post


Link to post
Share on other sites

Great module! Tried Contentbox first, but that screwed up my SmartBlog module...

 

I've got a similar issue regarding CDATA / scripts. I want to load a script from addthis, but do this async:

 

<script>var script = document.createElement('script'); script.type = 'text/javascript'; script.src = 'https://s7.addthis.com/js/300/addthis_widget.js#pubid=xxxx'; document.body.appendChild(script); 
</script>
 
However, after save it becomes:
 
<script>// <![CDATA[
//--><![CDATA[//><!-- //  var script = document.createElement('script'); script.type = 'text/javascript'; script.src = 'https://s7.addthis.com/js/300/addthis_widget.js#pubid=xxx'; document.body.appendChild(script); //--><!
// ]]></script>
 
And it's not injected in the HTML at all? Also notice the duplicate CDATA (and only one close).

When I just reference the JS inline, it's fine. But I don't want that, as that decrease my Pagespeed score significantly.

Share this post


Link to post
Share on other sites

 

Great module! Tried Contentbox first, but that screwed up my SmartBlog module...

 

I've got a similar issue regarding CDATA / scripts. I want to load a script from addthis, but do this async:

 

<script>var script = document.createElement('script'); script.type = 'text/javascript'; script.src = 'https://s7.addthis.com/js/300/addthis_widget.js#pubid=xxxx'; document.body.appendChild(script); 
</script>
 
However, after save it becomes:
 
<script>// <![CDATA[
//--><![CDATA[//><!-- //  var script = document.createElement('script'); script.type = 'text/javascript'; script.src = 'https://s7.addthis.com/js/300/addthis_widget.js#pubid=xxx'; document.body.appendChild(script); //--><!
// ]]></script>
 
And it's not injected in the HTML at all? Also notice the duplicate CDATA (and only one close).

When I just reference the JS inline, it's fine. But I don't want that, as that decrease my Pagespeed score significantly.

 

Same problem here!, I paste this code:

<script type="text/javascript">
var LHCChatOptions = {};
LHCChatOptions.opt = {widget_height:340,widget_width:300,popup_height:520,popup_width:500,domain:'domain.com'};
(function() {
var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
 
var location  = (document.location) ? encodeURIComponent(window.location.href.substring(window.location.protocol.length)) : '';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
})();
</script>
 
And after saving, the code looks like this:
<br />
<script>// <![CDATA[
//--><![CDATA[//><!-- //  var LHCChatOptions = {}; LHCChatOptions.opt = {widget_height:340,widget_width:300,popup_height:520,popup_width:500,domain:'domain.com'}; (function() { var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true; var refferer = (document.referrer) ? encodeURIComponent(document.referrer.substr(document.referrer.indexOf('://')+1)) : ''; var location = (document.location) ? encodeURIComponent(window.location.href.substring(window.location.protocol.length)) : ''; po.src = 'https://domain.com/some_directory/index.php/esp/chat/getstatus/(click)/internal/(position)/bottom_left/(ma)/br/(top)/350/(units)/pixels/(leaveamessage)/true?r='+refferer+'&l='+location; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s); })(); //--><!
// ]]></script>
 
This is the only code I have on htmlbox, Editor Off mode

 

Prestashop: 1.6.0.14

HTMLbox latest version, downloaded today.

Edited by mxmart.mx (see edit history)

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Hi, I got an error message when I tried to open the module in back office. We just moved to the new server.

 

This is the error message:

Fatal error: Call to a member function addChild() on a non-object in /home/main/public_html/modules/htmlbox/htmlbox.php on line 53
[PrestaShop] Fatal error in module htmlbox:
Call to a member function addChild() on a non-object 

Please advice what should I do to fix this. Thank you very much.

Edited by Ben90 (see edit history)

Share this post


Link to post
Share on other sites

Hi guys 

I don't know if this belongs here but after upgrading the modules yesterday I now have no access to modules. I get the is error message

[PrestaShop] Fatal error in module htmlbox:
Call to a member function addChild() on a non-object

 

 

Any help very much appreciated

Kind regards 

Len

Share this post


Link to post
Share on other sites

Hi guys 

I don't know if this belongs here but after upgrading the modules yesterday I now have no access to modules. I get the is error message

[PrestaShop] Fatal error in module htmlbox:

Call to a member function addChild() on a non-object

 

 

Any help very much appreciated

Kind regards 

Len

 

That's the same error I got. Can't open the module page in BO right now

Share this post


Link to post
Share on other sites

Hi guys 

I don't know if this belongs here but after upgrading the modules yesterday I now have no access to modules. I get the is error message

[PrestaShop] Fatal error in module htmlbox:

Call to a member function addChild() on a non-object

 

 

Any help very much appreciated

Kind regards 

Len

 

While waiting Vekia to reply this problem, this might solve the problem:

 

Go to modules\htmlbox\htmlbox.php, comment out some codes: (line 10 & line 35-65)

/**        $this->trusted();        */
/**    
        function trusted(){
            if (_PS_VERSION_ >= "1.6.0.8"){
                if (isset($_GET['controller'])){
                    if ($_GET['controller']=="AdminModules"){
                        if (defined('self::CACHE_FILE_TRUSTED_MODULES_LIST')==true){
                            $context = Context::getContext();
                    		$theme = new Theme($context->shop->id_theme);
                    		// Save the 2 arrays into XML files
                    		$trusted_xml = new SimpleXMLElement('<modules_list/>');
                    		$trusted_xml->addAttribute('theme', $theme->name);
                    		$modules = $trusted_xml->addChild('modules');
                    		$modules->addAttribute('type', 'trusted');
                    		$module = $modules->addChild('module');
                    		$module->addAttribute('name', $this->name);
                            $success = file_put_contents(_PS_ROOT_DIR_.self::CACHE_FILE_TRUSTED_MODULES_LIST, $trusted_xml->asXML());
                            if (defined('self::CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST')==true){
                                $xml= simplexml_load_string(file_get_contents(_PS_ROOT_DIR_.self::CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST));
                                //$xml=new SimpleXMLElement('<modules/>');
                                //$cs=$xml->addChild('modules');
                                $css=$xml->addChild('module');
                                $css->addChild('id',0);
                                $css->addChild('name',"<![CDATA[".$this->name."]]>");
                                $xmlcode=$xml->asXML();
                                $xmlcode=str_replace('<',"<",$xmlcode);
                                $xmlcode=str_replace('>',">",$xmlcode);
                                file_put_contents(_PS_ROOT_DIR_.self::CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST,$xmlcode);
                            }
                        }
                    }
                }
            }
        }     
*/

Now you should be able to open BO module page

Share this post


Link to post
Share on other sites

While waiting Vekia to reply this problem, this might solve the problem:

 

Go to modules\htmlbox\htmlbox.php, comment out some codes: (line 10 & line 35-65)

/**        $this->trusted();        */
/**    
        function trusted(){
            if (_PS_VERSION_ >= "1.6.0.8"){
                if (isset($_GET['controller'])){
                    if ($_GET['controller']=="AdminModules"){
                        if (defined('self::CACHE_FILE_TRUSTED_MODULES_LIST')==true){
                            $context = Context::getContext();
                    		$theme = new Theme($context->shop->id_theme);
                    		// Save the 2 arrays into XML files
                    		$trusted_xml = new SimpleXMLElement('<modules_list/>');
                    		$trusted_xml->addAttribute('theme', $theme->name);
                    		$modules = $trusted_xml->addChild('modules');
                    		$modules->addAttribute('type', 'trusted');
                    		$module = $modules->addChild('module');
                    		$module->addAttribute('name', $this->name);
                            $success = file_put_contents(_PS_ROOT_DIR_.self::CACHE_FILE_TRUSTED_MODULES_LIST, $trusted_xml->asXML());
                            if (defined('self::CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST')==true){
                                $xml= simplexml_load_string(file_get_contents(_PS_ROOT_DIR_.self::CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST));
                                //$xml=new SimpleXMLElement('<modules/>');
                                //$cs=$xml->addChild('modules');
                                $css=$xml->addChild('module');
                                $css->addChild('id',0);
                                $css->addChild('name',"<![CDATA[".$this->name."]]>");
                                $xmlcode=$xml->asXML();
                                $xmlcode=str_replace('<',"<",$xmlcode);
                                $xmlcode=str_replace('>',">",$xmlcode);
                                file_put_contents(_PS_ROOT_DIR_.self::CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST,$xmlcode);
                            }
                        }
                    }
                }
            }
        }     
*/

Now you should be able to open BO module page

 

 

problem solved, please read posts before.

new version of the module doesnt have the code

i already suggested to use new version of the module.

  • Like 1

Share this post


Link to post
Share on other sites

I didn't see this covered, but I may have missed it.  When I add a script to the editor that's attached to the header it's automatically inserting a <br /> before and adding a blank line at the top of my pages.  Is there a way to avoid this?

Share this post


Link to post
Share on other sites
  • 3 weeks later...

I have problems with the html box editor on a fresh installed 1.6.1 (no update, completely new installed). I entered the following code:

 <section class="footer-block col-xs-12 col-sm-2" id="block_various_links_footer">

<h4>Service</h4>

<ul class="toggle-footer">

<li class="item"><a href="http://shop.adorablepaws.de/haustierbedarf/content/zuechterrabatt" title="Züchterrabatt">Züchterrabatt</a></li>

<li class="item"><a href="http://shop.adorablepaws.de/haustierbedarf/content/widerrufsrecht" title="Widerrufsrecht">Widerrufsrecht</a></li>

<li class="item"><a href="http://shop.adorablepaws.de/haustierbedarf/content/widerruf-muster" title="Widerruf Muster">Widerruf Muster</a></li>

<li class="item"><a href="http://shop.adorablepaws.de/haustierbedarf/content/entsorgungs-umweltbestimmungen" title="Entsorgung- und Umweltbestimmungen">Entsorgung- und Umweltbestimmungen</a></li>

</ul>

</section>

Then click on save. The back office page refreshes and the code is suddenly missing the first and last line (<section class="footer-block col-xs-12 col-sm-2" id="block_various_links_footer"> </section> ) It just disappears and of course with that line gone, the box placed in the footer is not levelled with the other columns.

If I use the content box module everything is fine, but I’d prefer using the html box, because I also would like to use the Prestashop blog module and that doesn’t work with content box…

What am I doing wrong? Or why is the html box editor deleting those two lines by itself? Is the code incorrect?

Edited by AdorablePaws (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi,

Is it possible (with the free version) to display HTML Box in the center column ?

(I try to read the 23 pages of the topic but didn't find).

 

My aim is to had text under the description of only one category (!!).

Thanks,

Share this post


Link to post
Share on other sites

Hi,

Is it possible (with the free version) to display HTML Box in the center column ?

(I try to read the 23 pages of the topic but didn't find).

 

My aim is to had text under the description of only one category (!!).

Thanks,

 

hello

sadly speaking prestashop doesnt have the hook there (center column on category page) so it is not possible to put there any kind of module!

in this case you will have to customize the theme (add new hook) and put the code to this new hook with html box pro.

 

only pro version allows to define custom hooks

Share this post


Link to post
Share on other sites

Thanks vekia for this nice module !

 

Works fine on PS 1.6.0.6.

 

A tip to have buttons and text with our language is to add Inside : tinymce16.inc.js :

 

From line 29 :

language: iso,
skin: "prestashop",

Now I can read buttons end text with French language.

 

Friendly

Share this post


Link to post
Share on other sites

Thanks vekia for this nice module !

 

Works fine on PS 1.6.0.6.

 

A tip to have buttons and text with our language is to add Inside : tinymce16.inc.js :

 

From line 29 :

language: iso,
skin: "prestashop",

Now I can read buttons end text with French language.

 

Friendly

 

this is what you changed in tinymce file, right?

Share this post


Link to post
Share on other sites

@Vekia

I get around the problem by increasing my category short description.

Thanks for your reply.

 

 

im affraid that with free version it is not possible to extend category description

Share this post


Link to post
Share on other sites

@vekia

 

Yes I added this lines to have buttons with my language inside tinymce16.inc.js:

language: iso,
skin: "prestashop",

* Using "quotes" with IE 11 doesn't work for me to give an answer on the forum !

 

Friendly

post-777922-0-12372200-1440918655_thumb.jpg

Edited by myselfidem (see edit history)

Share this post


Link to post
Share on other sites
im affraid that with free version it is not possible to extend category description

 

I think I misspoke.

I wanted to put your HTML box under the banner category in the center column (which is not possible).

So increased the PrestaShop category short description and add what I wanted.

Share this post


Link to post
Share on other sites
  • 1 month later...

Nice plugin.

 

How many HTML blocks does it allow me to have? I need at least two HTML blocks, each of which will be put in it's own custom page.

 

For example, I need an HTML block to show up on page A, and another HTML block to show up on Page B.

 

Is that possible?

Share this post


Link to post
Share on other sites

Witam, mam problem z modułem.

Wersja prestashop 1.4.6.2 ( na 1.6 działa znakomicie)
Wersja modułu  v1.5.6

W momencie kiedy staram się zapisać własny kod w boksie stronka mi się standardowo odświeża, ale zmiany nie są zapisywane. 

Share this post


Link to post
Share on other sites

How can I add JavaScript code with this module? I tried

 

<script>
alert('test');
</script>

 

but as soon as I close the Source Code e open it again, it has been recreated like this:]

 

<br />
<script>// <![CDATA[
alert('test');
// ]]></script>

 

I've already disabled the HTML Purifier feature, and it didn't help. So, please, how can I add JavaScript code?

Share this post


Link to post
Share on other sites

Hello, Does your module work well with prestashop 1.6.1.1 and can i use it to add javascript on all pages?

 

module supports prestashop 1.6.1.1 and allows to include js script to all pages (use header hook)

Share this post


Link to post
Share on other sites

module supports prestashop 1.6.1.1 and allows to include js script to all pages (use header hook)

 

I tried to use this module, but unfortunately it didn't work. I don't understando why would someone want a JavaScript script be put on the header or footer or left of a page. Of course for HTML blocks of code it does make sense, but for JavaScript it don't make any difference wherever you put the JavaScript code, as long as the code is loaded when it needs to be called and executed, the location where the script is put does not matter.

 

The solution I found was to write my JavaScript codes in the footer.php file, through FTP. This way I can modify the code the way I want and need, without passing for yet another plugin/module layer.

 

If you are a developer, I think this is the most straightforward way to customize the code so that your pages looks like and behave the way you need. But if you are not a developer and only want or need some minnor changes/customizations, than it may be worth the effort to use a module like this one.

Share this post


Link to post
Share on other sites

Hello,

I installed the module without issues and also added a live chat  javascript wadget and also hooked it to header as you said. But module does not show at all. After adding the script, the script shows immediately how it would look like. But a front end it does not open. What could be the problem ?

 

Your help will be highly appreciated

 

Thank you

Ronnie

Share this post


Link to post
Share on other sites
Good evening, I just installed the module (the last free version) to put several CMS columns in the footer. It works well for what we want, but we found a problem.

 

The module generates an html box me, then do not know how I can remove, that is, if I return to the module to attempt to modify the html box I created, is not listed, make me a new one and accumulates.

 

How I can remove the html box ?, that have been created or modified since they already have. ¿?

 

 

post-1125087-0-28596200-1446116569_thumb.png

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hello

please can you help for set display of 3 html_module under their own categorie ?

 

Here are the category and the name of the module : this code into header.tpl is just displaying the text  for example mod=htmlanimaux  under the cat number 3

{if $id_category == 3}{l s='mod=htmlanimaux'} 
{/if}
{if $id_category == 4[spam-filter]{l s='mod=htmlbienetre'}
{/if}
{if $id_category == 13}{l s='mod=htmlmaisonjardin'}
{/if}

I would like to manage the display ok each module under their own category ( or hide 2 of them when a categorie is display

 

its under Prestashop 1.6.1

 

Thank you for your help

Share this post


Link to post
Share on other sites

 

Prestashop HTML Box module

--- for free ---

works with: 1.2.x + 1.3.x. + 1.4.x + 1.5.x + 1.6.x

This module is great tool for adding to your shop widgets created by other websites like twitter, facebook, pinterest, allegro, etc. Main feature in this module is an ability to add the "client side" code such like HTML, javascript, css for any place you want.

htmlbox-free-big.png

 

wait for tutorials about usage this module for adding facebook like box etc.

updates of the module

version | date

 

1.5.6 | 18.06.2015

1.5.4 | 02.10.2014

1.5.3 | 03.09.2014

1.5.2 | 01.06.2014

1.5.1 | 19.05.2014

1.5.0 | 01.04.2014

1.4.9 | 10.03.2014

1.4.8 | 19.02.2014

1.4.7 | 18.12.2013

1.4.6 | 11.12.2013

1.4.5 | 30.10.2013

1.4.4 | 23.09.2013

1.4.3 | 27.08.2013

1.4.2 | 13.05.2013

1.4.1 | 29.04.2013

1.3.0 | 07.11.2012

 

 

download:

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi, Trying to use this module to add a google verification tag, but when I click verify I get an error of "cannot find tag" or "the tag is formatted incorrectly". As I am just copying and pasting I do not see why it is not working. I hope you can advise. 

Share this post


Link to post
Share on other sites

Hi! Love your module by the way but I would like ask a question. I have used your module to add a video to the header but when I tried to add properties such as 'autoplay' and 'loop', it would disappear when I save it.

 

Is there anything I am missing? Thank you very much in advance.

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 2 weeks later...

Hello
is there a way to display this content box only on certain resolutions?
i mean, if the screen is 1920x1080 there's space for it, but as it is not responsive, if my screen gets  smaller 800x600 the html box gets on top of other elements.
so what could i modify to tell it to only display itself if the screen is big enough, i see the option to only display on home page, maybe its something similar.
im using it as a floating box to place a spotify list

like this:
 

<div style="width: 300px; height: 300px; display: block; position: fixed; right: 0px; top: 50px; background: none;"><iframe width="300" height="300" src="https://embed.spotify.com/?uri=spotify%3Aalbum%3A2rp5riHULWgrXPsDtsp1ir" frameborder="0" allowtransparency="true"></iframe></div>

any ideas?

Thanks!

Share this post


Link to post
Share on other sites
  • 1 month later...

hi

i need your help

i was trying to put google verfication code by using this module

after i put the code in module and selected header i saved it but this happened

ieek_header.png

i'm using prestashop for a month and not familier with it

please tell me what to do to remove this code from  header.

thanks

Edited by saeeda144 (see edit history)

Share this post


Link to post
Share on other sites
  • 1 month later...

I have installed HTMLBox for PS1.6.1.4,and I typed some words in editor ,then make it display right column,but I can't see any changes in front office,could someone help me solve this problem,many thanks!

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi i tried the html box module and when i was reading vekia's post and tried it with codepen, it seems to be working but on my website, it does not seem to work, can anyone help me ?

i have already disabled html purifier toggle and the box is ticked to display only on homepage and home .  The code is for an image on top with a script for slider for products .so i am clueless how to proceed

 

any help would be great , thanks in advance!

 

charmaine

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...

Hi I hope you can help, I tried to intsall TIDIO Chat and it advised to poy this code in Header with the HTML Box

 

<script src="//code.tidio.co/i76dsm1ebfvb16g4abekvcs2dsciyee1"></script>

 

Now this did not work but its left this line above on the top of my website, I have checked the header files for my theme but no luck, can you please tell me what file the HTML Box used when added to header so I can remove the above code ??

 

Thanks

John

Share this post


Link to post
Share on other sites

new version of module is ready to download

- added feature that supports <script></script> tags much better than before


1.6.1.5 ?

 

it supports 1.6.1.5 well

Share this post


Link to post
Share on other sites
  • 2 weeks later...

new version of the module is ready!


below you can find details about recent module update


 


1.6.3


- added updates notification system


- you can check for module update directly from back office


- you can enable / disable notifications about updates


- added fixes to save process in prestashop 1.4.x


- added fixes feature to enable / disable rich text editor in prestashop 1.4.x


  • Like 1

Share this post


Link to post
Share on other sites
  • 1 month later...

module has been improved to version 1.2

 

This update improved the interpretation of the characters you have used in your code, such as the ENTER (newline) were changed <br/> marker which caused problems in the operation of such scripts js

 

I invite you to the page of the module and to download the current version:

Prestashop HTML Box module

Hello vekia. My site is in both English and French. How can I display text in the nav bar in those two languages on two different homepages. Thank you for sharing your time and expertise with us. Peter

Share this post


Link to post
Share on other sites
  • 2 weeks later...

new version of this free module is available to download

- added feature to display block only for logged customers

- added feature to display block only for unlogged customers

- added better module updates checker

Share this post


Link to post
Share on other sites

Hello vekia. My site is in both English and French. How can I display text in the nav bar in those two languages on two different homepages. Thank you for sharing your time and expertise with us. Peter

 

html box free does not have feature to define multilanguage contents, at the moment it is available in pro version only

  • Like 1

Share this post


Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...

Hi all, It cannot work on my site. Everytime that I insert in the code, HELLO BAR code, the rich text editor, clear my code and i cannot se the correct code, because the module clear some part of the script and also put p<pre> tags even if i use "source" and put the script on the editor.

See the bar and the code on my home page www.mhoneiro.com (html site) it works, but on shop.mhoneiro.com, prestashop 1.6.1.9 no...

I've have disabled "html purify" also.

 

There is also my  script:

 

<script src="//my.hellobar.com/94adf7b38274bdb3204548fc59257ea6189ae0ba.js" type="text/javascript" charset="utf-8" async="async"></script>

 

Thanks

Share this post


Link to post
Share on other sites
  • 3 weeks later...

new version of html box module released

- added fixes related to tinymce editor

- prestashop from version 1.6.1.9 changed the way of how tinymce is loaded

- because of this it was necessary to change the module code to support these changes

- added better support of hooks in PrestaShop 1.7.x

- module has now two separated libraries (one for prestashop 1.7 and second one for older versions of PS)

Share this post


Link to post
Share on other sites