Jump to content

Recommended Posts

  • Replies 589
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Prestashop HTML Box module --- for free --- works with: 1.2.x + 1.3.x. + 1.4.x + 1.5.x + 1.6.x + 1.7.x   This module is great tool for adding to your shop widgets created by other

yes you can, today I will write tutorial how to add a free image slider with this module

module has been improved to version 1.2   This update improved the interpretation of the characters you have used in your code, such as the ENTER (newline) were changed <br/> marker which caus

Posted Images

  • 4 weeks later...

Thank you for share this module . 

i have problem with it , i add zopim code and was using for some days , my customer report that in ipad and iphone site loding half page division vertically , when i checked and disable module , site loading well , but when module enable Cart page , My account page become half .

Share this post


Link to post
Share on other sites

Bonjour et merci pour ce module.Je travail sur 1.5.6.2 et j'ai installé dans le footer un code pour intégrer une carte google maps.

Aucun problème cela fonctionne très bien même en local.

Par contre j'aimerais descendre la carte de 30px par rapport au block réassurance et de le déplacer de 20 px sur la droite et de lui rajouter une bordure de 3px.Peut on coller un code aussi?

.

(Ce block carte est complètement à droite du footer.)

 

Pouvez m'aider à résoudre ce petit problème: ci-joint le dossier collé pour avoir la carte:

 

<script type="text/javascript" src="http://www.supportduweb.com/google_map_gen.js?lati=37.062500&long=-95.677000&zoom=4&width=350&height=350&mapType=normal&map_btn_normal=yes&map_btn_satelite=yes&map_btn_mixte=yes&map_small=yes&marqueur=yes&info_bulle=Bienvenue%20%20chez%20Ecig-Vapotte"></script><br /><a href="http://www.supportduweb.com/generateur-cartes-google-maps-mettre-cartes-google-map-sur-son-site-gratuitement-gadget-widget.html">Générateur de cartes Google Maps</a>

 

Dans l'attente de votre réponse : Merci

Share this post


Link to post
Share on other sites

Bonjour et merci pour ce module.Je travail sur 1.5.6.2 et j'ai installé dans le footer un code pour intégrer une carte google maps. Texte en javascript. 


Aucun problème cela fonctionne très bien même en local.


Par contre j'aimerais descendre la carte de 30px par rapport au block réassurance et de le déplacer de 20 px sur la droite et de lui rajouter une bordure de 3px . Peut on coller un code aussi?


Pouvez m'aider à résoudre ce petit problème


Dans l'attente de votre réponse merci.


 


.


Share this post


Link to post
Share on other sites

Hello and thank you for this module. I work on 1.5.6.2 and I installed in the footer a code to integrate a card google maps. Text in Javascript.

No problem it works very well even in local.
On the other hand I would like to lower the cardmap of 30px with regard to the block reinsurance and to move him of 20 px on the right and to add him a border of 3px. Can one stick a code also?
Can help me to solve this small problem
Looking forward to your reply thank you..

Share this post


Link to post
Share on other sites

i can help but in this case i need an url to your website.

in cases related to css it's hard to help without an access to front office.

Thank you but I am in premises. How can it be done?

Share this post


Link to post
Share on other sites

what theme you use? and what code you tried to use?

the theme .graphileom thgr00027. 

The code:

 

<script type="text/javascript" src="http://www.supportduweb.com/google_map_gen.js?lati=48.6831654 &long=6.180246 &zoom=1&width=600&height=350&mapType=normal&map_btn_normal=yes&map_btn_satelite=yes&map_btn_mixte=yes&map_small=yes&marqueur=yes&info_bulle=Ecig-Vapotte"></script><br /><a href="http://www.supportduweb.com/generateur-cartes-google-maps-mettre-cartes-google-map-sur-son-site-gratuitement-gadget-widget.html"></a>

 

Thank you for your answer

Share this post


Link to post
Share on other sites

this code doesn't generate any kind of visible content for me ... :|

 

 

this code doesn't generate any kind of visible content for me ... :|

<script type="text/javascript" src="http://www.supportduweb.com/google_map_gen.js?lati=48.6831654 &long=6.180246 &zoom=1&width=600&height=350&mapType=normal&map_btn_normal=yes&map_btn_satelite=yes&map_btn_mixte=yes&map_small=yes&marqueur=yes&info_bulle=Ecig-Vapotte"></script><br /><a href="http://www.supportduweb.com/generateur-cartes-google-maps-mettre-cartes-google-map-sur-son-site-gratuitement-gadget-widget.html"></a>

 

Strange, me I have the map on the site

Share this post


Link to post
Share on other sites

Hi Vekia.

 

I am trying to use your module but I am not very good with html and alike.  I am trying to insert my phone number below the search bar of the header - but it puts it top of the screen as seen here.  I cant seem to make it go below the search bar.  I can make it with images too.

 

Any help you can offer?

 

Link here

Edited by Twinkles (see edit history)

Share this post


Link to post
Share on other sites

Hi Vekia.

 

I am trying to use your module but I am not very good with html and alike.  I am trying to insert my phone number below the search bar of the header - but it puts it top of the screen as seen here.  I cant seem to make it go below the search bar.  I can make it with images too.

 

Any help you can offer?

 

Link here

 

 

go to modules > positions and search for displayTop modules list (not displayHeader!)

move the html box module BEFORE your menu module

 

and use this code:

 

<div style="
    position: absolute;
    left: 380px;
    top: 95px;
"><strong><span style="color: #00000; font-size: 20pt; font-family: verdana,geneva;">+44 1621 826800</span></strong></div>

effect:

5rQIUy0.png

Share this post


Link to post
Share on other sites

Actually - I have found an issue.  If you zoom in or out and use anything other than full screen size on your browser  - it moves around and looses all its positioning.  Is that because I am using absolute positioning?   Is there a better way?

Share this post


Link to post
Share on other sites

Hi Vekia,    I loaded up the module on 1.5.4.1 installation, and added Facebook like code to my site. It seemed to work great at first, but I'm now unable to access my modules folder in Back Office.  I've turned on error codes and get this message:

 

Warning: Invalid argument supplied for foreach() in /websites/123reg/LinuxPackage22/pi/x_/8_/pix-8.co.uk/public_html/BIGhedz/modules/gamification/classes/Advice.php on line 99

 

Have you seen this before? could it have anything to do with the installation?   It's odd as my site still loads fine, but I need access to modules folder.  Is there any way to uninstall the module without going through prestashop back office? 

 

Any help appreiated. Thanks, Matt.

Share this post


Link to post
Share on other sites

Hi Vekia,  Thanks for your advice.

 

Here's what I have done : 

Firstly) turned off Module updates in Back office.

2nd) I have re-installed the gamification folder with the original PS version for 1.5.4.1.   

3rd) Checked the php Database, and tried to create 'hide' column in ps_advice folder , but cannot create as it already exists.

 

Not sure what to do now, is there something in the table that needs to added/deleted?  I have attached a screenshot of the 'ps_advice' structure as it stands. Does anything look wrong there? 

 

Very much appreciate the help you are offering. Matt.

post-711929-0-66691400-1392036832_thumb.png

Share this post


Link to post
Share on other sites

Hello I installed a cate google maps v2 on the module. And it works very well.

On the other hand I have warnings. We ask me of v3.

I do not know how to make.

Can use me ?. Thank you

 

Lattidude :48.6831654

Longitude :6.180246

Share this post


Link to post
Share on other sites

Here are the errors on firefox

Control is no longer supported in the Google Maps Javascript API v2. Please visit https://developers.google.com/maps/documentation/javascript/v2/v2tov3 to migrate your application to v3. %7Bmain,adsense,geometry,zombie%7D.js:66

OverviewMapControl is no longer supported in the Google Maps Javascript API v2. Please visit https://developers.google.com/maps/documentation/javascript/v2/v2tov3 to migrate your application to v3. %7Bmain,adsense,geometry,zombie%7D.js:66

Map.addControl is no longer supported in the Google Maps Javascript API v2. Please visit https://developers.google.com/maps/documentation/javascript/v2/v2tov3 to migrate your application to v3. %7Bmain,adsense,geometry,zombie%7D.js:66

 

On Google v2 and obsolete . They tell to put it v3. Then I stuck this code, to see the map of France, but no result:

 

<html>

02

<head>

03

<title>Code minimaliste pour afficher la carte de France grâce à google maps</title>

04

<style type="text/css">

05

#carte_gmaps { width:600px; height:600px; margin:auto; }

06

</style>

07

</head>

08

 

09

<body>

10

<div id="carte_gmaps"></div>

11

 

12

<script type="text/javascript" src="http://maps.google.com/maps/api/js?sensor=false"></script>

13

<script type="text/javascript">

14

var Gmaps = {

15

Init : function(id, typeRendu, latCenter, lngCenter, zoom) {

16

this.num=0;

17

this.marker = new Array();

18

this.txtBulles=new Array();

19

this.icon, this.point, this.titleMk;

20

 

21

var myOptions = {

22

center: new google.maps.LatLng((latCenter ? latCenter : 46.86178015), (lngCenter ? lngCenter : 1.70158805)),

23

zoom: (zoom ? zoom : 6),

24

mapTypeId: (typeRendu ? typeRendu : 'roadmap')

25

}

26

 

27

this.map = new google.maps.Map(document.getElementById(id), myOptions);

28

}

29

};

30

 

31

window.onload = function(){

32

Gmaps.Init('carte_gmaps');

33

}

34

</script>

35

</body>

36

</html>

On the other hand my code works, but it is v2:The map appear in the footer :

 

<script type="text/javascript" src="http://www.supportduweb.com/google_map_gen.js?lati=48.6831654 &long=6.180246 &zoom=1&width=600&height=350&mapType=normal&map_btn_normal=yes&map_btn_satelite=yes&map_btn_mixte=yes&map_small=yes&marqueur=yes&info_bulle=Ecig-Vapotte"></script><br /><a href="http://www.supportduweb.com/generateur-cartes-google-maps-mettre-cartes-google-map-sur-son-site-gratuitement-gadget-widget.html"></a>

Share this post


Link to post
Share on other sites

I download Htmlbox1.4.7 and upload it in my site through backoffice. When i try to install it shows error.

pls help me

 

PS Version 1.5.6.2

 

hello,

can you turn on error reporting and then - try to install module once again,

any error appear then?

Share this post


Link to post
Share on other sites
  • 2 weeks later...

The module works fine but I have no idea how to fix this problem. Firstly this is my code  

 

<div id="flag001"><a href="" target="_blank"> <img src="" width="270px" height="70px" style="display:block; position: absolute; right: 335px; top: 222px;" /></a></div>

 

 

The problem comes with the resolutions/CSS media queries for screens width <767px but I'm not sure where/how I should correct it. I mean, can I give that values in the module?

I tried to type some code in my theme css responsive file under @media only screen and (max-width: 767px) {

  html {    but obviously I did something wrong. 
Edited by jaimegomez (see edit history)

Share this post


Link to post
Share on other sites

 

The module works fine but I have no idea how to fix this problem. Firstly this is my code  

 

<div id="flag001"><a href="http://boysandgirlsfashion.com/anbX43WX7k3y7k/en/contact-us" target="_blank"> <img src="http://boysandgirlsfashion.com/anbX43WX7k3y7k/ChangesFolder/images/bannerbg.jpg" width="270px" height="70px" style="display:block; position: absolute; right: 335px; top: 222px;" /></a></div>

 

and this is the website  http://boysandgirlsfashion.com/

 

The problem comes with the resolutions/CSS media queries for screens width <767px but I'm not sure where/how I should correct it. I mean, can I give that values in the module?

I tried to type some code in my theme css responsive file under @media only screen and (max-width: 767px) {

  html {    but obviously I did something wrong. 

 

 

 

 

you have to define media queries for #flag001 not for HTML :)

Share this post


Link to post
Share on other sites

Can I add different content based on different language selected, and can this module auto display different content based on different language selected for the site? For example, if the visitor speaks French and selected French from the language drop down menu, can this module automatically show up the banner picture meant for French speakers?

Share this post


Link to post
Share on other sites

live effect: http://codepen.io/VEKIA/pen/BlfgJ

 

 

IqMa7Ba.png

<div style="width:240px; height:156px; display:block; position:relative; background: url(http://s28.postimg.org/59o2biost/Facebook_bg_like.png) no-repeat top left;">

<div style="position:absolute; top:97px; left:45px;">
  <iframe src="//www.facebook.com/plugins/like.php?href=http%3A%2F%2Ffacebook.com%2Fmypresta&width&layout=button_count&action=like&show_faces=false&share=false&height=21&appId=219236141603985" scrolling="no" frameborder="0" style="border:none; overflow:hidden; height:21px;" allowTransparency="true"></iframe>
</div>

</div>

Share this post


Link to post
Share on other sites

 

live effect: http://codepen.io/VEKIA/pen/BlfgJ

 

 

IqMa7Ba.png

<div style="width:240px; height:156px; display:block; position:relative; background: url(http://s28.postimg.org/59o2biost/Facebook_bg_like.png) no-repeat top left;">

<div style="position:absolute; top:97px; left:45px;">
  <iframe src="//www.facebook.com/plugins/like.php?href=http%3A%2F%2Ffacebook.com%2Fmypresta&width&layout=button_count&action=like&show_faces=false&share=false&height=21&appId=219236141603985" scrolling="no" frameborder="0" style="border:none; overflow:hidden; height:21px;" allowTransparency="true"></iframe>
</div>

</div>

 

Thank you very much!

Share this post


Link to post
Share on other sites

Hi Vekia, not getting this to work correctly on 1.6.0.5

 

Any known problems with 


Front Office Features
HTMLbox v1.4.9

?

 

The switch editor on / off does not work, but also it seems to be changing the code

 

If I put this into prestashop 1.5 html box and save and re-edit the code looks the same

 

<!--Start of Tawk.to Script-->
<script type="text/javascript">
var $_Tawk_API={},$_Tawk_LoadStart=new Date();
(function(){
var s1=document.createElement("script"),s0=document.getElementsByTagName("script")[0];
s1.async=true;
s1.src='https://embed.tawk.to/52c482f0420ef4ad3a0000c0/default';
s1.charset='UTF-8';
s1.setAttribute('crossorigin','*');
s0.parentNode.insertBefore(s1,s0);
})();
</script>
<!--End of Tawk.to Script-->

But in 1.6.0.5 the code gets changed to:

<!--Start of Tawk.to Script-->
<script>// <![CDATA[
var $_Tawk_API={},$_Tawk_LoadStart=new Date();
(function(){
var s1=document.createElement("script"),s0=document.getElementsByTagName("script")[0];
s1.async=true;
s1.src='https://embed.tawk.to/52c482f0420ef4ad3a0000c0/default';
s1.charset='UTF-8';
s1.setAttribute('crossorigin','*');
s0.parentNode.insertBefore(s1,s0);
})();
// ]]></script>
<!--End of Tawk.to Script-->

And the chat widget does not appear

 

Any ideas?

Edited by haylau (see edit history)

Share this post


Link to post
Share on other sites

it's because of tinymce editor changing code, this is how it works, also in 1.5.x 1.4.x 1.3.x etc.

on/off button doesnt work - that's right,

i have to update it.

Share this post


Link to post
Share on other sites

this is why there should be a button to turn of tinymce editor :D

release of 1.6 was related to HUGE modification of tinymce load script, 

i have to analyse it step by step 

i will do it ASAP, this is very important feature

Share this post


Link to post
Share on other sites

Hello vekia. I've been trying to use Google Adsense script code on this module to be shown on the footer, but it just doesn't make any change in the front. I'm inserting it as code source, then it automatically adds this labels:

<script>// <![CDATA[
google_ad_client = "ca-pub-1234567890";  /* Example */  google_ad_slot = "592345678";  google_ad_width = 160;  google_ad_height = 600;
// ]]></script>
<script src="http://pagead2.googlesyndication.com/pagead/show_ads.js">// <![CDATA[
  
// ]]></script> 

Am I doing something wrong? Thanks!

Edited by omar2886 (see edit history)

Share this post


Link to post
Share on other sites

Hello vekia. I've been trying to use Google Adsense script code on this module to be shown on the footer, but it just doesn't make any change in the front. I'm inserting it as code source, then it automatically adds this labels:

<script>// <![CDATA[
google_ad_client = "ca-pub-1234567890";  /* Example */  google_ad_slot = "592345678";  google_ad_width = 160;  google_ad_height = 600;
// ]]></script>
<script src="http://pagead2.googlesyndication.com/pagead/show_ads.js">// <![CDATA[
  
// ]]></script> 

Am I doing something wrong? Thanks!

Probably the same problem I am having. Are you on prestashop 1.6? If so, the module still has to be updated to work with the new tinymce system.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi Vekia, your module is working in PS 1.6. ? I'm having an user in Brazilian Forum with a Browser screen problem. Tiniy seems to be different in PS 1.6. and PS 1.5. In PS 1.6. there are missing several icons (HTML for ex.)

 

Compare my screen attached with the link of PS 1.6. here:

http://www.casimages.com.br/i/140401021901738085.png.html

 

Any fix for this problem ?

 

Best regards

 

Conny

post-741527-0-06457400-1396355899_thumb.png

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

module uses tinymce based on prestashops default tinymce library. in ps 1.6 tinymce hasn't got a lot of features, unfortunately, everything depends on prestashop - not me - so at the moment module uses default editor.

Share this post


Link to post
Share on other sites

several days ago we released new version (1.5.0) of the module.

we added support of new hook (new hook in prestashop 1.6)

  • Like 1

Share this post


Link to post
Share on other sites
  • 2 weeks later...

I've read through the thread carefully. Maybe I missed it with my old eyes but where is the tutorial how to insert a slider with this module?

 

Edit: To be clear. I have version 1.6, I do have the slider which comes with the default theme, but I want to shut that one down and use an own slider and thought that this HTML block might do the trick.

Edited by PietroPaoloVirdis (see edit history)

Share this post


Link to post
Share on other sites

you have to use code to insert the slider.

everything that you see in your shop is based on code, html, js, css etc.

if you want to display something - you just have to use correct code to display it.

 

there are a lot of sliders around the web,

 

example of the code:

http://runnable.com/Ua_T4Dgcl3M9AAAx/image-slider-using-jquery

 

remember about possible conflicts with PS jquery versions etc. - you have to be sure that code will work with default prestashop js libraries.

Share this post


Link to post
Share on other sites

The code I'm trying to insert is the open source Piecemaker by modularweb

http://www.modularweb.net/en/portfolio/piecemaker2

 

I had it up and working in another page but when I embedd this demo code:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
<head>
<title>The Piecemaker by Modularweb</title>
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<script type="text/javascript" src="scripts/swfobject/swfobject.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.cssSource = "piecemaker.css";
flashvars.xmlSource = "piecemaker.xml";
var params = {};
params.play = "true";
params.menu = "false";
params.scale = "showall";
params.wmode = "transparent";
params.allowfullscreen = "true";
params.allowscriptaccess = "always";
params.allownetworking = "all";
swfobject.embedSWF('piecemaker.swf', 'piecemaker', '1000', '600', '10', null, flashvars,
params, null);
</script>
</head>
<body>
<center>
<div id="piecemaker">
<p>Put your alternative Non Flash content here.</p>
</div>
</center>
</body>
</html>
 
It's chopped down to this in PS:
The Piecemaker by Modularweb
<script src="/admin4516/scripts/swfobject/swfobject.js"></script>
<script>// <![CDATA[
var flashvars = {}; flashvars.cssSource = "piecemaker.css"; flashvars.xmlSource = "piecemaker.xml"; var params = {}; params.play = "true"; params.menu = "false"; params.scale = "showall"; params.wmode = "transparent"; params.allowfullscreen = "true"; params.allowscriptaccess = "always"; params.allownetworking = "all"; swfobject.embedSWF('piecemaker.swf', 'piecemaker', '1000', '600', '10', null, flashvars, params, null);
// ]]></script>
<center>
<div id="piecemaker">
<p>Put your alternative Non Flash content here.</p>
</div>
</center>
 
This is all that happens http://lucabrasico.com/index.php
And I've transfered the necessary files via FTP
Edited by PietroPaoloVirdis (see edit history)

Share this post


Link to post
Share on other sites

your code is bad. so bad.

 

you can't use:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR...tml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
<head>
<title>The Piecemaker by Modularweb</title>
<meta http-equiv="content-type" content="text/html; charset=utf-8" />

+

</body>
</html> 

because these things are already defined in prestashop theme .tpl files, if you will use this anywhere "inside" website, it is more than possible that code will crash a lot of things in website.

 

in addition you use this script file

scripts/swfobject/swfobject.js

is this script uploaded somewhere to your website? it's necessary to use direct path to this file (with http)

Share this post


Link to post
Share on other sites

Thanks for taking the time

Yes, the code is terrible. It's the example code in the Piecemaker documentation. I intend to cut it down and remove unnecessary bits.

I have uploaded all the necessary files, including the folder with the script you mention.

There are two folders uploaded. One called Flash, one called Web and within these two are all the flash, shockwave, images etc.

 

The scripts/swfobject/swfobject.js is within the web folder which is directly under public_html

Edited by PietroPaoloVirdis (see edit history)

Share this post


Link to post
Share on other sites

I'm having a battle with this and trying to learn more about PS at the same time.

I've looked at another slider, Cub3r http://javascriptajax.com/cub3r/prestashop-cub3r.html, which claims you can use with Prestashop. It's quite simple to set up the slider in the software and then generate the necessary files which are:

- index.html file

- prestashop_slider.c3x, which is a project file for making changes later

- A "Data" folder where the images are stored

- An "Engine" folder containing four files: cu3ox,swf, cu3oxCSS1.css, cu3oxxml1.xml & swfobject.js

 

From the index file I am adviced to grab this (in red) part of the code and enter it on my page:

-------------

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>prestashop_slider</title>
 
 
<!-- Start cu3ox.com HEAD section -->
<script language="JavaScript" src="engine/swfobject.js" type="text/javascript"></script>
<!-- End cu3ox.com HEAD section -->
 
</head>
<body bgcolor="#ffffff">
<!-- Start cu3ox.com BODY section id=cu3ox1 -->
<div id="cu3ox1" style="width:1200px;height:496px;margin:0 auto;text-align:center">
<script language="JavaScript" type="text/javascript">
var cu3oxId = ("cu3ox" + Math.random()).replace(".","");
document.write('<div id ="' + cu3oxId + '" style="text-align:center;"><img src="data/images1/piecemaker1.jpg"/></div>');
if (swfobject.getFlashPlayerVersion().major)
swfobject.createSWF(
 {data:"engine/cu3ox.swf", width:"100%", height:"100%" },
 {FlashVars:"images=data/images1&cfgsuffix=1",menu:true, allowFullScreen:false, allowScriptAccess:'sameDomain', wmode:"transparent", bgcolor:'#FFFFFF', 
  devicefont:false, scale:'noscale', loop:true, play:true, quality:'high'}, cu3oxId);
</script>
<a style="display:none" href="http://cu3ox.com">Free 3d Photo Gallery by cu3ox.com v1.8</a><noscript>
<!--[if !IE]> -->
<object type="application/x-shockwave-flash" data="engine/cu3ox.swf" width="100%" height="100%"  align="middle">
<!-- <![endif]-->
<!--[if IE]>
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=10,0,0,0"
width="100%" height="100%"  align="middle">
<param name="movie" value="engine/cu3ox.swf" />
<!-->
<param name="FlashVars" value="images=data/images1&cfgsuffix=1" />
<param name="allowScriptAccess" value="always" /><param name="allowFullScreen" value="false" />
<param name="quality" value="high"/><param name="scale" value="noscale"/>
<param name="wmode" value="transparent" />
<param name="bgcolor" value="#ffffff" />
<img src="data/images1/piecemaker1.jpg"/>
</object>
<!-- <![endif]-->
</noscript>
</div>
<!-- End cu3ox.com BODY section -->
</body>
</html>

-------------

But as mentioned by other, things get added and changed when I use the HTMLbox. Like this in the beginning:

-------------

<!-- Start cu3ox.com BODY section id=cu3ox1 -->
<div id="cu3ox1" style="width: 1200px; height: 496px; margin: 0 auto; text-align: center;">
<script language="JavaScript">// <![CDATA[
-------------
What am I doing wrong?
And where should I upload the above mentioned folders and files? In the root or in the theme folder?
 
By the way, I'm using PS 1.6, latest HTMLbox Free version and the default template.
Edited by PietroPaoloVirdis (see edit history)

Share this post


Link to post
Share on other sites

remember that if your slider use some external libraries (<!-- Start cu3ox.com HEAD section -->

<script language="JavaScript" src="engine/swfobject.js" type="text/javascript"></script>
<!-- End cu3ox.com HEAD section -->) it's necessary to upload that file and use DIRECT PATH TO FILE as i already mentioned.
the same for any other files like css, swf etc. these files must be online and you have to use DIRECT PATH TO THESE FILES.
 
in addition
<body bgcolor="#ffffff">
is already defined in prestashop template core.
 
the same with images
<img src="data/images1/piecemaker1.jpg"/>
 
you uploaded this image? i don't think so, because path is not changed too...

Share this post


Link to post
Share on other sites

I have uploaded the files and the images. For instance in my ftp clien the complete path to one of the files is:

/lucabrasico.com/public_html/engine/cu3ox.swf

 

Is that the whole path I must write?

So... 

<object type="application/x-shockwave-flash" data="lucabrasico.com/public_html/engine/cu3ox.swf" width="100%" height="100%"  align="middle">

Instead of...?

<object type="application/x-shockwave-flash" data="engine/cu3ox.swf" width="100%" height="100%"  align="middle">

And should it maybe be in the theme folder instead?

Share this post


Link to post
Share on other sites

Of course, here it is http://lucabrasico.com/index.php

 

In the end I used the Piecemaker (not module), and with your guidance I could figure out how to edit the index.tpl to look like this (I'm really clueless when it comes to programming. It's like trying to deschiffer old egyptian hieroglyphs to me, but it works)

 

{if isset($HOOK_HOME_TAB_CONTENT) && $HOOK_HOME_TAB_CONTENT|trim}
    {if isset($HOOK_HOME_TAB) && $HOOK_HOME_TAB|trim}
        
<script type="text/javascript">
  var flashvars = {};
 
  var params = {};
  params.play = "true";
  params.menu = "false";
  params.scale = "showall";
  params.wmode = "transparent";
  params.allowfullscreen = "true";
  params.allowscriptaccess = "always";
  params.allownetworking = "all";
  
  swfobject.embedSWF('piecemaker.swf', 'piecemaker', '960', '440', '10', null, flashvars,    
  params, null);
 
</script>
 
        <div id="piecemaker">
        </div>
</div>
</div> <!-- END of slider -->
        <ul id="home-page-tabs" class="nav nav-tabs clearfix">
{$HOOK_HOME_TAB}
</ul>
{/if}
<div class="tab-content">{$HOOK_HOME_TAB_CONTENT}</div>
{/if}
{if isset($HOOK_HOME) && $HOOK_HOME|trim}
<div class="clearfix">{$HOOK_HOME}</div>
{/if}
Edited by PietroPaoloVirdis (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi vekia

 

the module works great,

only problem I have (probably my fault) is that I can't find the language options on the editor and I need to translate the content for my secondary language

 

What am I missing?

 

thanks!

Share this post


Link to post
Share on other sites

Hi vekia

 

the module works great,

only problem I have (probably my fault) is that I can't find the language options on the editor and I need to translate the content for my secondary language

 

Also, I'm using it to show a features bar at the top of my homepage (secure payment, worldwide shipping...)

But I want to make a landing page for the site and i read in another post that this module can be used for that too, but can I use it for both things at the same time? or will I have to use two separate modules?

 

What am I missing?

 

thanks!

Share this post


Link to post
Share on other sites

this module adds only code to page source, if code that you added doesnt work it just mean that code is wrong.

Are you sure that this script is compatibile with your prestashop? 

Share this post


Link to post
Share on other sites

More and more I know about basic html code so more and more I like to be able to do just anything and this module is great for my purposes. Thanks a million times for a great working (Prestashop 1.6.0.5) module!

Share this post


Link to post
Share on other sites
  • 3 weeks later...

new version released!

- module contains now: extended tinymce editor in prestashop 1.6

- buttons to turn on / off editor in prestashop 1.6

Share this post


Link to post
Share on other sites

A bit of a stupid question perhaps......?

I am trying to place script into the module.

There are 2 buttons on the top of the box - clicking either of them toggles the editor box on/off.

When I paste my script into the box (either when editor visible, or when it is not) ......and then save I get confirmation that module has updated.

At the working site, (depending upon where I have placed the script to be operating) I either see nothing OR a similar set of text to my script. (FYI it is skype buttons script). When it does not show at all I am presuming that is due to the fact that the hook is full already.

Additionally when I look back at the module, the editor is now empty (except below the box is the word script).

When I look at the source code, it is heavily amended and hence cannot run the script as originally put into the module.

I am 95% sure it is my ignorance that is causing the issue.

 

I have tried removing the script many times, and replacing it - but still have the same recurring issue.

How do I insert (via copy and paste) a known working script into the module box - should editor be on or off?

Should I be concerned that the source code is amending the script? - In which case my script is wrong?

 

Thanks for your continued input to this site vekia, lots of your other posts have moved my sites along nicely.

Share this post


Link to post
Share on other sites

A bit of a stupid question perhaps......?

I am trying to place script into the module.

There are 2 buttons on the top of the box - clicking either of them toggles the editor box on/off.

When I paste my script into the box (either when editor visible, or when it is not) ......and then save I get confirmation that module has updated.

At the working site, (depending upon where I have placed the script to be operating) I either see nothing OR a similar set of text to my script. (FYI it is skype buttons script). When it does not show at all I am presuming that is due to the fact that the hook is full already.

Additionally when I look back at the module, the editor is now empty (except below the box is the word script).

When I look at the source code, it is heavily amended and hence cannot run the script as originally put into the module.

I am 95% sure it is my ignorance that is causing the issue.

 

I have tried removing the script many times, and replacing it - but still have the same recurring issue.

How do I insert (via copy and paste) a known working script into the module box - should editor be on or off?

Should I be concerned that the source code is amending the script? - In which case my script is wrong?

 

Thanks for your continued input to this site vekia, lots of your other posts have moved my sites along nicely.

 

show me your code, i will try it on my own

Share this post


Link to post
Share on other sites

This is what I input:

<script type="text/javascript" src="http://www.skypeassets.com/i/scom/js/skype-uri.js"></script>
<div id="SkypeButton_Call_name_1">
  <script type="text/javascript">
    Skype.ui({
      "name": "dropdown",
      "element": "SkypeButton_Call_name_1",
      "participants": ["name"],
      "imageSize": 32
    });
  </script>
</div>

 

I still believe it is my mistake somehow.

 

Thanks for your input.

 

 

 

 

Edited by Dacron (see edit history)

Share this post


Link to post
Share on other sites