Jump to content

Recommended Posts

when you use simple editor - code stay untouched, when you turn on WYSIWYG editor - the code will be different (beause tinymce wysiwyg editor changing it)

Share this post


Link to post
Share on other sites
  • Replies 591
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Prestashop HTML Box module --- for free --- works with: 1.2.x + 1.3.x. + 1.4.x + 1.5.x + 1.6.x + 1.7.x   This module is great tool for adding to your shop widgets created by other

yes you can, today I will write tutorial how to add a free image slider with this module

module has been improved to version 1.2   This update improved the interpretation of the characters you have used in your code, such as the ENTER (newline) were changed <br/> marker which caus

Posted Images

when you use simple editor - code stay untouched, when you turn on WYSIWYG editor - the code will be different (beause tinymce wysiwyg editor changing it)

 

The HTMLbox can be attached to one position at a time which was selected in module configuration?

Share this post


Link to post
Share on other sites

Problem: one javascript code must be placed inside of the <head> tags, and another part of javascript MUST be placed just before the </body> tag: how to get this?

 

it isn't mandatory. You can put all code in one hook, believe me.

 

How do i turn on error log

about error reporting you can read here: how to turn error reporting

ps. why you want to turn it on?

Share this post


Link to post
Share on other sites

yes, in one block, just use <script>your code here</script> and paste it to the box. You can add other content too (html for example).

Share this post


Link to post
Share on other sites

yes, in one block, just use <script>your code here</script> and paste it to the box. You can add other content too (html for example).

 

is there way to implement a separate header.tpl template, that will store code like this:

 

<!-- Block HTML box HEADER -->

<link rel="stylesheet" type="text/css" href="{$absoluteUrl}css/style.css" />

<script src="{$absoluteUrl}js/myjavascript.js" type="text/javascript"></script>

 

<!-- Block HTML box HEADER -->

Edited by galactic (see edit history)

Share this post


Link to post
Share on other sites

nope, in free version it isn't possible to use more than one hook at the time.

 

I'm telling not about hook, I mean to implement header.tpl template for this module, to use it when javascript need be placed in header section.

Share this post


Link to post
Share on other sites

you can paste your code to the box and select header section - it will work the same as it will work with header.tpl file.

Share this post


Link to post
Share on other sites

you can paste your code to the box and select header section - it will work the same as it will work with header.tpl file.

 

well, but the rest code need be in the body section.

Share this post


Link to post
Share on other sites

in this version it isn't possible to use more that 2 hooks. As i said - you can paste your code (with css and js) in body section, it will works too, it isn't necessary to put it in the header section. Try it, and you will see that it works :-)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

in this version it isn't possible to use more that 2 hooks. As i said - you can paste your code (with css and js) in body section, it will works too, it isn't necessary to put it in the header section. Try it, and you will see that it works :-)

 

Dear Vekia, did you manage to set something up like a tutorial how to add your module at the contact page?

 

I would be the happiest man on earth if you could ;-)

 

//Patrik

Share this post


Link to post
Share on other sites
  • 2 weeks later...

I just installed this module. IT keeps changing some of the "/" in my code for "\" I can't figure out why.

It does it inmediately after saving changes :/

 

 

Ok, I checked better and simplified the code. What it's doing is to add the "\" in places where it shouldn't be!

 

My code: <img src="http://www.quirky-me.com/img/header_info.gif"/>

 

What comes out just after saving: <img src=\"http://www.quirky-me.com/img/header_info.gif\"/>

Edited by Cintia (see edit history)

Share this post


Link to post
Share on other sites
  • 1 month later...

html block is a useful tool when you're know something about html / css etc. coding. You can also paste there widgets etc.

 

anyway, here is the code for the bar:

 

<p class="title_block">This is header</p>

  • Like 1

Share this post


Link to post
Share on other sites

html block is a useful tool when you're know something about html / css etc. coding. You can also paste there widgets etc.

 

anyway, here is the code for the bar:

 

<p class="title_block">This is header</p>

 

Tnks! Muchas gracias por tu ayuda!

Edited by alfredo_agur (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...

Hello, I am trying to hook in the left column youl module, with add - it started with <script type="text/javascript"> ....than ends with </noscript>, but it doesn´t want to show up. It is hooked in header, and left column. I tried as well to hook it only in left column, with no result. Any advices please? Thank you.

http://poladoskovo.eu

Share this post


Link to post
Share on other sites

new version released, actual version: 1.4.3

 

new features:

  1. update checker
  2. ability to display block only on secured pages (with ssl - https://)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

unfortunately in this case it isn't possible. it's because there is no hook to handle this module there.

you will need to define new hook, and insert it there where you want

 

(modifications are necessary)

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Hi. I just used this to enter my business number in the header of my website but how can I place it where I want to? its a bit high and centered and I want it lower and off to the right above the search box.  you can see what im talking about at nvaporize.com. Thanks

Edited by NVaporize (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

It is great module for me and it work, but I see 2 errors on the top of back office when i am saving. 

How can fix it?

 

Notice: Undefined index: htmlbox_ssl in /home/triggerp/public_html/modules/htmlbox/htmlbox.php on line 85

Notice: Undefined index: htmlbox_home in /home/triggerp/public_html/modules/htmlbox/htmlbox.php on line 86

 

 

 

 

 

Share this post


Link to post
Share on other sites

hello

 

these messages aren't errors, these messages are notices. and you don't have to worry.

I will fix it in nearest update

 

thank you for your attention

 

with regards,

Milos

Share this post


Link to post
Share on other sites

Hi Vekia!

 

I love your module :)

 

I've loaded new version 1.4.4 in a PS 1.5.6.0 new install.

 

In the editor, I'm trying to load a picture with no success. I've checked that the image file was loaded fine.

Please see here screenshots, one with editor off and one with editor on

 

http://i42.tinypic.com/312cwuu.jpg

http://i41.tinypic.com/2vx3w4k.jpg

 

Any clue?

Many thanks.

Ciao

Valeria

Share this post


Link to post
Share on other sites

Hi Vekia!

 

I love your module :)

 

I've loaded new version 1.4.4 in a PS 1.5.6.0 new install.

 

In the editor, I'm trying to load a picture with no success. I've checked that the image file was loaded fine.

Please see here screenshots, one with editor off and one with editor on

 

http://i42.tinypic.com/312cwuu.jpg

http://i41.tinypic.com/2vx3w4k.jpg

 

Any clue?

Many thanks.

Ciao

Valeria

 

OMG, sorry Vekia, I cannot load a picture in any editor of BO.

So it's not your module issue, it's the whole PS issue.

Though I'm off-topic, could you please help? Thanks!

Share this post


Link to post
Share on other sites

it looks like your url is wrong. I suppose so.

you've got there /public_html/ etc. and by default this can't be a part of url

 

This is a temporary url.

The shop will then be moved to a proper url.

Share this post


Link to post
Share on other sites

I was afraid that it might be a problem with module :)

thank you for confirmation that you fixed your issue with appearing of this image :)

 

Thanks to you!

You deserve it for all the effort you put in this forum :)

 

Ciao!

Share this post


Link to post
Share on other sites

I have PS 1.4.11.  How can I use this module to show info on the product page depending on the parent category?  So for example if the product is in the catagory 'stationery' show 'x' else show 'y'?

Share this post


Link to post
Share on other sites

So I couldn't add this: {if $product->id_category_default ==3}{l s='some content'}{/if}{if $product->id_category_default ==4}{l s='some content for category 4'}{/if}

 

Why is that? I thought it would take any code.  Does the module not work like a php include on the page?

Share this post


Link to post
Share on other sites
  • 2 weeks later...

 

Prestashop HTML Box module

--- for free ---

works with: 1.2.x + 1.3.x. + 1.4.x + 1.5.x

This module is great tool for adding to your shop widgets created by other websites like twitter, facebook, pinterest, allegro, etc. Main feature in this module is an ability to add the "client side" code such like HTML, javascript, css for any place you want.

htmlbox-free-big.png

article about this module for free download

wait for tutorials about usage this module for adding facebook like box etc.

updates of the module

version | date

 

1.4.4 | 23.09.2013

1.4.3 | 27.08.2013

1.4.2 | 13.05.2013

1.4.1 | 29.04.2013

1.3 | 07.11.2012

download file:

 

 

Hi , if i need add few codes to different places , its possible to do ?

Share this post


Link to post
Share on other sites

Hi , if i need add few codes to different places , its possible to do ?

 

Unfortunately free version doesnt allow to use more positions. sorry. You can do it only with pro, it supports more than 24+ positions and you can add as many blocks to certain positions as you want.

Share this post


Link to post
Share on other sites

module updated! version 1.4.5 released

 

fixed problems with:

- appearing of block in old prestashop 1.3.x (now it works once again!)

- appearing of notification about undefined index htmlbox_ssl (in back office only)

 

 

enjoy!

  • Like 1

Share this post


Link to post
Share on other sites

Hi again,

I uploaded the module yesterday (transferred thorugh ftp). As soon as I had installed it a warning has shown up in my admin section saying "New version available, check MyPresta.eu for more informations" - I thought I had installed the latest version from you... Which one is the newest and correct version I should be using?

Also, the actual module is today flagged with a warning triangle and is no longer showing in my webshop. Do you know why this might be? Many thanks!

Share this post


Link to post
Share on other sites

Hi again - I deleted module from ftp then i downloaded module again from your link above and submitted it through the ftp again. What seems to happen is that the content (which I had added in the deleted module) shows up in the 'new' module added I used also all the error messages still show. Any ideas on how I can solve this?

By the way I could not use the link above (config.xml) to check version - it just reads that this page does not exist.

Share this post


Link to post
Share on other sites

it looks like individual issue,

can you grant me access to your back office? i will inspect everything for you

you can grant access only to the MODULES tab (i don't need any other back office sections)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Czy mogę gdzieś określić/zmodyfikować marginesy tego modułu/jego wymiar? Mimo usilnych prób nie mogę umieścić obok siebie trzech gifów. Trzeci zawsze wskakuje mi pod dwa poprzednie. Moduł nie posiada swojego własnego pliku css więc nawet nie wiem gdzie i co mógłbym edytować. Poza tym to i tak dopiero mój 6 dzień z Prestą...

 

http://www.boszet.vdl.pl/

Share this post


Link to post
Share on other sites

prestashop container #page has got 980px; width

you have got 3 images with width = 327

 

327x3=981

 

there is not enough space to display 3 images in one line. decrease width of one of them to 326px;

 

and to your <a> objects add styles 

display: inline-block;
float: left;

Share this post


Link to post
Share on other sites

Ok I managed to fix the problem. Apart from size of the image I had to change this line:

 

.sf-right {
  margin-right: 0px;
  float: right;
  width: 0px;
}

 

in file superfish-modified.css

 

 

Thanks for help anyway.

Edited by boszet (see edit history)

Share this post


Link to post
Share on other sites

Hello everyone ~

I am currently using a product similar to HTML box on my company homepage.

It looked fine in the past, until my we decided to upgrade to PS 1.5.6.1

Now, depending on the browser you use, the free html box area on the home

page doesnt look correct. Specifically, if you look at the home page using

Internet Explorer - it looks fine

Chrome - it forces all of the HTML to be left aligned underneath the categories

(left black margins). 

Please look at the home page using both Chrome and Internet Explorer to understand:

http://voigtglobal.com/

 

Have you had this kind of problem with this "HTML Box" free module?

 

Thank you 

 

 

Share this post


Link to post
Share on other sites

everything depends on code that you use, not on module.

what does it mean? it means that code you use is probably not correct.

 

i checked your page and it looks like:

zM9lSso.png

 

where the problem is?

 

and what code you use?

Share this post


Link to post
Share on other sites

use this code

<img style="position:absolute; left:360px;" src="http://fiskpaakrogen.dk/img/cms/top%20fisk.jpg" width="363" height="106">

effect:

ztuboMe.png

 

 

 

at the end i just want to say it's not module issue.

what you see depends on code that you use :)

Share this post


Link to post
Share on other sites

new version released!

module is now in 1.4.7 version, i added:

- prestashop 1.3.x version fix, now tinyMCE rich text editor works also in this PS engine

- buttons to switch editor type also works in 1.3.x now

- changed button to switch editor type

- fixed problems with escaping strings in database

  • Like 1

Share this post


Link to post
Share on other sites
  • 3 weeks later...

For my header I use the HTML box free, this works fine in full screen but when i resize my screen, lets say at 50%, the header dont resizes allong with the website-page. It's also the same on android tablet ,..im doing something wrong.

 

post-743566-0-23968600-1388692858_thumb.png

 

post-743566-0-99334800-1388692903_thumb.png

Share this post


Link to post
Share on other sites

everything depends on code that you use there.

you jave to use correct code, then everything will work fine

 

can you show your code please?

Share this post


Link to post
Share on other sites