Jump to content
Raptor

"Employee does not exist or password is incorrect" suite import BDD

Recommended Posts

Bonjour à tous : suite à installation en local via mamp, création de la boutique OK, connexion au Back Office OK. Tout fonctionne

Je décide d'importer 1 BDD créée sous la version PS 1.4.3 : je supprime donc toutes les tables de la nouvelle base et j'importe ma sauvegarde : import OK.

Par contre plus moyen d'arriver sur la boutique et en me connectant au Back Office, j'obtiens le message"Employee does not exist or password is incorrect". (J'ai comparé les fichiers config et ma BDD est renommée différemment mais encore...)

Ci-joint copie écran et rapport d'erreurs : si quelqu'un a 1 idée...

Merci à vous et bonne journée.

post-43238-0-19196400-1347877598_thumb.jpg

Share this post


Link to post
Share on other sites

Il te faut faire une demande de mot de passe oublié et le changer à nouveau, le changement de base à changer le codage des mots de passe.

Share this post


Link to post
Share on other sites

Bonjour

 

 

Pour une installation en local la demande de mot de passe ne fonctionne pas comme en ligne.

 

Par contre comme vous avez accès à la base de donnée vous pouvez faire toutes les modifications nécessaire.

 

1° chercher la table ps_employee et là à droite vous verrez l'adresse e-mail, donc déjà vous pouve vérifier si l'e-mail est bonne.

 

Si toute fois ça ne fonctionne toujours pas. Vous pouvez mettre un nouveau mot de passe pour ce faire :

 

1° dans le dossier config/setting.inc.php la ligne :

define('_COOKIE_KEY_', 'quQ1fbI3TeGE4pOzzON4mEmpq41aXtLyBoOmoNZyw3XYYZi8tmGhGiPk');

 

Là c'est un exemple d'une installation local mais ne jamais mettre en public cette ligne.

 

Copier : quQ1fbI3TeGE4pOzzON4mEmpq41aXtLyBoOmoNZyw3XYYZi8tmGhGiPk

 

ces lettres et chiffres les votres bien sûr puis vous allez sur le site de md5.fr

Là vous avez un grand cadre vous coller dedans et ajouter votre motdepasse accoller

 

quQ1fbI3TeGE4pOzzON4mEmpq41aXtLyBoOmoNZyw3XYYZi8tmGhGiPkMONMOTDEPASSE

 

Après vous cliquez sur le bouton Convertif en MD5

 

Puis vous verrez : Résultat : 89731cc50d5dbde71e77edfaa2919499

Vous copiez 89731cc50d5dbde71e77edfaa2919499 et vous collez ça dans la base de donnée table ps_employee et à la place du mot de passe enregistré et vous testez.

 

Attention de bien noter le mot de passe que vous mettez !! sinon il faut recommencer :)

Share this post


Link to post
Share on other sites

Salut à tous

 

Je me permets de remonter ce topic quelque peu ancien.

 

Ayant excatement ce même problème d'accès au Back Office, j'ai suivi la procédure décrite ci-dessus mais le problème persiste toujours.

 

Voici les messages d'erreur qui s'affiche après avoir activé le mode Debug dans le fichier config.php: @ini_set('display_errors', 'on');

 

Warning: include(C:\wamp\www\SITE/translations//admin.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory in C:\wamp\www\SITE\admin333\login.php on line 58

 

 

Warning: include() [<a href='function.include'>function.include</a>]: Failed opening 'C:\wamp\www\SITE/translations//admin.php' for inclusion (include_path='.;C:\php\pear') in C:\wamp\www\SITE\admin333\login.php on line 58

 

Warning: include(C:\wamp\www\SITE/translations//errors.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory in C:\wamp\www\SITE\admin333\login.php on line 59

 

Warning: include() [<a href='function.include'>function.include</a>]: Failed opening 'C:\wamp\www\SITE/translations//errors.php' for inclusion (include_path='.;C:\php\pear') in C:\wamp\www\SITE\admin333\login.php on line 59

 

Auriez-vous une petite idée du problème? Je m'arrache les cheveux depuis 2 jours.

 

D'avance merci pour votre aide

Share this post


Link to post
Share on other sites

Bon, il y a du mieux.

 

J'ai recommencer la procédure de génération de nouveau mot de passe.

 

Les messages d'erreurs ont disparu et j'arrive à accéder à un semblant de Back Office sauf que le warning error2.pngaccès interdit apparaît.

 

Une petite idée?

 

Merci

Share this post


Link to post
Share on other sites

Hello,

 

C:\wamp\www\SITE/translations//admin.php

 

La il manque les langues ! le /fr/ . Y a un gros soucis soit de cookie, soit de fichier absent mais là c'est mal parti.

 

Pourquoi tout simplement ne pas télécharger /config/settings.inc.php du site en ligne vers le local et dedans y modifier les accès à la base de données pour localhost en base _DB_SERVER_ et généralement et root sans mot de passe pour les identifiants _DB_USER_ et _DB_PASSWD_. Éventuellement corriger __PS_BASE_URI__ pour /SITE/ et/ou _DB_NAME_ si le nom de la base est différent.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour

 

C'est effectivement mal parti...

 

J'ai résolu le problème de langues. J'avais mis InnoDB à la ligne define('_MYSQL_ENGINE_', 'MyISAM'); au lieu de 'MyISAM' pour le reste tout était OK mais ça ne donne toujours rien.

Le mieux serait que je recommence toute l'installation depuis le début. Je finis par m'emmêler les pinceaux et ne plus avoir où j'en suis.

 

Merci quand même d'avoir pris la peine de me répondre

 

Bonne après- midi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More