Jump to content
verathom

Shop zeigt immer Nettopreise (CH) an.1.5.0.17

Recommended Posts

Guten Tag

 

Habe soeben Prestashop 1.5.0 final (1.5.0.17) installiert.

 

Habe folgendes Problem:

Der Shop zeigt bei den Produkteseiten immer den Nettopreis an. Im Warenkorb summiert der Shop jeweils zu den Nettopreisen (Produkt plus Versandkosten) die Mehrwertsteuer dazu.

 

Ich möchte folgendes erreichen:

Der Shop soll generell mit Bruttopreisen arbeiten. Es macht keinen Sinn, Nettopreise auf Versandkosten und Produkte anzuzeigen. Der Shop darf die Mehrwertsteuer separat ausweisen, aber nicht mit Nettopreisen auf Versandkosten und Produkte arbeiten.

 

Folgende Einstellungen habe ich breits geprüft:

- Katalog -> Produkte: Bei den Produkten ist ein Kaufpreis ohne MwSt, ein Verkaufspreis ohne MwSt und ein Verkaufspreis inkl. MwSt (8%) hinterlegt. Die Zeile "Endgültiger Verkaufspreis" wird inkl. MwSt. korrekt angezeigt.

- Kunden -> Gruppen: In dieser Kategorie haben sämtliche Kundengruppen den Wert "Preisanzeige" inkl. Steuer angegeben.

- Versand -> Versand: In dieser Kategorie können die Versandkosten nur ohne MwSt. angegeben werden. Mir ist es ein Rätsel, wieso und ich finde keine Einstellung, um diese Versandkosten mit MwSt. anzugeben.

- Lokalisierung -> Steuern: Steuern aktivieren ist eingeschalten und Steuern im Warenkorb anzeigen ist ausgeschalten (bei letzerem habe ich rumgespielt, aber die Steuern werden trotzdem angezeigt und alle Preise werden ohne MwSt. angezeigt). In dieser Kategorie: Eine Steuerregel von drei aktiv.

- Lokalisierung -> Steuerregeln: Eine von drei aktiv. Innerhalb dieser zwei Länder plus Alle zugewiesen und das Verhalten soll für diese Länder 8% MwSt. zuweisen. Alles aktiv. PLZ = 0 (Standard)

 

Den Cache habe ich mehrfach geleert (Browser und Smarty).

 

Habe ich was übersehen? Warum werden immer die Nettopreise statt die Bruttopreise angezeigt? Weiss jemand mehr? Habe im Forum nach Hinweisen gesucht, aber keine Brauchbaren gefunden.

 

Freundliche Grüsse

verathom

Edited by verathom (see edit history)

Share this post


Link to post
Share on other sites

Sorry, aber für Entwicklerversionen bist du hier falsch. Probleme mit nicht freigegebenen Entwicklerversionen werden lediglich im Englischen Forum oder im bug-tracker behandelt. Beides ausschließlich in Englischer Sprache.

 

1.5.1.7 ist nicht für den produktiven Einsatz gedacht. Hast du Probleme mit einer offiziellen, freigegebenen Version, dann darfst du deine Fragen und Probleme gerne hier posten.

Share this post


Link to post
Share on other sites

Eines aber vorab, wenn du gleich mit PS 1.5.X einsteigen möchtest: Für die Nutzung einer Prestashop Version 1.5. ist auch ein Server mit einem Minimum an memory_limit von 256M nötig, sowie ein sehr großer Webspace mit optimierten Cache-Module (e-accelerator, cloud, usw.) nötig.

Share this post


Link to post
Share on other sites

1.5.1.7 ist nicht für den produktiven Einsatz gedacht. Hast du Probleme mit einer offiziellen, freigegebenen Version, dann darfst du deine Fragen und Probleme gerne hier posten.

 

Die Version ist freigegeben als Version 1.5.0 und Final. Vergleiche dazu die Homepage. Ich schrieb zudem von der Version 1.5.0 final (1.5.0.17) und nicht von einer 1.5.1.7.

Edited by verathom (see edit history)

Share this post


Link to post
Share on other sites

Eines aber vorab, wenn du gleich mit PS 1.5.X einsteigen möchtest: Für die Nutzung einer Prestashop Version 1.5. ist auch ein Server mit einem Minimum an memory_limit von 256M nötig, sowie ein sehr großer Webspace mit optimierten Cache-Module (e-accelerator, cloud, usw.) nötig.

 

Diese Aussage kann ich nicht nachvollziehen. Angeblich sind folgende Requirements notwendig:

 

A domain name

  • Web server: Apache 1.3, Apache 2.x, Nginx or Microsoft IIS
  • PHP 5.1+ installed and enabled
  • MySQL 5.0+ installed with a database created
  • FTP access (ask for your credentials)

OPTIONAL

  • In the PHP configuration ask your provider to set memory_limit to "64M" and file_max_upload_size to "16M"
  • SSL certificate if you plan to process payments internally (not using PayPal for instance)
  • Optional PHP extensions: GD, cURL, SimpleXML, SOAP
  • To improve performances: MemCached, mcrypt PHP extension

Bis auf den MEMCash habe ich alles.

 

memory_limit 256 MB wäre schon extrem heftig, davon kann ich nirgends was lesen. Ab 32 MB sollte der Shop rauschen, ich habe 64MB und der Shop läuft schnell.

 

Ich spreche einzig davon, dass nur die Nettopreise angezeigt werden.

 

Schaue ich den HTML/JavaScript-Output an der generiert wird, sehe ich folgendes:

var productPriceWithoutRedution = '69.907407';

var productPrice = '69.91';

Der Product Price sollte meines Erachtens 75.50 sein.

Share this post


Link to post
Share on other sites

Oh sorry, das ist mir neu und keiner wurde darüber informiert...

Die Voraussetzungen die du ansprichst, gelten schon lange nicht mehr und ich habe immer wieder darauf aufmerksam gemacht, dass diese für eine Version 1.3. sind, aber nicht für eine 1.4. und jetzt auch nicht für eine 1.5.

 

Mindestanforderungen für 1.5. sind memory_limit mindestens 128M aber man sollte sich gleich 256M nehmen, wenn man vor hat Multishop zu nutzen.

 

Auch mcrypt ist nicht Optional und in einer 1.4. Version ebenso erforderlich. Sorry, für die Fehlinformation, ich kann nichts dafür wenn die das nicht anpassen. In der Praxis hat sich gezeigt, dass die Angaben veraltet sind.

 

Die Einstellungen von 1.5. gelten gleich wie in 1.4. Daran hat sich nichts geändert, bis eben auf die Serverressourcen. PS 1.5. benötigt 3X mehr Serverressourcen, als eine 1.3. und 2X mehr als eine 1.4. weil die Datenbank auch doppelt bzw. dreifach größer ist.

Auch das mit cURL stimmt nicht mehr, denn das Paypal-Modul benötigt diese Schnittstelle und ist kein Optional.

 

Bezüglich der Steuerklassen. Sind die Steuern den Produkten auch verlinkt ? Auch hier hat sich keinerlei Änderung gegeben zu einer 1.4. Version. Bis auf die Versandkosten, die man jetzt pro Artikel steuern kann. Die Steuern für die Versandkosten waren schon immer beim Versanddienst zu hinterlegen.

 

Nimm dir die aktuelle Wiki her. Es hat sich nichts am Erfassen von Produkten, Kategorien und Versanddiensten geändert.

 

Probleme bitte HIER hinterlegen.

Share this post


Link to post
Share on other sites

Oh sorry, das ist mir neu und keiner wurde darüber informiert...

Die Voraussetzungen die du ansprichst, gelten schon lange nicht mehr und ich habe immer wieder darauf aufmerksam gemacht, dass diese für eine Version 1.3. sind, aber nicht für eine 1.4. und jetzt auch nicht für eine 1.5.

Mindestanforderungen für 1.5. sind memory_limit mindestens 128M aber man sollte sich gleich 256M nehmen, wenn man vor hat Multishop zu nutzen.

 

Ich kriege nicht mehr als 64MB bei meinem Provider. Ich finde 128 MB allerdings heftig für nicht mehr. Tabellen hin oder her.

Gemäss dem angegebenen Wiki sollte der Server ausreichen: At least 32 Mb of RAM on your server (64 Mb is comfy, the more the better)

 

Ich nutze kein Multishop und habe viele Module deaktiviert. Billing gibts nur über Rechnung. Der Shop läuft quasi auf dem Minimum. Mit der 1.4er-Version hatte ich damals solche Probleme nicht, die Preise wurden mit Mehrwertsteuer angezeigt wie erwünscht. Ich habe das Gefühl, dass ich eine Einstellung übersehen habe und aus diesem Grund der Warenkorb nur die Nettopreise anzeigt usw. Haben den Shop komplett neu aufgesetzt, die 1.4er war nur experimental. Will nicht von 1.4 auf 1.5 später migrieren.

 

Aktuell sind rund 10 Produkte eingestellt. Falls der Shop eine entsprechende Nachfrage generiert, könnte man die Infrastruktur auf ein Prestashopangebot umstellen. Zum Testen muss die Infrastruktur allerdings reichen. Der Server hat null Last aktuell.

 

Auch mcrypt ist nicht Optional und in einer 1.4. Version ebenso erforderlich. Sorry, für die Fehlinformation, ich kann nichts dafür wenn die das nicht anpassen. In der Praxis hat sich gezeigt, dass die Angaben veraltet sind.

 

MCrypt läuft.

 

Die Einstellungen von 1.5. gelten gleich wie in 1.4. Daran hat sich nichts geändert, bis eben auf die Serverressourcen. PS 1.5. benötigt 3X mehr Serverressourcen, als eine 1.3. und 2X mehr als eine 1.4. weil die Datenbank auch doppelt bzw. dreifach größer ist.

Auch das mit cURL stimmt nicht mehr, denn das Paypal-Modul benötigt diese Schnittstelle und ist kein Optional.

 

Wie gesagt, brauche nur wenige Module. Will hier aber keine "Hast Du genug Power"-Diskussion führen, verlasse mich auf die offiziellen Angaben: http://doc.prestashop.com/display/PS14/Getting+Started#GettingStarted-Technicalrequirements

Gemäss dem 1.5er Wiki sollten meine Einstellungen ebenfalls reichen:

http://doc.prestashop.com/display/PS15/What+you+need+to+get+started

 

Bezüglich der Steuerklassen. Sind die Steuern den Produkten auch verlinkt ? Auch hier hat sich keinerlei Änderung gegeben zu einer 1.4. Version. Bis auf die Versandkosten, die man jetzt pro Artikel steuern kann. Die Steuern für die Versandkosten waren schon immer beim Versanddienst zu hinterlegen.

 

Die Preise für Pakete betragen CHF 8.- inkl. Mehrwertsteuer. Heisst das, dass man immer den Betrag ohne Mehrwertsteuer erfassen muss, auch wenn der Dienstleister dies nur mit Mehrwertsteuer anbietet?

 

Was heisst "Sind die Steuern den Produkten auch verlinkt?"? Bei jedem Produkt ist die Steuerregel 8% hinterlegt. Aus dem Grund zeigt es mir z.B. folgendes an:

- Verkaufspreis ohne MwSt

- Verkaufspreis inkl. MwSt

- Endgültiger Verkaufspreis

Alle Preise in der Produktübersicht sind korrekt. Ich will nun aber, dass die auf den Produkteseiten der endgültige Verkaufspreis angezeigt wird. Ich meine: Wie merkt der Kunde sonst, dass die Preise exkl. MwSt sind? Ist ja ne Zumutung, wenn er dies erst im Warenkorb merkt...

 

Der Warenkorb sieht aktuell wie folgt aus: Gesamt Produkte (exkl. MwSt.): CHF 69,91 Gesamt Versandkosten (exkl. MwSt.): CHF 8,00 Gesamtpreis exkl. MwSt.: CHF 77,91 Gesamt Steuern: CHF 5,60

 

Ich stelle mir die Konfiguration wie folgt vor: Gesamt Produkte (inkl. MwSt.): CHF 75,50 Gesamt Versandkosten (inkl. MwSt.): CHF 8,00 Gesamtpreis CHF 83,50 Davon Steuern: CHF 5,60

 

Mir scheit, dass ich da was übersehen habe, aber ich komme nicht drauf, was es ist.

 

Gruss

Share this post


Link to post
Share on other sites

Lokalisierung CH auch ausgewählt, bzw. bei der Installation CH gewählt ? Kriegst du es trotzdem nicht hin, dann bitte Bug-Tracker verwenden. Ich habe keinerlei Probleme und habe es soeben mit DE und AT Installation getestet. Evtl. liegt ein Fehler beim Lokalisierungspaket CH vor ?

Share this post


Link to post
Share on other sites

Bezüglich der Minimalkonfiguration, da wird leider nicht die Wahrheit geschrieben. Sorry, dass ich das so mal pauschal sagen muss. 128M sind ausreichend für bis zu 2.000 Produkte und ca. 300 Kunden mitsamt Bestellmanagement. Alles darüber hinaus hat sich gezeigt, dass man dafür ein memory_limit von 256M benötigt. Spätestens wenn man Module dazukauft oder installiert, wenn man den Shop schon einige Zeit am Laufen hat oder anfängt Attribute zu verwenden reicht es nicht mehr.

 

Also ich habe nichts davon, wenn ich dir sage: ja gut ist und du rennst voll in das Unglück, der Shop geht dann garnicht wegen den Restriktionen. Baust du gerade etwas auf, dann solltest du auch daran denken, dass der Shop nicht so klein bleibt und auch nicht geizig mit den Limits umgehen, sonder nach oben auch einen guten Polster offen lässt.

 

Ich bin im e-commerce bereits 9 Jahre tätig und verwende Prestashop auch schon über 2 Jahre. Ich sage dir nur wie es ist. Papier ist geduldig. Wir treffen uns sicher später im Forum mit dem Problem sicher wieder, wenn du den offiziellen Empfehlungen mehr Glauben schenkst, als die eines Users mit mehreren Prestashops am Laufen.

Share this post


Link to post
Share on other sites

Ich warne auch ausdrücklich davor diese Version als final anzusehen und sie produktiv einzusetzen ! Ich konnte alleine in den 2 Std. wo ich mich damit befasse 10 kritische Bugs finden, wenn man einen bereits funktionierenden Shop upgradet: http://www.prestasho...1425-auf-15017/

 

Bei neuen Projekten kann ich nichts dazu sagen, aber nach deinem Report nach, müsste die Lokalisierung CH ebenfalls einen Fehler enthalten. AT und DE funktionieren ohne Probleme. Dies gilt aber wirklich nur für absolut neue Shops. Trotzdem würde ich sehr, sehr vorsichtig mit der neuesten Version herangehen und doch vorerst eine 1.4.9 für den Live-Einsatz bevorzugen. Zumindest greift hier der 1-Button Fix und man hat nach wie vor jede Menge kostenlose und Kaufmodule, sowie Kaufthemen zur Verfügung.

 

Zu den Mindestvoraussetzungen verliere ich kein Wort mehr, es verhält sich genauso wie Hier weiter unten auf der Homepage übersetzten Variable "Unter Impressum zu finden" Prestashop AG. Prestashop ist garkeine AG. Prestashop ist eine GmbH. Ich habe des öfteren schon auf diesen Fehler hingewiesen. Er wird ignoriert....

 

Mache dir also selbst ein Bild darüber und glaube entweder dem geduldigen Papier, oder einen User mit einigen Prestshops und praktischer Erfahrung mit kleinen und auch sehr großen Shops mit über 10.000 Produkten.

Share this post


Link to post
Share on other sites

Vermutlich liegt das Problem genau in den Mindestanforderungen, wie ich vermutet habe. Mittlerweile melden einige das gleichen Problem, welches ich absolut nicht nachvollziehen kann. Siehe HIER.

 

http://www.prestasho...t-bei-mir-nicht

 

Eine andere Möglichkeit wäre auch die PHP-Version. Nicht alle funktionieren fehlerfrei. Meine Version ist 5.3.8. SOAP SSL, auch mit 5.3.9 SOAP SSL keine Probleme.

Share this post


Link to post
Share on other sites

Ich hab exaxt das gleiche Problem, aber denke, ich konnte es jetzt lösen. Und das hat mit sicherheit nichts mit der Leistung des Servers zu tun.

 

Kundengruppen => Besucher => Preisanzeige: inkl. Steuer auf Preisanzeige: exkl. Steuer

 

Bei mir werden die Preise nun im Frontend INKL. MWST. angezeigt. Ich denke, die anderen beiden Kundengruppen muss ich nun auch noch ändern. Ist das ein Übersetzungsfehler?

 

Wo liegt eigentlich der Unterschied zwischen Gast und Besucher? Kann eine der beiden weg?

 

Grüsse

Leser

 

EDIT: Kunden bzw. registrierte Benutzer musste ich auch auf exkl. Mwst. setzen, damit die Preise inkl. Mwst angezeigt werden. Ich kann damit leben, ist aber verwirrend.

Edited by Leser (see edit history)

Share this post


Link to post
Share on other sites

Das Problem hier ist ein anderes. Viele User geben bei der Installation nicht die Lokalisierung an, somit werden auch keine Steuern angelegt.

 

Dann liegt ein Denkfehler in der Logik vor.

 

Diese User verwenden die Option Steuern "neu" direkt im Artikel. Diese Funktion legt zwar einen Satz an, aber keine Regel dazu.

 

Aus diesem Grund funktionieren die Regeln dann alle nicht.

 

Man muss zunächst den Shop einrichten und dann erste Produkte und Kategorien anlegen, dann klappt alles ohne Probleme.

 

In Bezug auf memory_limit. Die Angaben sind schon steinalt. Wie die Praxis aber zeigt und die Shops bleiben ja nunmal nicht klein, wenn man wirklich erfolgreich verkauft, sollte ein Limit von 128M für 1.4 und 1.5. als Minimum eingestellt sein. Spätestens, wenn die 64M nicht mehr aussreichen hat man dann im BO und auch in Front Office weisse Seiten, oder Funktionen die nicht mehr geladen werden können.

Also warum geizig anfangen, um nach einigen Monaten dann überraschend einen Shop zu haben der nicht mehr funktioniert, weil er gewachsen ist ? Ich verstehe die Logik nicht. Aber na gut, ist ja auch nicht mein Problem...

Share this post


Link to post
Share on other sites

Gast ist einer der bereits eingekauft hat aber als Gast "Gastfunktion" ohne vollwertiges Kundenkonto. Besucher ist jemand der z.B. ein Konto erstellt hat aber noch nichts gekauft hat.

Share this post


Link to post
Share on other sites

Ist ja nicht mein erster Shop den ich baue, vorher nutzte ich aber Magento. Da Magento aber elend lahm ist, dachte ich, ich versuch mal Prestasop für ein neues Projekt.

 

Bei der Installation hab ich alles korrekt ausgewählt und bevor ich Produkte eingebe, kümmere ich mich um das Grundsetup, wie Steuern, Versand, Gruppen, Kategorien. Danach habe ich die ersten Produkte angelegt und diese wurden im Frontent netto angezeigt, obwohl alles korrekt eingestellt war. Erst nachdem ich in den Kundengruppen die Preisanzeige von inkl. auf exkl. Mwst. gestellt habe, werden die Preise BRUTTO inkl. Mwst. angezeigt. Also liegt da anscheinend ein Bug vor oder die Übersetzung ist falsch. Naja, es geht ja nun.

 

Grüsse

Edited by Leser (see edit history)

Share this post


Link to post
Share on other sites

Na ja. Dann viel Glück. PS ist kein Magento, es fehlt aber nicht viel... Willkommen im Klub. Magento habe ich auch sein lassen genau aus diesem Grund.

 

Bezüglich des memory_limits ist aber auch das Projekt welches umzusetzen ist ausschlaggebend. Mein Shop ca. 20.000 Produkte und 300 Filteroptionen. Bei mir geht ein memory_limit von 526M auf einem fast-cgi Netzwerk mit allen Optimierungen mit einer parse von 2 Sek. Klar dass ein Shop mit unter 2.000 Produkten nicht diese Ressourcen benötigt...

 

Bei Magento ? Frage mich nicht. Ich habe viele graue Haare deswegen...

 

Bezüglich der Übersetzungen kann ich dazu leider nichts sagen. Seit ich diese nicht mehr mache oder korrigiere, habe ich keinen Einblick mehr. Alles möglich, denn es versuchen sich jetzt Leute daran, die a) die Software nicht kennen und b ) keine Ahnung von den Fachausdrücken haben. Wenn ich krasse Dinge selbst finde, dann ändere ich diese ab, so dass sie für die nächste PS-Version wieder korrigiert zur Verfügung stehen. Als ich hier ausgestiegen bin, waren ca. 62% von mir übersetzt, die restlichen 39% haben irgendwelche Leute gemacht, deren Know-How und Zuverlässigkeit, bzw. Treffergenauigkeit leider nicht kenne. Der Rest ist noch unübersetzt.

Wo soll den die Stelle genau sein, damit ich sie mir ansehen kann ?

Share this post


Link to post
Share on other sites

Bei den Kundengruppen scheint Preisanzeige inkl. Mwst. und exkl. Mwst vertauscht zu sein, zumindest beim Setup für die Schweiz. Kann aber auch morgen selbst nochmal nachschauen. Achso, Version 1.5.1.

 

Gegenüber Magento ist die Geschwindigkeit echt super. Der Shop ist auch nur erstmal für max. 200 Produkte vorgesehen, also der Speicherbedarf hält sich in Grenzen.

Share this post


Link to post
Share on other sites

OK. Hier kannst du es mit 64M probieren, wenn nicht noch einige extra Kaufmodule dazukommen. Meistens bleibt es aber nicht bei so kleinen Shops und die Überraschung ist dann sehr groß, wenn plötzlich nichts mehr geht. Wer schaut auch täglich ins front-office ? So fällt es den meisten erst dann auf, wenn es schon lange zu spät ist und keine Bestelllungen mehr reinkommen...

 

Bei vielen 1.4. Shops reichen die 64M auch schon nicht mehr und es wird dann reklamiert, dass die Modulseite leer bleibt, oder die Übersetzungen nicht mehr geladen werden. Das sind die ersten Zeichen, für zu wenig memory.

Share this post


Link to post
Share on other sites

Ich hab ja keine Probleme mit Speicher, bei mir ist derzeit 128M eingestellt. Hab mich nur eingeklingt, weil ich das selbe Problem heute hatte, wie der Threadersteller.

Share this post


Link to post
Share on other sites

OK. ich dachte, weil du das Thema angeschnitten hast, bezüglich der Leistung. Beim Threadsteller sind des sicher mehrere Faktoren. Aber wenn ich genau die Passage weiss, dann schaue ich mir sie an und zwar in der Originalversion Englisch. Kann schon sein, dass meine Übersetzungen einfach überarbeitet wurden. Wie gesagt bin nach 6 Monaten ausgestiegen, weil es mir einfach zuviel geworden ist mit ehrenamtlicher Arbeit und meine eigene Arbeit einfach liegenblieb.

Share this post


Link to post
Share on other sites

@ Leser - genau wie du es erkannt hast und wie meine Vermutung auch war. Schade dass sich Leute an den Übersetzungen versuchen, die keine Ahnung haben, oder PS sabotieren möchten. Es kann aber auch einer sein, der bewusst Müll produziert um mich zu diskreditieren... (Ist eine sehr lange Vorgeschichte). Nochmals stelle ich hier klar, falls derjenige hier mitlesen sollte. Ich bin weder für die Übersetzungen verantwortlich, noch mache ich diese seit mehr als einem halben Jahr. Meine übersetzten und überarbeiteten Versionen waren 1.4.5.1 und 1.4.6.2, danach habe ich das Boot hier verlassen. Für diese PS-Versionen gab es keinerlei Probleme oder Kritikpunkte an den Übersetzungen. Alle Versionen danach hat irgendwer gemacht und meine gute Arbeit wieder ürberarbeitet. Genau aus diesem Grund habe ich das Boot auch verlassen, weil immer jemand meine Übersetzungen überarbeitet. Für Version 1.4.5.1 und 1.4.6.2 waren alle anderen User gesperrt, so dass nur ich daran arbeiten durfte. Danach wurde es wieder freigegeben und ich streike, weil ich unter diesen Bedingungen nicht arbeiten möchte, sprich meine Freizeit in unnützen Dingen verlieren möchte... Sorry...

 

Wie du im Bild erkennen kannst sind die Übersetzungen vertauscht. Ich korrigiere jetzt mal die Passage.

Share this post


Link to post
Share on other sites

Wo find ich denn das bei mir? Bin noch recht neu bei Prestashop.

 

Aber eben, da sucht man sich einen Wolf und dann sowas.

 

Danke für die Mühen.

 

EDIT: Gefunden hab ichs, muss aber noch irgend eine Variable in der php.ini setzen, da zu viele Felder.

Edited by Leser (see edit history)

Share this post


Link to post
Share on other sites

Unter Lokalisierung -> Übersetzungen -> Back Office und dann suchst du nach Preisanzeige wie ich es gemacht habe und änderst es.

 

Ich habe aber in den letzten Tagen auch noch einige andere Dinge geändert. Die aktuelle File zum Download findest du hier: http://www.prestashop.com/en/translations

 

Meine Änderungen von den letzten beiden Tagen sind noch nicht aktiv. Die DB scheint nur 1X wöchentlich aktualisiert zu werden. Einfach nächste Woche probieren.

 

Importieren kannst du auch unter Lokalisierung -> Übersetzungen. Der Import überschreibt jedoch deine eigenen Änderungen...

Share this post


Link to post
Share on other sites

Ah sorry, habe gerade gesehen, dass meine aktuelle Sprachfile schon zur Verfügung steht. Du musst nur scrollen... Dann siehst du wann sie aktualisiert wurde.

Share this post


Link to post
Share on other sites

In AdminCartRules ist es auch nochmal vertauscht. Also muss in AdminGroups und AdminCartRules getauscht werden.

Share this post


Link to post
Share on other sites

Mir fehlt fürs aktualisieren noch irgend ein Zugriffrecht: "close.png Das Archiv kann nicht extrahiert werden" bekomme ich, wenn ich ein Sprachpaket aktualiseren will.

Share this post


Link to post
Share on other sites

gzip auf deinem Server installiert und aktiviert ? Ggfs. bitte Provider kontaktieren. Das ist ein Serverproblem.

Share this post


Link to post
Share on other sites

In AdminCartRules ist es auch nochmal vertauscht. Also muss in AdminGroups und AdminCartRules getauscht werden.

 

Wo bitte ? Screen anhängen. Es sind über 4.000 Sprachvariablen...

Share this post


Link to post
Share on other sites

Bild im Anhang. Wobei ich mir jetzt nicht mehr sicher bin, ob ich das falsch rum korrigiert habe oder ob die Übersetzung falsch war. Falls es bei dir richtig ist, dann vergiss es einfach.

post-409745-0-27010400-1349867040_thumb.jpg

Share this post


Link to post
Share on other sites

Kann sein, dass ich bereits korrigiert habe. Bin mir aber nicht sicher. Ich habe da an den Übersetzungen von den Warenkorb-Regeln einiges angepasst vor 2 Tagen. Müsste wenn bereits geändert im Download vom 10/10 korrigiert erscheinen.

Share this post


Link to post
Share on other sites

Nein war nicht korrigiert. Ist aber jetzt erledigt.

Share this post


Link to post
Share on other sites

gzip auf deinem Server installiert und aktiviert ? Ggfs. bitte Provider kontaktieren. Das ist ein Serverproblem.

 

Nochmal hierzu: Was brauchts denn da auf dem Server? gzip als Programm ist installiert. Irgendwelche Zugriffsrechte auf Ordner? Ein bestimmtes PHP-Modul?

Share this post


Link to post
Share on other sites

gzip am Server meinst du jetzt ? Also wenn das installiert und konfiguriert ist, dann sollte es funktionieren. Ja Zugriffsrechte müssen so eingestellt sein wie hier angegeben. Also Schreibrechte, dennoch sind das dort Praxis Angaben und der CHMOD kann von Server zu Server variieren. Normalerweise sind Schreibrechte 0750 ausreichend, bei einigen Providern aber leider nicht, so dass man 0755 oder sogar 0777 vorfinden kann.

 

http://www.prestashop.com/forums/index.php?/topic/134187-tippserver-mindestanforderung-und-minimal-konfiguration-fur-prestashop-hostingempfehlungen/

Share this post


Link to post
Share on other sites

Mein Problem ist gelöst. Die Preise werden nun korrekt angezeigt. Mann muss in den Gruppen die Preisanzeige exkl. Steuern anzeigen, dann werden die Preise inkl. Steuern angezeigt. Unlogisch, aber ist so.

Share this post


Link to post
Share on other sites

Mein Problem ist gelöst. Die Preise werden nun korrekt angezeigt. Mann muss in den Gruppen die Preisanzeige exkl. Steuern anzeigen, dann werden die Preise inkl. Steuern angezeigt. Unlogisch, aber ist so.

 

Hättest Du den Thread gelesen, hättest Du bemerkt, dass die Übersetzungen vertauscht sind. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More