Jump to content
RaDi_FR

Al pagar con paypal no llega el pedido a prestashop

Recommended Posts

Hoy me puse a preparar el cobro mediante paypal, ya está configurado, pero he simulado pedidos, el cliente elige la forma de pago, le sale una ventana más donde dice confirmar pedido y le lleva a paypal, pero a mi no me llega ningún pedido, con lo que aunque el cliente lo pague, no sé que ha pedido.

 

alguna solucion?

Share this post


Link to post
Share on other sites

Hoy me puse a preparar el cobro mediante paypal, ya está configurado, pero he simulado pedidos, el cliente elige la forma de pago, le sale una ventana más donde dice confirmar pedido y le lleva a paypal, pero a mi no me llega ningún pedido, con lo que aunque el cliente lo pague, no sé que ha pedido.

 

alguna solucion?

Comprueba que no estés haciendo las pruebas con la tienda desactivada.

 

¿Supongo, que has probado pagar, es decir finalizar el proceso completo no?

Share this post


Link to post
Share on other sites

Tienda activa y si, he pagado 2 pedidos y en la cuenta del cliente, aparecen los pedidos y en el admin prestashop, ni rastro de ellos.

 

en el cuadro de mandos veo el pedido, pero en estado no pone nada, totalmente en blanco

Edited by RaDi_FR (see edit history)

Share this post


Link to post
Share on other sites

Hola,

 

Voy a emitir un post con este tipo de problemas. A mi también me ocurre y tengo pasarela de pago Paypal. Todo ha empezado desde que actualicé a la versión 1.4.9 con el nuevo módulode Paypal que viene con esta versión de PS.

 

Os comento los errores que esta versión de Paypal 3.0.6 está teniendo:

 

1º Los pedidos no se graban en la pestaña de pedidos incluso habiéndolo pagado el cliente

 

2º Si el cliente paga desde su cuenta de paypal, los gastos de envío no se guardan y aparecen como 0€, con lo cual el cliente no paga los gastos de envío. Y luego un mensaje aparece en el pedido y dice "la cantidad pagada mediante paypal no corresponde con la cantidad real"

 

3º Si el cliente paga mediante la pasarela de pago por tarjetas de Paypal, no se abre ninguna ventana de paypal, si no que el pago se realiza introduciendo los datos de las tarjetas en la misma página de la tienda, con lo que cuando el cliente ha efectuado el pago, le aparece un mensaje de que se ha confirmado el proceso de pago pero sigue apareciendo las opciones de los demás pagos en la misma página de la tienda. Esto puede llegar a confundir al cliente que puede optar por pulsar otro método de pago aún habiendo completado el pagop mediante Paypal, con el consiguiente mensaje de error diciendo que el pago no está disponible..(es lógico ya que se había hecho rpeviamente mediante paypal y al pulsar en otro método de pago la tienda no te deja continuar con ello diciendote ese mensaje...)Pero el caso es que puede llegar a confundir a los clientes loq ue dará una cierta imagen fea.

 

He estado leyendo en post ingleses y dicen que la versión de Paypal que trae el PS 1.4.9 es una versión de Payapl en desarrollo e ideada para el PS 1.5...lo que no entiendo es como coñ... lo han metido en el PS 1.4.9 sabiendo que da estos errores....

 

Estos despistes no deben de producirse ya que este tipo de BUGS son GRAVES!!!

 

SOLUCIÓN: yo me he bajado la versión previa de Paypal (2.8.7) y funciona al 100% en PS 1.4.9. Hasta que solucionen los BGSde la nueva

 

Saludos!!

  • Like 1

Share this post


Link to post
Share on other sites

En mi caso puse hoy paypal free 2.0, lo he quitado y he puesto paypal 2.8.7 y me falla :(

Share this post


Link to post
Share on other sites

Hola,

 

Voy a emitir un post con este tipo de problemas. A mi también me ocurre y tengo pasarela de pago Paypal. Todo ha empezado desde que actualicé a la versión 1.4.9 con el nuevo módulode Paypal que viene con esta versión de PS.

 

Os comento los errores que esta versión de Paypal 3.0.6 está teniendo:

 

1º Los pedidos no se graban en la pestaña de pedidos incluso habiéndolo pagado el cliente

 

2º Si el cliente paga desde su cuenta de paypal, los gastos de envío no se guardan y aparecen como 0€, con lo cual el cliente no paga los gastos de envío. Y luego un mensaje aparece en el pedido y dice "la cantidad pagada mediante paypal no corresponde con la cantidad real"

 

3º Si el cliente paga mediante la pasarela de pago por tarjetas de Paypal, no se abre ninguna ventana de paypal, si no que el pago se realiza introduciendo los datos de las tarjetas en la misma página de la tienda, con lo que cuando el cliente ha efectuado el pago, le aparece un mensaje de que se ha confirmado el proceso de pago pero sigue apareciendo las opciones de los demás pagos en la misma página de la tienda. Esto puede llegar a confundir al cliente que puede optar por pulsar otro método de pago aún habiendo completado el pagop mediante Paypal, con el consiguiente mensaje de error diciendo que el pago no está disponible..(es lógico ya que se había hecho rpeviamente mediante paypal y al pulsar en otro método de pago la tienda no te deja continuar con ello diciendote ese mensaje...)Pero el caso es que puede llegar a confundir a los clientes loq ue dará una cierta imagen fea.

 

He estado leyendo en post ingleses y dicen que la versión de Paypal que trae el PS 1.4.9 es una versión de Payapl en desarrollo e ideada para el PS 1.5...lo que no entiendo es como coñ... lo han metido en el PS 1.4.9 sabiendo que da estos errores....

 

Estos despistes no deben de producirse ya que este tipo de BUGS son GRAVES!!!

 

SOLUCIÓN: yo me he bajado la versión previa de Paypal (2.8.7) y funciona al 100% en PS 1.4.9. Hasta que solucionen los BGSde la nueva

 

Saludos!!

 

JuaquinBM, a mi me funciona correctamente el nuevo modulo de paypal, en todas las actualizaciones de tiendas que he ido procesando a mis clientes. (Al menos con la configuración básica)

Share this post


Link to post
Share on other sites

He borrado todo y lo he vuelto a instalar, el cliente realiza el pago, pero sigue sin llegar y es porque cuando eligen metodo de pago por paypal no pone estado al pedido.

 

con paypal free, al elegir paypal te salia un boton para confirmar pedido (ahí tendria que llegar el pedido a prestashop) pero no lo hacia, y con 2.8.7, lo mismo, elige paypal y le lleva directamente, allí, paga y nada, no me llega notificacion de pedido, y en cuadro de mando, el estado se queda en blanco.

 

 

edito, he instalado paypal 3.0.1.2 y me llegan los pedidos, pero una vez que lo ha pagado, digamos que el procedimiento es:

 

carrito, elige forma de pago paypal (ahí tendria que confirmar pedido pero no) le lleva a paypal, paga y una vez paga, le lleva a la web y ahí le dice que confirme el pedido, hay forma de cambiar ese orden?

Edited by RaDi_FR (see edit history)

Share this post


Link to post
Share on other sites

Yo hice una instalación limpia del PS 1.4.9 y he tenido fallos con el nuevo módulo de Paypal. Por eso digo que es muy probable que la causa sea un BUG del módulo y la versión PS 1.4.9.

 

Saludos

Share this post


Link to post
Share on other sites

Muchas gracias por la información, Joaquín, me ha resultado muy útil. Llevo dos días con estos problemas y me estaba volviendo loco. El cobro se realiza correctamente, pero el pedido no aparece (por suerte en el cliente se queda el carrito y el menos sé los productos que tengo que mandarle).

 

Voy a volver a la versión anterior de Paypal a ver si consigo que todo vuelva funcionar.

 

Muchas gracias

Share this post


Link to post
Share on other sites

Te va a parecer una tontería, pero... ¿de dónde te has descargado la versión 2.8.7? No la encuentro...

 

Gracias

Share this post


Link to post
Share on other sites

Me parece que estoy como vosotros, llevo una semana con la tienda "abierta" y aunque al probar Paypal en el entorno de pruebas,todo funcionaba, el primer pedido que pagan con Paypal, ocurre lo que comentáis antes.

 

Tengo PS 1.4.8.2 y Paypal 2.8.7, así que no creo sea cosa solo del 1.4.9

 

 

 

www.spaininyourhome.com

Share this post


Link to post
Share on other sites

Hola:

A mi me está pasando lo mismo, pero sólo con algunos clientes.

¿Alguien ha encontrado la solución?

Gracias

Share this post


Link to post
Share on other sites

A nosotros nos acaba de pasar lo mismo.

 

Nuestra clienta ha estado vendiendo diariamente en su tienda online mediante Paypal y sin problemas. Hoy ha tenido una venta también mediante Paypal y aunque el cliente ha pagado y el dinero ha sido ingresado en su cuenta, no ha recibido el email del pedido ni tampoco se ha generado éste. Sólo dispone del carrito para saber qué tiene que enviar.

 

Primero nos planteamos si el cliente podría haber cerrado su conexión justo después de pagar con PayPal y sin volver a la tienda pero viendo estos posts, pensamos que el problema podría ser otro.

 

La versión prestashop de la tienda de nuestra clienta es 1.4.5.1 y la de su módulo PayPal la 2.8.2-

 

Será bienvenida cualquier aportación.

 

Un saludo y gracias a tod@s.

Share this post


Link to post
Share on other sites

La verdad que no encuentro explicación para lo que nos ocurre. Mi solución, desinstalar el modulo, borrar carpeta, etc y volver a instalar hasta que funcione.

 

Ahora tengo funcionando Paypal 2.8.6 con PS 1.4.7.3 y Paypal 2.8.6 con PS 1.4.8.2 y de momento funciona, a ver hasta cuando.

 

Saludos.

Edited by serynun (see edit history)

Share this post


Link to post
Share on other sites

Hola:

En otro post han dado una solución, la pongo por si alguien le sirve.

 

http://www.prestashop.com/forums/index.php?/topic/171703-error-de-confirmacion-de-pedidos-desde-algunos-navegadores/page__view__findpost__p__973715

 

Yo después de aplicar el parche he tenido dos pedidos uno se ha procesado correctamente y otro no me ha aparecido.

:unsure:

Por lo que veo esto nos está ocurriendo a bastantes , por favor id diciendo si lo habéis arreglado porque me estoy volviendo loco.

Un saludo

Share this post


Link to post
Share on other sites

Hola CarlosAdrian:

 

Por favor te puedes explicar mejor, ¿qué modificaste y dónde?

Pero el enlace que has puesto es para corregir el error 500 ¿no?, a mi no me da error 500 sino que cuando pagan algunos cliente el pedido no llega. ¿Era el mismo problema?

 

Un saludo y gracias

 

A mí también me pasaba eso. Lo que hice fue instalar la última versión y luego cambiar lo del curl en paypal_connect.php (está explicado aquí http://www.prestasho...638#entry954638).

 

Con eso me funciona ahora a la perfección.

Share this post


Link to post
Share on other sites

Sí, es que a mí de u

Hola CarlosAdrian:

 

Por favor te puedes explicar mejor, ¿qué modificaste y dónde?

Pero el enlace que has puesto es para corregir el error 500 ¿no?, a mi no me da error 500 sino que cuando pagan algunos cliente el pedido no llega. ¿Era el mismo problema?

 

Un saludo y gracias

 

Sí, perdona, quizá he ido demasiado rápido. A mí me funcionaba la tienda, bien, y al pasar de la 1.4.8.2 a la 1.4.9 me empezó a pasar lo mismo que comentáis vosotros. Al instalar la versión 1.5.1 me empezó a dar el error 500, y al hacer hacer el cambio de lo del curl que se explica en ese enlace, me comenzó a funcionar la versión 1.5.1 con el Paypal, y me aparecen todos los pedidos bien.

 

Es decir, con la tienda en la última versión, la última versión del módulo y ese cambio en paypal_connect.php me funcionan a la perfección los cobros con Paypal.

Share this post


Link to post
Share on other sites

Lo último de paypal? ahi va.

 

Cuando un cliente realiza el proceso de compra y acaba en la pagina de seleccion de envio y check condiciones de venta. automaticamente debería salir los metodos d epago no?. pues no. este agarra y se va deliberadamente a la pagina de pago por paypal. y sale esto en el navegador.

<<www.midominio.com/?fc=module&module=paypal&controller=confirm&get_confirmation=1>>

Alguien sabe como solucionar o tengo que reinstalar la tienda? Saludos

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More