Jump to content
musicmaster

[Free Script] Prestools Suite: Mass Edit, Order Edit And Much More

Recommended Posts

@consoleland:

To change the quantities of combinations you need to add the field "combinations". That will result in a colored field with in it the number of combinations that you have. If you click that you come in the combination edit page where you can change the quantities of the individual combinations.

 

@ Docki

If I understand you right you want to have a link inside a product name. Prestashop does not allow that and for that reason Triple Edit doesn't allow it either. If you would want to have that it would be a custom modification and it might result in trouble if you later want to edit in the Prestashop backoffice.

hello musicmaster

this is not working when i change and "send" script is running but again back to old stock value.

do we need the new files you posted?

regards 

ivo

Share this post


Link to post
Share on other sites

Hi Ivo,

 

The new files are not related.

 

You should not press the Send button: that is for the Search block. You should press the Submit All button or use thelinesubmit buttons.

 

M

Share this post


Link to post
Share on other sites

Hi Ivo,

 

The new files are not related.

 

You should not press the Send button: that is for the Search block. You should press the Submit All button or use thelinesubmit buttons.

 

M

Sorry musicmaster

 

i pushed the sumit button but is not working also thelinesubmit  don't work

do you need to check in my shop?

regards

Share this post


Link to post
Share on other sites

Hi Ivo,

 

Sorry to hear it doesn't work.

 

Having access to your shop would help. You can pm me or send a mail to info@prestools.com.

 

Two questions:

 - you have multishop. Do the shops share stock?

 - can check "verbose", do a Submit All and report which Sql queries are made?

 

regards,

M

Share this post


Link to post
Share on other sites

Hi MusicMaster,

 

Whenever I press TinyMCE in description, it always said could not be loaded, check your internet connection.

 

How to fix this? Thanks  :)

Share this post


Link to post
Share on other sites

 

How to fix this? Thanks  :)

Triple Edit loads TinyMCE from the internet each time you use it. 

 

If you want access offline you would need to download it and change the links in the software.

Share this post


Link to post
Share on other sites

Triple Edit loads TinyMCE from the internet each time you use it. 

 

If you want access offline you would need to download it and change the links in the software.

 

I'm doing it from inside cpanel actually so it supposed to be online. Or is it related to IP block that I set in settings?

Share this post


Link to post
Share on other sites
 

 

 

@ Docki

If I understand you right you want to have a link inside a product name. Prestashop does not allow that and for that reason Triple Edit doesn't allow it either. If you would want to have that it would be a custom modification and it might result in trouble if you later want to edit in the Prestashop backoffice.

 

Hello musicmaster,

 

I am not trying to add links in the product names. I am just trying to change the name, see pics.

 

 

As a hint, I have noticed that it deletes whatever is after " sign.

 

Regards!

post-727502-0-51488900-1446802814_thumb.jpg

post-727502-0-38342800-1446802815_thumb.jpg

Share this post


Link to post
Share on other sites

Can't Triple Edit use Prestashop internal TinyMCE directly ?

 

For the deluxe version I think that would be impossible as it uses more options as Prestashop does. For the common version it might work but I am not sure. The fact that not every Prestashop version uses the same TinyMCE version might also cause problems.

 

I don't remember the details. But what I remember is that when I added TinyMCE I considered different options and settled on this one.

 

If I remember well someone in the past wrote in this forum thread how to install an offline version of TinyMCE.

 

I'm doing it from inside cpanel actually so it supposed to be online. Or is it related to IP block that I set in settings?

Did you try to load the script directly from the browser command line to see if there is something blocking it? 

http://tinymce.cachefly.net/4.1/tinymce.min.js

Share this post


Link to post
Share on other sites

I am not trying to add links in the product names. I am just trying to change the name, see pics.

As a hint, I have noticed that it deletes whatever is after " sign.

What version of Triple Edit are you using? If I remember well this was a problem in the very beginning but it has been solved a long time ago.

Share this post


Link to post
Share on other sites

What version of Triple Edit are you using? If I remember well this was a problem in the very beginning but it has been solved a long time ago.

 

I have the latest version, can you try to replicate it?

 

THank you!

Share this post


Link to post
Share on other sites

Of course I already tried to replicate it the first time that you mentioned it. I can't.

 

The attached file was made on the basis of one theory of what might go wrong in your installation. It assumes that somewhere something goes wrong with the setting of the correct character encoding/collation and that because of that the mysqli_real_escape_string() command doesn't work correctly. Could you try using the attached file and report what happens?

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites

Hello Musicmaster,

 

Back in July I asked about being able to turn on or off the advanced warehouse function.  I see in the latest release, I can change the warehouse name, etc, but maybe I'm missing it, but did you ever add the ability to turn on or off the advanced warehouse function ? 

 

Thanks for a great program !
Matt

Share this post


Link to post
Share on other sites

Of course I already tried to replicate it the first time that you mentioned it. I can't.

 

The attached file was made on the basis of one theory of what might go wrong in your installation. It assumes that somewhere something goes wrong with the setting of the correct character encoding/collation and that because of that the mysqli_real_escape_string() command doesn't work correctly. Could you try using the attached file and report what happens?

 

Same situation with the file too.

 

It seems to have a problem with " sign since I have tried to use ' sign and it does not encounter same issue.

 

Appreciate the help! 

Share this post


Link to post
Share on other sites

Same situation with the file too.

 

It seems to have a problem with " sign since I have tried to use ' sign and it does not encounter same issue.

 

Appreciate the help! 

Ok, different theory:

 - what browser and operating system are you using?

 - can you submit some name with quotes with the "verbose" option checked and report the result? And can you report the result as copied text and not as a screendump so that I can copy it and try myself?

  • Like 1

Share this post


Link to post
Share on other sites

Hi Musicmaster,

 

Thanks for a great tool! I would really like to use it, but unfortunately I get a 500 internal server error upon trying to access any of the scrips.

I already tried to re-upload all the files, but unfortunately to no avail.

 

I am on PS1.6.0.9 and I tried with both downloads.

 

Do you have any ideas how to solve this?

 

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Musicmaster,

 

Thanks for a great tool! I would really like to use it, but unfortunately I get a 500 internal server error upon trying to access any of the scrips.

I already tried to re-upload all the files, but unfortunately to no avail.

 

I am on PS1.6.0.9 and I tried with both downloads.

 

Do you have any ideas how to solve this?

 

 

Thanks!

Hi Decorocco,

 

Could you try the attached file instead of the one in the package?

 

It is a file that strips out all security - including the password. So you should replace it immediately after you have completed your test. However, it is a good way to see whether your problem is security related.

 

Please make sure that your files are in a subdirectory of your admin directory.

 

Regards,

M.

Share this post


Link to post
Share on other sites

Back in July I asked about being able to turn on or off the advanced warehouse function.  I see in the latest release, I can change the warehouse name, etc, but maybe I'm missing it, but did you ever add the ability to turn on or off the advanced warehouse function ? 

 

Actually you can't change the warehouse name as far as I remember. You only have an overview of what you have in your warehouses.

 

With the stockflag option you can switch warehousing on and off. Please use the latest version for that (1.09m).

Share this post


Link to post
Share on other sites

Hi Decorocco,

 

Could you try the attached file instead of the one in the package?

 

It is a file that strips out all security - including the password. So you should replace it immediately after you have completed your test. However, it is a good way to see whether your problem is security related.

 

Please make sure that your files are in a subdirectory of your admin directory.

 

Regards,

M.

Hi Musicmaster,

 

Thanks for your help! I tried this file, but unfortunately it does not make any difference. It is worth mentioning that when opening the directory (itself located in the admin directory) I see a list of all the files. The images open without problems, but the .php files throw an internal server error. I have contacted my host to see the error log. Hopefully this will bring us a bit closer to the solution. When I know more I will let you know here.

 

Best regards,

Decorocco

Share this post


Link to post
Share on other sites

Ok, different theory:

 - what browser and operating system are you using?

 - can you submit some name with quotes with the "verbose" option checked and report the result? And can you report the result as copied text and not as a screendump so that I can copy it and try myself?

 

Hello musicmaster,

 

Sorry for the delay I was unable to access the computer during the weekend.

 

-I have tried with multiple browsers, it has the same situation on all of them: safari, chorme, mozzila, IE. I have also tried with different OS, Windows 8 and 7.

-regarding the submission of a word with quotes, this is the message received after submitting this : Pulover "Imagine Daily" to the name of the product:

 

Go back to product-edit page

2 Records - of which 1 submitted.

SELECT id_feature, name FROM ps_feature_lang WHERE id_lang='2' ORDER BY id_feature

SELECT id_lang FROM ps_lang

select s.id_shop_group, g.share_stock, g.name from ps_shop s, ps_shop_group g WHERE s.id_shop_group=g.id_shop_group and id_shop='4'

*No changes*1: UPDATE ps_product SET date_upd='2015-11-09 12:00:42' WHERE id_product='102' - 1 affected

UPDATE ps_product_shop SET date_upd='2015-11-09 12:00:42' WHERE id_product='102' AND id_shop='4' - 1 affected

 

    UPDATE ps_product_lang SET name='Pulover \"Imagine Daily\"' WHERE id_product='102' AND id_lang='2' AND id_shop='4' - 0 affected

 

Finished successfully!

Go back to product-edit page

 

 

I really appreciate your help and dedication.

Share this post


Link to post
Share on other sites

I think I have it. Try this one:

 

Thank you!

 

It works and helps our business a lot!

  • Like 1

Share this post


Link to post
Share on other sites

Looks like a good tool and could be useful for me but im having trouble running it.

 

I have entered my db connection details then when running I get this error:

 

Fatal error: Call to undefined function mysqli_connect() in /home/******/******/******/******/******/approve.php on line 46

 

Any ideas?

 

Thanks

Share this post


Link to post
Share on other sites

Fatal error: Call to undefined function mysqli_connect() in /home/******/******/******/******/******/approve.php on line 46

 

What versions of PHP and MySql are you running? My first impression would be a very old PHP version.

Share this post


Link to post
Share on other sites

Server information Linux #1 SMP Thu May 16 20:59:36 UTC 2013 x86_64

Server software version Apache/2.4.12 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4

PHP version 5.5.27

MySQL version 5.6.27

 

MySQL engine InnoDB

MySQL driver: DbPDO

 

 

What is the recommended version of PHP/MySQL for Prestashop stores ?
Im running a VPS

 

Thanks

Edited by MerseyRay (see edit history)

Share this post


Link to post
Share on other sites

Then I assume that you don't have the php mysqli extension not installed.

 

extension=php_mysqli.dll in your php.ini

Share this post


Link to post
Share on other sites

 

musicmaster, on 08 Nov 2015 - 06:18 AM, said:

snapback.png

Hi Decorocco,

 

Could you try the attached file instead of the one in the package?

 

It is a file that strips out all security - including the password. So you should replace it immediately after you have completed your test. However, it is a good way to see whether your problem is security related.

 

Please make sure that your files are in a subdirectory of your admin directory.

 

Regards,

M.

Hi Musicmaster,

 

Thanks for your help! I tried this file, but unfortunately it does not make any difference. It is worth mentioning that when opening the directory (itself located in the admin directory) I see a list of all the files. The images open without problems, but the .php files throw an internal server error. I have contacted my host to see the error log. Hopefully this will bring us a bit closer to the solution. When I know more I will let you know here.

 

Best regards,

Decorocco

 

 

Hi Musicmaster,

 

I finally received the error log from the host (talk about fast service...) and it came back with the following two errors (I replaced my URL and the admin subdirectory with dashes for security reasons):

 

 

I am on a VPS with PHP 5.4.30, suPHP and Ioncube. However I must say that I have really no clue where to start looking for a solution for this issue.

 

SoftException in Application.cpp:413: Mismatch between target GID (500) and GID (502) of file "/var/www/html/virtual/---/www/---/triple-edit/product_edit.php", referer: http://---/---/triple-edit/

 

and

 

 

Premature end of script headers: product_edit.php, referer: http://---/---/triple-edit/

 

 

 

Do you have any idea how to make this working?

 

Thanks in advance for looking into this and best regards!

 

Decorocco

Edited by decorocco (see edit history)

Share this post


Link to post
Share on other sites

Hi Musicmaster,

 

Thank you for pointing me in the right direction. Since I have suPHP installed, apparently there was some issue with ownership. Working on that with the host now. Just the be completely sure one last (perhaps stupid) question: 

I am using PS 1.6.0.9. Should I have to choose triple edit 1.09n.zip?

 

Thanks for all the help!

 

Best regards,

Decorocco

Share this post


Link to post
Share on other sites

Hi decorocco,

 

Good to hear you this helped.

 

I am using PS 1.6.0.9. Should I have to choose triple edit 1.09n.zip?

 

As far as I remember the relevant database changes came only after PS 1.6.0.9. So any version of TE for PS 1.5/1.6 should work. Of course newer versions have bug fixes and improvements that the old ones don't have. And just as with any software there is always some risk that new versions bring new bugs - although that risk is rather limited as until now there haven't been any major rewrites.

 

So if you have a version that works for you there is strictly no reason to upgrade. However, my advice would be to occasionally upgrade to the latest version. 

 

Best regards,

M

Share this post


Link to post
Share on other sites

In 1.09o I have made some upgrades to order-edit to make its behavior closer match that of Prestashop. Any feedback is welcome.

Share this post


Link to post
Share on other sites

I think there is bug in category edit:

 

In category edit view if I sort categories e.g. by name and then try to update a field like "meta_description" or "meta_keywords", the response is Finished Succesfully but when I reload the page the edit is gone.

 

"UPDATE ps_category_lang SET meta_description='' WHERE id_category=' 37' AND id_lang='1' AND id_shop='1' - 0 affected

Finished successfully!"

 

Without attempting to sort category view, editing works without problem.

 

Prestashop version: 1.6.1.1

Tiple edit version: 1.09o

Share this post


Link to post
Share on other sites

I think there is bug in category edit:

 

In category edit view if I sort categories e.g. by name and then try to update a field like "meta_description" or "meta_keywords", the response is Finished Succesfully but when I reload the page the edit is gone.

 

"UPDATE ps_category_lang SET meta_description='' WHERE id_category=' 37' AND id_lang='1' AND id_shop='1' - 0 affected

 

Finished successfully!"

 

Without attempting to sort category view, editing works without problem.

 

Prestashop version: 1.6.1.1

Tiple edit version: 1.09o

Hi eozsoy,

 

Thank you for reporting this error. I uploaded a new version. Can you try it?

 

Best regards,
M

Share this post


Link to post
Share on other sites

 

Hi eozsoy,

 

Thank you for reporting this error. I uploaded a new version. Can you try it?

 

Best regards,
M

 

 

The problem seems to be solved. Thank your for your attention.

And thank you for Triple Edit. This is one of the best tools for Prestashop!

 

Best regards,

Share this post


Link to post
Share on other sites

Hi Musicmaster,

 

one question. How can I set reference as default value in Product edit search instead of main fields? Is it possible?

 

Thank you again for your amazing module!

 

KR

Boris

Share this post


Link to post
Share on other sites

Hi Musicmaster,

 

one question. How can I set reference as default value in Product edit search instead of main fields? Is it possible?

 

Thank you again for your amazing module!

 

KR

Boris

Hi Boris,

 

On line 1719 of the latest version of product-edit.php you find the line

in<br><select name="search_fld1" style="width:10em"><option>main fields</option>

You should change that to

in<br><select name="search_fld1" style="width:10em"><option value='p.reference'>reference</option><option>main fields</option>

  • Like 1

Share this post


Link to post
Share on other sites

Hi Musicmaster! Thanks for your great module.

I have one issue with Url-SEO Multi-Edit page. Radio buttons don't work. Hide&Show radio-buttons are OK but not Edit. Please see screenshot. Is this bug?

 

PrestaShop 1.6.1.2 + triple_edit-1.09p

 

 

aBW3QyX.png

Edited by serdib (see edit history)

Share this post


Link to post
Share on other sites

Nice tool!. But i have one problem (Prestashop 1.6.2). 

After changing categories in products i see this changes in product edit, but I have to save it one more time manually in presta to heve effect in proce rules.

 

Example:

 

Price Rulle PROMO1 - 50%

I add products to Category and Submit. In presta panel it is ok, but it is still full price. I have to click Save in every product to work.

 

What am I doing wrong?

Thanks in advance.

Share this post


Link to post
Share on other sites

Nice tool!. But i have one problem (Prestashop 1.6.2). 

After changing categories in products i see this changes in product edit, but I have to save it one more time manually in presta to heve effect in proce rules.

 

Example:

 

Price Rulle PROMO1 - 50%

I add products to Category and Submit. In presta panel it is ok, but it is still full price. I have to click Save in every product to work.

 

What am I doing wrong?

Thanks in advance.

Hi 2dm,

 

Did you try emptying the cache?

Share this post


Link to post
Share on other sites

Hi 2dm,

 

Did you try emptying the cache?

Hi. 

 

Yes, I even turned off cache. Mayby script don't change every neede tables?

 

I remove category form products it looks ok, but i have to save manually every product to works.

Share this post


Link to post
Share on other sites

Hi. 

 

Yes, I even turned off cache. Mayby script don't change every neede tables?

That is not the same. There is still some caching going on when you turn it off. So please try emptying the cache.

Share this post


Link to post
Share on other sites

That is not the same. There is still some caching going on when you turn it off. So please try emptying the cache.

I've done it first via presta panel. I didn't help. I can try to remove files manually from cache folders.

Share this post


Link to post
Share on other sites

I am a bit puzzled by your account:

 

 - You mention that the allocation of products to categories doesn't work and then you give as an example assigning a discount. 

 

 - As is clearly indicated, modifying discounts is part of the paid section of Triple Edit. You can make changes in the front end but - unless you bought the plugin - the code to save them is missing.

Share this post


Link to post
Share on other sites

No, no. Discounts are set in catalog price rules depending on category. But after submit in Triple Edit categories are "not fully changed". I have to enter every product and click Save button (in catergories tab evething looks ok)

Share this post


Link to post
Share on other sites

Ok, now I understand.

 

I will have to investigate this. As I am busy with other things it may take a few days.

Thanks in advance! I'm ready to buy full version if it would work.

Edited by 2dm (see edit history)

Share this post


Link to post
Share on other sites

Thanks a million for the script.

 

I have proven in 1.6.1, 1.6.2 and 1.6.3 the triple_edit-1.09s.zip version and always gives the same error: "Error connecting to database server"

 

But in other stores it works perfect, which can not be the fault.

Share this post


Link to post
Share on other sites

 

Hi,

is possible to disactivate all products?

Thank you

Regards

 

Yes. But if you have many products it may take some time.

Share this post


Link to post
Share on other sites

Yes. But if you have many products it may take some time.

I don't understand how I can do it...can you explain me?

Thank you

Regards

Edited by prestapp (see edit history)

Share this post


Link to post
Share on other sites

I don't understand how I can do it...can you explain me?

Thank you

Regards

well, that is then mutual. You are asking something that you could find out within 5 minutes by testing. And by being unclear about the properties of your shop you make it difficult to answer the question.

 

If it may help you: Triple Edit is a mass edit tool, but it has no specific function to disable all products at once. But you can disable them a few hundred (depending on your settings maybe even a few thousand) at a time. But it evades me why anyone would ever want to do such a thing. It also evades me why he wouldn't write one single simple MySql command that could do it within a second.

Share this post


Link to post
Share on other sites

Ok, now I understand.

 

I will have to investigate this. As I am busy with other things it may take a few days.

Any news about that? Thanks :)

Share this post


Link to post
Share on other sites
Picture 1: The Horizontal icon i want to move it up a bit and also reduce is font height .How can i move it up  & resize the font category in such a way that if i list 10 products it will apply auto width so that it wont have to list the remaining category in second line as it did in the picture i attached below? i will like as soon as my site is open through a desktop version. I want my advert slide pictures to show in full instead of half so that you have to scrow down before you can see it fully.

 

the bookmark icon at the  right bottom end of the horizontal bar. i want shift it left a bit to be properly align

 

 

 

Picture3 : I want the Newsletter icon to display as soon as my website is open www.aso-iyi.com then also it should have atleast 10 seconds timing before customers can click to close it incase they are not interested in receiving update about latest product from me.

 

At the follow us at the right bottom end of the page. the instagram icon is not displaying it and i had configure at the BO.

 

picture 4:  I want the customer address form to be align at the center of the page instead how it is now which is at the left end corner of the form. I want to ad

 

Picture5 : i want to set carrier price for city & state address of goods. even now that i have import states into my country. I have checked the localization & other directory of my BO didnt find where i can import city and state into carrier price range setting so that i can set different delivery price for different city within a state. Also different shipping price for different states within a country

 

 

I want to add free paypal module .i cant find it at the module list

post-1135166-0-68613200-1449391836_thumb.png

post-1135166-0-04331100-1449391843_thumb.png

post-1135166-0-13323500-1449392290_thumb.png

post-1135166-0-63814000-1449392294_thumb.png

post-1135166-0-33228400-1449392307_thumb.png

post-1135166-0-87969400-1449392309_thumb.png

post-1135166-0-06012200-1449392313_thumb.png

post-1135166-0-12119900-1449392324_thumb.png

Share this post


Link to post
Share on other sites

Any news about that? Thanks :)

Still busy with that.

 

Prestashop implements catalog rules by assigning a specific price to each of the affected products (with a flag so that you can't change them with the product). So every time a relevant property of a product is changed all the catalog rules have to be redone for that product to regenerate the concerning specific price rules. 

 

So I need to understand how the relevant code works and write something with the same functionality. I am still busy with that: it is a tough nut to crack.

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites

Hello Musicmaster,

 

Can you please provide me with your VAT number so I can register my purchase of your module to my local IRS? :)

 

Thank you!

Share this post


Link to post
Share on other sites

Hello Musicmaster,

 

Can you please provide me with your VAT number so I can register my purchase of your module to my local IRS? :)

 

Thank you!

Hi Docki,

I have updated the Terms and Conditions with that information.

Greetings,

M.

Share this post


Link to post
Share on other sites

Hi 2dm,

 

The attached file should handle the catalog rules correctly. 

 

Kind regards,

M

Yes it is working. You are great! Big Thanks. Time to buy pro version.

Share this post


Link to post
Share on other sites

Hi musicmaster,

 

First of all, thanks for your script.

I didn't tried it yet but it seems like people are likening it ^^

 

I'm sure I will ask the most stupid question, but I'm a zero when it comes to websitebuiliding...

 

to install your script, I need to use cPanel File Manager (on Siteground)

but I'm not sure where to upload the unziped files.

Can I upload them under:  public_html/myshop.com  ?

 

Thanks

Sabrina

Share this post


Link to post
Share on other sites

Hi musicmaster,

 

First of all, thanks for your script.

I didn't tried it yet but it seems like people are likening it ^^

 

I'm sure I will ask the most stupid question, but I'm a zero when it comes to websitebuiliding...

 

to install your script, I need to use cPanel File Manager (on Siteground)

but I'm not sure where to upload the unziped files.

Can I upload them under:  public_html/myshop.com  ?

 

Thanks

Sabrina

 

Hi Sabrina,

 

The first post where you can download the software contains also a short introduction. And you can download a manual there.

 

To be short: you are advised to copy the files into a new subdirectory (it doesn't matter how you name it) below your admin directory.

 

Kind regards,

M.

Share this post


Link to post
Share on other sites

Great work !!!

 

But one feature is really missing and it would be great if you can add it.

If you create a new group you have to edit all categories manually?
so the bulk updater would be great to realise that with one click?
 

Share this post


Link to post
Share on other sites

Great work !!!

 

But one feature is really missing and it would be great if you can add it.

 

If you create a new group you have to edit all categories manually?

so the bulk updater would be great to realise that with one click?

 

 

Great to hear you like it.

 

Unfortunately I don't understand your point about groups. Can you explain it in more detail?

  • Like 1

Share this post


Link to post
Share on other sites

Great to hear you like it.

 

Unfortunately I don't understand your point about groups. Can you explain it in more detail?

Yeah sure!

 

We have over 14000 categories.

 

If we create a new user group for customer we have to set all categories manually active for the group.

Click from category to category manually.....

 

If you have 10 categories, it takes 10 minutes.

 

If you have 14000 categories it will take 3 days....

 

 

Hope you understand 

Merry Xmas!

Share this post


Link to post
Share on other sites

Why 

 

We have over 14000 categories.

If we create a new user group for customer we have to set all categories manually active for the group.
Click from category to category manually.....

If you have 10 categories, it takes 10 minutes.

If you have 14000 categories it will take 3 days....

 

Why don't you write a simple php/mysql routine? In pseudocode it would be something like:

select id_category from ps_category order by id_category
Foreach id_category
 insert into ps_category_group SET id_category=id_category, id_group,newgroup

Of course the usual precautions apply:

 - first test it on a backup version. There is always a risk that you made a typo or something is wrong with the logic.

 - make a backup

 - given the large number the standard 30 seconds timeout of PHP may not be enough. So make it longer or be prepared to run the code more than once (with offsets) so that all categories are covered.

  • Like 1

Share this post


Link to post
Share on other sites

Why 

 

 

Why don't you write a simple php/mysql routine? In pseudocode it would be something like:

select id_category from ps_category order by id_category
Foreach id_category
 insert into ps_category_group SET id_category=id_category, id_group,newgroup

Of course the usual precautions apply:

 - first test it on a backup version. There is always a risk that you made a typo or something is wrong with the logic.

 - make a backup

 - given the large number the standard 30 seconds timeout of PHP may not be enough. So make it longer or be prepared to run the code more than once (with offsets) so that all categories are covered.

 

because i dont know how to do it.  :ph34r:

Share this post


Link to post
Share on other sites

because i dont know how to do it.  :ph34r:

 

I don't see a way to add that functionality nicely to Triple edit. So I would need to do it for your specifically. That would mean that I would need access to your backoffice and that I would need to charge you some money. Please PM me if you are interested in that.

Share this post


Link to post
Share on other sites

Hello,
I think there is an error in the file order-edit.php at line 265
(last version)

$net_tax = $price*(0+$products['tax_rate'])/100;

a+

Share this post


Link to post
Share on other sites

Hello,

I think there is an error in the file order-edit.php at line 265 (last version)

$net_tax = $price*(0+$products['tax_rate'])/100;

a+

What makes you think that that is an error?

  • Like 1

Share this post


Link to post
Share on other sites

In PHP:

0 + "n" => 0 always

0 + $n only return a numeric value different from 0 if $n (its value) can be converted to a number different from 0, ie: is_numeric($n) == true && $n != 0

Share this post


Link to post
Share on other sites

In PHP:

0 + "n" => 0 always

0 + $n only return a numeric value different from 0 if $n (its value) can be converted to a number different from 0, ie: is_numeric($n) == true && $n != 0

As these are database fields that are supposed to be numeric that should not be a problem. 

 

But for clarity I have switched to the use of "floatval" in the newest version.

Share this post


Link to post
Share on other sites

Qould it be possible to regenerate friendly URL with this script?
I have problem with accents in my friendly URL and I need to remove them from all my products.

I use Prestashop 1.6.1.1

 

 

Thank you

Edited by jkr (see edit history)

Share this post


Link to post
Share on other sites

Qould it be possible to regenerate friendly URL with this script?

I have problem with accents in my friendly URL and I need to remove them from all my products.

I use Prestashop 1.6.1.1

 

 

Thank you

Sure. Select the "link_rewrite" field  and choose then from the mass edit menu "regenerate for it".

  • Like 1

Share this post


Link to post
Share on other sites

Versions 1.09x and 1.19c (for PS 1.4) contain an error in product edit that causes it not to display all product categories in edit mode. Those using it are advised to upgrade,

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites

Sure. Select the "link_rewrite" field  and choose then from the mass edit menu "regenerate for it".

That is FANTASTIC!

Thanks a lot. Is it also get rid of accents from the category names?

Thank you

Share this post


Link to post
Share on other sites

That is FANTASTIC!

Thanks a lot. Is it also get rid of accents from the category names?

Thank you

Why don't you try?

 

The advantage of Triple Edit is that you the results before you submit them...

:)  :D

  • Like 1

Share this post


Link to post
Share on other sites

Hello, 

 

The VAT tax has changed in my country and I need to change the tax VAT in all products from the old value to the new.

I have created a new tax and now want to mass change all my products.

-have latest version

-777 permissions

-new tax is enabled

-i have also tried to submit for a single product, so no .php limit reached

-i have multishop

 

Unfortunately I receive this error 500 when I hit Submit. 

 

Any idea what I can do?

 

 

Server error

500
The website encountered an error while retrieving .../massedit/product-proc.php?c=2&d=1. It may be down for maintenance or configured incorrectly.
Edited by Docki