Jump to content
musicmaster

[Free Script] Prestools Suite: Mass Edit, Order Edit And Much More

Recommended Posts

Fehmi135, this likely has to do with the naming of your pictures. 1.5 has names like 467-large_default.jpg. 1.4 has names like 467-large.jpg. But your theme can use another extension. 

 

In the files settings1.php you can add additional extensions.

 

I cheked up, and I never modified the names of pictures. The name for the small pictures is : "830-small_default/-.jpg"

 

And in the files settings1.php, I have exactly the same name :

$img_extensions = array('-small_default.jpg','-small.jpg'); 

Thank you

Edited by Fehmi135 (see edit history)

Share this post


Link to post
Share on other sites

Fehmi, do you have the latest version? This bug was mentioned and repaired only recently - together with the arrival of the settings files.

 

Can you check in your Prestashop backoffice which image formats are switched on for products?

Share this post


Link to post
Share on other sites

Fehmi, do you have the latest version? This bug was mentioned and repaired only recently - together with the arrival of the settings files.

 

Can you check in your Prestashop backoffice which image formats are switched on for products?

 

 

I had the 0.95d version and I downloaded the 0.96, but the images still do not appear. 
 
The format is JPEG 
 
Thank you very much

Share this post


Link to post
Share on other sites

When I click on "Product Edit" then "Edit" for category I have several error messages : "No default found for 22" with different number, which is I think the product ID. And after this messages I can edit the categories.

Share this post


Link to post
Share on other sites

Fehmi, what browser are you using?

 

I am also puzzled by the slash and the last dash in your picture url "830-small_default/-.jpg". Can you provide me screendumps of the picture formats you have defined in your backoffice?

 

If you want I can have a look in your backoffice to analyze the problem. You can PM me your data for that.

Share this post


Link to post
Share on other sites

hello there, im using you module long time and there was no problem till i get one more shop and now i can login just to one and to another i get session error.

Warning: session_start(): open(/tmp/sess_t67, O_RDWR) failed: Permission denied (13) in

Warning: session_start(): Cannot send session cookie - headers already sent by

Warning: session_start(): Cannot send session cache limiter - headers already sent 

Warning: Cannot modify header information - headers already sent by

....

can you please help me a little to fix this so i can use it on both my webshops...

Share this post


Link to post
Share on other sites

Fehmi, what browser are you using?

 

I am also puzzled by the slash and the last dash in your picture url "830-small_default/-.jpg". Can you provide me screendumps of the picture formats you have defined in your backoffice?

 

If you want I can have a look in your backoffice to analyze the problem. You can PM me your data for that.

 

I'm using

- Google Chrome : v 32.0.1700.107 m

- Maxthon : v4.1.3.4000

 

36954221BO.png

Share this post


Link to post
Share on other sites

I am also puzzled by the slash and the last dash in your picture url "830-small_default/-.jpg". 

 

I think that the last dash comes from the simplified URL, in all my products there is a dash in the simplified URL

Share this post


Link to post
Share on other sites

hello there, im using you module long time and there was no problem till i get one more shop and now i can login just to one and to another i get session error.

Warning: session_start(): open(/tmp/sess_t67, O_RDWR) failed: Permission denied (13) in

Warning: session_start(): Cannot send session cookie - headers already sent by

Warning: session_start(): Cannot send session cache limiter - headers already sent 

Warning: Cannot modify header information - headers already sent by

....

can you please help me a little to fix this so i can use it on both my webshops...

I try all please help.... from job I can acces to one site and from home to another... what to do ?

Share this post


Link to post
Share on other sites

Fehmi, can you try in settings1.php to add "'-small_default/-.jpg'"?

 

shadyns, can you try the attached version of login1.php and tell me whether it helps?

 

 

Share this post


Link to post
Share on other sites

Fehmi, can you try in settings1.php to add "'-small_default/-.jpg'"?

 

shadyns, can you try the attached version of login1.php and tell me whether it helps?

THANK YOU VERY VERY VERY VERY MUCH!!! :D

I needed it urgent now and all works now good thank you 

Share this post


Link to post
Share on other sites

Fehmi, can you try in settings1.php to add "'-small_default/-.jpg'"?

 

Still nothing :/

Share this post


Link to post
Share on other sites

I cant see picture to from fitst version witch im using triple edit... but i was think its normal :D and why would I need picture if there is no option to edit it ... or there is  :D ?

Share this post


Link to post
Share on other sites

musicmaster I'm using your script and I'm trying to mass edit onsale prices but it's not working. This is the error I get...

 

NWSELECT id_feature, name FROM ps_feature_lang WHERE id_lang='1' ORDER BY id_feature
SELECT id_lang FROM ps_lang
select s.id_shop_group, g.share_stock, g.name from ps_shop s, ps_shop_group g WHERE s.id_shop_group=g.id_shop_group and id_shop='1'
*
: invalid onsale for

Share this post


Link to post
Share on other sites

vbadboi,

 

onsale is the onsale flag that determines whether there should be an "on sale" banner near your product. As such it can only have the values "0" and "1". Onsale prices are in the discount fields and those are not yet implemented in the script.

Share this post


Link to post
Share on other sites

Very nice and many thanks, tested on 1.5.6.2.

 

Just an idea:

 

It would be nice to have "Orders Status" easily updated from a list of orders (not one by one), just ticking the orders and selecting a new status, then "update".

 

This simple functionality is really missing in Prestashop.

Cheers

Rene

Share this post


Link to post
Share on other sites

I just saw this functionality is in 1.6.0.4 ... very nice, thanks.

Share this post


Link to post
Share on other sites

Fantastic!! I am not real talkative on here however this works for what I need to do and thank you so much!! I am using PrestaShop™ 1.5.6.2.

 

I would LOVE to see a spot to add the link url for the images! Upload the images (I noticed on mine, the images to one product the links are vary similar (IE  1. http://www.coralieakamrsroadrunner.com/shop/img/p/4/8/2/482.jpg 2. http://www.coralieakamrsroadrunner.com/shop/img/p/4/8/4/484.jpg of course they just go in order from there) , add to the program you made to all products that need that image...... this might bypass how presashop works with images? I am more then willing to do this for my images :)

 

So far I am loving this! Thank you again for all your hard work!!

Coralie

Share this post


Link to post
Share on other sites

mrsroadrunner, thank you for the explanation. Can you try the attached version?

 

Edited: New version is now at Post #1

Edited by musicmaster (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Thanks for your great work!!!

I found a problem, in page of the list of discounted products, the values ​​of the column "New price" is always equal to -1.00

you can solve this problem?

I post the screenshot:

post-473169-0-35767700-1394579464_thumb.jpg

Edited by occasioniweb.com (see edit history)

Share this post


Link to post
Share on other sites

occasioniweb, thank you for pointing out some problems.

 

Can you check the new version (at post #1)?

  • Like 1

Share this post


Link to post
Share on other sites

occasioniweb, thank you for pointing out some problems.

 

Can you check the new version (at post #1)?

Perfect!!!!!

now everything works fine! :

Share this post


Link to post
Share on other sites

mrsroadrunner, thank you for the explanation. Can you try the attached version?

 

Edited: New version is now at Post #1

I will give it a go thanks!!

Share this post


Link to post
Share on other sites

Thanks, very nice work!

 

But the images cannot be displayed in my case, so I change the code in fonctions1.php in 30 line with this:

  if($selected_img_extension == "")
    return '<a href="'.$base_uri.'img/p'.getpath($id_image).'/'.$id_image.'.jpg" target="_blank" title="'.$id_image.';'.$imagelist.'"><img src="'.$base_uri.'img/p'.getpath($id_image).'/'.$id_image.'-small_default.jpg" width="45px" height="45px" /></a>';
  return "xx";

now I got images displayed. Sorry for my english.

Share this post


Link to post
Share on other sites

Meditation, thank you for your reaction.

 

I would like to know what is going wrong in your case. As you seem to know some coding: could you help me by putting in some debug code and telling me what goes wrong?

 

I understand from your use of "==" in

 if($selected_img_extension == "") 

that the loop in line 22-28 of functions1.php does not find the right extension and I am puzzled why. The extension that you use is one of those that is defined in SETTINGS1.PHP. It may that something goes wrong with the path. In the file_exists() I need to use a relative path as the absolute path is relative to the harddisk (something like \home\users\johnsmith\htmldocs). 

 

Could you insert the sentence "echo $fff."<br>";" between lines 24 and 25 and report what is why those tested imagepaths test wrong on your shop? 

 

If you have this problem there will likely be others . So I would be grateful if you could help me solve this problem. 

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites

hi musicmaster

thanks for your reply.

 

I put "echo $fff."<br>";" in the place, i got this message:

../../../img/p/1/9/6/8/1968-small_default.jpg
../../../img/p/1/9/7/3/1973-small_default.jpg
../../../img/p/1/3/9/4/1394-small_default.jpg
../../../img/p/1/3/6/1/1361-small_default.jpg

....

But I have "xx" in the image place, 

 

If I change

"if($selected_img_extension != "")"

to

""if($selected_img_extension == "")

 

and

return '<a href="'.$base_uri.'img/p'.getpath($id_image).'/'.$id_image.'.jpg" target="_blank" title="'.$id_image.';'.$imagelist.'"><img src="'.$base_uri.'img/p'.getpath($id_image).'/'.$id_image.$selected_img_extension.'" width="45px" height="45px" /></a>';

to

return '<a href="'.$base_uri.'img/p'.getpath($id_image).'/'.$id_image.'.jpg" target="_blank" title="'.$id_image.';'.$imagelist.'"><img src="'.$base_uri.'img/p'.getpath($id_image).'/'.$id_image.'-small_default.jpg" width="45px" height="45px" /></a>';

I got my images back.

I'm not php coder  :) , I don't understand your code, but I hope it help.

sorry for my english.

Share this post


Link to post
Share on other sites

Thank you for your reply.

 

It looks like an old version of approve.php has been included. Can you try with the attached version?

Share this post


Link to post
Share on other sites

Thank you for your reply.

 

It looks like an old version of approve.php has been included. Can you try with the attached version?

it works like a charm! thanks very much

  • Like 1

Share this post


Link to post
Share on other sites

Thank you very much. Will save me a lot of time.

 

Worked on 1.5.6.1 but i don't think you need to know that since I just noticed previous post said it's working on 1.5.6.2!!

Edited by EdC (see edit history)

Share this post


Link to post
Share on other sites

Great script :D

 

I have 2 questions

1. It is possible to update script to newest PS 1.6?

2. In 'Product combination edit' it is possible to not only set + or - combination price but set one final VATprice price (default product price + increase/decrease combination price)?

Share this post


Link to post
Share on other sites

I haven't looked at 1.6 yet in connection to the script. I had understood that little would change with the database in the new version but I haven't checked yet. What are your experiences?

 

Product Combination Edit is the latest addition. I still have some plans for improvement. But that will take time.

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites

ehi!Thank you for your module..but why is it impossible to change Suppliers?

As you can have more than one supplier for a product and as there are connected fields like supplier price and code this is a bit complicated to code. So maybe sometime in the future....

Share this post


Link to post
Share on other sites

Thank you for response, and good work for the feature.

Instead I want to edit more product for "on Sale" but i can not:

 

1. I enter in a category

2. I check to show edit "onSale"

3. in the Mass Edit i select "replace" with value "0" to "1" and then i click "update all editable records"

 

After that the admin return in homepage and don't change nothing.

 

Where do i wrong?

 

Share this post


Link to post
Share on other sites

Hello,

I used this mod and today got a message and can't add product, maybe some help ?

 

 Notice: Undefined index: id_tax in /home/admin/domains/domain..../order-edit.php on line 125

MySQL error 1054: Unknown column 'pl.name' in 'field list'
Generated by URL '/order-edit.php'
with Query 'select p.weight,p.ean13,p.upc,p.reference,p.supplier_reference,p.quantity, ps.*,pl.name,pl.id_lang,l.iso_code,t.rate as tax_rate,t.id_tax, tl.name as tax_name from ps_product_shop ps left join ps_product p on p.id_product=ps.id_product left join ps_lang l on pl.id_lang=l.id_lang left join ps_tax_rule tr on tr.id_tax_rules_group=ps.id_tax_rules_group AND tr.id_country='14' AND tr.id_state='0' left join ps_tax t on t.id_tax=tr.id_tax left join ps_tax_lang tl on t.id_tax=tl.id_tax AND tl.id_lang='3' WHERE ps.id_shop='1' AND ps.id_product='55447' '

Share this post


Link to post
Share on other sites

Sorry, maybe this is problem from my site, error msg displays only when edit shipped orders.

Share this post


Link to post
Share on other sites

@Schnap: I will keep it in mind. It will mean yet another row of fields in the crowded interface;(

 

@giorinsrl: What about "Submit all"? Without submitting your changes won't be saved.

 

@rakepl: there is something weird with your query. I am missing the part with "left join ps_product_lang pl". Line 112 in order-edit.php.

Share this post


Link to post
Share on other sites

ok, but i have to click first  "update all editable records" and then submit all?
if i do so, does the script update all records showed?

Share this post


Link to post
Share on other sites

ok, but i have to click first  "update all editable records" and then submit all?

if i do so, does the script update all records showed?

Yes, Submit All updates all records showed.

 

You can also click on the hooks at the end of the rows to update them one at a time.

Share this post


Link to post
Share on other sites

hi,

 

Great work i love the script. is there anyway you can add the wholesale price to the product edit screen please or tell me how to do it. Really need this feature. sorry if it has been already covered in the previous posts i couldnt find it.

 

Thanks in advance

Paul

Share this post


Link to post
Share on other sites

@Musicmaster: I only posted what I see when edit a shipped order (with not shipped your mod is working fine)

Share this post


Link to post
Share on other sites

@rakepl: that shouldn't make a difference. I always test with a shipped order.

 

@webbie1985: I noted your wish. It is not yet there. You are the first one asking for it. 

Share this post


Link to post
Share on other sites

hi musicmaster,

 

Thank you for the great script, its fantastic.

 

BTW have you tested on multistore environment? i find all products which are not part of other stores also showing if i select products by shopwise?

 

prestashop do multiple entry in "ps_product_lang" table
 
if one creates a new product specific to a store , there are multiple entries in "ps_product_lang" table, one each for every store,
but in "ps_product_shop" table there are only one entry for the store you on entered the product for
 
that means if we have X Y Z stores and if we enter a product A for store X, same products get entrered for store Y and Z also. but there are only one entry in  "ps_product_shop" table [product A for store X "ps_product_shop" table]
 
see the sitemap bugs related to same multistore issue
 
 
 
i think same can be fixed by proper join query.
 
Please let me know how to fix that?
 
Thank you.

Share this post


Link to post
Share on other sites

@Matteoint: according to Prestashop the database for 1.6 is largely the same as for 1.5, so I expect it to work. But I haven't been able to do extensive testing yet. I hope other people will tell here their experiences.

 

@rajlaskar: Are you using the latest version? I thought I had repaired that bug a few versions ago. I tried to implement everything for multishop, but as we don't use multishop ourselves the testing is a bit less thoroughly as for the other parts.

Share this post


Link to post
Share on other sites
@webbie1985, @Schnap: the extra fields (Shipdepth, Shipheight, Shipwidth, Wholesale) you asked for have been included in the latest version. They are standard not visible. You need to click on "extras" to see them.

 

Discounts are now editable too, but in a clumsy way. Still a way to go this the way I want.

 

This is the last completely free version of triple edit. In the next version the software will be split in a free and a paid version. Most will stay free but the more complicated parts of product-edit will only be in the paid version.

Share this post


Link to post
Share on other sites

@musicmaster . Thank you very much. Really appreciated. Is the link for the update in the 1st post? As I'm away from the work computer and can't see version number

Share this post


Link to post
Share on other sites

@rajlaskar: Are you using the latest version? I thought I had repaired that bug a few versions ago. I tried to implement everything for multishop, but as we don't use multishop ourselves the testing is a bit less thoroughly as for the other parts.

Yes i have downloaded the files from the page one - main link , 

 

multistore issue is still exist

Share this post


Link to post
Share on other sites

@rajlaskar: Can you try the new version at post 1?

 

It works like a charm.

 

Thank you once again.

 

one suggestion: you can add a feature like export the selected data in csv format, like adding a checkbox "export to csv" if it is checked, then instead of displaying inline in browser, it will download a csv file.  user can use this csv for importing into various marketplaces like ebay,amazon by converting into their format.

  • Like 1

Share this post


Link to post
Share on other sites

It works like a charm.

 

Thank you once again.

 

one suggestion: you can add a feature like export the selected data in csv format, like adding a checkbox "export to csv" if it is checked, then instead of displaying inline in browser, it will download a csv file.  user can use this csv for importing into various marketplaces like ebay,amazon by converting into their format.

 

Thank you for helping me improve the software.

 

What defects do you see in Prestashop's csv export that I could improve on?

Share this post


Link to post
Share on other sites

Thank you for helping me improve the software.

 

What defects do you see in Prestashop's csv export that I could improve on?

 

the export feature available at admin>productlist, does not export product description, short description, multiple images, manufacturer, feature, etc, it has no use. all export modules are paid modules, as your script display details as per user input, with same query csv export can be done easily. 

 

Thank you

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

 

I try triple_edit-PS1.5_0.99b.zip with Prestashop 1.5.3.1.

 

I use part Order-Edit and need to change 

 

Before I use the edit form of order.

 

Table ps_order - column total_shipping = 160

Table ps_order - column total_shipping_tax_incl = 160

Table ps_order - column total_shipping_tax_excl = 132

Table ps_order - column total_shipping_tax_rate = 21

 

 

Table ps_order_carrier - column shipping_tax_excl = 132

Table ps_order_carrier - column shipping_tax_incl = 160

 
 
Now I change the Shipping cost to 250. There are no another changes.
I return to PS order detail.
Total price is OK, but price of shipping cost is still 160 - there is wrong.
 

Table ps_order - column total_shipping = 250

Table ps_order - column total_shipping_tax_incl = 160 (not changed)

Table ps_order - column total_shipping_tax_excl = 132 (not changed)

Table ps_order - column total_shipping_tax_rate = 21

 

Table ps_order_carrier - column shipping_tax_excl = 132 (not changed)

Table ps_order_carrier - column shipping_tax_incl = 160 (not changed)

 
Finnaly - I have correct total price, but in order detail and in invoice I have originaly price of shipping cost.
 
 
Edited by Vit JURASEK (see edit history)

Share this post


Link to post
Share on other sites

Ok - it possible :) I create QuickAccess menu with link:

 

 

/login1.php?username=NAME&pswd=PASS&url=/product-sort.php

 

and in login1.php must change all _POST -> _GET

 

I know thet is a simple way but its work for me :)

Share this post


Link to post
Share on other sites

Hi musicmaster,

 

After edit:

 

Table ps_order - column total_shipping = 250

Table ps_order - column total_shipping_tax_incl = 250 (now is OK)

Table ps_order - column total_shipping_tax_excl = 206 (now is OK)

Table ps_order - column total_shipping_tax_rate = 21

 

but in the table named "ps_order_carrier" the data stay unchanged...

 

Table ps_order_carrier - column shipping_tax_excl = 132 (not changed) - correct 206

Table ps_order_carrier - column shipping_tax_incl = 160 (not changed) - correct 250

Share this post


Link to post
Share on other sites

Hi Vit,

 

Sorry, I had overlooked that ps_order_carrier table. I had "shipping_tax_excl" implemented in ps_orders

 

However, I have a little problem. As far as I know Prestashop offers the possibility to split an order in more than one shipping. I wondered whether that results in more than one entry in that ps_order_carrier table. 

 

Do you know about that?

Share this post


Link to post
Share on other sites

This is the limit to which one can live. For example, I do not use the split consignment.

 

It is very difficult to finish the conversion into the second table?

Share this post


Link to post
Share on other sites

Nice! Everything was OK!

 

I try to add some code for invoice prices correction:

 

$query="update ". _DB_PREFIX_."order_invoice set ";
$query.=" total_shipping_tax_excl='".price($total_shipping_tax_excl)."'";
$query.=" ,total_shipping_tax_incl='".price($_POST['total_shipping'])."'";
$query.=" ,total_paid_tax_excl='".($total_shipping_tax_excl + $_POST['total_products'])."'";
$query.=" ,total_paid_tax_incl='".$total."'";
$query.=" where id_order=".mysql_real_escape_string($id_order);
$query.=" limit 1";
//echo $query;
dbquery($query);

Share this post


Link to post
Share on other sites

OK Vit, third try, now with ps_order_invoice modification added (note that the two "modify order" buttons each have their own sql queries). 

 

I hope this is good...

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites
Hello, 

 

Thank you for this wonderful module. 

 

One thing, you can not change even available?

Share this post


Link to post
Share on other sites

You can change (almost) everything, including available. Just remember to submit your changes.

 

If you have any problem, please let me know with an explanation of what you did.

Share this post


Link to post
Share on other sites
Perfect, thank you. 

One last question, there is no way to change the shipping costs with this script?

Share this post


Link to post
Share on other sites

What kind of shipping costs do you want to change?

 

Order-edit allows you to change shipping costs for individual orders.

Share this post


Link to post
Share on other sites

Hello

Thanks for this scripts, are very useful.

I am testing triple_edit-PS1.5 under Prestashop v1.6.0.6 and for the moment works fine.

Bravo!

  • Like 1

Share this post


Link to post
Share on other sites

jipicily, I really don't understand what you mean. Do you mean the transporter? The shipping costs? Shipping in general, by product or by order?

 

Maybe you can explain with pictures which setting in the Prestashop backoffice you want to change? 

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites

Hi MusicMaster,

 

Thanks for the great module.

I need to change the date of the order,  we enter quite few orders manually and always a few days after we have actually taken.

Is there a way to have you module doing so?

 

Thanks

Share this post


Link to post
Share on other sites

rajansinha02, as mentioned in the first post: this module should work with 1.6 as according to Prestashop that has largely the same database structure as 1.5. I just haven't been able to test it for myself extensively. As you can see in post #380 the only person who tested it until now and reported about it didn't find problems.

Share this post


Link to post
Share on other sites

excuseme for my stupid question.....how I save the work on tripleedit? after I make change in the product I haven't find to save it....please help me!

-.-

 

ok done!!!! no more problem, thanks for the beautifull module!!!!

Edited by rebeweb (see edit history)

Share this post


Link to post
Share on other sites

Thanks for your response

 

I did try to install it but throwing error blank page when trying to configure in 1.6

 

Thanks

Share this post


Link to post
Share on other sites

@rajansinha02:

 

As you can read in the readme and in post#1 of this thread this is not a module. So you cannot install and configure it from the PS backoffice.

 

Instead you need to copy the files to subdirectory of your admin directory and call them in your browser.

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites
My objective was to change the shipping of any products with your script.

Share this post


Link to post
Share on other sites

Hi

 

I've been able to use the script on PS 1.6.0.6 but I want to use it to mass move products from one category to another, can you explain how to do it from the script? There are so many options that I'm not certain how to go about it.

 

I want to move multiple products from one category to another.

 

TIA

Share this post


Link to post
Share on other sites

Jipicily, I am not sure what you want

 

peanut: first make category editable. Then in the mass edit block select "category" and then "add" the new category. Then "remove" the old category. Finally submit all.

Share this post


Link to post
Share on other sites

Thank you musicmaster

 

Works with a charm on 1.6, still testing it till date no problem.

 

 

Very appreciating Great job.

 

Thanks 

 

 

 

Share this post


Link to post
Share on other sites

After moving all files, I've tried to access the script, but it gave me next error

 

Notice: Undefined index: triple in /testedit/approve.php on line 10
 
Warning: Cannot modify header information - headers already sent by (output started at testedit/approve.php:10) in testedit/approve.php on line 29
Please login to view this page
 
Can someone help on this error?
 
Thanks

Share this post


Link to post
Share on other sites

Hello Music Master,

I am on v 1.6.0.6 and installed the files to a sub of admin.

When I access it through my browser I get the following error in Chrome

[an error occurred while processing this directive]

In IE9 it reports a internal server 500 error.

 

Any ideas?

Thanks,

Aaron

Share this post


Link to post
Share on other sites

hi, thank you music master

I want to know how to set cookie lifetime(session time), it‘s not enough by defaut. I just lost one hour of work.

 

thanks

Edited by meditation (see edit history)

Share this post


Link to post
Share on other sites
@meditation: the timeout of a cookie is set in with the setcookie command on line 52 in Login1.php. It is not mentioned in the way it is implemented. That means that it should expire at the end of the session. Normally that should workand I haven't heard about problems before. You can try something like "setcookie("triple", $encseed, (time()+60*60*24*30));"

 

@gopetsquad: This problem you mention is rather strange. Could it be that there is something wrong with the rights in your newly created directory?

 

@Lilybos: Can you try to change approve.php so that line 10 becomes "{ if (isset($_SESSION['triple']) && $_SESSION['triple'] == 'open')". That is: replace || with &&.

  • Like 1

Share this post


Link to post
Share on other sites

Hey, great job answer questions and keeping up with things. I'm impressed, good to see someone adding so much value to the community.

 

Sorry if this has already been asked. I'm on 1.6.0.6 and I need to change the carrier after the order has been placed so the proper tracking url will be displayed for my customer. Can this script do that?

 

Long story short...

 

I offer free shipping on all orders, but I use several carriers depending on the address. I never know which carrier I will use until I ship so the usual way of setting up carriers will not work for me. I'm thinking I could set up multiple carriers in the BO with the proper tracking url's, then select the carrier I actually used using this script.

 

Sound like it will work to you?

 

Thanks!

Share this post


Link to post
Share on other sites