Jump to content

Recommended Posts

Salut,

je cherche un tuto bien documenté sur la méthode pour changer de base de donnée.

J'ai actuellement un site en Prestashop 1.4.6.2.

Ma base et en mutualisée chez OVH.

Je viens d'acheter une sql privée.

 

Je cherche à rattacher cette nouvelle base à mon presta...

Ça bug sans cesse, presta ne fait pas le lien.

 

Je pense que le fichier settings.inc.php est tout simplement mal configuré, mais je ne vois pas quoi changer...

Entre les cookie key, les cookie IV et compagnie, je suis perdu...

 

Si vous avez des conseils, ils sont les bienvenus.

 

Merci ;)

Edited by jujutte24 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

En effet, il suffit de remettre dans le fichier setting.inc.php les différentes valeurs de connexion à la base MySQL.

 

 

define('_DB_SERVER_', 'ADRESSE_IP'); ### ADRESSE IP du SQL server privé

define('_DB_USER_', 'LOGIN'); ### Identifiant BDD

define('_DB_PASSWD_', 'PASSWORD'); ### Mot de passe BDD

 

Avez-vous fait la migration de la base de données entre les deux serveurs avant ?

  • Like 1

Share this post


Link to post
Share on other sites

Oui, j'ai intégré le contenu de l'ancienne dans la nouvelle.

Demain je fais un test.

;)

Share this post


Link to post
Share on other sites

Ça marche ;)

 

Merci.

 

Mais j'ai un bug, j'ai une table, la search_index, qui pèse très lourd (256MO), je ne peux pas l'importer, elle est beaucoup plus petite...c'est grave ?

Share this post


Link to post
Share on other sites

Bonjour

 

Mettez une table search_index vide, ce n'est que l'eregistrement des recherches effectuer sur le site.

Share this post


Link to post
Share on other sites

Bonjour,

je n'arrive pas à changer mon

settings.inc.php

Un coup de main ?

Prestashop 1.6

Bonjour

 

Créer Votre Topic pour Votre Problème, déjà là vous avez u  problème analogue mais pas la même cause.

Après vous aurez des réponses, mais d'abord une question qui permettras de donner la meilleur réponse.

 

Lire les règles du forum : https://www.prestashop.com/forums/topic/256108-regles-du-forum-officiel-de-prestashop-et-conseils-dutilisation/

 

Extraits :

1 topic = 1 sujet de conversation

- Si vous avez plus d’une question, créez plus d’un sujet !

- Ne posez pas votre question dans un topic qui ne traite pas exactement le même sujet. Ouvrez un nouveau topic, c’est fait pour ça !

Share this post


Link to post
Share on other sites

Bonjour,

 

En effet, il suffit de remettre dans le fichier setting.inc.php les différentes valeurs de connexion à la base MySQL.

 

 

define('_DB_SERVER_', 'ADRESSE_IP'); ### ADRESSE IP du SQL server privé

define('_DB_USER_', 'LOGIN'); ### Identifiant BDD

define('_DB_PASSWD_', 'PASSWORD'); ### Mot de passe BDD

 

Avez-vous fait la migration de la base de données entre les deux serveurs avant ?

Au top Sébastien, merci beaucoup

Share this post


Link to post
Share on other sites

J'ai eu le même soucis, en migrant de mon serveur local à OVH...Pour moi, ça a refonctionné quand j'ai vidé le cache dans Paramètres avancés > Performance et en haut à droite vider le cache (prestashop 1.7). Si ça peux aider quelqu'un ;)

Share this post


Link to post
Share on other sites

Bonjour

 

La vie d'un sujet  : 12 aout 2012 longtemps longtemps après : 4 juillet 2015 puis longtemps longtemps plus tard 29 novembre 2016  et enfin un peu plus tard 4 avril 2017

de la version 1.4 à la version 1.7 ça en fait du chemin et des heures de boulot :)

 

Troll du jour je ferme le topic sinon  il va encore fleurir en 2027

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More