Jump to content
tropikai

[Ajax / Server Error] textStatus: "error" errorThrown when trying to upgrade with 1Click Autoupgrade

Recommended Posts

I get this error when trying automatic update from 1.4.8.2 to 1.5RC2

[Ajax / Server Error] textStatus: "error" errorThrown:"Internal Server Error" jqXHR

 

I checked error log, this is what i got:

 

FastCGI: comm with (dynamic) server "/usr/local/fastcgi/cgi-bin/php-cgi" aborted: (first read) idle timeout (30 sec)

FastCGI: incomplete headers (0 bytes) received from server "/usr/local/fastcgi/cgi-bin/php-cgi"

 

What is wrong with it? Is it because of my/server fault or from module? Thank you

  • Like 1

Share this post


Link to post
Share on other sites

I originally posted this in another thread, but this thread seems more relevant.

I'm having the same problems with my clean RC1 install.

 

I tried to use the 1-click upgrade and got the following errors:

 

[Ajax / Server Error] textStatus: "error" errorThrown:"Internal Server Error" jqXHR: ""

 

The complete log of the upgrade progress:

 

 

 

 

And in the error.log file:

 

[Mon Aug 13 16:38:15 2012] [error] [client 213.89.96.175] PHP Warning:  Cannot modify header information - headers already sent by (output started at /home/evanionc/pockettech.se/html/rc/controllers/admin/AdminThemesController.php:357) in /home/evanionc/pockettech.se/html/rc/controllers/admin/AdminThemesController.php on line 346, referer: [url="http://pockettech.se/rc/backoffice/index.php?controller=AdminThemes&token=42ed4807416214d8bd2088714caad93e"]http://pockettech.se...d2088714caad93e[/url]

[Mon Aug 13 16:38:15 2012] [error] [client 213.89.96.175] PHP Warning:  Cannot modify header information - headers already sent by (output started at /home/evanionc/pockettech.se/html/rc/controllers/admin/AdminThemesController.php:357) in /home/evanionc/pockettech.se/html/rc/controllers/admin/AdminThemesController.php on line 347, referer: [url="http://pockettech.se/rc/backoffice/index.php?controller=AdminThemes&token=42ed4807416214d8bd2088714caad93e"]http://pockettech.se...d2088714caad93e[/url]

[Mon Aug 13 16:39:25 2012] [error] [client 213.89.96.175] File does not exist: /home/evanionc/pockettech.se/html/rc/js/jquery/datepicker, referer: [url="http://pockettech.se/rc/backoffice/index.php?controller=AdminSelfUpgrade&token=97e45f2db92a7dbeb587d5b868b3ac7d"]http://pockettech.se...587d5b868b3ac7d[/url]

[Mon Aug 13 16:39:25 2012] [error] [client 213.89.96.175] File does not exist: /home/evanionc/pockettech.se/html/rc/css/jquery.cluetip.css, referer: [url="http://pockettech.se/rc/backoffice/index.php?controller=AdminSelfUpgrade&token=97e45f2db92a7dbeb587d5b868b3ac7d"]http://pockettech.se...587d5b868b3ac7d[/url]

[Mon Aug 13 16:42:33 2012] [error] [client 213.89.96.175] PHP Fatal error:  Class 'Configuration' not found in /home/evanionc/pockettech.se/html/rc/backoffice/autoupgrade/latest/prestashop/install/upgrade/php/p15015_blockadvertising_extension.php on line 34, referer: [url="http://pockettech.se/rc/backoffice/index.php?controller=AdminSelfUpgrade&token=97e45f2db92a7dbeb587d5b868b3ac7d"]http://pockettech.se...587d5b868b3ac7d[/url]

 

Nothing is shown in the mysql.log

 

server info:

PHP Built on:  Linux k2.snowpeak.se 2.6.18-408.el5.lve0.8.61.1 #1 SMP Wed Apr 18 07:47:15 EDT 2012 x86_64
Database Version:  5.0.95
PHP Version:  5.3.15
Web Server:  Apache/2.2.22 (Unix)
Web Server to PHP interface:  cgi-fcgi
User Agent:  Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.75 Safari/537.1

 

Really hope we can get a solution to this. But after all it's a RC, And I can always reinstall with a RC2. I just want to see how easy it is with the 1-click installer.

Share this post


Link to post
Share on other sites

This seems to be an issue with the archive it downloads from prestashop.com I downloaded the archive from sourceforge and upzipped it to /admin/autoupgrade/prestashop and specified local directory in the configuration options for 1-clickupgrade, and it worked!

  • Like 1

Share this post


Link to post
Share on other sites

I tried that but it has worked for me ... any ideas?

Share this post


Link to post
Share on other sites

This did not work for me...

current version : 1.5.2.0. install version : null[ERROR] version to install is too old

 

is what comes up when I try to autoupgrade

Share this post


Link to post
Share on other sites

Hi....

 

Same problem happens to me when trying to update from 1.5.3.1 to 1.5.4

 

error.jpg

 

any idea how to fix it?

 

thanks

Share this post


Link to post
Share on other sites

autoupdate from 1.5.4 to 1.5.4.1

 

[Ajax / Server Error] textStatus: "error" errorThrown:"Bad Gateway" jqXHR: "

502 Bad Gateway

nginx/1.2.6

Share this post


Link to post
Share on other sites

Hi!

 

I've fixed the problem with an easy solution:

 

1º go to your server and make a complete manualy backup from all filles by FTP and backup you data base by backoffice

2º go to backoffice --> 1 - click module --> deactivate the option of making an automatic backup from files and database

3º update with the 1-click module option

 

that's all!

 

I hope it helps! :)

  • Like 1

Share this post


Link to post
Share on other sites

antakarana i change this value

 

2º go to backoffice --> 1 - click module --> deactivate the option of making an automatic backup from files and database

 

editing config.var file in /admin/autopugrade.

 

but whene i try to update again. without backup also fails.

Share this post


Link to post
Share on other sites

Hi!

 

I've fixed the problem with an easy solution:

 

1º go to your server and make a complete manualy backup from all filles by FTP and backup you data base by backoffice

2º go to backoffice --> 1 - click module --> deactivate the option of making an automatic backup from files and database

3º update with the 1-click module option

 

that's all!

 

I hope it helps! :)

 

FUNCIONOU PERFEITAMENTE! 

 

PROBLEMA RESOLVIDO!

Edited by tinu (see edit history)

Share this post


Link to post
Share on other sites

Well pissed now, followed instructions to use local copy of zip file loaded to server as auto download for update failed.

 

Files unzipped and copy started, then failed and has blown the shop site away completely. Cannot access admin backend or shop front. 

 

Log shows lots of files removed then fails here

 

Copied /prestashop_1.6.0.11.zip.

 

[DEV] ajax request : upgradeDb

 

/install/upgrade/php directory is missing in archive or directory

 

5 minute favour for a friend has turned into an alright f up and now I've got to manually restore the whole damn lot. Thanks guys.

Edited by mrwrighty (see edit history)
  • Haha 1

Share this post


Link to post
Share on other sites

Are there any new informations about this problem?

Share this post


Link to post
Share on other sites

Are there any new informations about this problem?

maybe because prestashop's server is busy,or network is busy,i upgrade scuceess,just upgrade in another time.

Share this post


Link to post
Share on other sites

I have the 1.6.0.9 and I cannot upgrade to any version since several months

 

I have tried uploading to local file, I have checked de 2 GIT files.... etc. 

Share this post


Link to post
Share on other sites

Well what do you know. I run a site on VPS, and apparently VPS didn't allow me to make backups, so I got the same error.

So I simply deactivated backup option, and in matter of seconds, I had my newest update PrestaShop 1.6.1.6 (from 1.5.0.14)

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More