Jump to content

Blocage : Le "é" dans les fichiers TPL...


Recommended Posts

Bonjour,

 

Petit problème que je n'ai pas pu résoudre avec les infos glaner sur le forum :

Je veux mettre un é dans un titre. Rien de plus simple. Par exemple : nouveautés... dans un fichier TPL. Seulement, le é seul fait disparaitre l'ensemble du titre.

Si je le remplace par &ecute; le é n'apparait pas non plus. Le &ecute; apparait en toute lettre.

 

Je bloque un peu et vous remercie de votre aide !

Share this post


Link to post
Share on other sites

Même si c'est effectivement possible de procéder de la sorte, c'est crade d'un point de vue architecture, et va à l'encontre de la possibilité de multilinguisme offerte par PrestaShop

Le mieux est donc de faire comme en natif, c'est à dire mettre toutes les chaines de caractères dans les .tpl en anglais (du coup, plus de pb d'accents) :

{l s='New products' mod='blocknewproducts'}

et de les traduire en français via Outils, Traductions, Modules.

Share this post


Link to post
Share on other sites

Non seulement c'est crade mais en plus ça ne fonctionne pas chez moi... (mystère ! Une idée du pourquoi ?)

Oui, c'est pas bête... Je vais faire comme ça via traduction directement !

 

Merci beaucoup...

 

Edit : Je viens de découvrir l'outil traduction du BO... Effectivement ça aide ! Re-merci...

Edited by steinbeck (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More