Jump to content

Recommended Posts

Bonjour à tous,

 

Le fameux syndrome de l'angoisse de la page blanche, ça touche aussi les webmasters ! Je partage donc la solution d'un problème que, comme beaucoup d'utilisateurs semble-t-il, j'ai rencontré :

 

Après une migration d'un site Prestashop 1.4.8.2 en local sur un serveur pour diffusion web, le site n'affichait qu'une page toute vierge. Aucune des nombreuses solutions trouvées sur le web ne m'a servi.

 

Le plus curieux c'est que j'avais au préalable fait une installation de test sur le serveur final (en l'occurrence chez Alwaysdata) et tout fonctionnait. J'ai ensuite développé en local tranquillement puis transféré le site proprement comme dans la procédure détaillée ici :

http://tinyurl.com/c5eoggq

 

Mais rien, page blanche…

 

Il se trouve que c'était la fonction mcrypt qu'il fallait activer sur le serveur en PHP5. L'absence de la fonction n'empêche apparemment pas une installation originale directement mais c'est fatal à un transfert ! En tout cas ce fut mon cas. J'ai activé mcrypt et le site s'est affiché tout beau tout propre, tout bien comme il faut.

 

Astuce bonus : dans config > config.inc.php pensez à changer @ini_set('display_errors', 'off'); en @ini_set('display_errors', 'on'); en cas de soucis d'affichage - ça vous permettra de lire les erreurs que rencontre le serveur au lieu de ne trouver qu'une bête page blanche. Personnellement c'est ce qui m'a fait avancer - merci à un anonyme sur un forum OVH :)

 

hth…

 

François

Edited by fbarret (see edit history)

Share this post


Link to post
Share on other sites

le problème est-il résolu ?

Et bien disons que mon post n'était pas vraiment une demande pour un problème à résoudre, je faisais juste part de mon expérience sur un cas de figure.

Share this post


Link to post
Share on other sites

Merci beaucoup pour ton astuce, j'ai pu résoudre mon problème de page blanche!

(dû à un problème avec Memcached qui était actif > settings.inc.php > passer le _PS_CACHE_ENABLED_ sur 0 > tout ok)

Share this post


Link to post
Share on other sites

Merci bcp pour l'info !!

J'ai pu résoudre mon soucis de page blanche sur Prestashop 1.5.6.1.

Dans le fichier /config/defines.inc.php j'ai activé le _PS_MODE_DEV_ à true et j'ai pu voir les messages d'erreurs !

 

Un simple soucis de droits d’écritures dans le dossier /cache/smarty

 

++

  • Like 1

Share this post


Link to post
Share on other sites

Merci fbarret car j'ai cherché 4 heures pensant que ça venais du serveur ....

C'est plus simple quand on a les erreur.
@ Bientot

Share this post


Link to post
Share on other sites

Bonjour,

 

j'étais en grande difficulté sur mon transfert de boutique. D'abord des problèmes SQL et ensuite des soucis de pages blanches. Merci beaucoup pour l'astuce visant à activer le mode debug qui m'a permis de trouver tout de suite le problème de mon site.

Share this post


Link to post
Share on other sites

Un énorme merci. Fin d'une galère de 10 jours.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More