Jump to content
Plectrums

[Solved] Het woordje "Zoeken" blijft staan als je in het invulveld gaat staan

Recommended Posts

Ik ben niet helemaal tevreden over mijn zoekveld.......

Ik zou graag willen dat als mensen in het zoekveld gaan staan om een zoekactie in te voeren dat het woordje "Zoeken" automatisch weg gaat. Als ik bij de zoekopdrachten van klanten kijk zie ik maar al te vaak dat het woordje "Zoeken" doodleuk voor hun zoekopdracht staat.

 

Is er een mogelijkheid om dit aan te passen zodat mensen gelijk een zuivere zoekactie kunnen uitvoeren?

 

Ik heb de volgende module ingebouwd: Snel zoeken blok v1.0 door PrestaShop

 

Edit: Een link is natuurlijk wel zo handig.... http://www.papas-plectrums.nl/

 

:)

Edited by Plectrums (see edit history)

Share this post


Link to post
Share on other sites

Je kunt de value="Zoeken"

 

in je module

 

<!-- Block search module TOP -->

 

het gaat om het bestand : blocksearch.tpl of iets in die richting (afh. van template)

 

leeg laten

Edited by Frens (see edit history)

Share this post


Link to post
Share on other sites

@ Frens!

 

Bedankt voor je hulp!

Ik ga er zo snel mogelijk mee aan de slag.

 

:)

Share this post


Link to post
Share on other sites

Op de een of andere manier werkt het niet.

Dit is het geen er voor mij gedaan is door een collega:

 

de search.tpl en top-serach tpl alle values voor search weggehaald en de nl vertaling Zoeken blank gemaakt.

 

Maar het woord "Zoeken" blijft zichtbaar......

 

Het mooiste zou zijn als het woord zoeken automatisch weg zou gaan zodra je in dat veld gaat staan, maar ik weet niet of dat mogelijk is.

 

:)

Share this post


Link to post
Share on other sites

Alles is mogelijk, kijk maar eens naar de zoekbalk bovenaan de pagina van mijn webshop :)

 

Je moet onfocus en onblur functies toevoegen aan de code. Hiermee kan je het woord "Zoeken" weg te krijgen als men met de cursor in het zoekveld staat en weer tevoorschijn laten komen zodra men het zoekveld weer verlaat.

Dit is de code zoals ik het voor mijn webshop heb aangepast:

<input class="search_query" type="text" id="search_query_top" name="search_query" value="{if isset($smarty.get.search_query)}{$smarty.get.search_query|htmlentities:$ENT_QUOTES:'utf-8'|stripslashes}{else}{l s='search a product' mod='blocksearch'}{/if}" onfocus="javascript:if(this.value=='{l s='search a product' mod='blocksearch'}')this.value='';" onblur="javascript:if(this.value=='')this.value='{l s='search a product' mod='blocksearch'}';"/>

 

 

De code moet wellicht wat aangepast worden voor je theme maar dat kan je aan je collega vragen.

 

Wat wel vreemd is, is dat je de vertaling niet kan aanpassen...

Share this post


Link to post
Share on other sites

Kleine toevoeging: als je TPL files gaat aanpassen, dan moet je wel de Force Compile optie in je BO (Preferences-->Performance) tijdelijk aanzetten. Anders worden de aanpassingen niet direct overgenomen in je frontend.

Share this post


Link to post
Share on other sites

Super! That did the trick!

Nu moet ik alleen nog eventjes kijken hoe het komt dat mijn NL vertaling niet zichtbaar is.....

 

Maar hij is solved!

 

:)

Share this post


Link to post
Share on other sites

Ik had het over de = submit = zoeken(go) , maar gaat hier dus om input veld !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More