Jump to content

Creating a new account, address country drop down is empty causing error message

Recommended Posts


When testing out the site and checking the sign up for an account form works, we found that the drop down menu under country when entering an address is blank. There are no options showing at all.

As a country can not be selected and the form is submitted, it displays an error message



There is 1 error :

  1. country ID is required.

We have checked some of the settings on country and the shop is set up to post to the UK only, however we can not work out how to populate the drop down menu to allow the form to submit.


Would be greatful for any advice.




Link to comment
Share on other sites

Hi Mike

Apologies for the delay, I didnt spot the reply until now. I have checked my settings against the snapshot you provided and all the settings match. I can confirm that it does state country:name in the address format.

We have only UK checked for the shop, so all other countries have been disabled.

Is there anything else you think may be worth a try?

thanks lots

Link to comment
Share on other sites

Hi Mike,


I have tried the editing the defines.inc.php and changed the ps dev mode to true but this has not worked. I dont really understandd the other bit about the table. Is there a guide to this at all?






Unfortunately, I don't believe we have a guide for that. You may want to consider posting directly on that thread for more information, as those users are still very active on the PrestaShop forums.



Link to comment
Share on other sites

  • 4 months later...

I've got a similar issue... I have just updated to 1.4.9 from 1.4.6.. Everything works ok at the initial registration but for some reason the 'Country' drop-down for both delivery and business does not work?!


I have replaced the table 'ps_address_format' but still an issue...?!

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 years later...

Hi friends,

   While users try to create an account there is an error code "There is 1 error 1.optin is required." that get them stuck and i have tried all areas to troubleshoot and it seems effortless.


Kindly help

Link to comment
Share on other sites

  • Create New...