Jump to content

[Résolu] Installation qui bloque à l’étape 3


Recommended Posts

Bonjour,

 

Suite à une mise à jour désastreuse, je tente une installation neuve de votre script mais je n'y arrive pas  :-

 

Sous IE7 il y a une erreur dans la barre des tâches (java ou active x) dès que l'on arrive à l'étape 3

 

Line:117
Char:3
Code:0
Error:Impossible d'activer le contrôle car celui-ci est, soit invisible, soit inactif, soit d'un type ne reconnaissant pas cette fonctionnalité.
URL:http://www.domaine.tld/boutique3/install/

 

le bouton suivant ne fonctionne pas et impossible d'aller plus loin.

 

Merci de votre aide

 

Henry

Share this post


Link to post
Share on other sites

Henry58 je te fais une réponse insatisfaisante mais tu peux faire ton installation en attendant avec FireFox ou Opéra et ainsi continuer a tester d'autres parties.

 

A+

Share this post


Link to post
Share on other sites

Quand tu as renseigné les parametres de ta base sql as-tu fait le test,  etait-il ok ?

pour ce qui de l'erreur sous IE7 il te faut desactiver le debugger dans les options avancées d'Internet Explorer 7.0

et normarlement ça passe

 

Share this post


Link to post
Share on other sites

Henry58 ce que tu peux faire et qui feras gagner du temps au dev c'est de passer toi même chacune des requètes à la main. Tu le fais avec PhpMyAdmin chaque requete est séparé par un ; la première est donc :

CREATE TABLE shop_lang ( id_lang INTEGER UNSIGNED NOT NULL AUTO_INCREMENT, name VARCHAR(32) NOT NULL, active TINYINT UNSIGNED NOT NULL DEFAULT 0, iso_code CHAR(2) NOT NULL, PRIMARY KEY(id_lang), INDEX lang_iso_code(iso_code) ) DEFAULT CHARSET=utf8;

 

Et ainsi de suite.

Share this post


Link to post
Share on other sites

Oui, merci  ;D 72 requètes à la main et je vais péter un cable LOL

J'ai déjà passé toute l'après midi avec l'install qui ne fonctionne pas, c'est plus une tête que j'ai  >:(

Share this post


Link to post
Share on other sites

Bonjour Henry,

 

Pourriez-vous me donner plus de détails sur :


  • [li]votre hébergeur (serveur local, 1and1, ovh, autre ?)[/li]
    [li]votre serveur (Apache1? 2? autre?)[/li]
    [li]votre version de php (4? 5?)[/li]
    [li]le sytème d'exploitation de votre serveur (windows, linux, mac...)[/li]

 

Il serait interressant d'executer le script ci-dessous et de me retourner la reponse affichée (les 50 premières lignes suffiront...) lors de son l'execution.

Notez que ce script n'installera rien sur votre serveur. Il permet simplement d'avoir plus de détails techniques.

N'oubliez pas également de le supprimer une fois executé.

 

NOM : test.php

EMPLACEMENT : [MY_SHOP]/ (racine de votre boutique)

CONTENU :

<pre>
<?php
error_reporting(E_ALL | E_STRICT);
$structureFile = dirname(__FILE__)."/install/sql/db.sql";
if(!file_exists($structureFile))
die('introuvable'."n");
$db_structure_settings ="";
if ( !$db_structure_settings .= file_get_contents($structureFile) )
die('erreur à l'ouverture'."n");

$db_structure_settings = explode(";".chr(13),$db_structure_settings);
foreach($db_structure_settings as &$query){
$query = trim($query);
$query .= ");";
}
print_r($db_structure_settings);
?>
</pre>

 

Merci de votre contribution,

 

A très bientôt.

Share this post


Link to post
Share on other sites

Bonjour, Lucas

 


  • [li]Hébergeur: OVH mutualisé 60gp[/li]
    [li]Serveur: Apache/1.3.39 (Unix)[/li]
    [li]Version php: 5.2.4[/li]
    [li]OS du serveur: Linux[/li]

 

Résultats du test avec le fichier test.php à la racine: en pièce jointe

 

EDIT  ---------- PS: avant de faire le test j'ai retiré les lignes concernant la réécriture d'url dans le .htaccess car il semble que ça pose des problèmes chez cet hébergeur.

 

Je retente une intall neuve en fin d'après-midi car là pas trop le temps

 

@+  ;)---------

test.txt

Share this post


Link to post
Share on other sites

Rebonjour,

 

Je n'ai pas actuellement la possibilité de tester l'application sur un serveur OVH, Pouvez vous m'afficher le retour du script en ayant préalablement remplacé son contenu par :

 

<pre>
<?php
error_reporting(E_ALL | E_STRICT);
$structureFile = dirname(__FILE__)."/install-dev/sql/db.sql";
if(!file_exists($structureFile))
die('introuvable'."n");
$db_structure_settings ="";
if ( !$db_structure_settings .= file_get_contents($structureFile) )
die('erreur à l'ouverture'."n");
$db_structure_settings =  nl2br($db_structure_settings);
$db_structure_settings = explode(";<br/>",$db_structure_settings);

foreach($db_structure_settings as &$query){
$query = trim($query);
$query = str_replace("<br />", "", $query);
}
print_r($db_structure_settings);
?>
</pre>

 

merci d'avance.

Share this post


Link to post
Share on other sites

Mes Conclusions:

 

Installation neuve de la 0.9 -------> impossible chez OVH (60gp)

 

Installation neuve de la 0.8.5.1 + mise à jour vers 0.9 par l'installeur ------> OK

 

 

Ne pas utiliser la réécriture d'url chez cet hébergeur ça pose des problèmes

Share this post


Link to post
Share on other sites

Le problème est résolu  :D

 

Un grand merci à Thibaud Samson pour son aide  ;)

 

Je pense qu'un correctif ou un patch sera en ligne bientôt, sinon avec son autorisation je peux mettre ici en pièce jointe les 2 fichiers modifiés

 

@+

Share this post


Link to post
Share on other sites

Je pense qu'un correctif ou un patch sera en ligne bientôt, sinon avec son autorisation je peux mettre ici en pièce jointe les 2 fichiers modifiés

bonjour,

j'ai moi aussi ce problème de BDD ; vous m'aideriez beaucoup en partgageant cette solution en attendant la version 0.9.1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More