Jump to content

[SOLVED] Manual Language Translation not working any ideas?


MathewB
 Share

Recommended Posts

Hi,

 

Iam trying to change the language of the paypal module which I believe should be no problem.

 

I have gone into the back office – tools - translations - Modify translations – Module Translations (drop down box) – then select the flag for the appropriate language you wish to change.

 

I make the changes but they don’t seem to stay even after being told they have been changed.

I should point out I have only tried to change a couple of lines just to test it.

 

It must be a really simple thing Iam missing can anyone help?

Share this post


Link to post
Share on other sites

Hi Mike,

 

Yep tried that.

 

Whats interesting is when I go back to look at my changes they are no there?

 

Very Odd

 

Have you checked the permissions of your /translations directory over FTP? If you don't have the proper permissions, you won't be able to implement your changes.

 

-Mike

Share this post


Link to post
Share on other sites

Iam guess I do as I can add products.

 

However how do I make sure?

 

Permissions can differ in different areas of your site.

 

You can check it over FTP by right-clicking on your /translations directory and selecting "File permissions."

 

-Mike

Share this post


Link to post
Share on other sites

Ok

 

755

 

Owner Permission

Read (ok)

Write (ok)

Execute (ok)

 

Group Permissions

Read (ok)

Write (NO)

Execute (ok)

 

Public Permissions

Read (ok)

Write (NO)

Execute (ok)

 

Should this be ok?

Share this post


Link to post
Share on other sites

Ok

 

755

 

Owner Permission

Read (ok)

Write (ok)

Execute (ok)

 

Group Permissions

Read (ok)

Write (NO)

Execute (ok)

 

Public Permissions

Read (ok)

Write (NO)

Execute (ok)

 

Should this be ok?

 

Are those permissions recursive into subdirectories?

 

-Mike

Share this post


Link to post
Share on other sites

Gave it a try just went to try translating and got the following

 

 

Total expressions : 1538. Click the fieldset title to expand or close the fieldset..

 

Warning, your hosting provider limits the maximum number of fields to post in a form:

1000 for max_input_vars

Please ask your hosting provider to increase the suhosin post and request limit to 1638 at least. or edit the translation file manually.

 

 

Can I do this?

Share this post


Link to post
Share on other sites

Gave it a try just went to try translating and got the following

 

 

 

 

Can I do this?

 

You'll have to contact your hosting provider and request what is listed in that message, as you will otherwise be unable to save all of your work. Alternatively, you could always do the translations manually in the individual files of that /translations directory.

 

-Mike

Share this post


Link to post
Share on other sites

Well I had to add the following to the ini.php folder

 

max_input_vars = 3000

 

suhosin.post.max_vars = 3000

 

suhosin.request.max_vars = 3000

 

 

But it now works - Only 1 small problem once you make a change if you want to remove it you HAVE to put something in its place. (the translation that is)

Edited by MathewB (see edit history)

Share this post


Link to post
Share on other sites

  • 4 weeks later...

I'm on a dedicated server running on apache and running PHP version 5.3.10. I had to up the max_input_vars to around 3000, and at first, it saved some modifications I made. But then it stopped working completely. The translation page shows up, the fields are there, i can make modifications, but even if i click update and get a message saying it was successful, when I look back to make sure everything was saved, the modifications have not been applied.

 

The server is NOT using suhosin. I tried all the above mentioned fixes, with no success (including setting proper permissions to the /translations folder and its subfolders)

 

Most of the translation had successfully been done while I was working on my localhost. Is there any way to either edit the translation manually (if so, detailed step-by-step?) or to export the translation to my localhost, translate it there and import it back online?

Share this post


Link to post
Share on other sites

I'm on a dedicated server running on apache and running PHP version 5.3.10. I had to up the max_input_vars to around 3000, and at first, it saved some modifications I made. But then it stopped working completely. The translation page shows up, the fields are there, i can make modifications, but even if i click update and get a message saying it was successful, when I look back to make sure everything was saved, the modifications have not been applied.

 

The server is NOT using suhosin. I tried all the above mentioned fixes, with no success (including setting proper permissions to the /translations folder and its subfolders)

 

Most of the translation had successfully been done while I was working on my localhost. Is there any way to either edit the translation manually (if so, detailed step-by-step?) or to export the translation to my localhost, translate it there and import it back online?

 

Yes, you can manually edit your translations through the files in your site's /translations directory.

 

-Mike

Share this post


Link to post
Share on other sites

So i've read, but these files don't look like they include module translations...?

 

Ah yes, modules can be translated within their individual directories. The various language files will be en.php, es.php, fr.php, etc. You can make the changes in there for each module.

 

-Mike

Share this post


Link to post
Share on other sites

Ah yes, modules can be translated within their individual directories. The various language files will be en.php, es.php, fr.php, etc. You can make the changes in there for each module.

 

-Mike

 

Hi mike,

 

Can you please give an example????

Share this post


Link to post
Share on other sites

  • 2 weeks later...

its greek language pack, and sometimes these character show and at the front. Now i have problem with the name of comments tab and with the name of shipping at the cart (but only at the front page).

Share this post


Link to post
Share on other sites

Hi aimilios,

Per the rules of the PrestaShop forums, please post only one issue per thread.

 

If the strange characters only show up in the source code, that is not a concern, as that is merely the code compensating for a language with different encoding. PrestaShop's encoding is UTF-8, so some languages with their own character sets may not look right in the code of the site itself, although it will still display properly. Can you please post a link to where it looks strange on your Front Office?

 

-Mike

Share this post


Link to post
Share on other sites

Thank you very much Mike for your support, i hope you understand why i can't post my link to the forum and send you pm. If when i finish the site have still problem with this i will post the link so you can help me if you can. Have a nice day

Share this post


Link to post
Share on other sites

Hi aimilios,

I can understand why you do not want to post your link publicly, but you can still discuss your issue here without the link now that I have it. This forum is a community resource for more than 350,000 users around the world, so any thread we can resolve will be a new resource for future users with the same issue. However, in order for that to work, the information on the specific issue (even without a link) must be available for comparison purposes.

 

If you would like to provide some more information here, I will be happy to continue to assist you.

 

-Mike

Share this post


Link to post
Share on other sites

Hi Mike, i found the solution in the Greek forum i try it and it works, and i am pasting it here for everyone who has this problem.

 

The solution is to go at config/smarty.config.inc.php add edit the line 95 ->if (!isset($params['js'])) $params['js'] = 0; and set to 1 ->

if (!isset($params['js'])) $params['js'] = 1;

Now my characters at the page source are show correctly. Do you believe that this solution is correct?

Thanks for your support.

Share this post


Link to post
Share on other sites

  • 1 month later...

Hi,

I have the same problem. Prestashop 1.5 installed onmy localcomputer (localhost) using XMAPP. I tried to make somechanges in translations but iam getting this message

 

Warning, your PHP configuration limits the maximum number of fields to post in a form:

1000 for max_input_vars.

Please ask your hosting provider to increase the this limit to 1255 at least or edit the translation file manually.

 

I copied the three code lines mentioned above and pasted it in ini.php but nothing changed.

 

I am wandering why there is ristriction like that.

Any advice about how to solve it. I want to modify the translations via back office

Share this post


Link to post
Share on other sites

  • 3 years later...

Hello! I try to manually translate my store based on PrestaShop 1.6.1.1. I went in store back office / Localization / Translations / Export a language. I saved the files "ro.gzip" on my desktop to try translate the store's files manually. I realized that the zip archive is twice archived, once in ".gzip" and a second time in an unknown format (Type of file: File). I unzipped this (.File) archive and only then popped up the folders with translations of the store. I translated some of the files but the problem arises when I try to archive the folders again. Could you please help me? What kind of archives is the .file archive and how can I archive the files correctly again to upload them into the site?  Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More