Jump to content
dandav55

Erreur validator w3c donne line + column, je ne comprends pas

Recommended Posts

Bonjour,

 

J'ai 31 erreurs à corriger et ne comprends pas bien les définitions de lignes et surtout de colonnes

 

Je recherche dans mon global css et ne trouve pas d'explications

 

Je voudrais savoir comment trouver ces erreurs dont voici un exemple

 

Je trouve bien la ligne 793 mais ce code n'y est pas, colonne 4 je ne trouve pas

 

Quelqu'un pourrait-il m'éclairer afin que je puisse corriger ses erreurs.

 

error.pngLine 793, Column 4: end tag for element "a" which is not open

</a>

The Validator found an end tag for the above element, but that element is not currently open. This is often caused by a leftover end tag from an element that was removed during editing, or by an implicitly closed element (if you have an error related to an element being used where it is not allowed, this is almost certainly the case). In the latter case this error will disappear as soon as you fix the original problem.

Share this post


Link to post
Share on other sites

Alors:

 

Colonne: 1 caractère sur un ligne. Donc 4e colonne, c'est 4e caractère.

Les indications de localisation (line, column) correspondent au rendu de la page, ou du css, donc en php ça ne correspond pas forcément (1 ligne de php pouvant générer plusieurs lignes rendues)

Share this post


Link to post
Share on other sites
J'ai 31 erreurs à corriger et ne comprends pas bien les définitions de lignes et surtout de colonnes

Actuellement il y a 32 Errors, 1 warning(s). Il y a beaucoup de sites qui ne sont pas valides, mais c'est mieux un site bien fait.

Quelqu'un pourrait-il m'éclairer afin que je puisse corriger ses erreurs.

Ce sont des erreurs de la page d'accueil, donc des lignes de code de la page principale à vérifier et ici ce n'est pas le CSS (c'est un autre validateur pour le CSS).

Line 793, Column 4: end tag for element "a" which is not open

</a>

Par l'exemple, il y a une balise pour fermer un lien, alors qu'il n'y a pas de balise <a> avant. Donc c'est une petite erreur à corriger.

Edited by Madrileño (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Actuellement il y a 32 Errors, 1 warning(s). Il y a beaucoup de sites qui ne sont pas valides, mais c'est mieux un site bien fait.

 

Ce sont des erreurs de la page d'accueil, donc des lignes de code de la page principale à vérifier et ici ce n'est pas le CSS (c'est un autre validateur pour le CSS).

 

Par l'exemple, il y a une balise pour fermer un lien, alors qu'il n'y a pas de balise <a> avant. Donc c'est une petite erreur à corriger.

 

Bonjour Madrileno,

 

Le problème est que je ne trouve pas ces erreurs dans le global css

Je ne sais pas trop quels sont les fichiers concernés

Bonne journée

Share this post


Link to post
Share on other sites

Bonjour,

 

Dans quel fichier effectuer les modifications?

Share this post


Link to post
Share on other sites

Ce sont dans les .tpl du theme.

Pour commencer, il faut editer le code source. POur avoir les numéro de ligne, j'utilise html validator sur firefox. Sinon, tu copies le code source sur notepad++ pour avoir les numéros.

Ainsi, tu pourras savoir plus facilement dans quel tpl il faut corrigé.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More