Jump to content

[SOLVED] PayPal error -- modules page blank!


Recommended Posts

Hi, I've been having an error using paypal, I tried to upload the latest version of the PayPal module 2.8.7 and my entire modules page and payments page in the back office has disappeared!

 

In reading this thread, I see I'm not the only one this has happened to.

 

The error I am getting when trying to make a purchase is:

 

FPDF error: Alpha channel not supported: /home/content/26/9159426/html/shop/img//logo.jpg

 

Then when I hit "back", it says the payment went through.

The url for the shop is: http://urbanxonline.com/shop/

 

Please help! This is the fourth time I'm posting on the forum, and I haven't gotten a response as of yet.

 

Thank you in advance for your time.

 

P.S. this is the thread I was talking about. http://www.prestashop.com/forums/topic/169325-api-paypal-not-working/page__p__829509__hl__paypal%20%7C%20error__fromsearch__1#entry829509

Share this post


Link to post
Share on other sites

done

 

OK I took a look at it, and your memory_limit *should* be enough to not have this sort of issue. Can you please delete the PayPal and paysafecard modules over FTP and let me know if that works any better for you?

 

-Mike

Share this post


Link to post
Share on other sites

Go ahead and use the version of PayPal that you can find here, but leave paysafecard out. We've found that is has caused some users issues, so if you don't use it, there's no need to have it on there.

 

Please let me know if that works for you.

 

-Mike

Share this post


Link to post
Share on other sites

Ack! Downloaded and uploaded from the link you provided, and my Modules and Payments pages are blank again.

 

OK, can you please try deleting a few other modules you don't use (but leave PayPal where it is for the time being), and let me know if that works any better for you?

 

-Mike

Share this post


Link to post
Share on other sites

Ok. I've deleted Moneybookers, Hipay, ebay, and cashondelivery. Same issue with the modules list. I'm not sure what else I should delete...the site is very simple as you can see from my original url, but i dont' want to get rid of Fedex or google checkout, even though I'm not using them at the moment. For now, we only want to use Paypal for payment and UPS and "My carrier - Urban X Shipping (Japan only)" for shipping.

Share this post


Link to post
Share on other sites

Ok. I've deleted Moneybookers, Hipay, ebay, and cashondelivery. Same issue with the modules list. I'm not sure what else I should delete...the site is very simple as you can see from my original url, but i dont' want to get rid of Fedex or google checkout, even though I'm not using them at the moment. For now, we only want to use Paypal for payment and UPS and "My carrier - Urban X Shipping (Japan only)" for shipping.

 

Now can you please temporarily delete PayPal one more time and let me know if the Modules tab comes back? If it is an issue specific to the PayPal module, I will check with a developer to see what we can suggest for you.

 

-Mike

Share this post


Link to post
Share on other sites

Now can you please temporarily delete PayPal one more time and let me know if the Modules tab comes back? If it is an issue specific to the PayPal module, I will check with a developer to see what we can suggest for you.

 

-Mike

Now can you please temporarily delete PayPal one more time and let me know if the Modules tab comes back? If it is an issue specific to the PayPal module, I will check with a developer to see what we can suggest for you.

 

-Mike

 

Yes it is back. Thank you...look forward to your response.

Share this post


Link to post
Share on other sites

Hi evelyn,

Can you please replace your tools/fpdf/fpdf.php file with the version I've attached below?

 

fpdf.php

 

Additionally, my developer recommended that you upload a new copy of your logo, the file appears to have some issues currently so replacing it would be a good preemptive step at this point.

 

I hope this helps.

 

-Mike

Share this post


Link to post
Share on other sites

Hi Mike, doesn't seem to have made any difference :/

 

I replaced that file, reinstalled the PayPal module and again, it has disappeared off of the modules list. In addition, when I try to reach the shopping cart on the front end of the shop, that page is blank as well. Clearly there is an issue with this latest version of the PayPal module. However, I no longer have a copy of the previous version, and i'm afraid the original problem with the error would return if I reverted to the older version.

 

Is there any way I can speak to your developer? Or would your developer like access to the back end of the shop? I have an extremely frustrated client on my hands.

 

Thank you!

Share this post


Link to post
Share on other sites

Hi evelyn,

I've had our developers look into this and confirm that it is not an issue with the module itself, but that doesn't mean we wouldn't like to help you.

 

However, due to PrestaShop policy, we cannot access your site without a signed contract. You are welcome to call our team at 888 947 6543 to discuss this further though.

 

Alternatively, what version of the PayPal module were you using previously? I can try to find that for you to use and attach it here.

 

-Mike

Share this post


Link to post
Share on other sites

Ok. It's confusing because in doing a search, I can see that I'm not the only one this has happened to when installing the latest version of PayPal.

 

I'm not sure what version it was :( It is what came with my version of Prestashop 1.4.7.0

 

Thanks for your help, Mike

Share this post


Link to post
Share on other sites

The module itself has been heavily tested, but sometimes it can be affected by some aspect of the configuration on a specific site, such as a theme, module or even hosting server. I've attached the version of the module that came with v1.4.7. Please let me know if this works any better for you!

 

paypal.zip

 

-Mike

  • Like 1

Share this post


Link to post
Share on other sites

Mike - I had a site today with the exact problem and I uploaded and installed the paypal zip file from your post here on: Posted 25 May 2012 - 01:03 AM and it worked perfectly.

 

It will be interesting to see how evelynpark goes with this as well !!!

Share this post


Link to post
Share on other sites

I had the same issue -

1. deleted the paypal module that came with prestashop 1.4.8 download ---(-to try and solve another problem)

2. installed the latest paypal module from the prestashop add-onns web -- and found all modules 'disappeared' in my admin

3. went back and re-added the paypal module that came with the full prestashop download-- and my modules were all 'back' again

 

so I reckon there are defenitly some coflict withthe paypal module available as a download on the add ons web and the latest prestashop 1.4.8

Share this post


Link to post
Share on other sites

I had the same issue - 1. deleted the paypal module that came with prestashop 1.4.8 download ---(-to try and solve another problem) 2. installed the latest paypal module from the prestashop add-onns web -- and found all modules 'disappeared' in my admin 3. went back and re-added the paypal module that came with the full prestashop download-- and my modules were all 'back' again so I reckon there are defenitly some coflict withthe paypal module available as a download on the add ons web and the latest prestashop 1.4.8

 

Yes, this is something we are aware of and working hard to address!

 

-Mike

Share this post


Link to post
Share on other sites

Thank you Mike.

 

I had the same problem with the Paypal 2.8.7 with PS 1.4.7.3. and this post was really helpful.

Wouldn't it be better to leave the previous version of the Paypal module in the Addons site, at less until the 2.8.7 it's really ok?

Share this post


Link to post
Share on other sites

can u plz mention all the process step by step , how to use paypal as i am new to this and i really dont understand terms like sanbox etc etc.

 

Hi ankit,

If you open the module and click the option to create your account, you should be able to gather the information you need in order to get this up and running properly.

 

-Mike

Share this post


Link to post
Share on other sites

Hi ankit,

If you open the module and click the option to create your account, you should be able to gather the information you need in order to get this up and running properly.

 

-Mike

thx , and why this error saying

L_SHORTMESSAGE0 -> Security error

L_LONGMESSAGE0 -> Security header is not valid

L_SEVERITYCODE0 -> Error

occurs , i have gone thru with the posts and came to know its a API problem , but i have generated API properly as i had also refered the youtube tutorial , process is same.

plz tell me y i facing the above said problem.

Share this post


Link to post
Share on other sites

thx , and why this error saying

L_SHORTMESSAGE0 -> Security error

L_LONGMESSAGE0 -> Security header is not valid

L_SEVERITYCODE0 -> Error

occurs , i have gone thru with the posts and came to know its a API problem , but i have generated API properly as i had also refered the youtube tutorial , process is same.

plz tell me y i facing the above said problem.

 

Hi ankit,

Please try the suggestions posted here and let me know if that resolves your issue.

 

-Mike

Share this post


Link to post
Share on other sites

I had the same issue and corrected it.

Heres how I got it to work correctly.

Go to the Settings tab in the PayPal module page.

Make sure that the first line that says: Sandbox mode (tests): is set to "Inactive"

 

I had mine set to "Active" and thats why I why getting the same message as you did.

Share this post


Link to post
Share on other sites

i had the same problem of evelynpark, solved with the paypal 2.8.6. But please do something for paypal module page download: with the latest PS the latest paypal does not work, and no messages, no older versions...

anyway thanks for all :)

Share this post


Link to post
Share on other sites

Hi Fabio,

Thanks for pointing this out. We are aware of this issue and are looking into it. In the meantime, however, you can always redownload PrestaShop from our homepage, unzip the archive and grab a new copy from there.

 

-Mike

Share this post


Link to post
Share on other sites

In italy we say "i talked too early"... internal server error after choosing paypal for paying, server log says:

 

Premature end of script headers: submit.php, referer: http://www.gruppofogliani.it/officinedellaluce/ordine?step=3

 

can you confirm me that it's another kind of trouble Mike? i read should be problems of permissions and i'm tryng to solve it in this way

Thanks

Fabio

Edited by Fabio D'Addario (see edit history)

Share this post


Link to post
Share on other sites

In italy we say "i talked too early"... internal server error after choosing paypal for paying ( mysite.it/modules/paypal/payment/submit.php ) can you confirm me that it's another kind of trouble Mike? i read should be problems of permissions and i'm tryng to solve it in this way

Thanks

Fabio

 

Hi Fabio,

I apologize, but I'm a little confused. Did my suggestion to Evelyn work for you or not?

 

-Mike

Share this post


Link to post
Share on other sites

Yes it worked for the list of installed modules in the back office, with

v2.8.7 was not working, with

v2.8.6 it works.

 

Anyway after installing v2.8.6 i had also a problem in front office: "internal server error". and log file says

 

Premature end of script headers: submit.php, referer:

http://www.gruppofog...e/ordine?step=3

 

So i was asking you if this front office problem is related to Evelyn's one or it can be a files/folders permissions matter.

 

Thanks a lot, and sorry for my English

:)

Edited by Fabio D'Addario (see edit history)

Share this post


Link to post
Share on other sites

Hi Fabio,

This appears to be an issue with your hosting provider and not PrestaShop, so I would recommend that you contact them for more information. You can also see a previous report on the Forge about this sort of issue here.

 

I hope this helps.

 

-Mike

Share this post


Link to post
Share on other sites

  • 3 months later...

It's incredible: I've downloaded the newest version of paypal's module from prestashop-addons and my shop doesn't work any more. All my products disappear and i'm not able to complete any order.

 

In the other hand the module version attached in the second page of the thread works like a charm.

Thanks Mike.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Hi all,

 

I'm not sure if this can help but I had the same problem with the lastest Paypal module available on the prestashop addon website.

I had a blanc page in "module" selection when I installed it in the module folder on ftp.

 

So this is how i did:

 

1) Delete any Paypal module in the module selection

2) Have a look into your ftp module folder to be sure that there is any Paypal folder left

3) Upload the Paypal module that came with your prestashop version and install it in your back office

4) Uninstall it directly after

5) Install lastest version of Paypall add on.

 

I don't know if it's clear but that's how I made it work in localhost and ftp (paypal 3.2.4).

 

Let me know if it works for you or not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More