Jump to content
shacker

[Modulo] Visible Customization V1.8- Ps 1.3/1.7

Recommended Posts

Tengo un problema con el módulo.

 

Ruego me ayuden.

 

He muesto unos campos de personalización (medida cintura, cuello y puño).

Al guardar sin el módulo acticvado funciona como se espera.

Se guarda y en color gris permanecen los datos introducidos.

 

Activo el módulo y dejo visible la personalización que sale en la parte inferior de la página (sino también pasa lo mismo, pero es para que se vea bien el problema).

 

Al introducir los datos en el módulo (zona lateral derecha) y guardar, no se mantienen los valores ni se guardan.

Si los introduzco en la zona inferior (como si no se usara el módulo), sí se guardan y permanecen en color gris clarito. En este segundo caso se actualizan los datos también en el panel de la derecha. Pero si luego corrijo y guardo desde este panel de la derecha tampoco funciona y salen los introducidos en la parte inferior inicialmente.

Es decir, es como si el modulo solo mostrase los datos pero no permitiese introducir nuevos (desde cero) o cambiar los introducidos desde el lateral (el módulo).

 

Lo que pretendo es poder desactivar el panel inferior y dejar sólo el lateral funcionando correctamente, es decir, que cuando la información se guarde en el lateral (en el módulo), permanezcan los datos y éstos se guarden.

 

No se si me he explicado.

 

He probado con firefox y con chrome.

La versión de mi prestashop es 1.6.0.9

 

Gracias.

 

 

 

Share this post


Link to post
Share on other sites

estoy trabajando en la update, es una incompatibilidad con las ultimas versiones

Share this post


Link to post
Share on other sites

v1.5-solucionado error al añadir a la cesta en ps 1.6 (hay que reinstalar)

Share this post


Link to post
Share on other sites

probando en 1.6.0.11, no consigo ocultar la personalización debajo de la descripción, ¿alguna solución para esto?

aparte agradecer este aporte, la personalización original es una chapuza en el lugar donde esta.

 

Gracias

Un Saludo

 

edito por que encuentro otro problema

después de instalado y funcionando, voy a las traducciones, modifico la traducción "Después de guardar su producto personalizado, no olvide añadirlo a su carrito." y tras guardarlo pasa algo que interfiere y hace funcionar mal otros módulos, entre ellos los módulos de pago redsys y Iupay a los cuales deja de funcionarles la configuracion, y ademas los pedidos pagados con estos módulos dejan de procesarse en la web y no vacían el carro.

no se que es lo que se daña, ya que no tengo ni idea de php, pero no se soluciona quitando y instalando el modulo, lo que sea, queda dañado y me hace instalar mi copia de seguridad.

 

todo esto ocurre tras modificar la traducción, si no modifico la traducción parece que todo funciona correctamente.

he hecho varias pruebas tras reponer la copia de seguridad, y siempre es al modificar y guardar la traducción.

 

si es posible revisar lo que puede ocurrir seria una gran ayuda, ya que con estos dos errores de momento no es utilizable en la versión 1.6.0.11 (es la única en la que lo he probado)

 

Gracias

Edited by kikor1 (see edit history)

Share this post


Link to post
Share on other sites

he instalado el modulo para poder poner la "personalizacion del producto" mas arriba y cuando lo he desinstalado me encuentro la desgracia de que no puedo visualizar ningun producto, es decir, se me queda la web en blanco...alguna solucion?

Share this post


Link to post
Share on other sites

probando en 1.6.0.11, no consigo ocultar la personalización debajo de la descripción, ¿alguna solución para esto?

aparte agradecer este aporte, la personalización original es una chapuza en el lugar donde esta.

 

Gracias

Un Saludo

 

edito por que encuentro otro problema

después de instalado y funcionando, voy a las traducciones, modifico la traducción "Después de guardar su producto personalizado, no olvide añadirlo a su carrito." y tras guardarlo pasa algo que interfiere y hace funcionar mal otros módulos, entre ellos los módulos de pago redsys y Iupay a los cuales deja de funcionarles la configuracion, y ademas los pedidos pagados con estos módulos dejan de procesarse en la web y no vacían el carro.

no se que es lo que se daña, ya que no tengo ni idea de php, pero no se soluciona quitando y instalando el modulo, lo que sea, queda dañado y me hace instalar mi copia de seguridad.

 

todo esto ocurre tras modificar la traducción, si no modifico la traducción parece que todo funciona correctamente.

he hecho varias pruebas tras reponer la copia de seguridad, y siempre es al modificar y guardar la traducción.

 

si es posible revisar lo que puede ocurrir seria una gran ayuda, ya que con estos dos errores de momento no es utilizable en la versión 1.6.0.11 (es la única en la que lo he probado)

 

Gracias

Hola. Aparentemente es problema de las traducciones, no del modulo. Intenta traducir algun otro campo de otro modulo

he instalado el modulo para poder poner la "personalizacion del producto" mas arriba y cuando lo he desinstalado me encuentro la desgracia de que no puedo visualizar ningun producto, es decir, se me queda la web en blanco...alguna solucion?

 

lo has desinstalado o deshabilitado?

 

otra cosa, edita el archivo config/defines.inc.php y pon display errors en true para ver el error

Share this post


Link to post
Share on other sites

Hola,

Hasta ahora el módulo me iba perfectamente,  era justo lo que estaba buscanto!!

Pero he actualizado a la versión 1.6.0.13 y no consigo que funcione,  me da error (error 03).

Tengo actualizado el módulo a la versión v.1.5 . Me dice que tengo que introducir la personalización (y ya lo he hecho). 

Que puedo hacer para que funcione en esta versión.????

Edited by mbantolin (see edit history)

Share this post


Link to post
Share on other sites

Buenas tardes,

 

Escribo porque he instalado el modulo, funciona genial pero me gustaría hacer el mismo cambio que realizó el usuario "el pollo" y que quede debajo del carro de compra pero no he visto en el foro como se ha realizado. Uso la plantilla por defecto de PS 1.6. MI página web es: www.relojeriabulevar.com

 

Gracias de antemano.

Share this post


Link to post
Share on other sites

descarga la ultima version desde nuestro sitio

Buenas tardes:

 

Ya la he vuelta a descargar, y me sigue dando el error,  No era 03  es 01

 

Error 1

  1. Por favor, rellene todos los campos requeridos, a continuación, guardar la personalización.

« Espalda

 

 

Pongo un enlace, de un producto dónde tengo personalización de producto, por si queréis comprobar lo que puede pasar

 

http://www.comprarpintura.biz/es/pintura-fachadas-color/47-revestimiento-liso-color.html

 

Cuando meto los datos en la personalización del producto original de prestashop en la parte de abajo de la página funciona correctamente.

 

La versión que tengo instalada del módulo es la v.1.5, y me la he descargado de vuestra página.

 

Gracias y un saludo

Share this post


Link to post
Share on other sites

Buenas tardes:

 

Ya la he vuelta a descargar, y me sigue dando el error,  No era 03  es 01

 

Error 1

  1. Por favor, rellene todos los campos requeridos, a continuación, guardar la personalización.

« Espalda

 

 

Pongo un enlace, de un producto dónde tengo personalización de producto, por si queréis comprobar lo que puede pasar

 

http://www.comprarpintura.biz/es/pintura-fachadas-color/47-revestimiento-liso-color.html

 

Cuando meto los datos en la personalización del producto original de prestashop en la parte de abajo de la página funciona correctamente.

 

La versión que tengo instalada del módulo es la v.1.5, y me la he descargado de vuestra página.

 

Gracias y un saludo

Forzaste compilacion?

Share this post


Link to post
Share on other sites

Buenas tardes,

 

Escribo porque he instalado el modulo, funciona genial pero me gustaría hacer el mismo cambio que realizó el usuario "el pollo" y que quede debajo del carro de compra pero no he visto en el foro como se ha realizado. Uso la plantilla por defecto de PS 1.6. MI página web es: www.relojeriabulevar.com

 

Gracias de antemano.

desde módulos, posiciones, puedes mover el modulo a extra button product actions, que seria abajo de la cesta

Share this post


Link to post
Share on other sites

Forzaste compilacion?

No, no había vaciado el caché.   Gracias !!,

Ya no me da ese error, pero ahora me manda directamente al carrito de compra con el producto seleccionado, y no me pone los datos que introduzco en el campo de personalización del producto.

 

La primer imagen corresponde al módulo (no sale nada)

 

 

 

pintura-plastica-tintometria.jpg

Pintura DECORATIVA Gama Alta (TINTOMETRÍA)

SKU : TintometríaLITROS : 0.750 L, Acabado : Mate, Color : COLORES PASTEL CARTA NCS 7,74 €-20%9,68 € 1 7,74 €

 

 

La SEGUNA imagen corresponde cuando introduzco el dato en el campo del final de la página (original), no en el módulo DATO INTRODUCIDO PRUEBA

 

 

  • Introduce AQUÍ, la referencia del COLOR DESEADO de la CARTA DE COLORES RAL ó NCS. ( Si quieres descargar las CARTAS DE COLORES, puedes hacerlo al final de la página.) : prueba

 
 
pintura-plastica-tintometria.jpg

Pintura DECORATIVA Gama Alta (TINTOMETRÍA)

SKU : TintometríaLITROS : 0.750 L, Acabado : Mate, Color : COLORES PASTEL CARTA NCS 7,74 €-20%9,68 €
 
7,74 €  
Muchas gracias por vuestra ayuda

Share this post


Link to post
Share on other sites

si, que version de presta tienes?

Versión de PrestaShop 1.6.0.13

 

Has encontrado el error?  Qué tengo que hacer para que funcione bien??

Muchas gracias

Edited by mbantolin (see edit history)

Share this post


Link to post
Share on other sites

Versión de PrestaShop 1.6.0.13

 

Has encontrado el error?  Qué tengo que hacer para que funcione bien??

Muchas gracias

Hola buenos días:

 

Habéis probado el módulo con la versión 1.6.0.13 ??  es por ver si el problema es mio, o es que no es compatible con esa versión.

 

De momento tengo el módulo des-instalado, pero estoy esperando que funcione para instalarlo de nuevo, porque es justamente lo que estoy buscando

 

A la espera de vuestras noticias, un saludo

Share this post


Link to post
Share on other sites

Lo hemos probado y funciona.  puedes mandarme un pm con acceso a la tienda y lo miro

Share this post


Link to post
Share on other sites

Hola buenos días,

 

Lo he instalado y es de gran ayuda, muchísimas gracias. Sin embargo, la instalación que he descargado de vuestro sitio está en inglés y no tiene cómo configurarlo en otros idiomas. Por favor, podrían decirme cómo solucionarlo. Gracias de antemano. Un saludo.

Share this post


Link to post
Share on other sites

viene traducido a todos los idiomas. que idiomas tienes instalado?

Share this post


Link to post
Share on other sites

Hola, gracias por responder. Tengo instalado español. Un saludo.

Share this post


Link to post
Share on other sites

ok, es raro, fijate si desde herramientas, traducciones, traducciones de los modulos esta todo traducido del modulo visible customization, para el theme por default y el  que usas

Share this post


Link to post
Share on other sites

Hola, acabo de revisar y está traducido tanto en el tema por defecto como el que utilizo.

Share this post


Link to post
Share on other sites

Creo que lo he solucionado. En las traducciones hay dos módulos de esta instalación, uno es "customize" y el otro "customize2" y este último era el que no estaba traducido. Muchas gracias por tu ayuda.

Share this post


Link to post
Share on other sites

Acabo de instalar el modulo 1.5.1 y funciona correctamente. Lo tengo correctamente colocado en el hook deseado pero... no me guarda los valores introducidos a la hora de pulsar guardar, y por lo tanto en el resumen de compra no aparece los campos personalizados. Os dejo el link del producto prueba. Un saludo.

 

http://sportmatch.es/futbol/529-725247-017.html

 

Y otra cosa, tengo un servidor compartido y no puedo editar el fichero php.ini para poder llegar a las traducciones de los modulos, sabeis como traducir este modulo manualmente ya que como podeis ver en el link me sigue apareciendo en ingles.

 

Gracias.

Edited by EvilEyes (see edit history)

Share this post


Link to post
Share on other sites

bajaste la ultima version desde nuestro sitio? las traducciones son desde el es.php en el modulo

Share this post


Link to post
Share on other sites

El tema traducciones ya lo he solucionado, si entras en el link lo podrás observar. Lo que intento es que el "Guardar" de vuestro módulo, actue exactamente igual que el original.

Guardando esos valores y apareciendo en el carrito. Estoy revisando el customize2.tpl y el product.tpl y los formularios son exactos y el submit aparentemente apunta al mismo lado. Pero no me funciona.

 

Si utilizamos vuestro modulo al pulsar Guardar se va directamente el producto al carrito pasando olimpicamente de la personalizacion.

 

Gracias.

Share this post


Link to post
Share on other sites

En vuestro sitio se encuentra la version antigua 1.0. Sigo con el mismo problema. No guarda los cambios... el boton guardar actua como "agregar a carrito".

Nadie sabe nada???

Share this post


Link to post
Share on other sites

ahi subi la ultima

fijate si no tienes errores javascript en la consola de chrome

Share this post


Link to post
Share on other sites

He visto que vuestro modulo utiliza el modulo utiliza el mismo product.js y de hecho entra correctamente en la funcion Savecustomizacion pero debe haber algo luego que desconozco que salta directamente al carrito sin guardar las personalizaciones, y no tengo ningun error java en la pagina.

 

http://sportmatch.es/index.php?id_product=529&controller=product

Share this post


Link to post
Share on other sites

Ok esta parte ya esta solucionada, descargando de nuevo el modulo de vuestro sitio. Gracias.

 

A todos os sale 2 veces el apartado de Personalizacion?????

 

Ahora otra cuestion... hay forma de que esas personalizaciones tengan precio???? y se incremente al producto????

Edited by EvilEyes (see edit history)

Share this post


Link to post
Share on other sites

He instalado el modulo 1.5.1 y funciona bien, se añade la información al carrito y el idioma está correcto. Mi prestashop es 1.5.3.1, sin embargo he visto varios problemas:

 

1.- Con el módulo instalado al producto añadido al carrito le desaparece la "X" para eliminar el producto del carrito.

2.- Ni rastro del módulo en el producto si entras con la versión móvil (esto también pasa con personalización de producto que trae prestashop, no sale en la versión móvil)

3.- Al desinstalar el módulo no funciona la personalización de producto que trae prestashop. (he tenido que restaurar un backup despues de probar varias cosas para que vuelva ha funcionar).

 

Un saludo :)

Share this post


Link to post
Share on other sites

Ok esta parte ya esta solucionada, descargando de nuevo el modulo de vuestro sitio. Gracias.

 

A todos os sale 2 veces el apartado de Personalizacion?????

 

Ahora otra cuestion... hay forma de que esas personalizaciones tengan precio???? y se incremente al producto????

con este modulo no

Share this post


Link to post
Share on other sites

He instalado el modulo 1.5.1 y funciona bien, se añade la información al carrito y el idioma está correcto. Mi prestashop es 1.5.3.1, sin embargo he visto varios problemas:

 

1.- Con el módulo instalado al producto añadido al carrito le desaparece la "X" para eliminar el producto del carrito.

2.- Ni rastro del módulo en el producto si entras con la versión móvil (esto también pasa con personalización de producto que trae prestashop, no sale en la versión móvil)

3.- Al desinstalar el módulo no funciona la personalización de producto que trae prestashop. (he tenido que restaurar un backup despues de probar varias cosas para que vuelva ha funcionar).

 

Un saludo :)

1- en que parte desaparece?

2-eso ya es de prestashop

3-recuerda limpiar la cache despues de desinstalar

Share this post


Link to post
Share on other sites

1- en que parte desaparece?

2-eso ya es de prestashop

3-recuerda limpiar la cache despues de desinstalar

1-Aquí, al desplegar el carrito no salía esa X para eliminar los productos del carro de compra.

12039327_10204905667986349_7985832804144

 

2 - Ok, intentaré crear un hilo en "bugs" para ver si solucionan lo de personalización de producto para la versión móvil. Aunque era preferible que se pudiera crear un atributo sobre el que se pudiera escribir, además de configurarlos con valores predeterminados, para que salga con el resto de atributos (color, talla, nombre[campo para escribir el nombre]), en vez de tenerlo a parte con "personalización de producto".

 

3 - Lo que hice fué poner la tienda en modo mantenimiento, luego en rendimiento, activar forzar compilación y desactivar la caché, desactivé el módulo no hizo ningun cambio, luego probé a desinstalar, y tampoco hizo ningún cambio al guardar. Finalmente opté por el backup y todo volvio a su sitio.

 

Saludos.

 

P.D.: Prestashop 1.5.3.1, tema default, url:www.menudapercha.com

Share this post


Link to post
Share on other sites

Buenas, soy nuevo en esto, acabo de instalar el modulo, y como hago para empezar a usarlo, por favor si me podrian ayudar.

Share this post


Link to post
Share on other sites

Hola Agru,

 

Para la personalización de un producto en prestashop debes ir desde tu back office a Catálogo/productos/ seleccionas el producto de la lista que quieres personalizar y entras en su ficha. Dentro de la ficha del producto a la izquierda tienes una serie de pestañas (Información, precio, SEO, Asociaciones...), casi al final hay una que pone personalización. Vas a esa pestaña y añades, por ejemplo, un campo de texto rellenando la casilla con un 1, después te aparecerá debajo el campo para poner el nombre con el que aparecerá en el producto de tu tienda.

 

Con el módulo "Visible customization" supongo que tendrías que ir desde tu back office a Módulos/módulos/buscar el módulo (ya que has dicho que ya lo instalaste). Arriba a la izquierda tendrás un recuadro en blanco, escribe en él "customize" y pincha en buscar, te aparecerá el módulo en la lista de módulos, y ahí verás si esta instalado y activado. Por último si en la parte inferior del módulo que te apareció pone la palabra "configurar" pincha ahí y entrarás a la pantalla de configuración del módulo.

 

Notas:

1.- Recuerda tener siempre un backup de tu tienda antes de instalar y/o modificar algún archivo

2.- Si miras mis últimas respuestas en este hilo verás que me dio problemas este módulo (Prestashop 1.5.3.1, tema default), y no conseguí solucionarlo, ni limpiando la caché, ni realizando una restauración con backup.

3.- El módulo me funcionó bien Shacker, a excepción de que en el carrito una vez añadido el producto con personalización, a ese producto no le aparece la opción de eliminar el producto de la cesta (la "x"), que en cambio a otros productos sin la personalización si que les aparecía, antes de instalar este módulo si salía con el de prestashop por defecto, con este módulo dejo de salir (sólo en el producto con personalización), después de desinstalar tampoco me sale (sólo en el producto con personalización) en el resto de productos si sale la "x".

 

Espero haberte sido de ayuda. :)

 

Un saludo

Edited by Javierlpz (see edit history)

Share this post


Link to post
Share on other sites

el modulo solo cambia de lugar los campos, no hace ninguna otra cosa. Cualquier funcion adicional es de prestashop

Share this post


Link to post
Share on other sites

Hola Shacker, yo sólo explico lo que me ha pasado a mí en mi versión prestashop (v 1.5.3.1, tema Default). No se de programación, por lo tanto no puedo arreglarlo (ni el módulo, ni Prestashop cualquiera que haya sido el problema), ni puedo asegurar ni rebatirte que sea de prestashop o del módulo. Abrí un hilo para solucionar el problema de que no aparezca la "x" de eliminar el producto en el carrito. Si alguien sabe como solucionarlo no dudaré en pasar por aquí y dejar constancia de como se soluciona. Espero que no te haya molestado ninguna de mis respuestas en este hilo.

 

Un saludo

Share this post


Link to post
Share on other sites

Buenas tardes,

 

He instalado el módulo y me sale dos veces en la ficha de producto: justo debajo de la descripción del producto y en la columna derecha.
¿Cómo podría eliminar una de las dos cajas?

Gracias.

Share this post


Link to post
Share on other sites

debes deshabilitarla desde la configuracion del modulo o por css la parte de abajo

Share this post


Link to post
Share on other sites

Buenas tardes,

 

He instalado el módulo y me sale dos veces en la ficha de producto: justo debajo de la descripción del producto y en la columna derecha.

¿Cómo podría eliminar una de las dos cajas?

 

Gracias.

 

 

Me pasa igual, me sale duplicado o no me sale.

 

Quiero colocarlo en displayproductbuttoms, pero no sale si activo sòlo ese hook, tengo que activar el header para que salga en cualquier sitio

 

Y si activo a la vez el header entonces si me sale ahi, pero duplicado, osea donde lo quiero y a la derecha

 

Llevo toda la tarde tocando cosas, pero a bulto y no consigo nada.

A ver si podeis ayudarme, me he bajado la ultima version

 

Muchas gracias de todas formas

Share this post


Link to post
Share on other sites

Lo tengo  en header y en el displatproductbuttoms , si lo pongo en mas sale mas veces, pero asi sale dos

Share this post


Link to post
Share on other sites

el que te aparece abajo de todo es el normal de prestashop, ese lo deshabilitas desde el modulo o por css editando el product.tpl

Share this post


Link to post
Share on other sites

Hola Tito58,

 

No sería demasiado complicado el moverlo donde quieras. Ten en cuenta que lo que tienes que mover es el hook en cuestión, es decir la línea "{if $HOOK_EXTRA_LEFT}{$HOOK_EXTRA_LEFT}{/if}". Si quieres que el módulo que se engancha aquí quede bajo de las opciones de imprimir y ampliar, deberías cambiar el código tal que así:

 

<ul id="usefull_link_block">

<li><a href="javascript:print();">{l s='Print'}</a><br class="clear" /></li>

{if $have_image && !$jqZoomEnabled}

<li><span id="view_full_size" class="span_link">{l s='View full size'}</span></li>

{/if}

{if $HOOK_EXTRA_LEFT}{$HOOK_EXTRA_LEFT}{/if}

</ul>

 

Prueba así a ver si te funciona como quieres.

Hola me puedes ayudar por favor tengo prestashop 1.6 y las categorias no me cargan. No soy experta ya borre la cache pero nada

Share this post


Link to post
Share on other sites

Hola. Utiliza un nuevo post para orto tema.  Si no te cargan puede que las hayas creado y restringido para un grup ode usuarios, o sea la cache desde preferencias

Share this post


Link to post
Share on other sites

solo debes instalarlo añadiendo el modulo. Y aparecera en donde tengas campos personalizados. Puedes ver el video demo dentro del modulo

Share this post


Link to post
Share on other sites

Hola, tienes toda la razón, acabo de completa la instalación, ahora tengo un problema, tengo la personalización visible, pero tengo también la pestaña debajo, tengo activada la opción para que se oculte la pestaña, adjunto unas capturas de pantalla.... como lo puedo solucionar

 

gracias

 

Captura%20de%20pantalla%202016-03-08%20aCaptura%20de%20pantalla%202016-03-08%20a

Share this post


Link to post
Share on other sites

debes configurar el modulo con la pocision n ose cual sera en tu theme, es cuestion de probar

Share this post


Link to post
Share on other sites

Tengo este tema Ap Furniture Prestashop theme la versión de paga... la configuración del módulo lo debo hacer por código o desde el back office? como se llama el módulo (o cambia el nombre dependiendo del tema). otro problema que pasa es que ahora debo registrar los campos obligatorios en los dos sitios si no lo hago me bota error

 

Como puedes darte cuenta no conozco mucho al Prestashop

 

Gracias

Edited by DavoMora (see edit history)

Share this post


Link to post
Share on other sites

dsde el back office, solo debes poner en que seccion esta la configuracion personalizada para poder ocultarla, si no sabes puedes ir probando numeros

Share this post


Link to post
Share on other sites

Hola!!!  no puedo solucionar un problema a ver si alguien por favor me puede ayudar

 

sobre personalizacion de productos de forma manual no tengo problemas

pero quiero activar la personalizacion de productos en mas de 2000 articulos asi que necesito hacerlo en forma masiva mediante archivo csv,

 

ahora el problema es que si lo hago de esta manera el area de texto no me aparece.

por ejemplo en este articulo sin imagen que dejare ahi para que lo vean 

 

http://lenceriapatagonia.com.ar/presta/index.php?id_product=1685&controller=product&search_query=854&results=6

 

no encuento la forma de que aparezca en forma automatica, si entro al articulo y hago click en guardar los cambios personalizados aparece el textarea pero no puedo hacerlo en los 2000 articulos

 

gracias

Share this post


Link to post
Share on other sites

gracias por la respuesta, me dices que seguramente no estoy cargando todas? para que se guarden bien los campos "personalizable" y "campo de texto" hay que cargar todos las tablas??

te consulto porque yo subo lo que necesito por ejemplo en este caso seria.

referencia, precio (si necesito actualizar) , personanizable y campo de texto que estos dos irian en 1.

 

ahora encontre en interter algunas sugerencias para ponerle nombres a estas areas de texto personalizadas, pero no me funciono ninguna.

por ejemplo aca, https://www.prestashop.com/forums/topic/330164-custom-text-field-as-product-attribut/

Share this post


Link to post
Share on other sites

claro, para que funcione debes añadirl oa varias tablas, y eso es lo que te esta faltando, sino nunca los veras. tambien prueba añadir uno a mano editando el producto y ver si se muestra el resto

Share this post


Link to post
Share on other sites

Buenos días

El modulo lo he instalado y perfecto. Pero a los clientes les produce muchos errores. Sé que no tiene que ver con el modulo pero igual me informais de como limitar el tamaño de las imagenes que quieren subir los clientes, para que sea mas facil de entender. En general intentan subir imagenes muy grandes y falla .

Como se pude ampliar. Un saludo

Share this post


Link to post
Share on other sites

Puedes editar el tpl del modulo e incluir un mensaje, o directamente subir el tamaño permitido desde preferencias, imagenes

Share this post


Link to post
Share on other sites

Buenos días, me gustaría que mis clientes vieran en tiempo real la personalización de sus productos ( tazas, puzzles, carteras, etc... )¿ me podría decir si con este módulo se podría hacer ? ¿ Sabe de algún módulo que lo haga ? Gracias de antemano. 

Share this post


Link to post
Share on other sites

Buenos días,

 

Todo perfecto con la nueva actualización, solo que tuve primero que eliminar el módulo anterior y vaciar caché para que la traducción tuviera efecto. Si suben el nuevo módulo sin quitar el viejo pueden tener algún problema en las traducciones. Por otro lado:

 

¿Cómo puedo hacer que vuelva a aparecer el icono de papelera en el carrito de la compra para quitar un producto? Que ha dejado de aparecer desde que instalé el módulo..tengo prestashop 1.6.0.9. Gracias!!

Share this post


Link to post
Share on other sites

Buenos días,

 

Estoy intentando instalar el módulo de manera manual subiéndolo a la carpeta modules de mi instalación de Prestashop pero no me aparece en la lista de módulos del backend. He comprobado todos los filtros para que estén correctamente. Utilizo Prestashop 1.6.0.14 y he descargado el módulo correspondiente para esta versión, no se a alguien le ha sucedido lo mismo y sabe como solucionarlo. Gracias de antemano :)

Share this post


Link to post
Share on other sites

Hola!

 

tengo instalado el módulo customize v1.6.0, pero cuando lo tengo en la tercera columna (debajo de añadir al carrito) no se guarda la personalización, automáticamente se añade a la cesta sin personalización.

 

En la columna central funciona correctamente. ¿a que puede deberse el error?

 

Mil gracias!

Share this post


Link to post
Share on other sites

Buenos días,

 

Todo perfecto con la nueva actualización, solo que tuve primero que eliminar el módulo anterior y vaciar caché para que la traducción tuviera efecto. Si suben el nuevo módulo sin quitar el viejo pueden tener algún problema en las traducciones. Por otro lado:

 

¿Cómo puedo hacer que vuelva a aparecer el icono de papelera en el carrito de la compra para quitar un producto? Que ha dejado de aparecer desde que instalé el módulo..tengo prestashop 1.6.0.9. Gracias!!

es es bastante raro. si deshabilitas el modulo vuelve a aparecer?

Buenos días,

 

Estoy intentando instalar el módulo de manera manual subiéndolo a la carpeta modules de mi instalación de Prestashop pero no me aparece en la lista de módulos del backend. He comprobado todos los filtros para que estén correctamente. Utilizo Prestashop 1.6.0.14 y he descargado el módulo correspondiente para esta versión, no se a alguien le ha sucedido lo mismo y sabe como solucionarlo. Gracias de antemano :)

desde el back office no te funciona?

Hola!

 

tengo instalado el módulo customize v1.6.0, pero cuando lo tengo en la tercera columna (debajo de añadir al carrito) no se guarda la personalización, automáticamente se añade a la cesta sin personalización.

 

En la columna central funciona correctamente. ¿a que puede deberse el error?

 

Mil gracias!

es por que el form se pone dentro del carro y envia sin guardar. Debes aplicar la solucion de nemo para que guarde todo sin darle guardar al boton

 

Share this post


Link to post
Share on other sites

jfr4n, on 19 Nov 2016 - 12:25 PM, said:snapback.png




Buenos días,


 


Estoy intentando instalar el módulo de manera manual subiéndolo a la carpeta modules de mi instalación de Prestashop pero no me aparece en la lista de módulos del backend. He comprobado todos los filtros para que estén correctamente. Utilizo Prestashop 1.6.0.14 y he descargado el módulo correspondiente para esta versión, no se a alguien le ha sucedido lo mismo y sabe como solucionarlo. Gracias de antemano  :)




desde el back office no te funciona?


 


Buenos días, gracias por contestar. Subo la carpeta indicada en las instrucciones a la carpeta modules, pero desde el back office no me aparece el módulo con la opción de instalar. Gracias


Share this post


Link to post
Share on other sites

es por que el form se pone dentro del carro y envia sin guardar. Debes aplicar la solucion de nemo para que guarde todo sin darle guardar al boton

 

 

Gracias por tu respuesta shacker, pero no encuentro la solucion de nemo.

Share this post


Link to post
Share on other sites

Tampoco encontré la solución de nemo y me pasa lo mismo que a molmo, no guarda la personalización y pasa directamente a la caja. Desde el tab sí funciona. tengo ps1.6.1.9

Share this post


Link to post
Share on other sites

debes sacarlo del hook de buttons y transplantarlo a otro hook

no está en el hook de buttons, está en Header y displayRightColumnProduct

Share this post


Link to post
Share on other sites

Buenas lo primero de todo darte las gracias por el módulo ya que lo que trae por defecto ps no es muy bueno.

 

Tengo el siguiente problema, para poder mostrar homogéneamente mi producto al cliente estoy intentando colocar tu módulo justo encima del botón "añadir al carrito". El campo de texto que tengo definido es obligatorio, y al darle al boton guardar me sale el mensaje "Error 1 Por favor, rellene todos los campos requeridos, a continuación, guardar la personalización.", osea es como si no cogiera el valor del campo. ¿puedes orientarme a que es debido este problema ?

 

Me da la sensación que tiene algo que ver con el post de molmo y sebadixon. Si es así, ¿no hay forma de colocarlo encima de añadir al carrito? Es que siendo una opción del producto colocarlo debajo, no queda muy intuitivo.

 

Uso ps 1.6.1.7

 

Gracias

Share this post


Link to post
Share on other sites

Buenas lo primero de todo darte las gracias por el módulo ya que lo que trae por defecto ps no es muy bueno.

 

Tengo el siguiente problema, para poder mostrar homogéneamente mi producto al cliente estoy intentando colocar tu módulo justo encima del botón "añadir al carrito". El campo de texto que tengo definido es obligatorio, y al darle al boton guardar me sale el mensaje "Error 1 Por favor, rellene todos los campos requeridos, a continuación, guardar la personalización.", osea es como si no cogiera el valor del campo. ¿puedes orientarme a que es debido este problema ?

 

Me da la sensación que tiene algo que ver con el post de molmo y sebadixon. Si es así, ¿no hay forma de colocarlo encima de añadir al carrito? Es que siendo una opción del producto colocarlo debajo, no queda muy intuitivo.

 

Uso ps 1.6.1.7

 

Gracias

si destildas el campo obligatorio seguro te lleva al carrito sin guardar. Leí que shaker proponía la solución de nemo, que es esta http://nemops.com/save-prestashop-custom-fields-add-to-cart/ intenté seguir el tutorial pero no tuve éxito, no se si me equivoqué en algo o que pero no me dió resultado, muy complejo para mí -.- por ahora lo dejo justo debajo del botón de añadir al carrito pero sin usar el módulo, corté y pegué el código del que viene por defecto.

Edited by sebadixon (see edit history)

Share this post


Link to post
Share on other sites

si destildas el campo obligatorio seguro te lleva al carrito sin guardar. Leí que shaker proponía la solución de nemo, que es esta http://nemops.com/save-prestashop-custom-fields-add-to-cart/ intenté seguir el tutorial pero no tuve éxito, no se si me equivoqué en algo o que pero no me dió resultado, muy complejo para mí -.- por ahora lo dejo justo debajo del botón de añadir al carrito pero sin usar el módulo, corté y pegué el código del que viene por defecto.

 

Efectivamente si quito el check añade al carrito pero sin la personalización. Voy a ver si puedo aplicar esta solución.

 

Os cuento.

 

Gracias

Share this post


Link to post
Share on other sites

Efectivamente si quito el check añade al carrito pero sin la personalización. Voy a ver si puedo aplicar esta solución.

 

Os cuento.

 

Gracias

 

Bueno me cito a mi mismo.....

 

Apuntar que no soy experto programador. He probado la solución que comentas y que el amigo shaker nos alumbró y a mi me ha funcionado (eso creo, he realizado pruebas y de momento todo ha ido bien). Ten en cuenta que solo he realizado la primera parte del tutorial, ya que yo solo tengo campos de tipo texto pero supongo que para los campos de tipo archivo también funcionara.

 

Anoche después de poner mi primer post, segui probando y me di cuenta que poniendo en primer lugar el módulo de shaker (en product.tpl) justo después de "short_description_block" y "Out of stock hook", en parte se soluciona el problema estético pero hace falta seguir guardando antes de añadir al carrito. Como bien decía shaker hay que sacarlo del bloque de compra.

 

Dejo un trozo del codigo por sino he sido claro y pongo en rojo donde colocar HOOK_EXTRA_RIGHT

                        <!-- end short_description_block -->
                         .
                         .
                         .
                         .
                         .
                        <!-- Out of stock hook -->
			<div id="oosHook"{if $product->quantity > 0} style="display: none;"{/if}>
				{$HOOK_PRODUCT_OOS}
			</div>
			{if $PS_STOCK_MANAGEMENT}</div>{/if}
			{if !isset($warehouse_vars.product_right_block) || !$warehouse_vars.product_right_block}
					{$HOOK_EXTRA_RIGHT}
			{/if}
			<!-- buy block -->
			{if ($product->show_price && !isset($restricted_country_mode)) || isset($groups) || $product->reference || (isset($HOOK_PRODUCT_ACTIONS) && $HOOK_PRODUCT_ACTIONS)}
			<!-- add to cart form-->

Gracias

.

Share this post


Link to post
Share on other sites