Jump to content
Sign in to follow this  
cascavalpane

[MODULE] Available Jobs v0.4

Recommended Posts

New version with Admin Tab in BackOffice!

Description:


This module let you to post vacancy jobs on your website.

How to install:


1. Copy the file in correct locations.
2. In BO-> Modules, install “Jobs block new v0.4”

For the admin TAB in BO:
In BO->Tools->Tabs->Add New

Fill the information:
1. Name: Jobs
2. Class: AdminJobs

V0.3 Tested in Prestashop V1.1, And V1.2.0.5
V0.4 Tested in Prestashop V1.2.1

I wait for your feedback.

UPDATE V 0.4 (for Prestashop V1.2.1.x)

- Admin Tab with picture upload and automatic resize;

- Implement the new TinyMCE;

- Small bug in code

UPDATE V 0.3 (for Prestashop V1.1 - 1.2.0.x)

- Small bug in some servers (className = ‘job’; change to className = ‘Job’;)

8961_WA6kbtLYL30DCuLbVAxO_t

8962_0TRHqf7wtQR7veuFMCrp_t

jobs v0.2.zip

jobs v0.3.zip

jobs v0.4.zip

10939_pt23lURvOY4GQjUOYvoH_t

Share this post


Link to post
Share on other sites

What's exactly a job for you ??
It's look like a product without price ?

Share this post


Link to post
Share on other sites

This is the idea: to keep the same colors and shapes for the site but to display other information.

In our company we have a lot of jobs available and we want to post all of them on website.

The main idea is: for my company I need a website not only a web-shop. Presta it’s a goot tool for shop but for other information we need to add features. (Jobs, Physical Stores – Adress – Contact Info-Maps, News, Sevicies, etc)

Share this post


Link to post
Share on other sites

I NEED SPECIAL PERMISSION TO UPLOAD THE ZIP FILE?


No you don't but max is 2000kb. If your file is to big you will need to upload it to your server or some free upload files host so you can share with us :-)

Share this post


Link to post
Share on other sites

I’m about to finish this module with in BO but something is not working.
I can’t save HTML code in TinyMCE box. If I save all the text is saved without HTML code.
If I put the text like in “Description” field, after save I get the text like in Qualification field (see picture)

Can somebody help me?

7294_3R64fyNaONUtnV6VVxj5_t

Share this post


Link to post
Share on other sites

Hi Cascavalpane,

Thanks for the module,

I have just installed your module, but in the back office when I click on the "Jobs" tab I get the message "Tab does not exist"

Any ideas ?

Share this post


Link to post
Share on other sites

Zip file modified!
Sorry, the zip file it was incorrect. It was missing one folder.

To correct copy the files:
“AdminJobs.php” in Admin/Tabs folder
“Job.php” in classes folder

Share this post


Link to post
Share on other sites

Hi,
Thanks for your quick reply,

I am still having problems with your module, (see pic) also in back office under modules it says "Jobs block new v0.1" not “Jobs block new v0.2” as it says in your post ?.


any ideas?

All the best,
Cerberus22

8982_JlXsx2AAUBaCI4Pztmzg_t

Share this post


Link to post
Share on other sites

Zip modified.

I tested in Prestashop V1.1, And V1.2.0.5 and it's working using clean isntall, the zip file and the intruction.

What version are you using?

Share this post


Link to post
Share on other sites

Hello again,
V1.1. clean install, non standard theme, also using tinymce update

I think it might be because I have installed prestashop in a folder (not root), I say this because when I viewed the jobs block content in shop the picture did not show, I had to add ../ to some of the code to make picture show, but I still cannot get it to show the editing block (area) in back office.

Share this post


Link to post
Share on other sites

On my server i have a several folders with different version and is working. All my test environments are not in the root...

Did you put the "AdminJobs.php" in the "admin/tabs" folder? and "Job.php" in "classes" folder?

Share this post


Link to post
Share on other sites

Hi Have just installed module. including the two supplementary files in the correct directories.

Jobs show up fine in front page - Have added tabs, and when clicking on new jobs tab, page displays, but there is no content - no Tiny MCE - just a blank rectangle.

Am I missing something?

HELP!!

Barry

Share this post


Link to post
Share on other sites

Can you try to manual modify the AdminJobs.php file from the Admin../Tabs?

Replace:
$this->className = 'job';

Whith:
$this->className = 'Job';

Share this post


Link to post
Share on other sites

New version on the firs post with administrator tool in BO for Prestashop V1.2.x!

- New AdminTab with picture upload;

- New Administrator tool with the new TinyMCE

Share this post


Link to post
Share on other sites

Hi this was very useful on our site - now testing version 1.4 and find it generates fatal error message:

Fatal error: Uncaught exception 'ReflectionException' with message 'Class JobCore does not exist' in /var/www/vhosts/thermometer.co.uk/httpdocs/testpshop/config/autoload.php:41 Stack trace: #0 /var/www/vhosts/thermometer.co.uk/httpdocs/testpshop/config/autoload.php(41): ReflectionClass->__construct('JobCore') #1 /var/www/vhosts/thermometer.co.uk/httpdocs/testpshop/classes/AdminTab.php(1553): __autoload('Job') #2 /var/www/vhosts/thermometer.co.uk/httpdocs/testpshop/admin999/tabs/AdminJobs.php(60): AdminTabCore->loadObject(true) #3 /var/www/vhosts/thermometer.co.uk/httpdocs/testpshop/classes/AdminTab.php(197): AdminJobs->displayForm() #4 /var/www/vhosts/thermometer.co.uk/httpdocs/testpshop/admin999/index.php(81): AdminTabCore->display() #5 {main} thrown in /var/www/vhosts/thermometer.co.uk/httpdocs/testpshop/config/autoload.php on line 41


Anyone know of a working version in 1.4?
thanks
Baz

Share this post


Link to post
Share on other sites

It’s an old version tested on 1.3.x version. I will restart working on this module for 1.4 version compatible in short period.

Sorry for any inconvenience….

Share this post


Link to post
Share on other sites

Hi! First of all, I would like to thank for this great module. So the thing is, I've installed successfully, and it shows the list in my home page. But I can't find the tab to use to add new entries. I tried to use the configure button in the modules list but it only shows these fields (please see screen shot) and I have no idea how to add my entries.

I have already copied the AdminJobs.php in my admin/tabs folder and Job.php in classes folder so I really am wondering where can I find the fields for adding new entries. Thanks!

42867_hemZxUVbUXrD6fn5hjz1_t

Share this post


Link to post
Share on other sites

Is onyone using this with the latest version of PrestaShop 1.4.0.17?!?!

Share this post


Link to post
Share on other sites

Anyone got a version of this to run on version 1.5 of Prestashop?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More