Jump to content
  • 0

Forum search problems


Patric
 Share

Question

Hi PrestaShop Community,

 

I would like the problems everybody encounters with the search function to be fixed!

 

So I open this topic to list these problems.

 

Anytime you make a search and get a "strange" (not expected) result, please come and describe it here.

 

Next, I will forward this list to the dev team.

 

Thanks.

 

Regards.

Share this post


Link to post
Share on other sites

21 answers to this question

Recommended Posts

  • 0

At the moment the forum search function is a complete mess. When I for example search for "Category multi-edit" I don't even get the post that I wrote with that title on the first page. Even worse: when I restrict the search to the forum where that subject is placed (Free modules, overrides and other tips that change your life) it still isn't on the first page.

 

The problem isn't restricted to double word searches. Single word searches too show many posts that completely irrelevant.

 

In addition the bug that you get an empty second page when you have a search term of more than one word is back too. It is a simple matter of faulty links but I start to doubt whether anyone at PS feels responsible.

 

Nowadays when I need information about some PS issue from the forum I go to Google.

Edited by musicmaster (see edit history)

Share this post


Link to post
Share on other sites

  • 0

hi all

i did also notice several problems with the search options from this forum

many times no result ,but the last few days t is ok again

 

in IE 9 i can open the forum but not read the messages and posts

 

 

For the people who want to search on anything ,,

there is an other option

 

go to google

and type :

 

www.prestashop.com/forums : YOUR SEARCH WORD

 

this will show the topics with the search word

Edited by maconl (see edit history)

Share this post


Link to post
Share on other sites

  • 0

hi Benjamin ,

you're welcome

i did just discovered that the forum also works again in IE9

cause i use firefox and chrome i didn't check it

 

the search option works good again ( at least for me )

i see good results when i use the search option

 

indeed , most time i use google on that way to search here on the forum and give always good results :)

  • Like 1

Share this post


Link to post
Share on other sites

  • 0

Hi

yesterday evening i saw in IE8 the forum doesnt work very well

 

No problems in IE9

Hi maconl,

Thank you for the report. We are aware of that problem.

I will report it again to make sure it will be solved.

But please post in the correct sections. This topic concerns the search problems.

Concerning IE, another one already exists in the PrestaShop.com forum.

 

Share this post


Link to post
Share on other sites

  • 0

Hi maconl,

Thank you for the report. We are aware of that problem.

I will report it again to make sure it will be solved.

But please post in the correct sections. This topic concerns the search problems.

Concerning IE, another one already exists in the PrestaShop.com forum.

 

Hi Patric

Oops indeed , my mistake

 

i can't delete my message inhere so

you or any other moderator may delete this and my other message about IE8

 

next time i will try to read better :)

Coen

Share this post


Link to post
Share on other sites

  • 0

 

 

Hi Patric

Oops indeed , my mistake

 

i can't delete my message inhere so

you or any other moderator may delete this and my other message about IE8

 

next time i will try to read better :)

Coen

 

Not so grave, don't worry. ;)

Share this post


Link to post
Share on other sites

  • 0

Hi,

 

I found that there is a css problem in the display of search results with Firefox :

 

Sometimes, seemingly when certain banners are presents in #addons-banner div, search results div is shifted to the right and appears off screen. (try searching "facebook" for exemple)

 

This happens for me only with firefox (on PC) and adding a css "clear:both" to #ipsBox div solves the issue.

 

Here is à screenshot : (I reduced zoom level to make the shifted div appear)

post-344943-0-85715800-1370130215_thumb.png

Share this post


Link to post
Share on other sites

  • 0

Hi Patric and all developers!

 

May be I'm fool, but it seems search not working as I need. You can see it here:

 

Step 1. I see in russian branch on the first page phrase "списка товаров"

 

0_b0285_b2326e33_XXL.gif

 

 

 

Step 2. I try to find same phrases only in titles (!) in all russian forum

 

0_b0286_81e1eb9_XXL.jpg

 

Step 3/ What is it?

 

 

0_b0287_eae97feb_XXL.jpg

 

For exaple in the fist post in serch results we have no word from asked.

 

Find words: списка товаров

Finded: При регистрации пользователя в "Корзине" не обновляются "Способы оплаты"

 

So I can't find any what I need :-(

 

Browser — Opera 12.14, 1738, Win32, Windows 7

Share this post


Link to post
Share on other sites

  • 0

I like to use Google as well.

 

 

Try this. 

 

When you search for example, "How to Turn on Error Reporting"

 

In Google, type in site:prestashop.com how to turn on error reporting

 

 

when you do site:prestahop.com into Google, it will ONLY search those words WITHIN the prestashop.com ecosystem, (Forge, PrestaShop, Addons)

  • Like 1

Share this post


Link to post
Share on other sites

  • 0

Thank you, Benjamin!
But it's not working :-(
 I use site:prestashop.com/forums/forum/  список товаров
I have got the result - 23 records.

 

But when I try to watch one of them, I do not see the post, but list of posts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More