Jump to content
Sign in to follow this  
Rose Khaki

Ajout CGV et autres, pieds de page, et autres questions de débutantes

Recommended Posts

Voilà 2 jours que je lis les différents sujets de ce forum sans trouver la réponse exacte à mes questions (ou alors que je ne comprends pas les réponses lol)

J'ai donc installé la nouvelle version de prestashop en mode simple (sans les modules prédéfinis).
J'ai eu beau chercher partout, je n'ai pas trouvé les pages CGV ou mentions légales prédéfinies, donc je suppose que cela vient de mon choix pour la version simple (?).

J'ai donc créé ma page CGV via les CMV dans l'onglet outils.
J'ai pu rédiger sans problème mon texte et enregistrer. Sauf que quand je veut ouvrir la page j'ai une erreur 404.

J'ai bien coché l'option url simplifiée
mon fichier .htaccess existait déjà donc je n'ai pas besoin de le renommer (un peu partout on parle de renommer htaccess.txt en .htaccess)

dans les modules>pieds de page : j'ai bien coché les CGV pour qu'elles apparaissent.

Bref, d'où vient le problème ? je précise que je suis chez infomaniak

Autre question pour les pieds de page :
J'ai coché l'option pieds de page et certains liens apparaissent automatiquement dans mon pieds de page (promotions, meilleurs ventes, nouveaux produits) hors je voudrais les supprimer : comment faire ?

Je rajoute une question :
je viens de tester le formulaire "contactez nous" directement en mettant "ma boutique" en ligne et ça ne fonctionne pas il me dit qu'il y a une erreur. que faire ? J'ai cherché sur d'autres discu mais je ne trouve pas.

Share this post


Link to post
Share on other sites

Je me réponds toute seule alors %-P
J'ai décoché url simplifié et mes pages apparaissent hourra !

Par contre quelqu'un pourrait-il m'expliquer ce que ça va changer si je ne peux pas avoir l'option url simplifiée ?
Ce qui est bizarre c'est que normalement infomaniak reconnaît de re-writing... j'y comprends plus rien.

Share this post


Link to post
Share on other sites

hello ninie :)
pour tes erreurs il faut faire attention au certains mot qui donne automatiquement un message d'erreur style union il faut mettre uni0n ( avec un zero) pour que ca passe moi ca m'etais arriver.

Share this post


Link to post
Share on other sites

coucou loly ;-)
Je ne pense pas que pour la page contact l'erreur vienne de l'écriture puisqu'elle est installée d'origine par PS. J'ai vérifié mon mail, il fonctionne correctement.

Share this post


Link to post
Share on other sites

jai pris la version presta simple, la derniere et les CGV tu les trouve dans:
outils CMS ;)
ya toute les mentions legale
c'est bien ca ton probleme?
autant pour moi c'est pas du tout ca ton soucis bon bah j'espere que quelqu'un t'apportera une reponse.
:)

Share this post


Link to post
Share on other sites

non moi je n'avais aucune CGV ni mentions légales, mais comme lors de l'installation j'ai choisi la version sans module préinstallé, je pense que ça vient de là.
Enfin pas grave j'ai trouvé comment les intégrer. d'ailleurs vu mon activité et mon statut j'ai dû faire des CGV vraiment particulières donc je ne pense pas qu'un modèle prédéfini aurait pu me convenir.

Ceci étant, j'ai toujours des problèmes avec :
- formulaire "contactez nous" qui m'indique une erreur
- j'ai voulu simuler une vente pour voir si ça fonctionnait et là aussi, ça plante. Mais bon, je n'ai pas fini d'étudier la question.

Share this post


Link to post
Share on other sites

javais des message d'erreur aussi parce que le SSL etait activé, je l'ai enlever et toutes les simulations de vente fonctionnais ..

Share this post


Link to post
Share on other sites

J'ai réussi à simuler une vente, par contre impossible de lire les CGV durant la passation de la commande, j'ai juste pu cocher la case "j'accepte". Je ferais une recherche demain pour trouver la solution à ce bug.

Personne pour répondre à mes autres questions ?

Share this post


Link to post
Share on other sites

perso, je n'utilise pas l'url rewriting. et ça fonctionne très bien (y compris le référencement / google)
sinon, pour ta page contact, il faudrait savoir quels paramètres tu as entré. et quelle version de PS tu utilises...

Share this post


Link to post
Share on other sites

J'utilise la dernière version 1.1
Sinon j'ai simplement enregistré mon e-mail en "service client" dans le panneau d'administration. J'ai rien fait de particulier.

Concernant l'ouverture de la page cgv lorsque le client cliques sur "lire" avant d'accepter les cgv, je suppose que les cgv ne sont pas trouvées pcq j'ai créé un nouveau doc CMS (puisque les cgv d'origine n'apparaissaient pas dans mon cas), c'est cela ?
si j'ai bien compris cette discu : problème redirection je dois remplacer un identifiant, mais je fais comment exactement ? Pcq moi ce genre de manip, c'est pas mon truc :red:
qui peut me faire un pas à pas spécial nunuche :-P

Share this post


Link to post
Share on other sites
J'utilise la dernière version 1.1
Sinon j'ai simplement enregistré mon e-mail en "service client" dans le panneau d'administration. J'ai rien fait de particulier.
Décidemment, je me répond à moi toute seule :roll: vous me direz, c'est comme ça que l'on apprend.

J'ai trouvé cette discu où une personne avait le même problème que moi avec une boîte de messagerie infomaniak : mail chez infomaniak et j'ai résolu mon problème de la même façon : j'ai rentré mes propres paramètres SMTP et ça fonctionne, hourra !

Reste ma question cgv. Personne pour m'aider ?

Share this post


Link to post
Share on other sites

Bonjour as tu essayé de desactiver l'URL simplifiée dans préferences?

Bon j'ai fait quelques test de mon coté pour répondre à ton probléme, et cela provient bien du fichier .htaccess

Donc tu dois en créer un fichier que tu mettra sur ton serveur .htaccess
pour cela tu prend ton bloc note tu enregistres un fichier vide que tu nome .htaccess tu enleve bien le txt qu'il y a derriere.
Aprés tu met ce fichier à la racine de ton serveur
tu va dans ton back office, à préférences tu va à la ligne Url simplifiée tu clic sur générer un fichier .htaccess puis générer le fichier .htaccess
apparement ton hébergeur infomaniak le gére sans probléme.

apres dans module Footer links block vérifie bien que tes CGV sont cochés dans la configuration.

test et dis moi

Share this post


Link to post
Share on other sites
Bonjour as tu essayé de desactiver l'URL simplifiée dans préferences?

Oui, je l'ai indiqué un peu plus haut : quand je désactive la fonction url simplifiée, mes pages CMS s'ouvrent sans problème.
La procédure que tu me proposes c'est pour pouvoir de nouveau cocher cette option url simplifiée ?

Pcq visiblement j'ai aussi un problème de redirection quand je demande à lire les cgv avant de les accepter lors de la commande. Est-ce que la "réparation" du fichier .htaccess va aussi solutionner ça ?

Share this post


Link to post
Share on other sites

Donc ce que je te propose ca te permet d'afficher normalement tes pages avec l'option URL simplifiée d'activée.

Share this post


Link to post
Share on other sites

ok merci, je regarde ça dès que mes enfants m'en laissent le temps. Je te tiens au courant.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More