Jump to content
blackarma

Admin product edit in FireFox 11.0 tinymce strange behaviour

Recommended Posts

Hey,

 

After last upgrade of FireFox (11.0) prestashop 1.4.7.0 (don't know about other versions) has some issues with tinymce editor in product edit page.

 

When i enter in edit mode for any product Short Description tinymce field is just blank and can't enter anything, tho when i change language and switch it back to original text inside appear and i can edit it just fine.

Also i can edit that tinymce field if i click on html source button.

 

Anyone know if tinymce has to be upgraded or something?

 

I should mention that it only happens to me with short description edit field, but not with long description.

 

I attached jpg file (150KB) to display issue.

 

Any suggestions?

post-319074-0-31357900-1332299782_thumb.jpg

Share this post


Link to post
Share on other sites

same here :-(

It was already reported to PS forge, so we can probably only wait. I checked few other installations and it seems to be issue for all PS versions.

Share this post


Link to post
Share on other sites

Same problem with 1.4.4.1

Thanks for reporting, it was driving me crazy :blink:

Is it posible no go back to older Firefox version after upgrading?

Share this post


Link to post
Share on other sites

Same probleme.. :-(

Firefox 11.0

Prestashop 1.4.7.0

 

But Worked in IE 9.. ..

Share this post


Link to post
Share on other sites

I have the same problem - Prestashop 1.4.6.2 - Firefox 11 - on Mac OSX and Windows 7

 

Short description - locked out - long description - working fine, also no probs with the CMS pages.

 

Everything working fine in Safari and I.E.

Share this post


Link to post
Share on other sites

i've tried upgrading tinymce 3.4.9 but it doesn't work..

 

Can anyone pls kindly help a desperate soul here...

Share this post


Link to post
Share on other sites

Hello,

this bug will be fixed on next PrestaShop 1.4 release soon, it's a TinyMCE problem with Firefox 11, we will update this script.

 

Regards

Share this post


Link to post
Share on other sites

Thank you Raphaël !

Is there any way to fix this without upgrading PrestaShop. I have few clients on other versions (1.2.5, 1.3.7) so upgrading to 1.4.7. would be too complicated way to fix this.

Share this post


Link to post
Share on other sites

I don't know if it will be possible, since I don't know if the version of tinyMCE is the same in 1.4 and in 1.2.5. I will tell you here when the fix is finished if there is an easy way to fix this bug on previous versions.

 

Regards

Share this post


Link to post
Share on other sites

Funciona correctamnete con tinymce 3.4.9 solo tienes que subirlo encima del tinymce que ya tienes instalado. Si borras la carpeta tiny_mce y la sustituyes por la nueva no funciona, tienes que copiar la nueva carpeta tiny_mce en la tiny_mce vieja.

 

Un saludo a todos

Share this post


Link to post
Share on other sites

Hello,

the only way to fix this bug on previous versions, is to upgrade tinyMCE. Get the last version on their website, and replace the content of folder js/tiny_mce in PrestaShop.

 

Regards

Share this post


Link to post
Share on other sites

I would jump at an option to just disable it all together. That would be a nice global feature.

Share this post


Link to post
Share on other sites

I just upgraded to latest TinyMCE one of my installations (PrestaShop 1.3.1.1) and it works OK. Thank you Raphaël!

 

EDIT: i replaced TinyMCE on several other installations and it works OK including latest 1.4.7 version. Make reload the page in Firefox (or delete temp files).

Share this post


Link to post
Share on other sites

reloading page a few times and everything works OK. Thanks Raphael

Share this post


Link to post
Share on other sites

didn't work for me, it's worst. you can see it on the image.

i tried with 3.4.7; 3.4.9; and the latest version. maybe did i forget something, i juste extracted files and copied tiny_mce in js/

 

is there anything else to do?

 

 

post-69317-0-20603000-1334479743_thumb.jpg

 

Edit: it works i just forgot to copie the skin.

Share this post


Link to post
Share on other sites

Hi,

 

Just to let you know that I had the same problem but after updating Firefox to version 12 the issue is solved.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More