Jump to content

[RESOLU]Votre configuration n'est pas valide!


Recommended Posts

Salut,

Après ne pas avoir réussie à résoudre un problème pour mettre en ligne mon site, j'ai décidé de l'installer directement en ligne sauf que maintenant c'est pour l'installation que je rencontre des problème.

Je suis héberger chez infomaniak et ma version de prestashop c'est la 1.4.7.

En faite sa m'affiche sa :

  • Droits en écriture sur les fichiers et dossiers:
  • /config x
  • /tools/smarty/compile x
  • /tools/smarty/cache x
  • /tools/smarty_v2/compile x
  • /tools/smarty_v2/cache x
  • /sitemap.xml x
  • /log x
  • Droits en écriture sur les dossiers (et leurs sous-dossiers) :
  • /img x
  • /mails x
  • /modules x
  • /themes/prestashop/lang x
  • /themes/prestashop/cache x
  • /translations x
  • /upload x
  • /download x

Paramètres optionnels

  • Paramètres PHP (Demandez de l'aide à votre hébergeur si nécessaire) x
  • Ouverture des URL externes autorisée x

Quelqu'un aurait la soluce?

Merci d'avance de bien vouloir m'aider :)

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour

 

Comme c'est écris :

Droits en écriture sur les fichiers et dossiers:

/config x

/tools/smarty/compile x

/tools/smarty/cache x

/tools/smarty_v2/compile x

/tools/smarty_v2/cache x

/sitemap.xml x

/log x

 

Via Filezilla sur votre ftp vous cliquez avec le bouton droit vous avez un menu, en bas Droit d'Accès au fichier vous cliquez dessus et vous avec une autre boite là où est marqué valeur numérique vous mettez 777

 

Pour appliquer aux fichiers et dossiers vous cochez Récursion dans les sous-dossiers puis Appliquer a tous les fichiers et dossiers

 

Pour :

Droits en écriture sur les dossiers (et leurs sous-dossiers) :

/img x

/mails x

/modules x

/themes/prestashop/lang x

/themes/prestashop/cache x

/translations x

/upload x

/download x

 

Pareil qu'avant sauf dans Récursion dans les sous-dossiers puis vous sélectionner Appliquer uniquement aux dossiers (ce qui inclus les sous-dossiers)

 

 

Attention une fois prestashop installer il faut remettre les droits qui était avant donc relever les :)

  • Like 1

Share this post


Link to post
Share on other sites

Oui j'y suis arriver juste après avoir posté merci décidément tu travaille pour prestashop ou quoi ? Tu est drôlement présent pour aider sur le forum :) euh en revanche j'ai zapper de les relever mais je crois que c'était tous 775 sauf un c'était un truc du genre 600 et quelque mais je sais plus lequel c'était

Share this post


Link to post
Share on other sites

Non je ne travaille pas chez et ni pour prestashop.

 

Je suis totalement indépendant, je connais prestashop depuis Mars 2009, j'ai galérer au début jusqu'au jour où ça a fait Tilt, que j'ai compris son fonctionnement. Je suis aussi auto-didacte, donc j’apprends sur le terrain et j'aime partage mes connaissances.

 

Oui pour les dossiers et sous-dossiers c'est en général 755 et 644 pour les fichiers.

Share this post


Link to post
Share on other sites
  • 1 month later...

slt a vous moi c'est pareil je galere j'ai tous en rouge ou presque et je suis chez 1&1

je galere depuis se matin...

je fais clic droit etc...

mais rien filemachintruc m'envoie balader je déprime auriez vous une solution a mon soucis?

merci

Share this post


Link to post
Share on other sites

slt a vous moi c'est pareil je galere j'ai tous en rouge ou presque et je suis chez 1&1

je galere depuis se matin...

je fais clic droit etc...

mais rien filemachintruc m'envoie balader je déprime auriez vous une solution a mon soucis?

merci

 

Bonjour

 

Vous faites clic droit où sur le ftp avec ffilezilla et après vous faites quoi ?

Avez-vous regardé dans la gestion de votre hébergement si vous avec un accès http sur les dossiers, fichiers et un moyen de modifier les droits.

 

Chez certain hébergeur c'est via le gestionnaire d'hébergement :)

Share this post


Link to post
Share on other sites

Bonjour, impossible de retablir les chmod en 755 pour le dossier "compil" et" cache" de smarty pour un site en production sur un serveur OVH... Quelqu'un a-t-il le même problème un une solution ?

 

Merci

 

PS 1.4.7.3

Share this post


Link to post
Share on other sites

Bonjour,

j'ai, il me semblerait, un problème identique..

je suis en train de tenter l'install de prestashop, mais suis stoppé net par le test de compatibilité. En effet, il y a deux petites croix rouges sur la page, sur /sitemap.xml et l'autre sur magic quotes (qui elle ne m'inquiète pas plus que cela, n'étant pas obligatoire manifestement).

Mon problème est que quand je veux changer les droits en utilisant Filezilla (clic droit), cela est impossible. Filezilla me renvoie systématiquement une erreur 550 (could not change perms on sitemap.xml: permission denied). Je suis hébergé chez OVH, avec un serveur type perso...mais recommandé par un livre (editions eni). Je tente de ne rien casser ici avant de réussir, mais ce n'est pas évident :-)

 

Si quelqu'un a une solution...

Merci d'avance (beaucoup)

 

 

Version prestashop: 1.4.8

PC

Share this post


Link to post
Share on other sites

Bonjour Carl,

et merci pour ton intervention.

Pour ma part, je peux modifier les CHMOD sur tous les autres fichiers (a priori, je les ai pas tous testés bien sur...!), mais pas sur le sitemap...je dois donc disposer des droits nécessaires, en toute logique, enfin c est ce que j imagine.

C est mon propre ordi, je suis seul à l'utiliser, sous windows 7...

J'ai passé il y a 5 mn tous les fichiers en 755 depuis la racine, et ai retenté le test mais toujours rien. J aiu alors tenter de repasser le sitemap en 777 mais toujours le meme problème...permission denied.

Je tente de garder mon calme :-) mais ce n est pas évident !!

Merci d avance

Tristan

Share this post


Link to post
Share on other sites

Ah, une nouvelle: je viens d'uploader de nouveau le sitemap, en écrasant l'ancien...et j'arrive à modifier les droits.

Maintenant le nouveau probleme est que ca ne change pas la page compatibilité de prestashop...j'ai fermé la page, quitté filezilla, tout relancé, et je ne passe toujours pas l'étape...la croix rouge reste allumée et ma configuration toujours non valide...

C est déjà un petit pas d'effectué (tout petit).

Share this post


Link to post
Share on other sites

Help !!!

Quelqu'un a-t-il une idée ?

Si mes autorisations sont bonnes (CHMOD 775 ok pour le sitemap.xml), pourquoi je ne passe toujours pas l'étape de validation ???

que faire ?

C est assez décourageant...bien que j'insiste :-)

Merci

Share this post


Link to post
Share on other sites

La nuit portant conseil...

J'ai tout enlevé du serveur et tout réinstallé. Ca fonctionne maintenant.

merci pour ton aide Carl, et..à bientôt j'imagine.

Cette fois c est en effet RESOLU.

Share this post


Link to post
Share on other sites

Bonjour tristi954,

 

Désolé je n'ai pas pu répondre à tes derniers messages. Oui parfois tout enlever et recommencer est ce qu'il y a de plus simple à faire ! :)

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 1 year later...

Bonjour,

 

est-ce que quelqu'un a listé les droits d'accès d'origines et le nom des dossiers concernés ?

 

Je souhaite les repasser, mais bon...j'ai perdu mes notes.

Peut-être un  module ou un truc du genre existe...?

 

Merci de votre aide ;)

cordialement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More