Jump to content

Can't translate my WebShop because suhosin php patch


Recommended Posts

Hello PrestaGurus!

 

I have problems with "suhosin php patch", can not translate modules on my Online WebShop.

 

Already found possible solution for this here in Presta Forum and created mentioded "php.ini" file with needed 2 lines... but in my case problem still remains.

After translating few modules many already translated words came back, reversed in English. :(

 

My next try was to move WebShop from WebHost to virtual server (XAMPP on local PC) and to upload it back after translate.

Here I faced with new problem... now can not use BackOffice because many things are mising and can not press national flag for starting translating Modules.

 

I'm suffering still and can't go even one step further. :(

 

If somebody faced with same problem please provide solution.

post-340302-0-50857700-1332097994_thumb.jpg

Share this post


Link to post
Share on other sites

Solved WebHost "suhosin php" problem by reducing Modules in my Online PrestaShop, now is under 3600 words.

But still won't translate, won't remember words I transated. :(

What can be the main problem???

 

PrestaShop Support Team? Any idea?

Share this post


Link to post
Share on other sites

I hav e the same problem, since my provider migrated to PHP 5.3

 

Warning, your hosting provider is using the suhosin patch for PHP, which limits

the maximum number of fields to post in a form:

1000 for suhosin.post.max_vars.

1000 for suhosin.request.max_vars.

Please ask your hosting provider to increase the suhosin post and request limit to

5371 at least. or edit the translation file manually.

 

My provider tells me they have to keep the limit on 1000 otherwise there would be a security issue with PHP.

 

Can anyone confirm?

 

@ Prestashop support: patch?

Share this post


Link to post
Share on other sites

it is a valid security concern. if they are unwilling to change it, what i would recommend is to install a product like WAMP on your local desktop, and increase the max input vars setting to 6000. then install a copy of your store on your desktop. make your translation changes on your local desktop. once complete, you can just copy your translation files to your live site.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More