Jump to content

Paypal authorization failed with empty error message


Recommended Posts

Hi all,

 

I'm encountering an issue trying to configure Paypal in my testing environment.

 

I've installed Prestashop 1.4.7 with WAMPSERVER installed locally on my computer.

 

I've created a sandbox account in Paypal and have configured the Paypal module with the API parameters I've retrieved form Paypal.

 

In the Paypal order summary form (/paypal/payment/submit.php), after having clicked on "I confirm my command", I receive the following error message:

 

Paypal authorization failed

Please refer to logs:

1. Paypal answer:

2. ->

3. Paypal returned an error

 

I don't have anymore information in the message and the log tab in the back office does not contain any message.

 

I've aleady uninstalled / reinstalled the module as well as regenerated the API parameters with no more success.

 

I suspect something wrong or missing in WAMPSERVER configuration but I don't know where to look for.

 

Does anybody already encounter / fix this problem?

 

Moreover, the error message indicates to refer to logs. Where could I find log files with Paypal relative error (I've found nothing in Paypal folder)

 

Thanks in advance

Share this post


Link to post
Share on other sites

After having enabled log feature, I get the following additional information:

  1. Making new connection to 'api-3t.sandbox.paypal.com/nvp'
  2. Connect failed with fsockopen method
  3. PayPal response:
  4. 0 ->
  5. ->
  6. PayPal returned an error

 

What could be wrong with the connexion to Paypal?

 

Thanks

Share this post


Link to post
Share on other sites

I found the following while Googling my problem:

 

If you encountered the above error using Prestashop 1.4.0.17 with Paypal module version 2.1, do not worry!

Please check whether you have set up API parameters in the “
Settings
” tab under Paypal module (back-office). Try leaving the API password field blank too!

This should solves the above error messages you have seen.

 

I don't know why, but setting the API password field blank has fixed my problem !!! :rolleyes:

  • Like 1

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 1 month later...
  • 2 years later...

I have the same error.

 

Paypal Version 3.6.5

PrestaShop 1.5.6.2

 

I can't leave the Api-Passwordfield blank (throws a popup with an error-message).

Hope someone can help me.

 

fsockopen is activated (curl deaktivated), so _connectByFSOCK is used.

 

An


gives: 


Ändere ich aber die fsockopen-Zeile auf:


erhalte ich folgende Meldung:

PayPal response:TIMESTAMP -> 2015-01-16T17:23:14ZL_ERRORCODE0 -> 10002L_SHORTMESSAGE0 -> Authentication/Authorization FailedL_LONGMESSAGE0 -> You do not have permissions to make this API callL_SEVERITYCODE0 -> Error

Hope somebody can help me to fix this.

Share this post


Link to post
Share on other sites
  • 1 year later...

So what is your question?

 

I think he is trying to leave password blank as it was metioned earlier in the thread that removing the password solves the problem.

 

I am having issues that I get a 500 Internal Service error when I click to pay with paypal after the cart has been populated. Rang PayPal and they said it's not their issue as the website is never actually getting to them, rang hosting provider and they said it's not their issue as I am not on my own server. :( :( have no idea how to fix it. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 2 months later...

So what is your question?

Do you read in the thread before you answer, by yourself??

 

It's a problem for so many people, with the PayPal module (API) which don't work, for more reasons. So people here in Presta Forum, who ask questions, looks more or less desperately, for an answer! And to read what you wrote, do not make the day better!

Share this post


Link to post
Share on other sites

That solution was written 4 years ago, using a different version of Prestashop and a different version of the Paypal module.  Yet I am the one that has a reading disorder?

 

If you encountered the above error using Prestashop 1.4.0.17 with Paypal module version 2.1, do not worry!

 

Share this post


Link to post
Share on other sites

If you read your own answer in #9 in the thread (old, or not), I see it posted at the 23 May 2016  -  That's why I reacted to your answer!

Share this post


Link to post
Share on other sites

My answer in #9 is not an answer, it is a question to NestorAcevedo

 

I asked him what his question was, to which he never replied. 

 

The point of the matter is that we are talking about a solution that applied to an old version of Prestashop, and an old version of the Paypal module.  So unless you are using those very old versions, then this solution does not apply to you...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More