Jump to content
Sign in to follow this  
Jean-Bruno

[Résolu] SVN : bug en FO à l'install dû à date_default_timezone_set

Recommended Posts

Bonjour (heu bonsoir)
A l'install du SVN 633 j'ai un bug. Apparemment la classe DateTimeZone.php n'existe pas dans les fichiers

En FO et BO ça donne

Warning: require_once() [function.require-once]: Unable to access /var/www/vhosts/denaska.com/httpdocs/boutiqueSVN/config/../classes/DateTimeZone.php in /var/www/vhosts/monsite/httpdocs/boutiqueSVN/config/config.inc.php on line 20

Warning: require_once(/var/www/vhosts/denaska.com/httpdocs/boutiqueSVN/config/../classes/DateTimeZone.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/monsite/httpdocs/boutiqueSVN/config/config.inc.php on line 20

Fatal error: require_once() [function.require]: Failed opening required '/var/www/vhosts/monsite/httpdocs/boutiqueSVN/config/../classes/DateTimeZone.php' (include_path='.:') in /var/www/vhosts/monsite/httpdocs/boutiqueSVN/config/config.inc.php on line 20



En BO

Si je crée un fichier classes vide j'ai alorsen BO

Warning: date_default_timezone_set() expects parameter 1 to be string, array given in /var/www/vhosts/monsite/httpdocs/boutiqueSVN/config/config.inc.php on line 145



Je commente les trois lignes, dans le BO c'est OK mais en FO j'ai une page blache sous le header

Me demandez pas d'expliquer, juste je rapporte, suis nul en php et je capte pas tout
Par contre si vous voulez bien remettre ce fichier sur la SVN je suis preneur

Merci

Share this post


Link to post
Share on other sites

tu as une copie d'écran de ce prob ? suis à jour en SVN 633. et ça m'a l'air ok.
sinon, t'es sous skype ou ichat ? (si oui PM)

Share this post


Link to post
Share on other sites

bon, j'ai jeté un oeil sur les SVN, y'a pas de DateTimeZone.php

sinon, est-ce que tu as indiqué ton fuseau horaire ? ça peut être ça. dans BO/préférences. essaie.

Share this post


Link to post
Share on other sites

SAlut Fabrice

Merci pour le soutient. En BO/Pref j'ai ces fameuses trois phrases et rien d'autre, corneguidouille !

Share this post


Link to post
Share on other sites

J'ai aussi une erreur du genre à la mise à jour SVN. La structure de la BDD a du changer.

J'ai tout réinstallé et c'est rentré dans l'ordre.

Share this post


Link to post
Share on other sites

Heu ben moi quand j'installe une SVN c'est pour tests, donc avec les produits exemples.

Share this post


Link to post
Share on other sites

faux espoir : tout est OK sauf mes préférences du BO
Bon dodo et à demain, tans pis !

Share this post


Link to post
Share on other sites

j'aurais adoré mettre RESOLU mais oui, m^me problême sur install neuve !!

Share this post


Link to post
Share on other sites

MERCI DAMIEN
pour ce correctif très efficace, ces maudite trois ligne ont disparu avec la SVN 647. COOL vais pouvoir passer a la phase 2 du plan.
MERCI MERCI MERCI

Share this post


Link to post
Share on other sites

yes Zendik,
Quelle acuité, t'arrives à me surveiller entre le moment ou je post et celui ou je met Résolu. ;-)
Promis, la prochaine fois je met résolu avant de mettre la solution,
je suis trop content ce matin, merci Zendik pour le boulot incroyable que vous faîtes tous.

MERCI DANKE GRAZIE MILE THANK YOU :-)

Share this post


Link to post
Share on other sites

c'est pas Zendik, c'est Zorro. (caché derrière un buisson... et hop ! coup de fouet !) :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More