Jump to content
Vilas

< SOLVED > Is it Possible to remove ON SALE text field of Product Page?

Recommended Posts

Hello Friends,

 

I like to know is it possible to remove "ON SALE" text from product page? I wish to keep image of On sale & want to remove text field only.

 

Please find image for referance.

 

Thanks

Share this post


Link to post
Share on other sites

I'm not sure which theme that is but it should be similar for all themes.

 

As I can see this is the product's page. You can remove the On sale text by commenting out some code in the product.tpl file for that theme. You can find the file in the root PrestaShop directory on your hosting account, in themes/name-of-theme. The code that you have to delete or comment out should look something like this:

 

<span class="on_sale">{l s='On sale!'}</span>

 

To comment it out simply put an exclamation mark and two hyphens after the first bracket (e.g. <!--span class...), and two hyphens before the last bracket (e.g. </span-->).

 

Don't forget that when you make changes to template files you should also enable the Force compile option from the backend (Preferences tab>Performance sub-tab), so that you can see the change when you refresh the frontend. After you're done with the changes disable the force compile.

 

Hope this helps.

  • Like 2

Share this post


Link to post
Share on other sites

Hi. Just spotted this thread and attempted to do the same thing (to comment out the code that puts 'on sale' by products on my shop page).

 

Bit of a newbie - it hasn't worked. Did I do something wrong? I edited the product.tpl file and uploaded it back to the remote server. I then turned off force compile. Nothing happened after I refreshed the live site, so I opened the file again and re-saved and uploaded, but still nothing's changed.

 

I've now turned force compile off.

 

Any help greatly appreciated!

Share this post


Link to post
Share on other sites

Hi Friend,

 

Please enable force compile option for 2-3 minuites meantime access your site by deleting cookies and temporary files. I am sure it will resolve the issues. Or delete files in compile which is located under tools -- smarty -- compile. Dont forgot to set force compile to off.

 

Thanks

Share this post


Link to post
Share on other sites

Hi! Many thanks for the advice.

 

It has worked to an extent, although I've realised I have to amend about three different files to change the wording on the front page, featured items page and main products page. I've found the code for two of them and will hopefully have it sorted soon.

 

Thanks again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More