Jump to content
Sign in to follow this  
buggindave

Help Please: USPS Module (standard) not working

Recommended Posts

Hello everyone,

I've had Prestashop as my shop's cart system since October now, and it's worked pretty well so far.

 

The one issue I've had is the USPS shipping module. It just won't work no matter what I do. I've already had my USPS account switch to "Productive" from the "Testing" phase.

 

The account ID does connect to the webservice, and I get a "U.S.P.S. Rate Calculator is configured and online!" message, but I get the following for my list:

 

First-Class Mail (2-3 days) [REGULAR RATE] (Available)

First-Class Mail (2-3 days) [COMMERCIAL RATE] (Available)

Priority Mail (1-3 days) [REGULAR RATE] (Not available)

Priority Mail (1-3 days) [COMMERCIAL RATE] (Not available)

Express Mail (1-2 days) [REGULAR RATE] (Not available)

Express Mail (1-2 days) [COMMERCIAL RATE] (Not available)

Parcel Post (2-9 days) [REGULAR RATE] (Not available)

Media Mail (2-9 days) [REGULAR RATE] (Not available)

Library Mail (2-9 days) [REGULAR RATE] (Not available)

 

Now I've tried to even get First Class Mail working in my Checkout, but it won't even come up.

 

I have a Fedex module that works great, but I sell several small items that I'd like to offer the more affordabe USPS option with these items.

 

I've checked the Weight Ranges (as all my calculations are based on weight, not price), and the USPS options all have 0-10k lbs as their ranges.

 

My current Prestashop version 1.4.6.2.

 

I'd appreciate any help you could offer :-)

 

-Dave

SPF

Share this post


Link to post
Share on other sites

I don't get it either. I can't for the life of me get First-class mail working. I just keep seeing Priority everywhere. And why isn't there a guide to use the USPS module? All the ones I've seen don't even tell you what you're supposed to be putting in each field when it comes to weight-related calculations. For example, why do I have to put a number into the "Fees" area at the bottom of the main "Shipping" page if I'm measuring by weight? It makes no sense.

Share this post


Link to post
Share on other sites

Is anyone able to help me with this? The USPS Module still doesn't operate on my store, I'd really like to get it working.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More