Jump to content
Sign in to follow this  
Wonder.x

[Vyřešeno]Problém s rewritem u CMS modulu

Recommended Posts

Ahoj všem,

updatoval jsem prestashop na nejnovější verzi 1.4.6.2. Mám takovej problém s modulem CMS(nevím jistě, zda-li je to modulem). Když se chci dostat na cms stránky tak 5 z 8 odkazu fungují správně a cms stránka se zobrazí. Zbylé tři prostě vyhodí chybu 404. Když vypnu přátelské url vše funguje. Když změním url rewrite z dorucovani-zasilek na dorucovani-zasilek1 tak cms stránka funguje. V htaccess jsem měnil cestu k cms stránkám místo /content/ na /info/ a i v classes/links.php jsem změnil kód, který generuje odkazy. I když jsem vše vrátil do původního stavu tak se nic nezměnilo. Nejsem si jistý jestli byl problém i před úpravou. Resetování modulu cms, generování htaccess jsem dělal. Vím, že bych problém vyřešil hned přepisem na jinou pěknou url ale spíš mě zajímá co to může způsobovat. Předem díky za reakce.

 

Edit: Nahradil jsem soubor Link.php v /classes/ souborem z čisté instalace a najednou to jde. I když jsem si 100% jistý, že to co jsem upravoval jsem upravoval správně a podle návodu. Takže vůbec netuším co to bylo za haluz.

 

Edit2: Nakonec mezi židlí a obrazovkou. I když mám v mozille zakázáno ukládat historii i cookies, tak to bylo díky cookies. Smazal jsem a načetl znovu a jde to :ph34r:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More