Jump to content
Sign in to follow this  
Faby

Problème de couleur de caractère "créer mon compte"

Recommended Posts

Bonjour,

 

Utilisateur de prestashop 1.4.3 depuis 1 ans, je passe mes jours et mes nuits à éssayer de corriger le problème suivant:

Dans le block créer mon compte, lorsque l'on clique sur les champs de renseignement, le curseur est de couleur verte. Comme le fond des champs sont gris, le client ne vois pas du tout ce qu'il inscrit. Ce qui représente biensur un frein à toutes inscriptions et pire, de commande. Une fois le champs renseigné, les textes passent au blanc. Une capture d'écran permettra d'identifier mon soucis "qui est de taille". Ce que je souhaite, c'est remplacer cette affreuse couleur verte, par le blanc. De cette manière la visibilté sera parfaite. J'ai parcourus tous les fichiers et dossiers, en remplaçant par exemple tout les "color=green" par "color=white", mais rien n'y fait meme en vidant le cache smarty.

Comment puis-je faire ????

Merci d'avance pour vos réponses.

 

Fabien

post-319815-0-57805400-1327242358_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour, dans le global.css va à la ligne 432 et rajoute la ligne "color: white;"

 

input.text {

color: white;

height: 18px;

padding-left: 2px;

padding-right: 2px

 

Cela devrait fontionner.

Share this post


Link to post
Share on other sites

Je n'attendais pas une réponse si rapide, je te remercie beaucoup. Je part de suite tester ta proposition.

Fabien

Share this post


Link to post
Share on other sites

Voila, j'ai inseré les lignes mais le soucis c'est que tout est décalé et la page est complètement dénaturé du thème de base. Mais pour une fois, je vois un changement, peut etre radical celui-ci...

 

A bientôt

Share this post


Link to post
Share on other sites

Il n'existe pas une ligne qui gère uniquement la couleur du curseur et de la police ???

 

Merci

Share this post


Link to post
Share on other sites

Il ne faut pas tout insérer, juste la ligne color: white; après input text {

 

Les autres lignes existent déjà dans le global.css à la ligne 432. C'était juste pour t'indiquer l'emplacement. J'espère que cela ira.

Share this post


Link to post
Share on other sites

Oui tout à fait, mais toujours pas de changement. Voila ce que j'ai de la ligne 431 à 436 :

431 #innerlogincontact p a:hover {

432 color : #000;

433 }

434 .logininputcontact:focus {

435 border : 1px solid #222;

436 color : #71A311;

 

C'est incompréhensible... Ce qu'il faut savoir aussi, c'est que le thème n'est pas celui d'origine prestashop. Le global.css d'origine est éffectivement comme tu le dit. celui de mon thème est différent.

Merci pour ton aide

Share this post


Link to post
Share on other sites

couocu

 

bon oui vous n'avez pas le même thème touts les deux donc pas le même global.css ^^

 

donc Faby annule les modifications que tu as faite a la ligne 432

 

recherche avec ton éditeur input.text

 

tu va trouver si ça existe

 

input.text {

color:#XXXXX;

+ des autres lignes

tu remplace donc color#XXXX par color:withe comme la indiquer Kant74

 

si tu est sous chrome ou firefox tu peut aussi faire bouton droit de la souris et "inspecter éléments" sur le zone de texte ou tu veut changer la couleur et dans la colonne de droite en bas qui va s'afficher tu verra quel fichier CSS il faut modifier le nom de l'ID ou de la Class et vers quel ligne la couleur est déclarée

 

@++

 

Loulou66

Share this post


Link to post
Share on other sites

ok Loulou66, je te remercie. Je tente ta solution de suite.

Share this post


Link to post
Share on other sites

Loulou66, ça marche, c'est nikel. Enfin mes clients n'aurons plus peur de s'inscrire.

Merci infiniment pour votre aide à tous les deux.

 

Fabien

Share this post


Link to post
Share on other sites

Effectivement, j'utilise fire fox pour mes pages courantes. Ca fonctionne super sous firefox, curseur blanc et lettres blanches. En revanche, je viens de tester mon site sous explorer et la, petit changement sans gravité cette fois, les lettres sont bien blanches, donc tous vas bien, en revanche le curseur est gris foncé lol. C'est du à quoi cette bizarrerie ???

Merci d'avance

Share this post


Link to post
Share on other sites

coucou

 

oui IE n'as pas le même paramétres de bas que firefox d'ou la différence de couleur du curseur qui clignote.

 

@++

 

Loulou66

Share this post


Link to post
Share on other sites

Ok, je me doutais bien d'un truc comme ça.... mdr. Il y aurait une modif à faire et qui serait spécifique à IE???

Share this post


Link to post
Share on other sites

coucou

 

pas a ma connaissance

 

d’après ce que j'ai vu IE prend la couleur opposer du background donc fond blanc=curseur noir fond gris=curseur gris foncé

 

@++

 

Loulou66

Share this post


Link to post
Share on other sites

Je te remercie pour tes précieux renseignements.

 

Fabien

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More