Jump to content
Sign in to follow this  
sweetbid

Problème URL simplifiées !

Recommended Posts

Bonjour,

 

Cela fait deux fois que ma boutique plante lorsque je coche les cases optimisation et générer les URL simplifié... je suis un peu perdu...

 

J'obtiens cela :

sur l'adresse du site

 

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /homez.483/sweetbid/www/PrestaShop/index.php on line

 

et sur mon panneau d'administration (auquel j'avais accés juste avant de toucher les URL) je tombe sur une page banche immobile.. Impossible d'obtenir quelque chose, j'ai actualisé rien ne se passe.

 

Je pense être sur un serveur apache comme c'est écrit sur le petit message d'avertissement car j'ai déjà eu les URL simplifié sur une autre boutique... je suis hébergé chez OVH .

 

Merci de m'indiquer la marche à suivre s'il vous plait.

Share this post


Link to post
Share on other sites

Bonjour sweetbid,

 

Peux-tu mettre le mode debug sur on dans ton fichier config\config.inc.php.

 

Il faut changer :

 

/* Debug only */

@ini_set('display_errors', 'off');

 

par

 

/* Debug only */

@ini_set('display_errors', 'on');

 

Cela te permettra de voir un message d'erreur quand tu vas sur le panneau d'admin.

Share this post


Link to post
Share on other sites

Bonjour,

 

et merci pour ta rapidité Carl!

 

j'obtiens désormais :

 

 

Fatal error: Undefined class name 'configuration' in /homez.483/sweetbid/www/PrestaShop/config/config.inc.php on line 104

quelque chose me dérange aussi, j'ai deux dossier admin dans mon ftp, comme suit :

 

 

/admin et apres tous les fichier presta et en parallèle ( c à d au meme niveau que admin) j'ai un fichier racine www qui contient mon admin0 (celui avec lequel je me connecte..) dois-je supprimé tous ce qui est avant le www ?

J'ai déjà mis une boutique en ligne sans toute ces embuches je m'avoue un peu perdu ..

 

Merci pour tout !!

Share this post


Link to post
Share on other sites

Est-ce que tu pourrais me donner l'accès à ton FTP par MP que je comprenne un peu mieux l'organisation ?

Share this post


Link to post
Share on other sites

Avec plaisir, quelle est ton adresse? je ne vois pas de lien vers une messagerie privée.

 

encore merci :)

Share this post


Link to post
Share on other sites

Ok c'est un peu plus clair, tu as en fait :

 

\root\ > un premier presta

\root\www\PrestaShop\ > un deuxième presta

 

Lequel est le bon ?

 

Tu as installé les 2 sur la même base de données avec le même préfixe ?

  • Like 1

Share this post


Link to post
Share on other sites

As-tu reçus mes messages, mes réponses sont elles satisfaisantes ? demandez moi toutes infos supplémentaire j'actualise toute les 3 sec ma pages.

Share this post


Link to post
Share on other sites

Tu peux également répondre sur le sujet, tant que cela n'est pas "critique" ou personnel :).

 

Reprenons, sur \root\www\PrestaShop\, tu as fait l'installation complète sans erreur ?

 

Sur tes 2 installations, tu as déjà créé des produits ou elles sont encore relativement vides ?

Share this post


Link to post
Share on other sites

J'explique car c'est un peu complexe..

 

Sweetbid est un site que j'ai mis en ligne avec catégories, produits... tout fonctionné à merveille.

Suite à l'installation d'un thème (qui n'as jamais fonctionné) je recevais le meme message d'erreur que j'ai aussi sur une autre boutique tous ca apres avoir coché la case URL simplifié !!

 

J'ai donc tout supprimé du ftp pour réinstaller la nouvelle version de presta téléchargé sur le site officiel.

Pour les 2 sites!

Ps: ce matin dans mon panneau d'administration je pouvais lire prestasop version 1,4,0 (première version de 1,4) <_<

 

Sweetbid marchait ce matin, j'y ai installé le thème matrice que j'ai commencé à paramètre.. puis j'ai cliqué URL et poof messages d'erreurs sur messages d'erreurs.

 

L'autre boutique plante mais c'est pour une autre raison mon hebergeur ovh ne veut plus installé le module prestashop (que j'ai installé sans probleme sur sweetbid.fr) j'ai envoyé un mail au support.

 

Merci pour tout ton temps qui doit être précieux, mais j'ai l'impression que tu es susceptible de trouver la solution à mes malheurs. :rolleyes:

Share this post


Link to post
Share on other sites

Si tu penses que tout supprimer pour tout recommencer est une bonne solution tu as mon accord, je suis devenu trés rapide pour ce qui est de recommencer une boutique de 0. ^^

 

J'ai tout mes fichiers trés bien classés je sais ou mettre quoi je n'en ai pas pour plus d'une heure si je repars d'une boutique vide.

 

Merci !

Share this post


Link to post
Share on other sites

C'est ce que je te conseillerais de faire pour repartir sur de bonnes bases. En plus tu auras la dernière version car tu as une 1.4.4.0 dans le dossier PrestaShop.

Share this post


Link to post
Share on other sites

Ok, je supprime tout je remet tout et je te tiens au courant, supprimer mes boutiques devient monnaie courante ^^ encore merci !

Share this post


Link to post
Share on other sites

Fais bien le ménage dans tous les répertoires pour ne pas laisser trainer de vieux fichiers :)

 

Je t'en prie.

Share this post


Link to post
Share on other sites

Alors sur sweetbid ya pas de prob tout se supprime normalement, mais sur l'autre boutique je n'arrive pas à supprimé un fichier d'un thème payant deco evo il reste alors que j'essai sans relâche de le supprimé.

 

dans mon ftp, il n'y a plus rien, dois-je créer un fichier /www et mettre le contenu du dossier presta à jour dedans?

 

Ps: j'ai le bouquin prestashop et je le suis à la lettre.. je me sens un peu débile d'avoir autant de problèmes..

Share this post


Link to post
Share on other sites

Alors si tu veux que lorsqu'on tape sweetbid on tombe directement sur ta boutique il faut prendre tous les fichiers et répertoires dans l'archive Prestashop et les mettre dans \www.

 

Pour ton thème tu as bien les droits dessus ?

Share this post


Link to post
Share on other sites

J'ai un thème deco-evo que jai acheté pour l'autre boutique donc oui je pense avoir les droits.

 

Et pour sweetbid c'est le thème matrice que j'ai telecharger gratuitement, j'ai pu commencer à le configurer donc je pense que j'avais les droits non?

 

la phrase :" prendre tous les fichiers et répertoires dans l'archive Prestashop et les mettre dans \www"

veut bien dire dézipper le fichier le fichier de la version stable 1,4,6,2 ouvrir le fichier decompressé faire copier coller tout ce qu'il y a à l'intérieur dans /www.

 

Je préfère te poser les questions maintenant que te re déranger plus tard ..

Mercin pour ta patience !

Share this post


Link to post
Share on other sites

Vérifie que tu es bien le propriétaire du dossier, cela doit être ça qui coince.

 

Et c'est bien ça, tu prends tous les fichiers et dossiers dans l'archive et tu les mets dans \www

Share this post


Link to post
Share on other sites

Comment puis-je vérifier si je suis bien propriétaire...

 

cela peut planter car je ne suis pas propriétaire apres avoir installer et modifier le thème ??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More