Jump to content
NickKK

æøå virker ikke i søgefeltet

Recommended Posts

Hej folkens,

 

I en shop, jeg har sat op med 1.4.6.1, virker æ, ø og å ikke i søgefeltet.

Der er lagt en template købt på MonsterTemplates på.

 

Eksempel:

 

Skriver man OPS i søgefeltet, virker det fint.

Skriver man OPSÆTNING i søgefeltet, finder den intet.

 

Der er selvfølgelig varer oprettet, med ordet OPSÆTNING i teksterne.

 

Er der nogen af jer, der har prøvet dette?

 

/Nick

Share this post


Link to post
Share on other sites

Virker det med standard theme? Hvis ja, så er problemet dit theme, hvis nej, så må det være en "feature" i version 1.4.6.1 - det virker i version 1.4.4.0

Share this post


Link to post
Share on other sites

God idé. Jeg slog over på standardtema og der virker æøå heller ikke.

Pis, det må være en "feature" i den version :-(

 

Det er ikke godt - man kan jo ikke bare sådan nedgradere...vel?

Share this post


Link to post
Share on other sites

Det er ikke godt - man kan jo ikke bare sådan nedgradere...vel?

 

Ikke mig bekendt - det virker vist heller ikke, selv om det er tænkt, at man skal kunne. Men hvis du har en backup af din database, kan du måske installere den på en ældre version. Jeg har ikke helt styr på, hvad det præcis er, de laver af ændringer i de mange mange versioner der er spyttet ud på det seneste. Men det er vel et forsøg værd.

Share this post


Link to post
Share on other sites

Tjae, det er en shop jeg har sat op for en kunde, så det ville jo være rarest, om æøå kom til at virke...

Share this post


Link to post
Share on other sites

Nu har jeg godt nok haft rigtig juletravlt og følger ikke helt med i historik og hvem folk er, der skriver her i forum - jeg har blot prøvet at hjælpe så mange, som jeg kan. Men ligesom Timpet skriver i denne tråd, går min grænse også ved dem som løser betalingsopgaver for andre og løser dem vha. gratis hjælp her i forum - specielt når jeg også selv hjælper folk mod betaling.

Share this post


Link to post
Share on other sites

Bare rolig, du har ikke hjulpet med at jeg kunne tjene penge på den shop, det er en kunde i en helt anden sammenhæng, som jeg blot har gjort en tjeneste med shoppen. Det er to forskellige ting. Jeg hjælper også andre med ting, som jeg normalt får løn for - Handelsbetingelser f.eks.

 

Så jeg har ikke forsøgt at drive rovdrift på din hjælp - beklager hvis jeg udtrykte mig, så det kunne misforståes.

Share this post


Link to post
Share on other sites

I øvrigt er jeg ret interesseret i om problemet kan løses, netop fordi jeg selv overvejer at opgradere min egen shop.

Share this post


Link to post
Share on other sites

Så kunne det jo være fordi 1.4.6.1 er fejlbehæftet, hvilket du sikkert kan få bekræftet af de utallige indlæg om den version. De handler alle sammen stort set om fejl.

Share this post


Link to post
Share on other sites

Pertho > Ja, tilsyneladende. Irriterende læreproces, men sådan er det, når man dummer sig og bruger nyeste version af software :-)

Share this post


Link to post
Share on other sites

Jeg fik lavet en slags nødløsning:

 

De varer, som der skal kunne søges på via ord med æøå i, tilføjer jeg nogle tags, som indeholder internet-i-ficerede versioner (ae, oe og aa) af ordene, og så laver jeg en Typos-liste med alias'er til de ord.

 

Det er ikke optimalt, men det gør at folk kan finde de rigtige emner i shoppen.

 

Hermed er idéen givet videre, til hvis andre støder ind i samme problem. Det gælder tilsyneladende 1.4.5.1 og fremefter.

Share this post


Link to post
Share on other sites

Det er tilsyneladende søgeindekset der ikke bliver opdateret korrekt (jeg har lige tjekket i en version 1.4.7 hvor søgning med æ, ø og å heller ikke virkede). Prøv at genopbygge indeks via BO - Indstillinger - Søg, under Indeksering vælges Genopbyg hele indekset.

Share this post


Link to post
Share on other sites

bruger version 1.4.7

har forsøgt at genopbygge hele index, dette virker stadig ikke med øæå

NickKK > hvor er det du siger man kan tilføje disse søgebogstaver?

Share this post


Link to post
Share on other sites

Jeg synes da jeg har prøvet at hjælpe. Det virkede som sagt i den shop, jeg har sat op - så det må jo skyldes noget andet, og så er jeg blank på hvad.

Share this post


Link to post
Share on other sites

genopbyggede hele index igen,

slettede cache samt internet cookies.

nu virker det..

mange tak

Share this post


Link to post
Share on other sites

Hej Presta folk. Jeg har også problemet med æ ø å i min shop. køre version 1,4,7. Har prøvet de ting som er nævnt her.

 

Slettet cache: To clear cache ''tools\smarty\cache\'' and ''tools\smarty\compile\''

delete files in these folders.

 

Genopbygget hele mit index via Fortrukken - Search - genopbyg hele index

 

Slettet cockies i min ie

 

Men stadigvæk kan jeg ikke søge på FO på nogle ting som indholder æ ø å :-(

 

Nogle guldkorn til denne løsning, da mange af mine vare indholder æ ø å

 

siden er www.soveværelset.dk

Share this post


Link to post
Share on other sites

Som jeg vist har skrevet før, så smider du "bare" nogle typos ind. Altså du skriver søgeordene ind i listen med stavefejl og henviser til de samme ord, bare stavet med ae, oe og aa og så skriver du disse stavemåder ind på varekortet i metafeltet.

 

Det er langt fra perfekt, men det virkede sidste jeg brugte det på en shop.

Share this post


Link to post
Share on other sites

Jeg har "løst" det ved at tilføje denne linie i search.php linie 175 (i 1.4.7.3):

 

$word = str_replace('%', '\\%', $word);
$word = str_replace('_', '\\_', $word);
$word = Tools::replaceAccentedChars($word);  << TILFØJET

 

Det betyder så at f.eks. o og ø bliver opfattet som samme bogstav, så du kan søge efter "søløve" ved at taste "solove", og omvendt, men det er til at leve med synes jeg.

 

Tommy -

Share this post


Link to post
Share on other sites

Jeg brugte tidligere overstående fix, men kunne ikke få det til at virke på ord med flere æ/ø/å (f.eks. lædersnørre eller afspærringsbånd)

 

Dog har http://www.belvg.com løst problemet fuldt ud for mig.

Er testet uden problemer på Prestashop 1.4.7 og Prestashop 1.4.8.2

 

Vedhæftede fil skal overskrive den originale i Classes mappen.

 

Husk at genopbygge Search Index bagefter.

Search.php

Edited by FPDK
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More