Jump to content
Sign in to follow this  
philiber30

[RESOLU] Besoin d'un coup de mains pour liaison serveur distant

Recommended Posts

Bonjour,

 

J'aurais besoin de conseils, voir de l'intervention d'un développeur pour un problème de fonction Php sur serveur distant.

Je m'explique :

Ma boutique tourne sous PS 1.4.6.2 , thème : prestashop_new (1.5)

Le panier ne fonctionne pas sous ajax sur le serveur distant alors qu'il fonctionne bien sur mon serveur local (wamp).

Mon hébergeur (PlanetHoster) me fournit Php 5.3.6

Mon serveur local est en Php 5.3.0

Malgré l'ajout de la fonction Php mbstring, cela ne fonctionne toujours pas alors que lorsque je supprime mbstring sur mon serveur local, je reproduit la même erreur que sur le serveur distant.

Prestashop addon a eu la gentillesse de jeter un œil sur ma boutique et m'indique en retour le message suivant :

" Fatal error: Call to undefined function mb_split() in /home/marquage/public_html/tools/smarty/plugins/shared.mb_str_replace.php on line 30 "

 

 

J'ai relancé à nouveau mon hébergeur qui a basculé ma boutique sur un autre serveur mais en me précisant des erreur 4... pendant ce basculage (et la fonction mbstring est bien présente)

J'ai acheté un module de clonage de déclinaisons qui fonctionnait bien sur la boutique en local mais plantait sur la boutique distante.

Après tests effectués, voici sa réponse :

Il y a bien un problème lié à Ajax sur votre site. Le script d’affichage des catégories et produits ne se lance même pas.

 

Voilà ou j'en suis , c'est à dire saturé.

Mes connaissances ne me permettent pas d’appréhender correctement ce problème.

Je fais donc appel à une bonne volonté qui pourrait consacrer un peu de son temps et beaucoup de ses compétences afin de me libérer de ce casse tête.

 

Très cordialement,

Philippe

 

Boutique : http://www.marquagetextiles.com

Je tiens à disposition les accès BO et Serveur si nécessaire

Share this post


Link to post
Share on other sites

Problème résolu : Changement de serveur incompatible qui tournait sous Php 5.3.6 basculé en Php 5.3.0

Mon hébergeur "PlanetHoster" à géré ce problème avec brio (ça a été un peu long car l'équipe de PlanetHoster était très occupée par d'autres problèmes mais jamais ils ne m'ont laissé tomber)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More