Jump to content
Sign in to follow this  
IC INDUSTRIE

Temps execution des script

Recommended Posts

Bonjour,
comme certains le savent je finalise PrestaFiles (Logiciel pour la gestion des produits...)
Hors lors de l'intégration de mes CSV, sur un serveur mutualisé (amen) j'ai une erreur 500 à environ 40 à 50 secondes après le lancement de l'intégration des lignes du csv (intégration de photos de 70 à 700 k).

Hors je ne trouve trace nul part d'autre utilisateurs ayant eu ce problème, donc je pense que cela vient de chez moi, peut etre...
J'ai modifié toutes les valeurs possible dans le php.ini, rien n'y fait. il reste à modifier max_execution_time mais là impossible car on est sur du mutualisé.

Ma réflexion est donc la suivante : mon prog en phase final sera INUTILISABLE par bon nombre d'utilisateur ... (j'intégre sans pb de 12 à 18 prod ...)

Doit on passer sur un serveur dédié?

Je ne suis pas assez fort en php pour savoir si c'est contournable par le code, (je suis expert C, C# c'est déjà bien...)


si vous voulez des infos : http://www.adopte-un-sextoy.com/phpinfo.php

D'avance merci....

Share this post


Link to post
Share on other sites

Je continue mais test, mais je pense que je vais bientot abandonner...
Sur mon serveur de dev en local (easyphp de base....) il me faut 5m 35 secondes pour intéger 33 produits avec photos entre 1 et 3 par produit.
Donc sur un mutu si la base de réglage est 30 ou 60...ca explose...simplement, je n'ai pas d'info sur mon erreur 500, juste fatal error!

PERSONNE N'A JAMAIS INTEGRER DE PRODUITS En PROD PAS SUR UNE TABLE DE DEV... EN REEL!

Share this post


Link to post
Share on other sites

salut ....faut pas désespérer....on va trouver une soluce...

peut tu me faire passer ta requête sql pour l'insertion des donnes stp ....je voudrais y jeter un coup d'œil.....

Merci

Share this post


Link to post
Share on other sites

donc ...on récapitule :

1. tu fait un import du csv depuis le BO de prestashop ?
2. tu uploade par ftp test images ?

c'est bine ca ?

Share this post


Link to post
Share on other sites

Non :
j'ai créé un rep sur mon serveur qui contient 2400 images.
je charge par le BO de PS un csv d'environ 50 lignes, et dans la colonne produit, j'ai les urls des images : http://monsite/morep/image1.jpg,http://monsite/morep/image1.jpg
l'import se passe à MERVEILLE pour 12 à 15 Produits puis une erreur 500 est levée. temps d'execution environ 40 secondes...(tiens c'est assez proche du paramètre 30 s de Apache ça non?)
en Local, le traitement sur une petite machine sous easyPHP dure ...4m25secondes pour 33 produits !!!!!! mais sans erreur!

je donne mon csv à qui le veux (je vous préviens ce sont des sextoys....)


PS je te propose de continuer ici :
http://www.prestashop.com/forums/viewthread/11017/P30/discussion_generale/logiciel_de_preparation__prestafiles__dot__dot__dot_des_nouvelles

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More