Jump to content

Recommended Posts

Prestashop'ta en büyük sıkıntıyı üye sayfasında yani authentication.php sayfasında yaşıyorum. Burada Ad, Soyad ve Şehir gibi kısımlarda büyük İ harfi yazamıyorsunuz hata veriyor. Mesela İbrahim İnce, İstanbul gibi bir bilgi kabul etmiyor kesinlikle. Bu sorunla karşılaşıp çözebilen var mı?

 

Hadi şehir kısmını eyaletleri şehir gibi düzenleyerek drop down menü halinde yapabiliyorum ama ad soyad kısmını ne yapacağız? Sıkıntının kaynağı ne bilemiyorum. Kodlarla aram iyi değil, ama phpmyadmin'de olsun prestashop ve tema dosyalarımda olsun UTF-8 açısından bir problem görünmediğini söyleyebilirim. Tek şüphem .tpl dosyalarındaki |escape:'htmlall':'UTF-8' kodu. Bu kod kaynaklı bir sorun olabilir mi? Ya da alakası yoksa sorun nereden kaynaklanıyor?

 

Presta 1.4.2.5 kullanıyorum. Örnek hata görüntüsünü ekte verdim, toplam 5 hata görünüyor:post-285788-0-52506600-1323640025_thumb.png

 

Hata 1 eksik bilgi girişi

Hata 2, 3 ve 5 bahsettiğim sorun

Hata 4 eyaleti zorunlu alan yapıp, ülke eyalet içermez diye seçmek

 

Daha önce bir kişi bu konuyu açmış ama kimse cevap vermemiş:

http://www.prestasho...hir-adi-hatasi/

 

 

(Bu arada yeni eyalet ekleyip onlara şehir ismi vermek iyi bir çözüm değil, mesela PayPal ile ödemek istediğinizde resmen eyalet yazıyor o kısımda! Şehir ismini tekrardan manuel girmek zorunda kalıyor kullanıcı - eğer PayPal'u ilk defa kullanıyorsa )

Share this post


Link to post
Share on other sites

Bende öyle bir sorun yok.

 

İstersen ps 1.4.6.2 gibi son sürümlerin dosyalarını atıp dene

 

Bunu 1.4.6.1 de denedim

 

Ne yazık ki kullandığım bazı modüller var bunları ileri sürümlerde kullanamıyorum. Mesela 1.4.4.1 denemiştim hemen bozulmuştu sayfalar modül uyumsuzluğu yüzünden. Tekrar 1.4.2.5'e geri çektim. Yalnız benim anlamadığım i harfi ile ilgili problemin tam olarak nerede olduğu, yani tema mı problemli yoksa presta mı? Ben sanmıyorum ki sorun prestada olsun. Bu tema ile alakalı bence ama nasıl çözülür bilemiyorum.

Share this post


Link to post
Share on other sites

evet bendede böyle bi sorun yaşamadım oseda. sürümüm 1.4.0.0

 

Sürüm 1.4.2.5 problemli gibi anladığım kadarıyla. Bugün 1.4.6.2 kurdum ve maalesef birçok modüle veda etmek zorunda kaldım. Ama problem çözüldü. Database'i de sıfırdan oluşturuyorum.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×