Jump to content
  • 0
alcium

Erreur 500 après installation.

Question

Bonjour à tous,

Je viens de proceder à l'installation de Prestashop, en suivant scrupuleusement la doc.
Celle-ci s'est déroulée sans soucis ni message d'erreur.
Mais je ne parviens pas à acceder à la page principale, j'ai directe une erreur:

HTTP 500 Erreur interne au serveur
Le site web ne parvient pas à afficher la page, etc...


Par contre je peux acceder au back office.
J'ai repris la doc d'installation à zéro plusieurs fois, pour être certain ne rien avoir oublié, j'ai bien vérifié tous les droits sur les différents répertoires et fichiers, mais là je sèche.
Si une âme charitable pouvait me venir en aide.
merci d'avance.

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
Bonjour, et merci de la réponse.
Je suis chez Nfrance.
Le php5 est bien activé chez l'hebergeur.

Concernant le htaccess, le générateur m'indique que la génération est bien effectuée, mais je ne retrouve pas le fichier sur le serveur. Si j'essaye d'en créer un moi même, celui-ci disparait quand j'essaye d'acceder au site.

Par contre, en consultant les (nombreux) messages de ce forum, j'ai trouvé une piste qui a changé un peu les choses:
Sur le back office, dans les preferences, j'ai coché la dernière case "utiliser smarty 2 au lieu de smarty 3", et là j'ai pu acceder au front office.
Mais, car il y a un "mais", au bout de quelques instants, je me retrouve avec la même page HTTP 500 erreur etc...
Pareil si j'essaye de naviguer sur le site.

Share this post


Link to post
Share on other sites
  • 0
Bonjour

[quote]Concernant la htaccess, le générateur m'indique que la génération est bien effectuée, mais je ne retrouve pas de le fichier sur le serveur. Si j'essaye d'en créer un moi même, celui-ci disparait quand j'essaye d'acceder au site.[/quote]

Le fichier .htaccess est un fichier caché, si vous utilisez filezilla dans le menu Serveur >> coche Forcer l'affichage des fichiers cachés.

Share this post


Link to post
Share on other sites
  • 0
Recrée un htacess sur le BO en spécifiant ceci dans la personnalisation :

[CODE]
AddHandler php-fastcgi5 .php
[/CODE]

Pour savoir si le fichier est créé essaye d'uploader un fichier .htacess. Si filezilla te demande d'écraser ou non c'est que ton fichier est bien généré. Si ce n'est pas le cas alors cela veut dire que la génération ne marche pas.

Share this post


Link to post
Share on other sites
  • 0
J'ai déjà été en contact plusieurs fois avec nfrance, et il n'y a à priori aucun soucis sur le serveur pour l'installation de prestashop.

Je peux gérer moi même les droits d'écriture sur les dossiers et fichiers du serveur dans filezilla, pas de problème de ce coté là.
Quand je veux générer le fichier .htaccess, le BO me precise qu'il faut avant ça que je crée un fichier .htaccess vide que j'upload sur le serveur, ce que je fais. Et quand je modifie les droits d'écriture comme demandé, c'est là que le fichier disparait.
A partir de ce moment là, je peux acceder à la génération du fichier sur le BO, mais quand je clique sur le bouton "générer le fichier .htaccess", on me propose à la place le téléchargement du fichier "index.php"...

Share this post


Link to post
Share on other sites
  • 0
Bonjour

[quote name='alcium' timestamp='1322148338' post='689309']
J'ai déjà été en contact plusieurs fois avec nfrance, et il n'y a à priori aucun soucis sur le serveur pour l'installation de prestashop.

Je peux gérer moi même les droits d'écriture sur les dossiers et fichiers du serveur dans filezilla, pas de problème de ce coté là.
[color=#0000cd]Quand je veux générer le fichier .htaccess, le BO me precise qu'il faut avant ça que je crée un fichier .htaccess vide que j'upload sur le serveur, ce que je fais. Et quand je modifie les droits d'écriture comme demandé, c'est là que le fichier disparait.[/color]
A partir de ce moment là, je peux acceder à la génération du fichier sur le BO, mais quand je clique sur le bouton "générer le fichier .htaccess", on me propose à la place le téléchargement du fichier "index.php"...
[/quote]

Tester : Upload du fichier .htaccess mais sans toucher au droit une fois sur le serveur, puis testez de générer le fichier .htaccess, il est possible que dans la configuration du serveur apache que c'est le serveur qui prends la main sur le .htaccess à voir avec l'hébergeur.

Le téléchargement du fichier index.php c'est pas logique où est-ce le navigateur qui veut télécharger un fichier index.php ? Vous avez par hasard Firefox ? J'ai eu ce problème avec Firefox au lieu d'actualiser la page il télécharge le fichier!

Share this post


Link to post
Share on other sites
  • 0
Le message est un peu vieux mais pour ceux qui ont le problème de page blanche (erreur 500) sur le front voila comment je l'ai résolu.
Jusqu'à la version 1.4.8.2 j'utilisais la ligne dans le htaccess:
[i]php_value memory_limit 128M[/i]

Mais après la mise à jour vers la 1.4.9 j'ai eu le problème sur le front.
En rajoutant à la place de cette astuce la ligne (dans config/config.inc.php):

[i]@ini_set('memory_limit','16M');[/i]

Le problème a été résolu.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×