Jump to content
  • 0
sebgy

Souci 1&1, allow_url_fopen

Question

Bonjour,

 

après avoir cherché dans plusieurs topic et fait des essais pour résoudre mon problème je me tourne vers l'aide de la communauté presta.

 

Voilà j'ai un souci avec allow_url_fopen qui me bloque pour Ebay et pour les mises à jour via upgrade

j'ai mis un fichier php.ini avec:

allow_url_fopen=on allow_url_include=On

safe_mode=off

magic_quotes_gpc = off

register_globals = Off

à la source de mon répertoire mais rien à changer, j'ai essayé d'autre variante pareil

j'ai essayé aussi dans le répertoire modues/ebay

 

Le soucis viens de 1&1 mutualisé?

 

Ma config:

1&1 mutualisé - Prestashop 1,4,2,5

 

Merci d'avance,

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Bonjour,

 

voici ce qui est précisé sur la doc 1and1

Important: Il est impératif que le fichier php.ini comprenant les nouveaux arguments soit placé dans tous les répertoires, sinon, la valeur de la variable PHP ne sera pas modifiée.

et après un test c'est vrai.

Share this post


Link to post
Share on other sites
  • 0

Dans TOUS les répertoires ? et sous-répertoires ? ca fait du monde...

Bonjour,

 

Oui mais 1and1 propose un script php pour faire cela simplement, vous le trouverez dans la FAQ

Share this post


Link to post
Share on other sites
  • 0

pas vraiment dans tous les répertoires, mais dans le répertoire destiné et ses répertoires parents .

testé ok sur 1and1 dédié

Bonjour,

 

Il faudrait juste m'expliquer l’intérêt de surcharger la configuration php à l'aide d'un php.ini sur votre espace d'hébergement alors que vous avez un dédié et que de ce fait vous pouvez modifier le php.ini initial ?

Share this post


Link to post
Share on other sites
  • 0

bonsoir

 

désoler de faire remonter ce topic mais je suis confronté au même problème

quand j'arrive sur mon back de ma boutique j'ai ce message

 

Pour recevoir les alertes de mise-à-jour, vous devez activer la commande <b>allow_url_fopen</b> dans le fichier de configuration <b>php.ini</b>. [Plus d'infos]

Si vous ne savez pas comment le faire, merci de contacter l'administrateur de votre hébergement.

 

alors j'ai voulu vérifier ( je suis sur 1&1 ) et j'ai fais un fichier phpinfo.php.

 

j'ai pourtant reussi à changer les off en on ( sur allow_url_fopen et include ) mais j'ai toujours ce message dans la boutique ...

 

comment on dois procéder ?

Share this post


Link to post
Share on other sites
  • 0

Bonsoir,

 

Je sais que ce poste commence à avoir de l'age, mais j'ai également rencontré ce problème. Mais pour faire plus simple pour que le php.ini soit pris en compte, pas la peine de le mettre partout comme indiqué plus haut, mais simplement placer le php.ini dans le répertoire admin. Tout simplement.

 

Voilà, je voulais juste apporter ma contribution au sujet, malgré son age =)

 

Cordialement

Share this post


Link to post
Share on other sites
  • 0

Mr Newbie, merci pour l'astuce, je crois que j'avais transféré le fichier php.ini partout, sauf dans le dossier admin...

Problème réglé, merci à vous !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×